Everyone has information. Musicians to programmers, grandmothers to students, everyone has information.

But how does this information relate? What comes first? Where does it lead? What keeps appearing, over and over?

OmniGraffle lets you visualize your ideas: store, organize, relate, clear up, re-organize, print, share, compare, re-organize again, experiment, and publish them to the web.

OmniGraffle’s main purpose is to let you jump in and do these things quickly; start up the app, noodle around a bit, and suddenly you have a clear picture of what you’re thinking about. A picture you can share with others, without having to wave your hands or tote around a whiteboard.

This is a concepts manual: here we’re going to introduce you to OmniGraffle. If something catches your eye, you’ll find more detail in the on-line help.
Step 1:
Insert the OmniGraffle CD into your Macintosh's CD-ROM drive. You should see a window similar to this one:

In addition to the OmniGraffle application, your CD also contains some useful information for helping you get started (in case you forgot to look at this manual, but you're clearly smarter than that), and unlicensed versions of The Omni Group's other products for you to try out and fall in love with as well.

Step 2:
If you want, you can go ahead and run OmniGraffle now by double-clicking the OmniGraffle icon. But you probably don't want to run OmniGraffle from the CD, since you'd have to have said CD in your computer all the time. Instead, you should drag the icon to a folder on your local or network disk.

Where you put it is up to you; however, most Mac OS X applications work best if you put them in the main Applications folder on your hard disk. If you have multiple users on your computer, OmniGraffle will then be accessible to all of them. (Note that you'll have to be logged in as an administrator to write to the Applications folder.)

If you're the administrator of a Mac OS X network (you'd know if you were) and you've bought multiple copies of OmniGraffle, you may want to put OmniGraffle in the /Network/Applications folder so that it can be available to all network users.
Step 3:
Run OmniGraffle for the first time by double-clicking on its icon. You'll be presented with a panel letting you know that you should enter your license key. Click Licenses…, and a new window will appear:

![Licenses window](image)

This is the Licenses window, in which you can keep track of any OmniGraffle license(s) you may own (for more information about its general use, see the online help.)

Step 4:
Click Add License…, and a sheet will appear in which you can enter your license information as it appears on the CD sleeve. Also, here you can choose to install your license for Personal, Computer, or Network use. Once you've entered the license information, click Save to save it (as you might expect).

Personal, Computer, or Network? Huh?
When installing OmniGraffle, you'll want to decide who else can use your license (see sidebar). There are three ways you can use your license:

- **A Personal license** is available only for you, the user who installed it. It's stored in your home folder, so it is only available when you're logged into your account.

- **A Computer license** is what you would usually choose: it's available to any user who can log into your Mac.

- **A Network license** is available for any user on any machine on your Mac OS X network, and is generally only used if you have bought lots of licenses (for instance, at a university lab).

Feel free to copy OmniGraffle to other computers without its license: it will function in a limited mode as a document viewer when unlicensed.

OmniGraffle's license terms:
Each OmniGraffle license you buy allows you to either:

- Have as many users you want use OmniGraffle on one machine, or
- Have one user use OmniGraffle on as many machines as she wants.

Note that doing both is not allowed — licenses aren't “floating” and thus, if you have one license and two machines in your house, and your roommate also wants to use OmniGraffle, you can either decide that both you and the roommate can use OmniGraffle on one of your machines, or that you can use OmniGraffle on both machines and your roommate can buy her own copy.

So, in this example, you'd want to install your license as a Computer license if you're trying to share OmniGraffle with your roommate on one machine, or as a Personal license if you want to use it on either machine and not share with her.

For companies and other institutions, a simplified way of saying this would be: “You should purchase as many licenses as you have either machines or total potential users, whichever is fewer.”
OmniGraffle is easy to get into, but allows you to drill down into great detail. The basic interface is simple, but, like a fancy cake, layers upon layers of wonderful things lie beneath.

**The main window**

The main window, also called the “canvas,” is where you create your diagrams. You'll add shapes, text, and lines using the tools from the toolbar and the palettes, you'll drag in pictures from the web or your desktop, and then you'll modify everything using the info panels, the font panel, the colors panel, and assorted menus.
The Info panel

The Info panel modifies your shapes and lines. You'll usually have one or more instances of this panel on screen to make editing your creations easier. You can bring the “main” Info panel onto the screen by using Tools > Show Info.

There are eight different panes inside this panel: the first four are in the Info panel’s toolbar by default and the last four are accessible by clicking on the chevron on their right. Command-1 through Command-8 are shortcuts to these panes (see the Tools > Info Panes menu).

Each pane has controls for editing an aspect of your drawing; we've tried to group them logically, so operations you'll want to do together are on the same panel (e.g., setting the background color and the border color of a shape are both on the Style pane). There's also an All pane (accessed from the far left of the toolbar) also displays the other eight pane buttons for easy access.

You can create extra Info windows by using Tools > New Info Viewer, or clicking the button on the All pane. Why would you do this? Well, say for instance you use the Shape and Style panes a lot. You might create a second info window, and make the second one have only those two panes on its toolbar. OmniGraffle remembers how you've laid out your Info panels between sessions, so customize your workspace the way you like.

Smart controls

The controls on the info panes are all smart, so they'll deactivate themselves (turn gray and not respond to you) if they don't apply to any of the shapes or lines you have selected.

For instance, if you select a square shape and show the Line pane, you'll find that all the controls are deactivated. But if you have selected two squares and three lines, the Line pane will be active and ready to change those three lines.

The palettes

The Palettes panel gives you access pre-made shapes for your diagrams. The toolbar at the top of this panel lets you select between sets of them; don't worry if you don’t understand what some sets are for — some were obscure even to us. Just use the ones you like.

Drag any shape onto your main window and drop it where you want it. You can alternatively create shapes of a precise size using the Shape tool on the toolbar. Most people do a mix of both: the Shape tool is great for drawing several versions of the same shape, the palettes are nice if you're creating a diagram with a lot of different shapes and you don't immediately care about exact sizes (you can always resize shapes later). Again, use OmniGraffle the way you want to.

A plethora of palettes

We include five palettes with this version of OmniGraffle, but we're always adding more shapes. (Note to lawyers: this isn't a legally binding promise.) We'll have some more palettes on our website soon, at http://www.omnigroup.com/applications/omnigraffle/ when they are ready.

There are many third party palettes available on the net that you can use in OmniGraffle, try doing a search on google for "OmniGraffle palettes" to find the latest.

Finally, you can create your own palettes; see page 18 for details. If you create a really cool palette and want to share it, please send us e-mail at omnigraffle@omnigroup.com.
So what do you do first? Let’s just make a simple diagram. Assume you want to sketch out the game of Paper–Rock–Scissors in order to solve its eternal mystery: who beats whom?

(First click on the shape tool button.)

First lay out the three shapes we need — one for Paper, one for Rock, and one for Scissors. Shapes can be made two ways; you can drag them off of a palette or you can draw them using the shape tool. Let’s try the shape tool first. Click once on the shape button in the toolbar (it looks like a square). Click near the top of the canvas and drag until the shape is the right size. After you’re done drawing the toolbar changes back to the selection tool; if you’d like to stay on the shape tool double-click its button, see page 8 for more on this.

(Now click on the palettes button.)

For the other two shapes, let’s use the palettes. Open the palettes window if needed by clicking on the Palettes button on the toolbar (it’s the piece of paper with the simple colored shapes on it). Find the large upside-down arrow shape on the Basic palette and drag it onto the canvas. Then use the selection tool (the arrow at the far left of the toolbar) to resize it as you please. Do the same with the hexagon, and your diagram should look like the one at right.

(Double-click on the text tool button.)

Before you can figure out who beats whom, we need to put names in each of the shapes. Double-click the text tool button (the letter A in the toolbar) to get it to stick, so you can do all three shapes without having to keep selecting the text tool again and again. Click with the I-beam cursor inside one of the shapes and type one of the titles; for instance, ‘Rock.’ Repeat the process to put labels in the other two, and you should have something like the diagram at left.

As a shortcut, you can also edit a shape’s label by double-clicking inside the shape with the selection tool.
Now we need to connect the shapes together in the right order. (In case you’ve forgotten, Paper smothers Rock, Rock smashes Scissors, and Scissors cuts Paper. And people say video games are violent.) Double click on the line tool (the line with an arrowhead in the toolbar) so we can draw three lines in a row. Click inside one shape, then click again on the appropriate shape that it beats. You can click anywhere inside the shapes and the line will automatically be connected to the entire shape. Do this twice more, and now you can plan your master Paper–Rock–Scissors strategy.

As a shortcut, you can also Control–drag between two shapes with the selection tool to create a line. If you create an extra line, just select it and press the Delete key to remove it or use Edit > Undo.

What else could I do with this graph?

- Pull up the colors panel (under the Tools menu) and use the Style Info pane to set background colors on your objects. Drag a color from the colors panel to the color well on the Info panel, or just drag it onto the shape itself to set its fill color.
- Change your objects to be different kinds of shapes by selecting one and using the Shape Info pane.
- Select all your shapes and make them rotate all at once using the wheel on the Size Info pane. You’ll sell your GameCube™ after this one.
- Set a different font for the labels by selecting a shape and using the font panel (Format > Font > Show Fonts).
- Add a bend to a line by double-clicking on the line to add a point, and drag the new point to make a kink.
- Drag an image from your Pictures folder (or anywhere on your hard disk, or even the web) onto one of the shapes to set it as the fill pattern for that shape.
- Play with partially transparent colors using the colors panel; try filling a shape (Shape Info pane) with a partially transparent color and moving it over another shape. Note that by default shadows in OmniGraffle are partially transparent, meaning if you move a shape over another shape the shadow will draw like a real shadow, darkening the colors under it instead of replacing them with flat gray.

As a last touch, we’ll let OmniGraffle pretty up our graph a bit by making the shapes equidistant. Go to the Layout Info pane (it’s probably under the chevron pop-up on the right of the toolbar). Choose Force-directed at the top, and then select Animate Layout and Random Start Locations to make it more fun. Click a couple times on the Layout Graph button to get a feel for how layout works. Try turning up the Object Repulsion and watch how the shapes end up farther apart.

We have finally discovered the secret of Rock–Paper–Scissors: the only way to win is not to play.
OmniGraffle has many handy tools that are all available at the touch of a button.

You can pick these tools up in a bar: a toolbar.

The shape tool is a fast and easy way to draw a the indicated shape at any size.

The selection tool is used to select, resize, or move shapes and lines.

The line tool allows you to connect shapes or just draw lines.

The text tool gives you a quick way to add text that’s not on a shape or line.

These three tool buttons are special in two ways:

- When you click on a button once, it temporarily activates its tool. The button will turn grey to indicate it will revert to selection mode after drawing one shape or line or text. If you want to draw the same shape repeatedly, double-click on a tool, and its icon will turn blue to indicate that tool is stuck on. Draw as much as you want, then click on any other tool to get unstuck.

- You can change the shapes or lines or text these tools will create in the current document by clicking on a tool and then setting the attributes you want in the appropriate panels (Shape Info, Line Info, or the font panel, respectively). The tool's icon will even change to reflect your new attributes.
Other Awesome Icons You Can Add to Your Toolbar

Group
Select some shapes and click Group, and then these shapes will all be treated as one. Unity, brother. Change your mind? Click Ungroup and the one shall become many.

Layout
There are two Layout buttons — one lays out a selection, and the other lays out the whole graph. Either way, one click will tidy up your graph. (If only the house would do this.)

Font
Maybe you can only think when your labels are in Figmenton XO Bold. Pick whatever fonts you desire for any of your labels.

Color
Yes, plain old black and white graphs can get a little boring. Color is the spice of life! Use as many different colors as you want. (Clashing colors may make the graph difficult to look at.)

Print
Need to make hard copies often? Put the Print button on your toolbar.

Spaces, Separators, and Customize
Is your toolbar getting cluttered? Spaces, separators, and flexible separators (which push icons after them all the way to the right) can help you bring order to chaos. Can’t decide? Put the Customize icon on your toolbar and it’s even easier to change things.

Toolbar customization
- Use Tools > Hide Toolbar or click the lozenge in the upper-right corner of a window’s title bar to hide and show its toolbar.
- Use Tools > Customize Toolbar... or use Option-Command-click on the lozenge to customize your toolbar.
- Command-click on the lozenge to select a different display mode (Icon and Text, Icon Only, or Text Only).
- Command-drag a toolbar item to move it (or remove it) without entering the customize toolbar mode.
- Control-click on the toolbar to get a context menu which lets you do all of the above and more.

OmniGraffle uses the standard toolbar mechanism from Mac OS X’s Cocoa frameworks — so most of these shortcuts will also work in other Mac OS X applications, including Mail, Address Book, Project Builder, and (of course) OmniWeb.
The Info panel is a key part of OmniGraffle. Here you can set every property of every item in your document, from color, to size, to shape, to font, to the way the whole graph is laid out.

**Style Info pane**
This pane allows you to set the general appearance of shapes and lines.

- **Select whether or not the object is filled or shadowed, and if so, what colors to use.**
  Try partially transparent shadows, they’re cool.

- **For a shape’s border, you can set how thick the lines will be, their color, and if they are dotted, dashed, or solid.** This part of the pane also works on lines (as does the shadow, above).

You can drag an image here to put it inside your shape — for more information, see ‘Importing Images’ on page 15.

**Size Info pane**
This pane is one of the simplest: it can set the size or orientation of a shape. It only works on shapes because lines have their endpoints anchored to shapes or the canvas.

- **Want that square to be a little off-kilter?** Enter in an angle or drag the little button around the circle. (Don’t make yourself dizzy.) You can use the Shift key when dragging to limit yourself to $15^\circ$ increments.

- **Shape pointing the wrong way?** Flip it horizontally or vertically, respectively.

- **If mousing the shape’s size and placement isn’t precise enough, you can be more exact here.**
Shape Info pane

This pane changes shapes to other shapes, and positions labels on them.

![Shape Info pane](image)

You can change any shape on the canvas to be any other shape. If you want an arrow that faces left, for instance, use the right facing arrow and flip it using the Size info pane.

If you check this, then as you edit the text in a shape, the shape will grow or shrink to perfectly encompass the text.

Line Info pane

This pane changes all the properties unique to lines. Color, shadow, thickness, and pattern are on the Style Info pane, since they apply to shapes as well.

![Line Info pane](image)

What does the tail look like?

Oops, Paper doesn’t beat Scissors. Flip the head and the tail with the Reverse button.

Each line can have three labels, and each of them can be anywhere on the line. Select which label you’re modifying, hide or show it, then drag the sliders until you’re happy with its position.

Should the label follow the line? Or be perpendicular to it? Which would you prefer?

If you don’t want the line to show through the label’s characters, make the label stand out by filling in its background. And pick your favorite color, while you’re at it.

Heads or tails?

Since you can put an arrowhead at either end of a line, what does it matter which end is the head and which is the tail?

Well, for some graphs, it won’t. But if you’re going to use the hierarchical layout feature (see page 13), you’ll want to make sure you keep line directions consistent or you’ll get a mess.

So, for the record, the first point you make on a line is always the tail, and then you work your way to the head. When doing hierarchical layout, shapes on the tail ends of lines are put before shapes on the heads.

Hey, these don’t look like my Info panels

Yup, the toolbar is missing. If you want your Info Panel to look this way, just click on the little lozenge on the right side of its titlebar, and its toolbar will disappear.

You might want to create two or three info viewer windows (use Tools › New Info Viewer) and configure their toolbars to have just the panes you want grouped together in each window.

Or, if you have a really big screen, you could create eight Info Panels, set each one to show a different pane, and then hide their toolbars, so you can edit any property you want without ever having to click around.
The Info Panel:
Grid, Align, Layout, and Pages

Grid Info pane
Got to have everything lined up just so? Snap it all to a grid using the Grid Info pane.

Align Info pane
Grids not quite what you want? Line shapes up with each other using the Align Info pane.
Layout Info pane

The Layout Info pane: now this is cool. You can have your graph lay itself out according to rules you specify.

**Force-directed** will lay out the graph according to the three forces below.

**Object Repulsion**: how much objects don’t want to be next to each other.

Animation looks really cool but can be slow for big graphs.

Layout just the selected shapes, or the whole graph.

**Prefer a simple hierarchy?** You can pick from either vertical or horizontal (note all the options below are only for Force-directed layout).

**Line Springs**: how strongly a line between two shapes will try to pull them together.

**Canvas Edge**: how much the shapes are afraid of the sides of the document.

If your graph seems hopelessly ugly, try randomizing the start locations and clicking Layout Graph again and again until you hit on an arrangement that looks decent.

Pages Info pane

If you have a lot of information, your graph can get big pretty easily. In the Pages Info pane, you can decide how much you want it to sprawl.

**Set how many pages you want by clicking where you want your canvas to end...**

...or just type in numbers the old-fashioned way.

**Changes the scale, above, so that all the graphics on the canvas will perfectly fit on a single piece of paper (as defined in File > Page Setup...).**

**How much space do you want on the sides of the document?** Keep in mind that no printer can print all the way to the edge of its paper.

**Is that plain old white background too drab for you?** Change it! Make your life more exciting! (If your background color isn’t showing up when you export your canvas, see Preferences, page 21.)

**Changes the ratio of the sizes of the screen and the printed page; useful if you decide your diagram is too large or too small when printed.**

Simulated annealwhatnow?

There are two totally different layout algorithms in OmniGraffle, Force-directed and Hierarchical, both products of years of research we didn’t do.

**Hierarchical** layout is pretty easy to explain — OmniGraffle tries to layout your graph in the very familiar “tree” format, like an org chart or family tree. The only option you can set for this type of layout is whether OmniGraffle will automatically add or remove pages to your canvas if the new version ends up being a different size. Hierarchical layout works really well for some types of diagrams (unsurprisingly, the types that involve trees, a.k.a. “directed acyclic graphs”) but makes a total mess of others, such as more free–form diagrams with lots of lines all over. Remember the Edit > Undo command, it’s your saviour when playing with automatic layout.

**Force-directed** is in many ways the cooler algorithm, although it can be a little daunting at first because of the three force sliders. This approach is based on a concept called “simulated annealing.” It’s a neat idea that boils down to: “Wiggle the shapes around randomly a little bit, and see if they are happier in their new positions than their old ones. If not, put them back. Do this again and again until no amount of wiggling makes them any happier.”

But what makes a shape happy? Well, we tell the shapes to try to stay away from each other (**Object Repulsion**), but also to try to stay close to shapes they are connected with (**Line Springs**), and to be afraid of the edges of the canvas (**Canvas Edge**). Using the sliders you can set how strongly the shapes feel about any of these factors. It’s fun to turn on Animate Layout and experiment with the sliders... for instance, turn up the Canvas Edge force and your shapes will all cower in the center of the page. Turn up Object Repulsion and the shapes will spread out more.
The features keep coming. Once you’ve gotten a decent grasp on the earlier topics, go ahead and give these a try.

**The Selection Panel**

Oops, you made squares instead of circles. Or you printed your diagram and discovered all the lines are too thin. Will you have to select all of these objects by hand to change them? Heck no. The Selection Panel allows you to select a whole class of objects — all squares, or, for that matter, all red squares — and then modify all the objects of that class in one fell swoop. To get to the Selection Panel, use Tools > Show Selection, hit Command-0, or click on the Selection button in the toolbar.

These numbers show how many objects you have selected versus how many there are on the canvas.

You’ve only got one gray square.

You’re pretty stingy with the cyan diamonds, too.

You’ve got five curvy lines. You must have clicked on two of them, because that’s how many are selected.

---

**Navigation between text fields**

Don’t like to leave the keyboard? Well, if you just hit Tab when you’re editing a text field, you’ll start editing the next object with text in it. You’ll jump through them top to bottom, left to right.

If you start out here...

...then tab will take you here...

...and two more tabs find you here.
**Importing images**

OmniGraffle can import almost every kind of image; they can be used to fill shapes, or placed on the canvas by themselves. Just drag an image into the document from the Finder or your web browser. Dragging an image onto a shape or the image well on the **Style Info** pane will fill the shape with the image. Dragging an image onto a blank area of canvas will create a plain rectangle with no border that contains that image.

**All about magnets**

Shapes on some palettes (for instance, **Magnetized** and **FlowChart**) have magnets on them. What the heck are these?

Normally when you end a line on a shape, the line will always automatically draw itself connected to the closest edge of the shape. As you move a shape the line will move around the outside edge of the shape. This works great for a lot of types of diagrams, but for things like flowcharts, you really want to attach a line to a certain spot on a shape and have it stay there, because the meaning of the line depends on where it’s connected.

That’s where magnets come in. Magnets are spots on shapes where you connect lines so they won’t move around. When you are drawing a line to a shape with magnets you can either connect to the magnets or the shape itself. Magnets draw as little blue circles around a shape, highlight one and end a line there to connect to it. If instead you connect when the shape itself is highlighted, the line will keep itself connected to whichever magnet point is closest to it, automatically changing magnets as you move things around.

Magnets are enabled by default, but you can shut them off with **Format ▶️ Connection Magnets ▶️ Disable Magnets**. Although you can’t create arbitrary magnets in the current version of OmniGraffle, you can copy and paste them to new shapes using the options under **Format ▶️ Connection Magnets**.

---

**Keyboard shortcuts**

- Pressing 1 through 4 when not editing text will activate the selection, shape, line, or text tool, respectively.

When using the selection tool:

- If you Option-drag to select shapes, only objects completely enclosed in the selection rectangle will be selected. (Normally any object touched by the selection rectangle is selected.)
- Option-dragging a shape copies the shape and drags that instead of picking up the original. Option-dragging multiple shapes duplicates them all.
- Shift-dragging to select inverts the select — that is, if a shape inside the selection rectangle was selected, it’ll become unselected.
- Shift-clicking or Command-clicking on a shape selects the shape if it wasn’t selected, otherwise it removes the shape from the current selection.
- Holding down the Control key temporarily enables the line tool, so you can connect shapes or just create new scribbles.
- Holding down the Shift key when resizing an object causes the object to maintain its current aspect ratio as it is resized (that is, it’ll get bigger and smaller but not thinner or taller).
- Double-clicking a line adds a new point. Option-double-clicking adds a new label.
- Double-clicking a shape edits its label.

When using the shape tool:

- Holding down the Option key when dragging to create an object causes the first point you click to be the center of the new shape rather than its upper-left corner.
- Holding down the Shift key when dragging to create an object causes the shape to maintain a 1:1 aspect ratio as you resize it (e.g., the shape will fit perfectly inside a square).

When using the line tool:

- Holding down the Option key when placing a point keeps the point from attaching itself to any nearby objects. (This also works when moving a point using the selection tool.)
Not everyone has OmniGraffle. (Notably, those deprived people on that *other* platform.) For those people, you can export OmniGraffle documents to all sorts of popular, web–standard image formats.

OmniGraffle can also import files created by some other programs that we thought could use some diagramming.

**Importing other formats**

OmniGraffle can import Project Builder files, Mac OS X frameworks, Diagram 2 files, OmniOutliner files, Enterprise Objects models, and web-standard DOT files. Just open them like you would a OmniGraffle file (use the open panel or drag the file onto OmniGraffle's icon) and OmniGraffle will lay them out for you in a new document.

The new file will be given a name based on the file you’ve just imported, but if you edit and save this file *you are not replacing the original data, you’re making a new file*. Thus, for instance, OmniGraffle doesn’t try to be a substitute for Project Builder, it’s just a cool new way to view your class hierarchy.
Exporting OmniGraffle files

Exporting (File ➤ Export...) is one of the key parts of OmniGraffle. At some point, you're going to want to share your work with other people. You might just have them gather around your machine (especially if you have one of those sweet Cinema Displays), but here are some other options with tips on how to make them work:

- You want to e-mail your work to a colleague who doesn't have Mac OS X. You'll probably want to send the poor deprived soul a PDF file, since that preserves the resolution-independence of your document, so pick that option from the Export panel's popup. You could also send a PNG if you used transparency in your diagram, although printouts of this format might not look as sharp as PDF (see sidebar).

- You want to publish your work on the web. In this case you'll probably want JPEG or GIF, since those are the most recognized formats on the web. If you export as a PDF lots of people won't be able to view your document inside their browser — they'll have to load another program to see it. PNG would look the best, but some older browsers don't understand it.

- You want to use your diagram as part of a larger document you're making in another program (like InDesign, which laid out this manual, or Illustrator). If you want to stay in vector graphics you'll probably want to use PDF or EPS, but you might also use PNG or TIFF, which would be bigger and have a fixed resolution, but do the best job representing transparency.

- You want to send your diagram off to a high-quality print shop. In this case, you'll probably end up exporting PDF, since that's what most of them want, and any of the non-vector formats (TIFF, JPEG, GIF, PNG) have a specific, fixed resolution.

- You want to print your document. No need to bother exporting, just use File ➤ Print.

- You want to preview your document. Use File ➤ Print, and click the Preview button on the print panel.

The Export sheet.

Pick a format.

Image format primer

Vector formats store your objects as a series of drawing commands (“draw a curve from here to there”), so no matter how much you enlarge vector images they still look great.

- PDF is currently the most popular vector format. Its only drawback is it doesn't support transparency right now, so if your document uses transparency it'll look different in PDF.

- EPS is an older vector format that is becoming less common, but the option is there if you need it. EPS also doesn't understand transparency.

Bitmap formats store your objects the way film does, and, like film, if you enlarge them a lot they get grainy.

- TIFF represents pictures 100% faithfully and does a perfect job with transparency, but fewer programs understand TIFF than JPEG or GIF. (Photoshop does understand TIFF.)

- JPEG does a great job compressing pictures but tends to look strange with vector drawings, like the kind OmniGraffle produces. It also has no transparency.

- GIF is common as dirt and does OK with diagrams, except GIF files can only have 256 colors in them, so if you are including pictures in your diagram GIF isn't a good choice. GIF's idea of transparency is tragically simple — a pixel is either fully transparent or not, so diagrams with transparency tend to get a bit mangled when exported to GIF.

- PNG is a great and faithful format, and has an awesome transparency model, but, like TIFF, not all programs understand PNG (some web browsers don't, for example, although OmniWeb does).

What's the difference between exporting to PDF and saving the PDF from a print preview?

When you print, your document will get broken up into multiple pages, depending on your page setup and document size. When you export to PDF (or any other format) you end up with one big page.
OmniGraffle comes with palettes to help you create some common types of diagrams, but we haven’t thought of everything. Well, in a way, we did: you can make your own palettes, as well, so your options are limitless.

It’s sort of a theme with this program, isn’t it?

Creating a new palette

Select **Tools ➤ Palettes ➤ New Palette**. Now just draw some shapes in the new window as you would with any other graph. Note that, if you have the Palettes panel up, you can watch and even use your palette as you create it. If you want to create multi-part shapes that will get dragged out as one shape, group them together on your palette using **Format ➤ Group**.

Each of these shapes is now available for dragging onto any canvas from the palette window.

Note that the lines and objects in the third shape will be treated as separate shapes unless you group them all together.
Saving the palette

Save the palette wherever you like, as you would a normal document. Now whenever OmniGraffle starts up, it will add your new palette to its list of palettes.

Putting the new palette in the palette toolbar

To make the palette show up in the palette toolbar, select **Tools > Customize Toolbar** when the palette window is frontmost. You should see the palette you saved in the list of icons. Just drag its icon up onto the toolbar, and presto! You can now click on that icon to bring up your custom palette.

Further editing a palette

To edit an existing palette, either click on the **Edit** button in the palette window's toolbar, or select **Tools > Palettes > Edit Palette**. This will bring up the palette as a document which can be further edited and saved just like when you made a new palette.
Preferences. How are they created? Whenever two customers disagree on how a feature should work, a preference is born.

Because, in our world, all of our customers are right.

**General preferences**
So-called because, frankly, they don’t fit into neat categories.

These two checkboxes speak for themselves.

- Normally you’ll want to save documents as a single file, since those are easier to share than file wrappers. But if you have a lot of big images it’ll be faster to save as a file wrapper.
- Since Mac OS X 10.1 does not support transparency when printing, if you often print your diagrams you may want to turn this feature off so you aren’t tempted to use it in your diagrams.

**Drawing tools preferences**
This sets the default attributes for any given tool. Just click on a tool and use the Info Panel to change its properties, and any new document you create will get your modified toolset. (There’s actually nothing you can change for the selection tool, it’s just there for completeness.)

You could change this tool to create orange circles, if you had a hankering.
Templates preferences
If you often construct the same types of documents over and over again, you can create templates for them. Just layout an OmniGraffle document, and save it in one of the directories listed in the panel below, or make your own directory and add it to the panel. Next time you restart OmniGraffle you can select File → New from Template to create documents based on your template.

These are the places OmniGraffle will look for templates when it starts up.

Export preferences
An entire pane dedicated just to the File → Export… menu option.

What happens when I export without the background color?
OmniGraffle attempts to create an image that has transparency, or an alpha channel, as the background if you don’t save the background color for the format you are using.

For some image formats (TIFF, PNG, PDF, EPS) this works really well — your exported image can be put in front of an arbitrary background (like a patterned web page) and it’ll look great.

With GIFs, the transparent background can introduce strange artifacts; you’ll want to double-check that things came out as you expected. And with JPEGs it just doesn’t look right at all: best to leave the background on for that one.

For more on export image formats see page 17.

Templates for paper sizes
If you often create documents with different paper sizes than the ones built into Mac OS X, you can create a new template with the paper size you like. See the Advice section on page 23.
Here’s a selection of advice for using OmniGraffle that we think is useful. Some of these are questions actual users have asked us, others are questions we wish you’d ask so we just made them up.

**Q:** I have a great-looking graph in OmniGraffle, but when I export it, and then try to insert the graphic in another application’s document, the diagram comes out all fuzzy! What’s going on?

**A:** OmniGraffle lets you set the resolution that will be used when we export graphics; open up OmniGraffle’s preferences, select the **Export** pane, and change the **Export bitmaps at a resolution of** setting (see page 21).

**Q:** When I try to print an OmniGraffle document, the beautiful transparent shadows I see on the screen look different! I know I can turn them off, but I’d rather have them there, looking like I see them on my monitor...

**A:** When OmniGraffle hands a document off to Mac OS X for printing, the image is converted into Adobe's PDF format, which doesn't support transparency yet — so that information gets stripped out by OS X when the document is sent to the printer. This is what’s changing the shadows. Adobe has mentioned plans to add transparency support to PDF; once that version of PDF is worked into Apple's application frameworks, printed shadows will look more like the ones on screen. In the meantime you can export your diagram as a PNG file at the resolution of your printer (see page 21), and then print that from Mac OS X's Preview application.

**Q:** I'm typing text into OmniGraffle, and I want to break it up over several lines. How do I do that? Hitting Return ends my editing!

**A:** Easy! You can use **Edit ▶ Insert Newline**, or you can hold down the Command or Option keys while hitting Return. Incidentally, Option-Tab inserts a tab character if you want one.

**Q:** I've exported my OmniGraffle document to PDF, but when I open it up in Illustrator to do some more editing, it's all one big graphic; is there a way to break the graph up into individual elements so I can edit it further?

**A:** Yup, but one of our users had to tell us it was possible... here’s what you do: open the graph in Illustrator. You’ll see that the objects are all part of a clipping mask. If you select any object in the graph, and then release the clipping mask (**Object ▶ Clipping Mask ▶ Release**), you can now tweak the graph to your heart’s content.
Q: I want to create a huge one-page document, but when I print OmniGraffle breaks it up into multiple pages. What can I do?

A: Use the shape tool to make a rectangle in your document. Bring up Info Panel, and select the Size Info pane. Change the rectangle so it is the size of the document you're after. In the Style Info pane, set it to have a Fill of “None”, and uncheck the Line and Shadow boxes. Lock the object so lines won’t try to connect to it (Format → Lock). Finally, on the Export preferences panel, uncheck the Export with room around the graphics box. Now, just draw everything on top of this large object. When you're done you can export the file (File → Export...) and it'll be a single large page; you can print this using the Preview application or send it to a print shop. If this is a document size you're going to be using frequently, you may want to save the single large rectangle you created in one of your templates directories so you can use it as a basis for new documents (see page 21).

Q: There was this cool application called “Diagram!” that ran on my old NeXT machine. Can I use any of my Diagram! documents or palettes in OmniGraffle?

A: Sure can! OmniGraffle can open Diagram 2 files and palettes, though we can't import any attached EPS images, sounds, or links. Palette files will be initially opened as plain documents, but you can create a new palette (Tools → Palettes → New Palette), select all your old shapes (Edit → Select All), and then Option-drag them all to the new palette.

Q: It’s really cool that OmniGraffle can import Cocoa frameworks and Project Builder files. I’m unsure as to the significance of the different colors of lines and boxes. What does it all mean?

A: Categories have blue borders and lines, protocols get colored red, and if a shape has a yellow fill, it means that the class is defined outside of the project you're working in.