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Introduction to the Interface

The menu bar. Just like in any Mac OS X application, this is where you can
access all varieties of commands.
The toolbar provides easy access to the controls of your choosing. Select
Customize Toolbar from the View menu to arrange your favorite tools on the
toolbar. Most importantly, the toolbar is home to the tool palette you use to
create diagrams. You can show and hide the toolbar using the white button
on the right side of the title bar.
The Canvases Sidebar shows all of the canvases in your document and the
layers they contain. You can click a canvas to work on it in the main canvas
view.
The Outline sidebar gives a hierarchical, text-based view of the diagram on
the selected canvas. This is an excellent way to quickly create lots of objects,
connect them together, and rearrange their structure. You can also switch to
the List sidebar, which shows the front to back order of every object on every
layer of the selected canvas.
Continued on the next page

Welcome to OmniGraffle
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The canvas view is where your drawing actually happens. You can use the
drawing tools to create shapes and connect them together with lines. You can
drag objects around, group objects, make tables, and do way more stuff than
can be mentioned in this overview.
The stencils window contains lots of pre-made objects for a huge range of
purposes. OmniGraffle comes with plenty of good stencils, and you can even
search Graffletopia, an excellent third-party repository for stencils created by
OmniGraffle users.
The inspectors contain all of the controls you need to modify selected objects
on the canvas, the canvas itself, and the whole document. There are sixteen
different inspectors, organized based on the kinds of things they affect: Style,
Properties, Canvas, and Document.
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Introduction to the Interface

Drawing basics
Creating a shape
The most basic way to create a shape is with the Shape tool.
• Click the Shape tool. (Note that this tool might look different if you have
changed its style.)

• Drag across the canvas until you have a shape that is the size you want.

Selecting, resizing, and moving objects
To select an object, first make sure you are using the Selection tool (
), then click
the object. The object is highlighted, and if it can be resized, eight handles appear on
its edges and corners. Once you have selected an object you can modify it with the
inspectors or perform menu commands on it.
To select or deselect more objects without losing the selection you already have, hold
Command as you click them.
To select several adjacent objects at once, click in an empty area of the canvas and
drag a box around the objects you would like to select. If you hold Option while
dragging, you'll get only the objects that fit completely inside the rectangle.
To resize an object, first select it. Then drag one of its resize handles (the tiny
squares that appear when an object is selected) until the object is the right size.
Smart guides appear to help you size objects uniformly.
To move an object, use the Selection tool to click and hold on the object, then drag
it to its new location. Smart guides appear to help you align objects to one another.

Drawing basics
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Editing objects
Any attribute of an object can be changed using the Style and Properties inspectors:
its size, shape, color, position, and so on. When you select an object, the applicable
inspectors become available; use the inspector that deals with the attribute you
want to change. As you change the settings in the inspector, the object on the canvas
changes.
For example, say you want to change the color inside a shape object (its "fill"):
• Select the object.

• If you don't see the Fill inspector, select Fill from the Inspectors menu. Click
the color well in the upper-right of the Fill inspector.

• Use the Colors panel to choose a new fill color for the object.
• Your object has a new fill color! Yeah!!
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Basics: Editing objects

Connecting objects with lines
You can connect any two objects with the Line tool (

).

• Click the Line tool. (Note that this tool might look different if you change
its style.)

• Click the first object you would like to connect. This object becomes the
"source" of the line.
• Click the second object you would like to connect. This object becomes the

"destination" of the line.
• Once objects are connected by a line, they stay connected no matter how
much you change them or move them around. That means the logical

integrity of your diagram is preserved regardless of how you choose to style
it. You can disconnect a line from an object by selecting the line and then
dragging one of its endpoints.

Basics: Connecting objects with lines
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A Quick Tutorial
Welcome
OmniGraffle excels at clarifying complex relationships, and nothing says "complex
relationships" like a Shakespeare romantic comedy. Let's try to make some sense
of Much Ado About Nothing, and learn a bit about OmniGraffle in the process.
Of course, this play is just a handy example; if there's another story you're more
familiar with, you can go ahead and use it instead. The Tale of Genji, Steppenwolf,
The Fifth Element... Whatever works best for you.
To get started, create a fresh document by selecting Template Chooser from the File
menu; for this tutorial we'll use the "Basic" template.
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A Quick Tutorial

Tutorial 1: Creating objects with the outline view
The Drawing Basics section taught you how to create shapes and connect objects
with lines. But there's another clever way to enter data: the outline sidebar. If you've
ever used an outliner (say, OmniOutliner, a fine product indeed), this should be
familiar to you. If not, you'll probably pick it up easily anyway.
Because you chose the Basic template, the outline sidebar is already visible to the left
of the main canvas area. Click the blue outline area to create your first item. An item
called "Topic" appears in the outline, and simultaneously a shape labeled "Topic"
appears on the canvas.

Continued on the next page

Tutorial 1: Creating objects with the outline view
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The item's text is already highlighted, so you can just start typing to rename it. This
item represents our first character, so type "Don John".

Press Return to finish with this item and move on to the next one. A new item
appears below the first one in the outline, and a new shape appears on the canvas.
Name this one "Don Pedro".
Press Return once more to create a third item, and name it "Leonato". Now you
have three items in your outline and three shapes on your canvas.
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Tutorial 1: Creating objects with the outline view

Tutorial 2: Outline hierarchy
It's nice that you can create shapes quickly from the keyboard like this, but the real
magic is in adding depth to the outline. All of the characters you've created so far
exist on the same level, but now let's add some more characters one level below
them.
The next two characters are soldiers who fought under Don Pedro's command, so
we'll add them below him in the diagram. Click the Don Pedro item in the outline
to select it, then press Return to create a new item below it. Name the new item
"Benedick".

Continued on the next page

Tutorial 2: Outline hierarchy
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Now press the Tab key; Benedick in the outline becomes indented, and the corresponding shape on the canvas gets a connection line from Don Pedro. With
Benedick still selected, press Return to create another item at the same level and
name it "Claudio". Now you have two characters that "belong" to Don Pedro.

Now use the same technique to add Beatrice and Hero underneath Leonato; they're
his niece and his daughter. In the diagram, you'll see that they exist on the same level
as Benedick and Claudio, but are connected to Leonato instead of Don Pedro.
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Tutorial 2: Outline hierarchy

Tutorial 3: Line labels
To clarify the relationships we have so far, let’s use the Text tool to add labels to the
connection lines. Get out of the outline view by clicking some empty space on the
canvas.
Click the Text tool; it's the one with a letter 'A' on it. Then click it again so that it'll
stay active instead of reverting back to the selection tool after you use it.
Put the mouse pointer over the line between Don Pedro and Claudio so that the line
glows, then click it. Type "boss" into the label's text to show that Claudio works for
Don Pedro.

Continued on the next page

Tutorial 3: Line labels
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Add labels to the three remaining lines in the same way, indicating that Don Pedro is
also Benedick's "boss", and that Leonato is Hero's "father" and Beatrice's "uncle".
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Tutorial 3: Line labels

Tutorial 4: Making more connections
You've already got a fine diagram, but sometimes you want to diagram relationships
that are not strictly tree-like. Let's manually add some more connections. Before you
start connecting things together yourself, it's a good idea to turn off the automatic
layout feature. Choose Diagram Layout from the Inspectors menu to show the
relevant inspector, then deselect the Automatic Layout checkbox.

Now let's make the Line tool match the lines already on the canvas. Click and hold
the Line tool button in the tool palette, and a menu appears. Under Canvas Styles,
select the Straight, Stroke: Obsidian entry. Now the lines you make with the Line
tool will look the same as the lines that were created automatically by the outline
view.
Continued on the next page

Tutorial 4: Making more connections
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To connect two shapes, just activate the Line tool, click one shape, then click the
other shape. Make connections and label them to signify the following relationships:
Don John and Don Pedro are half-brothers; Don Pedro and Leonato are friends;
Hero and Claudio are in love; Benedick and Beatrice are (eventually) in love. As
you do this, feel free to use the Selection tool to move shapes into more comfortable
locations.

Now that the diagram is more complicated than a simple outline, you won't be
needing the outline view any more. Choose Outline from the View menu again to
hide it, or just click its icon in the toolbar.
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Tutorial 4: Making more connections

Tutorial 5: Styling objects
Look at your work so far—no literary minutia can escape your organizational prowess! Okay, so, the diagram makes sense, but it's not particularly attractive. Let's
pretty up those objects with some style attributes.
You've seen the Diagram Layout inspector, but now we're going to start using the
inspectors in earnest. They're convenient little windows full of controls that you
can use to modify any object on the canvas, or the canvas itself. There are six Style
inspectors, each one of which controls a certain element of the selected objects' appearance. The first inspector we'll use is the Fill inspector; if you don't see it on your
screen, select Fill from the Style section of the Inspectors menu. Then, select Don
John on the canvas.
Right now the selected object has a plain white fill color. Click the color well in the
inspector's upper-right corner and then use the Colors panel that appears to choose
a new fill color. If you like, you can even choose a blend style from the menu at the
left of the inspector, then choose a different color for each well that appears.

Continued on the next page

Tutorial 5: Styling objects
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Next let's use the Lines and Shapes inspector to change the line drawn around the
outside of the shape. There are six icons across the top of the Style inspectors window; click the second one to switch to the Lines and Shapes inspector. From there,
try setting the stroke thickness to 2pt, and the corner radius to 5pt. This makes for
a nice, heavy, rounded stroke around the shape. Choose a nice stroke color just like
you did for the fill color.
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Tutorial 5: Styling objects

Switch to the Text inspector and click the Font button (the one with a big letter 'A');
this summons the standard Mac OS X font panel. Choose a nice font, then click the
color well next to the Font button and choose a color to contrast the fill. Now you
should have one quite charming shape object.

Tutorial 5: Styling objects
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Tutorial 6: Style proliferation
Now you can apply the same styles to your other shapes without having to repeat
every step for each one.
With Don John still selected, look at the bottom of the main window for the style
tray. It contains all of the style attributes for the currently selected object, each one
represented by a little square "style chit". Try dragging the "All Styles" chit (the
isolated one on the far left of the style tray) and dropping it onto the Don Pedro
shape in the diagram.
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Tutorial 6: Style proliferation

Whoa! That's pretty easy. Do the same thing to Leonato so that all of the elder
generation characters have a consistent appearance.

Tutorial 6: Style proliferation
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Tutorial 7: More selecting and styling
Let's style the remaining objects. A quick way to select lots of shapes at once is with
the Selection inspector, which is part of the Canvas inspector window. If you don't
see it on your screen, select it from the Inspectors menu.
The Selection inspector lists all of the different kinds of objects on the canvas,
based on their styles. At the moment, it should show that you have one out of three
colored rectangles selected. There should also be an item representing the four plain
white rectangles with black strokes; click it to select all such objects at once, and it
changes to show that you have selected four of four such objects.
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Tutorial 7: More selecting and styling

You can use the Properties inspectors to change aspects of an object that are not
strictly related to its visual style. We'll use the Geometry inspector to change the size
of the four selected objects. If the Geometry inspector is not on your screen, select it
from the Inspectors menu. In the width and height fields, enter some new values to
make these shapes somewhat larger than the others.

Tutorial 7: More selecting and styling
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Tutorial 8: Layers
Layers contain different sets of objects on the same canvas. We'll put our background image on a new layer to keep it separate from the character diagram.
Click the Canvases button in the toolbar to see the canvases sidebar. It contains the
one canvas you have so far; click the disclosure triangle next to it to see its layers.
You only have one layer right now, so we'll add another one. Click the Add Layer
button
below the sidebar. A new layer is born. You can name it if you like;
something like "Background" should suffice.

The order of layers is important; stuff on higher layers appears in front of stuff on
lower layers. We want the background to appear behind our relationships diagram,
so drag the new layer and drop it below the other one in the list.
Let's concentrate on the background layer. The layer you're working with right now
has a pencil icon to the left of its preview in the drawer. If the background layer
doesn't have the pencil icon, click just to the left of the layer preview to put it there.
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Tutorial 8: Layers

For your background, find a nice image on one of your disks (or download one from
the Web). Drag the image file from the Finder and drop it on a blank area of the
canvas. A new shape containing the image is created on the background layer.

Continued on the next page

Tutorial 8: Layers
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Drag the selection handles on the corners of the shape to stretch it to a nice big size;
hold Shift as you drag to keep the image from getting distorted. Then use the Image
inspector to set the image's opacity to about 15%.

Now you have an attractive, informative diagram. You know how to use the outline
view to create objects, how to label and connect them, and how to add styles. You
know how to propagate styles around to many objects. You know how to use multiple layers. At this point, you're pretty much unstoppable!
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Tutorial 8: Layers

Tutorial 9: Overachievers' Corner
If you're ambitious, try getting your diagram to look like this.

It might be helpful to lock the background layer by clicking its little padlock icon
in the utility drawer; this prevents you from accidentally selecting or changing the
background image.
The title can be created with the Text tool, the style of the connection lines can be
changed from the Lines and Shapes inspector, and the positioning of the line labels
can be changed with the Geometry inspector.

About Pro features

Throughout OmniGraffle Help, features exclusive to the Professional edition appear
in a box like this one. All of the other features are available in both the Standard
and the Professional editions of OmniGraffle.

Tutorial 9: Overachievers’ Corner
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Tool palette tips
Expando-collapso technology
OmniGraffle 5 includes advanced expando-collapso technology. There's a button,
after the Text tool by default, which you can click to collapse the tool palette down
to just the leftmost items. This way you can save precious toolbar space for other
buttons, but still expand the palette and get at the rest of the tools when you really
need them.

Collapso

Expando

You can move the divider in the Drawing Tools preferences to change which tools
are available in the palette's collapsed state, or get rid of the expansion button
entirely.

Persistent tool activation
By default, clicking a tool once activates it for one use; after that one use the Selection tool becomes active again. A tiny dark blue “1” icon appears on the tool to
remind you.

To activate a tool persistently, click it again. The icon goes away to show that the
tool will stay active until you choose a different one.
You can change this behavior in the Drawing Tools preferences, so that tools are
always (or never) activated persistently.

Using OmniGraffle
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Inspecting a tool
Normally the inspectors are used to modify a selected object on the canvas. But
you can also use them to change the style of objects a tool creates. Option-click
the Shape, Pen, Line, or Text tool (or just click it, depending on the Drawing Tools
preferences); the tool button gets highlighted in your highlight color to show that
you are inspecting it.

While the tool is being inspected, any change you make applies to the tool itself. For
instance, if you make the Line tool's stroke color red, every line you draw with it
will have a red stroke.
You can always select Restore Defaults from a tool's pop-up menu to reset it.
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Inspecting a tool

Style menus
The Shape, Pen, Line, and Text tools have style menus; these contain various styles
that you can apply to the tool itself. Click the triangle in the corner of the button or
click and hold on the button to open the menu.

The very top item in the menu is the last style you set.
OmniGraffle Pro includes a Favorite Styles list, to which you can add styles you intend to reuse. You can switch freely between the current style at the top of the menu
and the styles in the favorites list. Select Duplicate Style to add a copy of the selected
style to the favorites list. Select Delete Style to remove the selected style from the favorites list. You can also add styles to the favorites list by Control- or right-clicking
an object and choosing Add to Favorites, or by Option-dragging an object from the
canvas to the tool button.
The Canvas Styles list shows the applicable styles if any exist on the canvas. If you
choose one, a copy of it will replace the current style.
Continued on the next page

Style menus
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The Stencil Styles list shows available styles from the stencil you have open. If you
choose one, a copy of it will replace the current style.
Select Inspect Style to focus the inspectors on the tool itself, so that you can change
its style.
Select Restore Defaults to return the tool's style to its original, blandest settings.

Floating tool palette
If you like, you can open a tool palette window separate from the one in the toolbar;
just choose Tool Palette from the Window menu. Drag the corner of the floating
tool palette to reshape it, and position the window near your document window to
attach it there magnetically.

Quick access to tools
Instead of clicking, you can press the number keys to activate tools. Each key from 1
to 0 corresponds to a tool in the palette, from left to right.
You can also set up hot keys in the Drawing Tools preferences.
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Floating tool palette

Selecting, moving, and editing objects with the Selection tool
The selection tool is the most basic tool; it looks like the ordinary Mac OS X
mouse pointer.

Selecting objects

Click an object on the canvas to select it.
When an object is selected, the Style and Properties inspectors become enabled. You
can use the inspectors to change anything about the selected object.
To select several objects at once, click in an empty area of the canvas and drag a box
around the objects. If you hold Option, only objects entirely inside the rectangle are
selected. Command- or Shift-click an object to add it to the selection or remove it
from the selection.
To select a member of a group, table, or subgraph, click once to select the group
as a whole, then click again to select the member. The rest of the canvas dims to
show that you are in group editing mode. Click anywhere outside the group to leave
group editing mode.

Selecting, moving, and editing objects with the Selection tool
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Moving objects
To move an object, click it with the Selection tool and drag it to a new location. If
you want to move a line, you might have to detach its end points from any objects
they're attached to. To move an object straight horizontally or vertically, hold
Shift as you drag. To rotate an object, hold Command and drag one of its selection
handles; you can also hold Shift to restrict the rotation to 15-degree increments.
To move the selected object very precisely, press the arrow keys. Hold Option or
Shift to move by larger steps.
If you have smart guides enabled, they appear as you drag to help you line up objects and space them evenly. Hold Command after you start dragging to temporarily
enable or disable smart guides.
To drag a copy of an object instead of the object itself, hold Option as you drag.

Resizing objects
When you select something resizable, like a shape or a group, it gains eight selection
handles. Drag one of these handles to change the shape's size. Hold Shift while
resizing the object to maintain the aspect ratio— that is, to avoid squishing it. Hold
Option while resizing an object to keep it centered on the same point.
If you select a table, the edge handles look like little grids. You can drag them to
change the number of rows or columns in the table. Drag the corner handles to
resize the table normally.
If you have smart guides enabled, they appear as you drag to help you size objects
equally. Hold Command after you start dragging to temporarily enable or disable
smart guides.

Extending the diagram
To create a child of the selected object, Command-click an empty spot on the canvas. To create a sibling, Command-Option-click an empty spot on the canvas. The
new shape uses the same style as the original shape. The line connecting the shapes
uses the style of a line already connected to the original shape; if no lines already
existed, it uses the Line tool's current style.
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Moving objects

Editing points
When you select a connection line or a custom shape, it shows the points that define
its shape; these points appear as tiny diamonds.
Any line (created with the Line tool) has two points: a red one at its source and
a green one at its destination. A line may also pass through any number of blue
midpoints. Drag one of the points to move it; by dragging the source or destination
point you can make the line connect to or disconnect from other objects.
Custom shapes (created with the Pen tool) and Bezier-type lines have control points
at each vertex. Click a control point to select it; if a control point is hiding behind a
selection handle, Option-Command-click to select it, or just select a different control
point first to make the handles go away. If a control point has bezier handles, they
appear when you select the point. Drag either of the two handles to adjust both, or
Option-drag to adjust them one at a time. Shift-drag to constrain the handle's angle
to 45-degree increments. Command-drag a point to give it handles. If you drag a
handle close enough to the point itself, the handle disappears entirely.
The default way to add points to an existing line is to double-click the line, but this
can be changed in the General preferences.
To add a point to a custom shape, double-click somewhere along the shape's stroke.
To delete a point from a line or a custom shape, select it and then either press the
Delete key or select Delete from the Edit menu.

Editing points
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Creating shapes with the Shape tool
This tool is quite simple; use it to create shape objects. Drag across the canvas until you get the size you want.

Hold Shift while dragging to make a shape of equal width and height (a perfect
square, a perfect circle, and so on).
Once you have created a shape, you can select it and change its attributes with the
Style and Properties inspectors.
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Creating shapes with the Shape tool

Connecting objects with the Line tool
Use the Line tool to make logical connections between objects. Connected
objects stay connected unless you disconnect them, no matter how much you
move them around or change them.

To create a new line:
• Click where you would like the source of the line; this can be an object (to
which the line will stay attached) or an empty spot on the canvas (so the
beginning of the line remains unattached).
• Click as many empty spots on the canvas as you like to give the line midpoints.
• End the line at an object by clicking the object (to which the line will stay
attached), or end the line at an empty spot on the canvas by double-clicking
there (this can be changed in the Drawing Tools preferences).
Hold Shift while drawing a line to constrain the next point to angles at 45 degree
increments from the previous point. Hold Option while drawing a line to prevent it
from connecting to objects.
When two objects are connected by a line, the object at the source is considered the
parent of the object at the destination. This defines the objects' relationship in the
outline view and when you use automatic layout.
Lines can have labels attached to them. Click a line with the Text tool to create a
new text label. Or, drag an existing shape to the line until the line is highlighted,
then drop it to attach it as a label.
Connecting objects with the Line tool
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Creating and editing text with the Text tool
Use the text tool to add a label to an object, to edit the label on an object, or
to create a new shape with text inside.

Click a shape to start editing its text. While you are in text editing mode, the
top ruler becomes a text ruler, and you can use standard Mac OS X text editing
commands (for example, you can use the arrow keys to move the insertion point
around).
Click or drag in an empty area of the canvas to create a new shape with settings
particularly suited to containing text. A single click creates an object that expands
horizontally to fit the text you enter; a drag creates an object of a specific width.
Remember that the objects you create in this way are not fundamentally different
from other shapes; they just start with certain settings in the Text inspector which
make them convenient for containing text.
Click a connection line to add a new label to it. This label is just like the object created when you click an empty area of the canvas, except it is attached as a line label.
Text inside objects can be found by Mac OS X's Spotlight search feature, in case you
need to find your OmniGraffle diagrams that contain certain words.
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Creating and editing text with the Text tool

Drawing your own shapes with the Pen tool
Use this tool to create custom shapes. We've included a lot of nice shapes in
the Lines and Shapes inspector and on the stencils, but perhaps you would
like to draw your own.

To start a new shape, click anywhere on the canvas. Each subsequent click adds
a new point to the shape, until you double-click or press Return to make the final
point. At any point, instead of clicking, you can drag to create a point with bezier
handles. While creating a shape, you can press Delete to remove the last point you
added.
Bezier handles can define virtually any shape, once you get the hang of them. Each
point can have a handle facing the next point, and a handle facing the previous
point. The line between two points is defined by the first point's forward-facing
handle and the second point's backward-facing handle. With no handles at all, you
get a perfectly straight line. With handles, the line between them is a curve that tries
to compromise between the handles' length and direction. This is truly one of those
things that makes a ton more sense once you try it for yourself, so please do.
Once you have created a shape, you can select it with the Selection tool (See the
Selection Tool section for details) and edit its points, adjust existing handles, add
handles to points without them, or change the shape’s attributes with the Style and
Properties inspectors.

Drawing your own shapes with the Pen tool
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Rapidly creating structure with the Diagramming tool
This tool is for rapidly creating new objects on the canvas. This tool is especially fun if you have automatic layout turned on.

If you have nothing selected, click any empty spot on the canvas to create a new
generic shape there and select it.
Once you have a shape selected, click any empty spot on the canvas to create a new
shape connected to the original one. Hold Option to create a sibling (connected to
the same parent as the selected shape) instead. Hold Shift to add an aunt (essentially
reversing the connection line of the new object), or hold Command to create a completely disconnected shape.
Click an existing shape to select it, so that you can use it as a starting point for
creating more connected shapes.
Once you get the hang of the modifier keys, you can create really complex diagrams
with just a few clicks.

42

Rapidly creating structure with the Diagramming tool

Replicating styles with the Style Brush tool
Use this tool to replicate styles. When you first open OmniGraffle, the Style
Brush tool is empty, and its cursor has arrows showing that you can absorb a
style. Select it and click any object on the canvas to absorb the object's style
into the brush. Once the brush contains a style, you can click any object to
replace the object's style with the style in the brush.

The tool's pop-up menu contains a list of styles that can be absorbed; select
whichever ones you like, and the brush will only absorb or apply those styles. For
example, if you only select Fill, you can apply a certain fill style to objects without
affecting any of their other styles.
To reset the contents of the brush, select Clear Contents from the tool's pop-up
menu; you can then absorb a new style. You can also Option-click a different object
to replace the brush's contents.

Replicating styles with the Style Brush tool
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Duplicating objects with the Rubber Stamp tool
Use this tool to replicate objects. When you first open OmniGraffle, the Rubber Stamp tool is empty, and the dot on its front is hollow. Select it and click
any object on the canvas to grab the object into the stamp; the dot becomes
filled. Once the stamp contains an object, each click on the canvas creates a
new copy of the object.

To reset the contents of the stamp, select Clear Contents from the tool's pop-up
menu; you can then grab a new object. You can also Option-click a different object
to replace the stamp's contents.
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Duplicating objects with the Rubber Stamp tool

Adding and adjusting connections with the Magnet tool
Use this tool to add magnets to a shape or to edit a shape's existing magnets.

Magnets are special spots on a shape that attract connection lines. If there are no
magnets on a shape, all lines connect to the shape's center. If there is at least one
magnet, each connected line is attracted to the nearest one. Generally, the magnet
position presets in the Connections inspector should be good enough, but sometimes
you might want to put magnets in very specific places on a shape.
Even if you haven't turned on Show Magnets in the View menu, an object's magnets
become visible when you put the pointer over it with the magnet tool. Click and
drag an existing magnet to move it, click a spot with no magnet to create one, or
Option-click a magnet to delete it.

Adding and adjusting connections with the Magnet tool
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Getting a closer look at the canvas with the Zoom tool
Use the Zoom tool to get a nearer or farther view of the canvas.

Click anywhere on the canvas to center on that point and double the zoom percentage. Option-click anywhere on the canvas to center on that point and halve the
zoom percentage.
Click and drag a box across the canvas to specify the rectangle you would like to
zoom to; the shading shows the area that will be visible in the window when you let
go. If you hold Option and then drag, the rectangle is centered on the spot where
you start dragging. While dragging, you can hold Shift to move the rectangle around
instead of resizing it.
Shift-click the zoom tool in the tool palette to return to 100% zoom, "actual size".
You can always zoom to a specific percentage with the zoom menu in the lower-right
of the canvas window.
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Getting a closer look at the canvas with the Zoom tool

Moving the canvas around with the Hand tool
Use this tool to drag your view of the canvas around, to see part of the
canvas that is out of sight. Click anywhere on the canvas and drag to move
the view.

Moving the canvas around with the Hand tool
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Activating scripted objects with the Browse tool
Use the Browse tool to work with interactive OmniGraffle documents.

When you click an object, it performs its action as set in the Action inspector. An
object with no action does nothing when clicked.
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Activating scripted objects with the Browse tool

About objects
Shapes

A shape is a two-dimensional object that can contain text, and can be filled with
colors and images. You can make shapes with the Shape tool or the Pen tool, or
drag them from stencils. You can also use the Text tool to create shape objects that
are especially useful for containing text.
You can select a shape with the Selection tool, then use the inspectors to edit it. You
can also use the Selection tool to move, resize, or rotate a shape. If you have custom
shapes drawn with the Pen tool, you can use the Selection tool to edit their points.

Lines

Lines can make logical associations between objects. You can make lines with the
Line tool. Each line has a direction; it travels from its source to its destination, passing through its midpoints along the way.
Continued on the next page

About objects
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You can select a connection line with the Selection tool, then use the inspectors (particularly the Lines and Shapes inspector) to edit it. You can also use the Selection
tool to move a line's points or connect it to an object.
Lines can have shapes attached to them as labels; see the Line Labels section for
details.
Note that you can also use lines without connecting them to anything at all. To
prevent a line from trying to connect to objects, select it and use the Connections
inspector to disable connections.

Connecting shapes
On the Connections stencil included with OmniGraffle 5 is a new kind of object:
connecting shapes. These are objects that can be styled like shapes, but connected to
objects like lines.
To add a connecting shape to your document, just drag one from the Connections
stencil and then style it however you like.
When you select a connecting shape, notice that it has a red “source” handle and a
green “destination” handle just like a connection line. Drag one of these handles to
another object to make a connection. The shape stretches and reorients to stay connected just like a line, but can have a shape and a fill just like a shape. How about
that!

Smart arrows
Furthermore, the various arrow shapes in OmniGraffle 5 have some smart behavior,
whether they are connecting shapes or not. When you resize an arrow shape, it tries
to keep its arrowheads the same size, rather than stretching them along with the rest
of the shape. If you want to change the size of the arrowheads or the thickness of
the stem, click the blue handle in the crook of the arrowhead and drag.
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Connecting shapes

Line labels

A line label is a shape object that has been attached to a line.
When you click a connection line with the Text tool, a line label is created. But this
is not the only way to create one. Any shape object can become a line label; drag
a shape to a line and drop it there when the line becomes highlighted. This works
only if the line is set in the Connections inspector to allow labels. A line label can be
removed by dragging it away from the line.
A line label stays attached to its line until you remove it; this means you can move
or reroute the line without losing the labels.
You can change the position and orientation of a line label with the Geometry
inspector. You can also press the arrow keys to adjust the location and offset of the
selected line label; note that the Right arrow always means “toward the head of the
line”, regardless of whether the line is pointing to the right or not.

Groups

Several objects can be grouped together. Select two or more objects and use the
Arrange ‣ Group menu command to turn them into a group. A group behaves like a
single object; you can select it, move it around, resize it, use inspectors to change its
style and properties, connect lines to it, and so on. Any objects can be grouped, even
a group.
Click once to select the group as a whole, then click again to select an individual
member of the group. You can keep clicking to select members of groups within
groups.
To take apart a group, select it and use the Arrange ‣ Ungroup command.

Line labels
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Tables [Pro feature]
A table is a special kind of group that organizes rows and columns of objects.
To make a table:
• Create a single shape object to be the first cell of your table.
• With the object selected, choose Arrange ‣ Make Table. Your object is now a
1 x 1 table.
• Drag the right-side table handle to the right to add columns.
• Drag the bottom table handle down to add rows.

You can also select a number of already-existing objects and then use the Make
Table command; OmniGraffle rearranges the objects into rows and columns as best
it can.
Table cells can't be rotated, and when you create a table the objects you use are reset
to zero degrees of rotation.
Table cells can be selected and edited just like group members. If you resize a cell,
the rest of the cells in its row and column resize accordingly. When selecting cells,
you can Shift-click to select everything between the cell you click and the last cell
you selected.
You can add or remove rows or columns at any time by dragging the table handles
outward or inward. Resize the table as a whole by dragging the ordinary corner
handles.
There is an Edit ‣ Tables submenu which contains commands you can use when you
have a table cell selected.
To disassemble a table, select it and choose Ungroup from the Arrange menu.
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Tables

Subgraphs [Pro feature]
A subgraph is a special kind of group that can be expanded to show the hierarchy
inside it, or collapsed to make it a single compact object.
To make a subgraph:
• Select some objects on the canvas.
• With the objects selected, choose Arrange ‣ Group as Subgraph. Your objects
are enclosed by a subgraph rectangle.
• Style and label the enclosing rectangle however you like.
To collapse a subgraph, select it and then choose Collapse Subgraph from the Arrange menu (or from the contextual menu that appears when you right- or Controlclick the subgraph). The objects contained in the subgraph are hidden away, and
the subgraph becomes a single object. Any incoming or outgoing connection lines
belonging to objects in the subgraph become incoming or outgoing lines of the collapsed object itself.

Subgraph members can be selected and edited just like group members: click once to
select the subgraph, then click again to select a member inside.
You can resize the containing rectangle, as long as you don't make it too small to
contain its member objects.
To disassemble a subgraph, select it and choose Ungroup from the Arrange menu.

Subgraphs
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About canvases and layers
Using canvases
The canvas is your work area, where you create, edit, and move objects. Any document contains at least one canvas, and you can create as many as you like (and thus
have as many separate work areas as you like) in the same document.

The Canvases sidebar
The canvases in your document are listed in the canvases sidebar. To open it, select
Canvases from the View menu or click the Canvases toolbar button. Each canvas
has a title, a disclosure triangle for showing its layers, and a preview image.
To select a canvas, click its name or preview. The canvas appears in the document
window, where you can add and edit objects.
To rename a canvas, double-click its name in the sidebar.
To create a new canvas, click the new canvas button at the bottom of the sidebar.
To delete a canvas, select it and then press the Delete key or choose Delete Canvas
from the Action pop-up menu at the bottom of the sidebar. Any document needs at
least one canvas, so you can't delete the last one.

Canvases can be dragged around to rearrange their order, or to copy them between
documents.
To change the style attributes of a canvas, first click its preview in the sidebar; it
becomes highlighted in color rather than in gray to show that you are now working
in the sidebar rather than the main canvas area. While the canvas is highlighted
in color, use the Fill inspector, Lines and Shapes inspector, and Image inspector to
change its style.
To change other attributes of the currently selected canvas, like size, units, grid,
or automatic layout, whether you're working in the canvas sidebar or not, use the
Canvas Size inspector, Grid inspector, and Diagram Layout inspector.
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About canvases and layers

Drawing on layers
The layers of a canvas are listed in the canvases sidebar. To open it, select Canvases
from the View menu or click the Canvases toolbar button.
Click the disclosure triangle next to a canvas to see its layers. Layers are transparent,
so behind the top layer's contents you see the second layer's contents, and so on to
the contents of the bottom layer.
Each layer in the list has a small preview of its contents, a title, and when you put
the mouse pointer over it, three icons. The layer you are currently editing has a
pencil icon to its left. To edit a different layer, click just to the left of its preview
and the pencil icon moves there.
To make a layer visible or invisible, click its eye icon . To set whether a layer appears when the canvas is printed, click its printer icon . To lock or unlock a layer,
click its padlock icon . Locking a layer prevents its contents from being changed.
You can rearrange layers by dragging them in the list. You can also drag a layer to
move a it to a different canvas; Option-drag to copy it instead. If you drag it to a
completely different document, it will always be copied there.
To add a new layer click the new layer button at the bottom of the canvases drawer.

To delete a layer, select it and then press the Delete key or choose Delete Layer from
the Action pop-up menu at the bottom of the sidebar. Any canvas needs at least one
layer, so you can't delete the last one.

Drawing on layers
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Sharing layers between canvases [Pro feature]
You can share a layer between multiple canvases. That way, whenever you change
the layer, it affects every canvas that shares that layer.
To share a layer between canvases:
• Choose New Shared Layer from the Action pop-up menu at the bottom of
the canvases sidebar.
• The shared layer appears in a distinctive color and with a shared-layer icon
to the left, to remind you of its special nature. The exact color depends on
your highlight color as set in the Appearance pane of Mac OS X System
Preferences; for example if you use the default blue highlight color, your
shared layers are orange.
Add and edit objects on the layer normally.
Whenever you want to start sharing the layer, just drag it to any other canvas in
the sidebar. Another copy of the shared layer appears inside that canvas. You can
reorder the shared layers freely.
Any further changes you make to any copy of the layer are also applied to all other
copies of it.
Objects on shared layers, the corresponding items in the list sidebar, and shared
layer previews in the canvases sidebar all appear in the distinctive shared layer
color, to remind you that you could be affecting many canvases if you edit them.

You can remove a copy of a shared layer from a canvas by deleting it normally.
If you delete the last copy of a shared layer, it is deleted completely. There is also
a Delete All Copies command in the Aciton pop-up menu at the bottom of the
canvases sidebar.
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Sharing layers between canvases

Using inspectors to edit objects
Inspector tips
The inspectors are floating windows which contain information and controls related
to what's selected in the main window. If you don't see them, click the Inspect button in the toolbar, or pick one from the Inspectors menu.
You can show and hide an inspector's various sections by clicking the icons at the
top of each inspector window. Hold Command while clicking to open an inspector
section without closing the ones already open.
Each of the four inspector windows contains several different sections you can view;
just click one of the icons across the top of the window to switch to that inspector,
then click the icon again to hide the inspector. If you want to view more than one
inspector in the same window, hold Command while you click their icons, or drag
across several icons.
If there's a particular inspector section you find yourself needing to use quite a bit,
you can lock it in the open position. Just double-click the section's button instead of
single-clicking it; the button gets a green lock icon. As you show and hide other sections in the same inspector window, the locked section remains visible. When you're
done, just double-click the button again and the lock icon goes away.
In all of the inspectors, you can click in a text field that contains a number, then
press the up or down arrow keys to increment or decrement the number. Also, once
you click a circular rotation control, you can keep the mouse button held down
while moving the pointer away from the control to gain more rotational precision.
Any color well can have its color dragged to an object on the canvas or to another
color well. When you drag to an object, you can drop the color on the object's
stroke, fill, or text.
In places where you can enter measurements, such as in the Geometry inspector,
values are shown in the current ruler units, or, if there is no unit scale, in the canvas
units. You can, however, enter values in any units that are available in the ruler. As
soon as you finish entering the value, OmniGraffle automatically converts it to the
correct units.
You can also perform simple arithmetic and mix units. Add (+), subtract (-), multiply (*), or divide (/) numbers right in the input fields.

Using inspectors to edit objects
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Coloring shapes with the Fill inspector

Use the Fill inspector to choose a color or gradient to fill the inside of the selected
shapes.
The Fill checkbox determines whether the shape should have a fill at all.
When it is selected, controls for choosing the type of fill become available.
Use the pop-up menu on the left side of the inspector to choose from the five
kinds of fill: Solid, Linear Blend, Radial Blend, Double Linear Blend, and
Double Radial Blend.
The blend rotation control becomes active when you choose a linear blend;
enter a number of degrees in the field or drag the circular control to set the
angle of the gradient. The blend position control becomes active when you
choose a radial gradient; drag its crosshair to move the gradient's center.
Click the color well to choose the color of the fill.
If you have chosen a two-color blend, you can click the swap button to
exchange the two colors.
If you choose a blend, two or three color wells become available. Click them
to choose the colors to blend together.
Drag the bias slider on the far right to shift a blend toward one side or the
other.
You can also edit the fill color of a canvas itself. Just click the canvas in the sidebar
(so that it becomes highlighted in your selection color), then use the Fill inspector
normally.
OmniGraffle Pro offers an extra section in the Color panel for creating pattern
fills.

58

Coloring shapes with the Fill inspector

Using the Lines and Shapes inspector

Use the Lines and Shapes inspector to change the appearance of the selected connection lines or of the line drawn around the edge of the selected shapes.
The Stroke checkbox determines whether the path of the connection line or the
outside of the shape should be traced with a stroke at all. When it is selected,
controls become available for changing the appearance of the stroke.
Two buttons determine whether to draw a single stroke or a double stroke.
Click the color well to choose a color for the stroke.
Enter a number in the Thickness field or use the arrow buttons next to it to
choose how thick the stroke should be.
Use the Corner Radius field to set how round the corners of the shape or line
should be; enter 0 for perfectly pointy corners.
The first of the three pop-up menus determines the stroke pattern (solid, dashed,
dotted, et cetera). The center pop-up menu determines how the stroke appears
at its ends: The Butt option ends the line by cutting across its endpoint at an
angle perpendicular to the line itself, while the Round and Square options let
the line extend past its endpoint based on the stroke width. The third pop-up
menu determines how the stroke appears at its corners: Miter creates a sharp
corner, Round creates a soft corner, and Bevel creates a cut-off corner.
The bottom section changes depending on what kind of object you have
selected.
Continued on the next page

Using the Lines and Shapes inspector
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If you have a shape object selected:
• A grid containing the available shapes appears. It includes all of OmniGraffle's built-in shapes plus all of the current canvas's custom shapes (ones
created with the pen tool or shape combinations).
If you have a connection line selected:
• The three pop-up menus determine the style of the tail, middle, and head of
the line. Use the tail and head menus to set the line endings. Use the middle
menu to set how the line travels from its source to its destination: Straight
for a line that takes the shortest possible path between points, Curved for a
line that turns smoothly to pass through each point, Orthogonal for a line
that always travels horizontally or vertically, or Bezier for a line with control
points you can adjust with the selection tool.
• Use the fields below the tail and head menus to change the line ending sizes.
Click the reverse button to swap the line's source and destination points.
• Click Remove Midpoints to get rid of all points between the source and
destination points.
• The Line Hops menu determines what the line should do when it crosses
other lines; choose one of the hop types to make the line jump over or under
other lines, or choose Ignore this line to prevent other lines from hopping
over or under it. The hops depend on the ordering of the lines involved; you
can reorder objects with the Bring and Send commands in the Arrange menu.
• You can also edit the stroke of a canvas itself. Just click the canvas in the
sidebar (so that it becomes highlighted in your selection color), then use the
enabled controls in the Stroke inspector.
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Using the Lines and Shapes inspector

Making objects cast shadows with the Shadow inspector

Use the Shadow inspector to drop a shadow behind the selected objects.
The Shadow checkbox determines whether the object should cast a shadow.
When it's selected, controls become available for changing the appearance of
the shadow.
Drag the blur slider to make the shadow sharper or fuzzier.
Click a button to choose whether the shadow appears in front of objects or
behind objects on the same layer. If you choose to let shadows appear in front
of objects on the same layer, the ordering of objects matters; you can reorder
objects with the Bring and Send commands in the Arrange menu.
Drag the crosshair in the offset control or enter numbers in the offset fields to
set how far away from the object the shadow should fall.
Click the color well in the upper-right to choose a color for the shadow;
partially transparent black tends to work best.

Making objects cast shadows with the Shadow inspector
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Placing graphics inside a shape with the Image inspector

You can use this inspector to position an image inside a shape. (Note that instead
of creating an object and then adding an image, you could also simply drag an image file from another application straight onto the canvas.)
Use the Image pop-up menu to set an image in the selected shape. Once an
image is set, a Remove Image command appears in the menu.
When you browse for an image file, you have the option of creating an alias
(or "link") to the image instead of adding the image to the OmniGraffle file
itself. If you do this, the OmniGraffle document depends on the original image file; the alias will not work if you delete the image file or open the document on a different computer. If an object's image comes from an alias, some
extra commands become available in the Image pop-up menu: you can Open
the original image file, Reveal the original file in the Finder, or stop using the
alias and Embed a copy of the image in the OmniGraffle document.
Another way to set an image is just to drag an image file from another application and drop it on the image well, or on the shape object itself.
The first button displays the image at its natural aspect ratio, with a zoom
level and position as set with the controls below. The second button makes
the image stretch to fit inside the object. The third button makes the image
tile indefinitely across the object.
The positioning offsets are enabled if you are displaying the image at its natural aspect ratio, as set by the first of the three buttons above. You can type a
positive or negative percentage, or just drag the image around in the image
well to indicate the area you want.
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Placing graphics inside a shape with the Image inspector

The zoom controls are available unless you are stretching the image to fit the
shape. You can enter a zoom percentage, or just drag the slider, to make the
image larger or smaller.
You can make the image transparent and let the object's fill show through by
decreasing the value of the opacity field, or by dragging the opacity slider.
You can also add an image to a canvas. Just click the canvas in the sidebar (so
that it becomes highlighted in your selection color), then use the Image inspector
normally.

Placing graphics inside a shape with the Image inspector
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Positioning and styling text with the Text inspector

Use this inspector to control the positioning and appearance of the selected shape's
text.
With the horizontal alignment buttons, you can align left, center, align right,
or justify the text.
Click the font button to choose a font face and size.
Click the color well to choose a font color.
There are three buttons for controlling what happens when the shape
contains more text than can be contained within its bounds. You can choose
to let the text overflow outside of the shape, to clip off the text that doesn't
fit inside the shape, or to resize the shape to make the text fit. If you choose
resize, the object will only be manually resizable in the horizontal direction; it
will resize vertically according to its text. Select the Wrap to shape checkbox
to limit the text's width to the limits set by the Text Offset settings below.
There are three buttons for setting the vertical alignment of the text; choose
to align to the top, middle, or bottom of the shape.
On the right side are controls for setting the Kerning (automatic character
spacing for ideal balance), Tracking (manual character spacing), Leading
(distance between lines), and Margins (distance between text and the edges of
the text area). These controls become enabled or disabled depending on other
controls in the inspector, or the amount of text in the object.
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Positioning and styling text with the Text inspector

In OmniGraffle Pro, at the bottom of the inspector is a box containing Text
Offset and Text Rotation controls. The X, Y, Width, and Height fields create
a box, relative to the shape itself, into which the text goes. Select the Use
default offsets checkbox to put the text in a box that begins at the upper-left
corner (X and Y at 0%) and covers the entire shape (Width and Height at
100%). Deselect the checkbox to enter your own values.
Also in OmniGraffle Pro, the text's rotation value in degrees can be Relative
to the object's own rotation (as set in the Geometry inspector) or Absolute.
Enter a rotation value in the field or drag the circular control to rotate the
text.

Positioning and styling text with the Text inspector
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Changing object position and size with the Geometry inspector

This inspector deals with objects’ position and orientation.
The X and Y fields contain the selected objects' horizontal and vertical
coordinates; the value represents the distance between the canvas's origin and
the upper-left corner of the object (which might not be obvious if the object is
rotated or flipped). If you have multiple objects selected, two hyphens (--) appears in the fields that have different values. You can enter a new X or Y value
for the selected objects to move them on the canvas.
The Width and Height fields contain the selected objects' horizontal and vertical size. If you have multiple objects selected, two hyphens (--) appear in the
fields that have different values. You can enter a new width or height value for
the selected objects to resize them on the canvas. If the Maintain aspect ratio
checkbox is selected, then when you change the height or width, the other
value changes proportionally.
To rotate the object, enter a degree value in the rotation field, or drag the
circular control.
Click the flip buttons to reverse the object vertically or horizontally.
Below the separator are controls for dealing with line labels; they become
active when you select a line label. Drag the Label Location slider to move
the label along the length of the line. Drag the Label Offset slider to move the
label perpendicular to the line. Use the pop-up menu to select the label's rotation: Parallel and Perpendicular set the rotation relative to the line, and the
rest set the rotation independently.
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Changing object position and size with the Geometry inspector

Changing the way objects connect with the Connections inspector
Use this inspector to control how objects connect to one another.
Deselect the Allow connections from lines checkbox to make it impossible for connection lines to use the selected objects as sources or destinations.
If you have a group or a table selected, you can choose whether connection lines
should be allowed to connect to objects in the group or only to the group as a
whole.
The pop-up menu contains a bunch of magnet presets you can choose for the
selected shape object. Magnets are points on a shape object that attract connection
lines. You can choose to have no magnets, magnets placed according to cardinal
directions (North, South, East, and West), magnets on each vertex (corner), or a
certain number of magnets on each side of the shape.
If you select some number of magnets per side, then hold Shift while opening the
pop-up menu and selecting another number, the two numbers are added together;
you can get up to 10 magnets per side in this way.
Of course, you can always use the Magnet tool to customize a shape's magnet arrangement.
If you have a line selected, the Lines checkboxes become available. Deselect the Allow connections to other objects checkbox to make it impossible for the line to have
an object as its source or destination. Deselect the Allow shapes to become labels
checkbox to make it impossible to drag a shape onto the line and make it a line
label; existing labels stay attached.

Changing the way objects connect with the Connections inspector
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Making objects interactive with the Action inspector
This inspector determines what should happen when someone clicks the selected
object with the Browse tool.
The default action is Does Nothing. You can click the object all you want, and nothing happens.
If you choose Opens a URL or Opens a file, you get a text field and two buttons.
You can type a URL or file path into the field, or drag a file to the panel, or click the
Choose File... button to browse your disks for a file. Note that file paths are relative:
they start from the folder containing the document you're working on, not from the
root of your hard drive. Click the Open button to try opening the file or URL in the
field. When the object is clicked, the file or URL is opened.
If you choose Runs a script, you get a text field for entering an AppleScript. The
script that you enter is run such that "self" refers to the clicked object. Click the
Check Syntax button to make sure that the AppleScript is correct, then click Run
Script to try it out. When the object is clicked, the script runs.
If you choose Jumps elsewhere, you get another pop-up menu for choosing where
in the current document to jump. You can jump to a specific canvas, the next or
previous canvas, or a specific point or object on any canvas. Some of these options
offer a tiny canvas preview, in which you can click or drag to indicate which object
to highlight, which point to center on, or where to zoom.
If you choose Shows or Hides Layers, you can indicate whether to show, hide, or
toggle the visibility of any layer of the current canvas.

Adding data to objects with the Note inspector [Pro feature]
The Note inspector contains a field for entering text to associate with the selected
object, and a table of custom data.
The note can be formatted as Rich Text, which means you can use all of the different font styles and colors that you can use elsewhere in OmniGraffle. When you put
the pointer over an object with a note, the note’s text appears in a help tag floating
over the object.
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Making objects interactive with the Action inspector

You can use the custom data table to keep your own information about the project
or about individual objects. Custom data is stored as key/value pairs: the Key is like
a label for what type of information you are storing, and the Value is the information itself.
For example, imagine you have a diagram of a computer network, and you want to
assign a model number to each component. Click the placeholder row or the plus
button to create a new key/value pair. In the Key column, you would type Part
Number, and in the Value field, you would type, say, A1181. This data doesn’t have
any effect on the way OmniGraffle works; it’s just a way for you to store arbitrary
data about objects in your diagram. To delete a row of data, click the ‘x’ button on
the right side of the row.
You can also edit the note of a canvas itself. Just click the canvas in the sidebar (so
that it becomes highlighted in your selection color), then use the Note inspector
normally.
Notes can be found by Mac OS X’s Spotlight search feature, in case you need to find
your OmniGraffle diagrams that contain certain words.

Adding data to objects with the Note inspector
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Changing the canvas size and scale with the Canvas Size inspector
Use this inspector to change the size of the canvas, how the canvas fits onto printed
pages, or what kind of measurement units to use.
The Canvas Size fields control the width and height of the canvas. You can use any
of the units available in the Ruler, or enter a number of pages.
Select Size is multiple of printer sheets to make the edges of the canvas snap to the
edges of pages. This prevents the canvas from ending in the middle of a page.
If you select Auto-adjust the canvas size, the canvas will grow or shrink to fit the
objects you create.
When you print, if Print canvas on one printer sheet is selected, the canvas gets
scaled up or down to fit a single piece of paper regardless of its size on the screen.
The Orientation of pages can be portrait (vertical), landscape (horizontal), or can
be taken from the settings in Page Setup.
• Ruler Units
The Ruler Units pop-up menu is where you set the type of measurement
units you’d like to use for the current canvas. All of OmniGraffle’s supported
units are listed, with their standard abbreviations.
The actual size of your diagram does not change when you change the units;
it is merely measured differently. The ruler and the inspectors display measurements in whichever unit you select here.
Units marked with an asterisk (*) can be used as canvas units. This means
that when you set up a unit scale (see below), only these units can be used on
the left-side “actual size” part of the equation. Any kind of units can be used
on the right-side “theoretical size” part of the scale equation.
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Changing the canvas size and scale with the Canvas Size inspector

• Unit Scale [Pro feature]
The Unit scale control can interpret simple expressions of scale. Several useful scales, such as 1 in = 1 ft, are available, and you can also enter your own
scale by choosing Custom.
For example, say you enter 1 cm = 1 m. What was 1 centimeter on the
ruler now becomes 1 meter, objects on the canvas that were 2 centimeters
wide now become 2 meters wide, and so on. The units setting changes to
match the second value in the equation.
You can also enter a ratio. Imagine that you enter 1:12. The ruler units stay
the same, but objects on the canvas now claim to be 12 times larger than
they were before you changed the scale.
To change the scale back to normal and treat the ruler and objects as “actual
size”, select Reset Scale from the Unit scale pop-up menu.
If you already have a scale set up and you convert directly to a different one, the
objects change their actual size on the canvas to fit the new scale. For example,
imagine you are working in 1 cm = 1 m, and then you convert the scale to 2 cm
= 1 m. The marks on the ruler become twice as far apart as they were, and the
objects on the canvas, staying true to the ruler, grow twice as large on the screen.
You can get a new scale without resizing the objects by choosing from the Reset
Scale To: section of the Unit scale pop-up menu.
By default, the very upper-left corner of a canvas is its origin (that is, the point
where the rulers’ measurements start from, where the coordinates are 0,0). To
change the origin, enter values in the two Origin fields. (You can also drag the
origin from the corner where the rulers meet.) The coordinates in the Geometry
inspector are based on this origin point.

Changing the canvas size and scale with the Canvas Size inspector
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Setting up a grid with the Grid inspector
Use this inspector to set up a grid on the canvas, so you can keep objects lined up
nicely.
The Major Grid Spacing field determines how large each square of the main grid
should be. Click the color well next to it to choose a color for the major grid.
The Minor Grid Steps field determines how many minor grid squares should fit
across one major grid square. For example, if your major grid squares are 100 pixels
across, and you have 10 minor grid steps, your minor grid squares are 10 pixels
across. Click the color well next to it to choose a color for the minor grid.
While the Snap to grid checkbox is selected, all objects fit themselves to the grid as
you create or move them. (If you want to snap objects already on the canvas, use the
Align To Grid button below.)
Select Grid in front to make the grid visible in front of objects on the canvas.
Select Print grid to include the grid when printing.
Select Show grid to make the minor grid visible, and Show major to make the major
grid visible as well.
The controls below the separator affect the currently selected objects. The Center on
grid and Edges on grid buttons determine whether the center point of the object or
the object's edges should align to the grid. Click the Align To Grid button to make
all of the selected objects line up to the grid right away.

Finding objects with the Selection inspector
This inspector contains representations of all the different styles of objects on the
canvas.
Each style of object has a representation of the object and a pair of numbers. The
first number is how many objects you have selected which match that style; the
second number is how many objects of that style exist on the canvas.
Click a box to select all objects that match it. You can then use the Style and Properties inspectors to modify the objects on the canvas as if you'd clicked them individually. This is convenient if you'd like to, for example, change all blue diamonds to
pink hearts.

72

Setting up a grid with the Grid inspector

You can also drop a style chit from the style tray onto a box in this inspector to apply the style to all associated objects.
The Filter pop-up menu contains style attributes that you can use to differentiate
types of objects from one another. For instance, if you want objects with different
fills to be considered different types, but you don't care about whether their strokes
are different, select Fill and deselect Stroke.
Type in the Search field to select objects whose text, note, or custom data match a
certain word or phrase. As you type, objects become selected or deselected depending on whether they match. The magnifying glass pop-up menu stores your most
recent searches.

Positioning objects neatly with the Alignment inspector
Use this inspector to line up and space out objects uniformly.
The matrix of nine buttons on the left changes how the alignment buttons work.
It represents all of the combinations between vertically aligning to the top, middle,
or bottom, and horizontally aligning to the left, center, or right. If you want, for
example, to align objects by their upper-right corners, click the upper-right button in
the matrix.
Next to the button matrix are the align buttons. Their icons change to reflect the
state of the button matrix. Click the horizontal-align button to line up the selected
objects horizontally. Click the vertical-align button to line up the selected objects
vertically. These buttons are only useful when you have at least two objects selected.
Next to the align buttons are two spread buttons. Click the horizontal spread button
to distribute the selected objects evenly between the leftmost and rightmost objects.
Click the vertical spread button to distribute the selected objects evenly between the
top and bottom objects. These buttons are only useful when you have at least three
objects selected.
To the right are two fields and their associated spacing buttons. Enter a value in
the top field and click the horizontal spacing button to put the specified amount
of horizontal space between the selected objects. Enter a value in the bottom field
and click the vertical spacing button to put the specified amount of vertical space
between the selected objects. These buttons are only useful if you have at least two
objects selected.
Continued on the next page
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If Align to canvas is selected, the align and spread buttons consider the canvas edges as “objects” when arranging the selected objects. This makes it so that you can
align objects to a canvas edge, or space objects evenly between the canvas edges.

Automatically arranging objects with the Diagram Layout inspector
Use this inspector to automatically lay out shapes based on the logical relationships
established by the connection lines between them.
Select the Automatic layout checkbox to make OmniGraffle lay out the objects on
the canvas whenever the connections between them change.
Four layout type buttons indicate the four methods OmniGraffle can use to lay
out the diagram. The hierarchical layout creates layers of equally-ranked objects,
extending in one direction. The force-directed layout grows in semi-random directions from the center, rather than in one particular direction from the edge. The
circular layout tries to arrange sibling shapes in a circle around their parent. The
radial layout tries to arrange sibling shapes in arcs around their parent.
When you use a hierarchical layout:
• The Direction buttons change where the top level objects start, and which
way to layer the lower level objects from there.
• The Rank Separation field controls how far away each level of objects should
be from the next.
• The Object Separation field controls how far away each object should be from
other objects on the same level.
• Use the Selected Object Rank buttons to assign a hierarchical rank to the
selected objects. Default lets OmniGraffle decide the rank based on connections, Minimum puts the objects at the top of the hierarchy, Maximum puts
the objects at the bottom of the hierarchy, and Same makes sure that the objects end up on the same level. These assignments don’t change the directions
of connection lines, so you can always select all of your objects and choose
Default to return them to normal.
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When you use other layout methods:
• Connection lines can stretch and compress, but you can adjust their average
length by dragging the Line Length slider.
• In a force-directed layout, you can select individual lines and then click the
Custom length checkbox to adjust them separately from the rest of the lines.
• The Shape Repulsion slider determines how strongly the shapes try to avoid
coming near one another. If the line length and shape repulsion are small
enough, shapes can be made to overlap.

Storing information about your document in the Data inspector
The Document Data inspector has fields for lots of information about your document, in case you care to keep track of such things: the available fields are Copyright, Version, Subject, Description, Comments, Authors, Organizations, Languages,
Keywords, and Projects. All of this data is made available to Mac OS X’s Spotlight
searching feature, to help you find the diagram you’re looking for.

Controlling document-wide settings in the Document inspector
The pop-up menu under File format options determines whether to save your document as a flat file or a file package. A flat file is a single file on the disk, with all of
the attached images embedded in it. A file package is actually a folder disguised as
a single file, with all of the attached images rattling around loose inside. In some
technical cases, it might be desirable to use one type or the other; if you don’t even
know why this should matter, it’s safe to stick with the Automatic setting.
Normally OmniGraffle documents are “property list”–based text files. If the Compress on disk checkbox is selected, your file is instead saved in a binary format that
takes up less space on the disk but whose innards can’t be read by scripts or text
editor applications. If you don’t have any idea why someone would want to open up
their OmniGraffle documents with a text editor, go ahead and compress your files.
You can specify page margins, or just choose to use the Printer margins as defined
by your printer driver (or by your custom Page Setup settings).

Storing information about your document in the Data inspector
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Using the style tray

At the bottom of the main document window and the stencil window is a tray which
contains style chits for the selected object. The isolated chit on the left represents all
of the styles applied to the selected object, while the rest of the chits each represent a
single style attribute: fill, stroke, image, shadow, shape, font, and text position. Drag
any of these chits to another object, to a group in the Selection inspector, or to a tool
in the tool palette, to copy the style there.
Note that the absence of a style, such as having no stroke, no fill, or no shadow,
counts as a style; you can for instance apply drag a "no fill" chit to an object to
remove its fill.
If you select more than one object, only the styles that those objects have in common
appear in the style tray.

Using the outline sidebar to edit a hierarchical diagram
The outline sidebar gives you a quick way to enter lots of data, and an alternate way
to look at hierarchical diagrams. To see it, choose Outline from the View menu. If
you have the list sidebar open, you can also click the button at the top of it to switch
to the outline sidebar.
The outline shows any shapes you've created on the canvas, arranged hierarchically
according to the lines that connect them. Likewise, as you enter text into the outline,
shapes are automatically created and connected on the canvas with corresponding
text.
To start working in the outline, just click an existing item, or double-click in an
empty area to create a new item. While you work in the outline view, the following
keys can be used to create and arrange items:
Press Return to create a "peer" of the currently selected item. Peers appear on the
same indentation level in the outline, and, if they are beyond the top level, have connections from the same parent object in the diagram.
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Press Tab to indent the currently selected item, making it a "child" of the item above
it in the outline. A connection line is drawn in the diagram from the parent object to
the child object.
Press Shift-Tab to outdent the currently selected item, making it a peer of what used
to be its parent.
Press Escape to switch between selecting an item and editing the item's text.
There are also keyboard shortcuts especially for quickly building outlines. Check the
Keyboard Shortcuts file in the Help menu for details.
An item can be dragged around the outline view by its handle, the dot or triangle
to the left of each item. Dragging an item with children brings its children with it.
While you drag an item, a black line appears to show the location and indentation
level the item will have when you drop it.
A group, table, or subgraph on the canvas is shown as a single item in the outline,
surrounded by brackets. Click the arrows on the right side of the item to see the
objects inside and edit their text.
The Action pop-up menu below the outline sidebar offers quick access to commands in the Outlining submenu of the Edit menu, as well as commands to manage
diagram styles.
If you have chosen a diagram style for the canvas, objects in the diagram are created
to match the diagram style. A preview of the selected diagram style appears above
the pop-up menu. If you change the diagram style, objects already on the canvas
change to match the new style, unless they have been styled manually. You can force
manually styled objects to conform to the diagram style by selecting them and using
the command Format ‣ Restyle Selected Objects, or you can force all objects on the
canvas to conform by choosing Format ‣ Reapply Diagram Style.
While the outline view is handy for entering lots of information quickly, an outline
can't always perfectly represent the relationships in a complicated diagram. Objects
with more than one parent, lines connected to other lines, and circular ancestry
("I'm my own grandpa!") are all examples of the kinds of things a simple outline
can't properly show. In these cases, the outline view tries its best to be accurate. If
your diagram is not strictly tree-like, you should probably not rely on the outline
view very much.
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Using the list sidebar to order objects
The list sidebar shows you every object on every layer of the current canvas, in front
to back order. To open it, choose List from the View menu. If you have the outline
sidebar open, you can also click the button at the top of it to switch to the list
sidebar.
Layers are listed in front to back order, and inside each layer is a list of objects
in front to back order. You can drag objects into different ordering or into different layers. You can also use the buttons below the list to move the selected objects
forward or backward one step at a time, or all the way to the front or back of their
layers.
In OmniGraffle Professional’s General preferences, you can choose to make the list
sidebar show the unique identification number for each object, which can be useful
for scripting.

About the rulers and the inspector bar
The rulers help you position objects on the canvas. To see the rulers, select them
from the View menu or click their toolbar icon.
As you drag an object around the canvas, lines appear on the ruler to help you find
just the right placement.
In OmniGraffle Pro, you can also create manual guides from the ruler: click and
hold in the top or side ruler, then drag to the canvas area.
By default, the very upper-left corner of a canvas is its origin (that is, the point
where the rulers’ measurements start from, where the coordinates are 0,0). To
change the origin, drag the origin from the corner where the rulers meet. (You can
also enter values in the Canvas Size inspector’s Origin fields.) The coordinates in the
Geometry inspector are based on this origin point.
When you are editing text, tab stops appear on the ruler and text formatting controls appear above it. You can style text, change the spacing and alignment, or drag
tab stops to and from the ruler.
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When you aren’t editing text, the area above the ruler contains controls for editing
basic attributes of selected objects; this is the inspector bar.

The X and Y position, just like in the Geometry inspector.
The width and height, also just like in the Geometry inspector.
A pop-up menu for choosing a fill type; three color wells which become
enabled depending on the type of fill you choose; a rotation control for orienting linear blends.
A pop-up menu for choosing a stroke type, corner style, connection line type,
and line head and tail styles; a color well for choosing a stroke color; a field
for stroke thickness.
A button for quickly turning shadows on or off. For more control over shadows than just turning them on or off, visit the Shadow inspector.
A button for quickly enabling or disabling connections to or from other
objects. For finer control, visit the Connections inspector.

About the rulers and the inspector bar
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Using stencils to keep and share commonly-used objects
A stencil is a set of useful objects that you can drag into your own diagrams. To see
your stencils, select Stencils from the Window menu.

Click these buttons to see the objects as they appear on the stencil or separated out with each in its own box.
Use the Action pop-up menu to edit stencils, customize the stencils list, or create new stencils; see more about these commands below.
Type something in the search field to find stencils whose names match, or
stencils containing objects whose text or notes match. You can even search
online to find stencils other people have made. See below for more about
stencil searching.
Select a stencil in the list to see its contents; select a whole folder to see the
contents of all the stencils inside.
The stencils you select appear here; drag objects from here to your document.
If you have opened a stencil that isn't yet installed, click the Install button
that appears in the title bar to copy it into your home folder for safekeeping.
When you select an object, some information about it, including any notes or
custom data it may have, appears here in the metadata pane.
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If you don't want a whole object, but just one or all of its styles, drag a style
from the style tray to an object in your document.
Click this button to show or hide the metadata pane.
To put an object on the canvas, just drag it from the stencil and drop it wherever
you like. A copy of the object is made and the original remains on the stencil, so
take as many copies as you need. You can do the same sort of selection tricks that
you can do on a canvas, like Command-clicking or dragging a rectangle to select
multiple objects.
The stencil list is divided into several sections.
Your Stencil Library includes all of the stencils you have installed, whether they're
built in to OmniGraffle or in an Application Support folder.
Recent Stencils lists the last five stencils you looked at. If you open a not-yetinstalled stencil, it appears in the recent list; you can click the Install button near its
title to copy it to the right location in your Home folder.
The Favorite Stencils section is fully customizable. You can drag any installed stencils you like into it. Choose New Favorite Stencil Folder from the Action pop-up
menu to create a folder for organizing your favorites.
To search your stencils, type in the search field above the stencil list. OmniGraffle
searches your stencils' titles, the text of the objects on each stencil, and the notes
and custom data. Stencils that match appear in the special Search Results section of
the stencil list. Normally, if any object on a stencil matches, then all objects on that
stencil appear in the results. But if you turn on the Filter setting in the search field's
pop-up menu, then objects that don't match what you typed disappear.
To search the online OmniGraffle stencil repository, click the search field’s pop-up
menu and choose Graffletopia. This is Patrick Crowley’s free service, where anyone
can share useful stencils. When you search Graffletopia, stencils whose names or
descriptions match appear in the Search Results list. Click a stencil to see a preview
and a description, then click the Download button to get a copy for yourself. Open
the file that appears in Finder, and then you can use or install the stencil normally.
You can also visit Graffletopia from OmniGraffle’s Help menu, or by going to
graffletopia.com.
Continued on the next page
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To make a new stencil, choose New Resource ▸ Stencil from the File menu. You
can edit the document that appears just like you would edit a normal OmniGraffle
diagram. A preview of the stencil appears in the stencil window as you work. Once
the stencil looks just how you want it, choose Save from the File menu; the default
location for saving is the Application Support folder inside your Library.
To edit a stencil, select it in the list and then choose Edit Stencil (or Copy and Edit
Stencil, if it's built-in) from the Action pop-up menu above. Then edit and save the
stencil just like a normal OmniGraffle document.

General preferences
The General preferences are accessible by choosing Preferences from the OmniGraffle menu.
• Startup
Select Open documents which were open the last time you quit if you’d like
OmniGraffle to remember your open documents.
Select Create new document if nothing else is open to start with a new document when you aren’t making OmniGraffle remember open documents, or if
there were no open documents the last time you quit.
• New Documents
Select Show Template Chooser to be presented with a window for choosing
a template every time you create a new document. Select Use Template, and
choose your default template, if you’d rather bypass the chooser. Either way,
you can always get to the template chooser with the Template Chooser command in the File menu.
• Text Editing
Decide how you would like the Return and Tab keys to behave while you
are editing an object’s text. Whichever way you choose, you can hold Option
while pressing the key to do the reverse instead.
• Selection
Small objects get smaller versions of the handles that appear when you select
them; if you really like the small ones, you can click Always use small selection handles to see them all the time.
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When you click in the middle of a shape object that isn’t filled with an image
or color, you might want to select the object or you might want to select
whatever is behind it. Use the Click through objects with no fill checkbox to
indicate which you prefer.
• Help Tags
When you move or resize an object, a little help tag appears to let you know
the object’s new location and size exactly. That is, unless you find it annoying
and turn it off here.
• Backup
OmniGraffle can periodically save a backup of your files as you work on
them; if something unfortunate happens you can then recover some of your
work.
• List Sidebar
In OmniGraffle Professional, if you’re accessing OmniGraffle objects with
AppleScript, or you’re otherwise endeared to unique IDs, you can select Show
object identification numbers to add a column to the list sidebar.
• Preferences Reset button
Each preference pane has a Reset button in the lower left. Clicking this button
returns all of the settings on the pane to their defaults. To reset all settings on
all preference panes, hold Option while clicking the Reset button.

Drawing Tools preferences
Drawing Tools is the second preference pane, accessible by choosing Preferences
from the OmniGraffle menu.
You can drag tools around in the list to reorder them in the palette. Move the separator line to change where the expansion button appears in the toolbar; move it to
the end of the list to get rid of the button entirely.
Double-click a tool’s hot key to change it. A hot key activates a tool for only as
long as you hold the key down; once you release the key, the previously active tool
becomes active again.
• Inspect a tool
By default, in order to inspect a tool you need to Option-click it. If you prefer,
you can make it take just one normal click to inspect a tool.
Continued on the next page
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• Keep tool active
By default, it takes one click to temporarily activate a tool, and two clicks
to make a tool “stick” in an active state. You can choose to make tools stick
after only one click, or make it so that every tool selection is temporary.
• Line Creation
When you are creating a line, clicking an object will always connect the line
to the object and end the line. If you click in an empty area of the canvas,
though, you might want to end the line there or you might want just to add
a point there and continue creating the line. Use this preference setting to
indicate which you prefer.
• Line Editing
When you double-click a line, you might prefer to add a new point to the line,
or you might prefer to add a label. Choose one; Option-double-click will do
the other.

Presentation Mode [Pro feature]
Presentation mode is available from the View menu; it fills the entire screen with
your document so that you can easily present it to others.
Each canvas acts as a slide; use the arrow keys to move between canvases. You can
also press Return or Enter, or click, to move to the next canvas. If your Presentation
preferences are set to highlight an object when you click it, doing so won’t advance
to the next canvas; you can still click an empty area of the canvas to advance. If you
move the mouse cursor to the bottom of the screen, a navigation interface appears,
with buttons for going forward or back, exiting, or moving directly to a particular
canvas.
You can highlight objects to draw attention to them during the presentation. Use the
Presentation preferences to control how highlighting happens.
To leave presentation mode, press Escape or click the X button that appears when
you move the mouse pointer to the bottom of the screen.
Actions set up in the Action inspector work while in presentation mode. When
you click an object that has an action assigned, it performs the action as if you had
clicked it with the Browse tool.

84

Presentation Mode

Presentation preferences
In presentation mode, you can highlight objects on the canvas.
Choose whether to have an object become highlighted whenever you put the
pointer on it, whenever you click it, or never. You can also choose to display a
badge for objects that have actions set up in the Action inspector.
Click the color well to choose a color for the highlight. One good trick is to use
selectedControlColor from the Developer palette; this color always matches
the highlight color selected in Mac OS X’s Appearance preferences. Use the slider
to control the thickness of the highlight.
If you have more than one window open, the frontmost window is used for the
presentation. If you have two displays, you can put the presentation on one screen
while editing the document on the other.
• Select New Window on “Document” (where Document is replaced by your
document title) from the Window menu.
• Drag one window to the second display.
• Click the window on the second display to make sure it is frontmost.
• Enter presentation mode. The second display shows the presentation while
your first display keeps its normal document window.
• Now you can edit the document on the first display and the presentation on
the second display updates itself.

Creating and managing templates
A template is a document that acts as a starting point for new documents. For
example, the “1cm = 1m” template that comes with OmniGraffle has its units set up
for drawing on a large scale. Other templates are set up with diagram styles which
suit certain types of drawing. OmniGraffle comes with several templates, and you
can create your own if you make the same kinds of documents often.
In the template chooser, you can choose a template for your new document. You
can also create a new template, edit a template that belongs to you, or set a template
as the default. Once you set a default template, OmniGraffle bypasses the template
chooser and uses that template for any new documents you create. If you want a different template, you can still use the Template Chooser command in the File menu.
Continued on the next page
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When you create an OmniGraffle template, everything about it is preserved, from the
canvas size and grid layout, to layers, to visibility of extras, to the automatic layout
settings. To create one, choose New Resource ▸ New Template from the File menu,
then choose an existing template to begin from. Set up the document exactly the way
you want it, then save it. The default save location is inside your own Application
Support folder, where OmniGraffle looks for your templates. Once a template is saved
in that location, it becomes available in the template chooser.

Using diagram styles
Diagram styles are OmniGraffle documents that define an appearance you can apply
to an outline or a diagram. There are infinite ways to represent the same data; a
diagram style helps you indicate just how you want the data to be represented.
The main situations when diagram styles come in handy are when you write an
outline with OmniGraffle’s outline view (using the Choose Diagram Style command
in the Format menu) or when you import an OmniOutliner file (using the importing dialog). In these situations, the diagram style translates text items into visible
objects. Several diagram styles come with OmniGraffle; try using the outline view
with various diagram styles to see their effects.
When you apply a diagram style, the items of the outline are styles to match the
diagram style’s shapes, connection lines, and automatic layout settings. Items at each
level of the outline become shape objects matching objects at the same level of the
diagram. If the outline has more levels than the diagram style, the deeper items use the
styles of the deepest level of the diagram style.
To create your own diagram style, choose New Resource ▸ New Diagram Style from
the File menu, then choose a template to begin from. Set up a one-canvas, onelayer diagram containing some interconnected objects, styled the way you want. A
diagram style should be a strictly tree-like structure; this means the connection lines
should create a hierarchy without doubling back on themselves. When you’re ready,
save it. The default save location is inside your own Application Support folder,
where OmniGraffle looks for your diagram styles. Once a template is saved in that
location, it becomes available in the diagram style chooser.
If you intend to import OmniOutliner files with multiple columns, you can create a
diagram style with a group of shapes, rather than a single shape, to represent each
item. In this case, you should put a text label on each object so that you can associate columns with them when opening the OmniOutliner file.
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Automatically saving document backups
When you turn on the backup function in the General preferences, OmniGraffle
keeps a backup version of each document as you work on it. In the case of a crash,
power failure, or other nasty event, the backup version remains on the disk. When
you reopen the document, the last auto-backed-up version appears as a document
with unsaved changes. You can continue working with the backed up version, or
you can choose Revert To Saved from the File menu to go back to the saved version.
If you close a document andchoose not to save it, the backup version is discarded.

Exporting to different formats
You can create files of several different types from your OmniGraffle diagrams.
Select Export from the File menu. When you export, a new file is written to the disk,
leaving your original document as it is on the screen. Of course, not all aspects of a
diagram can be represented in all file formats.
The available file formats are:
• OmniGraffle document [Pro feature] — an OmniGraffle document. You can
make the file read-only (not editable), and you can choose to include linked
images in the file so that they show up properly on someone else’s computer.
• PDF vector image — Portable Document Format. This is a nice cross-platform
format that has good support for both vector components and bitmaps.
• TIFF bitmap image — Tagged Image File Format. This format supports transparency.
• PNG bitmap image — Portable Network Graphics, a popular format for the
Web. This format uses lossless compression to retain the details of an image
while decreasing its file size. It supports transparency.
• JPEG bitmap image — a popular compressed image format. You can lower
the image quality to get a smaller file size.
• EPS vector image — Encapsulated PostScript. This is a common format in
professional printing.
Continued on the next page
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• HTML image map — A hypertext file and a JPEG, PNG, or GIF image. URL
actions in the original OmniGraffle document are coded into the image map as
links so that the image can be clicked to follow them.
• OmniOutliner 3 — Represent the diagram as a text outline, using the connection lines between shapes to create a hierarchy. This doesn’t work as well for
diagrams that don’t have strictly tree-like structures.
• SVG vector drawing [Pro feature] — An open internet standard that uses XML.
• PICT vector image — A legacy Macintosh graphics format.
• Photoshop® image — File format for the popular image-editing application.
• BMP bitmap image — A legacy graphics format.
• OmniGraffle Diagram Style, OmniGraffle Template, OmniGraffle Stencil —
Resources for OmniGraffle.
• Visio® XML document [Pro feature] — The XML-based file format for the
Microsoft® diagramming application.
Depending on the file format you choose, you have different options. Most offer
an Export Area option, with which you can choose how much of the document to
export.
• Current Selection — Only export the objects that are selected right now.
• All Objects — Export all of the objects on the canvas, but not the empty areas.
• Region — Specify a precise region of the canvas to export.
• Current Canvas — Export the entire canvas.
• Whole Document — Export everything, creating one image file for each
canvas.
Depending on the format you choose, you can also choose a scale for exporting
smaller or larger than actual size, the resolution, the compression level, and whether
to make the background transparent.
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Importing from other applications
Several different file formats can be understood by OmniGraffle. You can import
these files by opening them just as you would open a normal OmniGraffle file.
• Microsoft® Visio® documents, templates, and stencils (.vsd, .vdx, .vst, .vtx,
.vss, .vsx) [Pro feature]
Documents saved by Microsoft® Visio® diagramming software in its XMLbased file format (and now even in its original binary file format! Yeah!) can
be read by OmniGraffle Pro. Note that while you can open the binary format,
you can’t export to it; you’ll have to save as an OmniGraffle diagram or export to the XML format. Also note that graphics in the Microsoft® Enhanced
Metafile (EMF) format can’t be imported.
• DOT files (.dot)
OmniGraffle understands a subset of the DOT language used by Graphviz.
This isn’t a full implementation of DOT, but it can be quite useful.
• Diagram! 2 documents (.diagram2 and .dpalette2)
Diagram is a NeXTSTEP/OPENSTEP application similar to OmniGraffle.
OmniGraffle can import the objects in a Diagram file, but not attached EPS
images, sounds, or links.
• OmniOutliner documents (.ooutline and .oo3)
When you open an OmniOutliner file, the items of the outline are interpreted
as a diagram. A dialog appears; use it to indicate exactly how to interpret the
outline:
• Use the pop-up list to choose a diagram style.
• In OmniGraffle Pro, use the table to assign objects in the diagram style to
columns in the outline. If you want to show multiple columns of information for each item, use a diagram style that has grouped objects. You can
also assign a column to the objects’ notes.
• Choose whether to put the outline in a completely new document or in a
new canvas on the open document.
• Xcode projects (.xcode), Project Builder projects (.pbproj), and frameworks
(.framework)
OmniGraffle uses the Objective-C headers to construct a diagram of the
inheritance, protocol, and category relationships.
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• Interface Builder nib files (.nib) [Pro feature]
OmniGraffle graphs the connections in the nib file for easy visualization.
• EOModeler files (.eomodeld)
OmniGraffle creates a diagram of the database relationships described by the
file.
• Folder structures
Drag a folder from the Finder and drop it on OmniGraffle’s application icon
to map out the folder’s contents as a diagram.
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AppleScript support
OmniGraffle has extensive AppleScript support; open the OmniGraffle dictionary in
Script Editor for details about OmniGraffle's object model and commands.
You can store AppleScripts in OmniGraffle’s scripts folder, for easy access from the
Scripts menu (see the Application Support folders section for details). You can also
attach scripts to individual objects on a canvas, using the Action inspector. When
you activate the Browse tool, then click an object with a script attached, the script
runs.
If you select some objects and then choose Copy As AppleScript from the Edit menu,
you get the exact lines of AppleScript necessary to create those objects. This is a
great way to learn how OmniGraffle's AppleScript support works, or to add specific
objects to your own scripts.

ColorSync support [Pro feature]
OmniGraffle Professional supports Apple's ColorSync technology, which tries to
keep colors as accurate as possible when viewed on any ColorSync-compliant display and when printed on any ColorSync-compliant printer.
ColorSync is OmniGraffle's fourth preference pane; you can get to it by choosing
Preferences from the OmniGraffle menu.
Select the Use color profiles checkbox to turn on OmniGraffle's ColorSync support.
OmniGraffle will embed color profiles in the documents you save, and will try to
read color profiles from the documents you open. A color profile helps ColorSynccompliant software and hardware display the document's colors accurately.
You might receive documents saved with different color profiles than the one you
are using. Use the pop-up menu to decide what OmniGraffle should do in such a
situation. Select Preserve original to leave the color profile in the document as it is.
Select Convert automatically to translate the color profile to match your own defaults. Select Ask when opening to have OmniGraffle present you with a choice each
time you open a document with a different color profile.
Default Profiles shows the color profiles you currently have set up in the systemwide ColorSync preferences. Click the button to open these preferences, where you
can change these profiles to match your hardware. These profiles are the ones that
will be embedded in documents you create.
Note that you can manually set and convert color profiles from the Format menu,
thereby overriding these defaults.
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LinkBack
LinkBack is a way of embedding content between applications in such a way that
you can always go back and edit the content with the software that created it.
For lots of information about LinkBack, and a list of applications that support it,
check the web site at www.linkbackproject.org.
To embed OmniGraffle content in another LinkBack application, just copy and
paste the content like you would normally. The same goes for embedding other applications’ content in OmniGraffle diagrams.
To embed OmniGraffle content inside a single object in OmniGraffle, choose Copy
As PDF from the Edit menu, then Paste normally. The objects you copied become a
single image; you can double-click the object to edit the original content.
To edit OmniGraffle content embedded in another application:
• Double-click the OmniGraffle content in the other application’s document; an
OmniGraffle window appears containing the content.
• Edit the content in the OmniGraffle window, just like you would edit a normal diagram.
• Choose Save from OmniGraffle’s File menu; the content in the other application updates automatically.
To edit other LinkBack applications’ content embedded in an OmniGraffle diagram, just double-click it. When you save in the other application, the content in
the OmniGraffle diagram updates.
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Licensing
Select the Licenses menu item from the OmniGraffle menu to see the Licenses
dialog. From here you can review and edit your OmniGraffle licenses, which verify
that you've actually paid for the software. (Thanks!)
To buy a license:
• Click the Buy Licenses button and you will find yourself magically transported to The Omni Group's store on the web. Naturally, this only works if
you have a live Internet connection.
To add a new license:
• Click the Add License button.
• If you have a license key in an e-mail message, copy and paste both the
Owner name and the License Key into the appropriate fields. If you can't
copy and paste the information, you'll have to type it in; make sure you copy
everything exactly as it appears in your license message. Also, double-check
that the license you’re entering really is a license for OmniGraffle 5, and that
it is for the correct edition (Professional or Standard).
• Use the drop-down menu to select the type of license you would like to use.
(Keep reading to learn about license types.)
• Click the Save button.
Continued on the next page
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OmniGraffle has three different types of licenses:
• Personal: This license is for your personal use, and will only be available on
this computer when you are logged on as the user who installed the license.
You can install this license on more than one computer, but only for your
personal use. You should not use the software on two different computers at
the same time with this kind of license. If a personal license is available, the
application will always use it.
• Computer: You can use this license on this computer, and so can any other
user of this computer. However, you should not install this license on more
than one computer. If both a network license and a computer license are
available, the application will prefer the computer license.
• Network: This license sits on your network and is available to any user on
the network. However, only a certain number of users (indicated by the
number of "seats") can use the license at one time. OmniGraffle will only
use a network license if neither a personal nor a computer license is available.
To remove a license:
• Select the license you want to remove.
• Click the Delete License button.
To move a license from one Mac to another:
• First, find the license file on the old computer. OmniGraffle license files
are located in the folder Library/Application Support/Omni
Group/Software Licenses, where Library is either at the top level
of your system disk (for computer licenses), or in your home folder (for
personal licenses). The file you are looking for has a name like omnigraffle-123456.omnilicense. Move this file to the new computer.
• On the new computer, choose Licenses from the OmniGraffle menu and then
click the Add License button.
• On the sheet that appears, click the Import License File button.
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Software Update preferences
OmniGraffle can automatically use your internet connection to check for new and
updated versions of itself; you can get to these options by choosing Preferences from
the OmniGraffle menu, then clicking the Update button.
If the Check for Updates checkbox is selected, you will be notified when there is a
new version of OmniGraffle ready for you to enjoy. Click the Check for Updates
Now button to look for the newest version manually.
You can select the Include system information checkbox to volunteer some information about your computer’s configuration when you check for updates. This
information helps Omni make decisions about hardware support in our software.
For more details about what kind of information we collect and how we use it, click
the Learn More button on the preference pane.

Application Support folders
Application Support folders are special locations where programs can store important files. OmniGraffle checks these folders for Diagram styles, stencils, templates,
and AppleScripts. Each of these file types has its own appropriately named folder
inside the OmniGraffle Application Support folders.
Files in ~/Library/Application Support/OmniGraffle/ (where ~ is your
home folder) are available only to your user account. You don't need any special
privileges to add or remove files there; it's your own special space.
Files in /Library/Application Support/OmniGraffle/ are available to any
account on your Mac. You need administrative privileges on the computer to add or
remove files there.
Files in /Network/Library/Application Support/OmniGraffle/ can be
seen by any copy of OmniGraffle being used by anyone on your entire network. You
need administrative privileges on the network to add or remove files there.

Software Update preferences
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Hold a hot key to temporarily activate the tool. These hot keys can be changed in the
Tool Palette preferences. Press number keys to switch between tools.
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Selection Tool
Select an object

Click

Select multiple objects

Click the canvas and drag a box

Add to or remove from the selection

⌘-click or ⇧-click

Move an object

Drag

Move orthogonally

Hold ⇧ while dragging

Reverse smart guides setting

Hold ⌘ while dragging

Resize an object

Select, then drag the resize handles

Resize and keep aspect ratio

Select, then ⇧-drag a resize handle

Resize from center

Select, then ⌥-drag a resize handle

Rotate an object

Select, then ⌘-drag a resize handle

Duplicate an object

⌥-drag

Create child of selected object

⌘-click the canvas

Create sibling of selected object

⌥⌘-click the canvas

Edit a shape's text

Double-click

Add a text label to a line

Double-click (depending on preferences)

Select control point

Select object then click point

Select point behind resize handle

⌥⌘-click

Add bezier handles to point

⌘-drag the point

Move one bezier handle at a time

⌥-drag the handle

Add point to line

⌥-double-click (depending on preferences)

Add point to custom shape

Double-click the edge

Shape Tool
Create a shape

Drag

Create with equal height/width

⇧-drag

Create from center

⌥-drag
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Line Tool
Add a point

Click (depending on preferences)

Create semiorthogonally

⇧-click

Delete last point created

⌫

Finish creating line

Double-click (depending on preferences)

Text Tool
Edit a shape's text

Click the shape

Create a shape to contain text

Click or drag on the canvas

Add text label to a line

Click the line

Pen Tool
Create a point

Click

Create semiorthogonally

⇧-click

Create a point with bezier handles

Drag

Restrict handles to 45º increments

⇧-drag

Delete last point created

⌫

Finish creating a shape

Double-click or ↩

Diagramming Tool

Style Brush Tool

Add child

Click

Absorb a style

⌥-click

Add Sibling

⌥-click

Paint a style

Click

Add Parent

⇧-click

Rubber Stamp Tool

Magnet Tool

Absorb an object

⌥-click

Create a magnet

Click

Stamp an object

Click

Delete a magnet

⌥-click

Zoom Tool
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Zoom in

Click

Zoom out

⌥-click

Zoom to area

Drag

Zoom to actual size

⇧-click the tool in the palette

Keyboard Shortcuts

The OmniGraffle web site
The OmniGraffle web site is always a good place to find the latest information
about OmniGraffle.
http://www.omnigroup.com/applications/omnigraffle/

Forums
The Omni Group maintains online forums for all of our products, and you're invited! Come share your questions and ideas with other users and Omni staff.
http://forums.omnigroup.com/

E-mail support
If you're stuck, if you have a good idea for the next version of OmniGraffle, or if
you just want to let us know how we're doing, go ahead and send us an e-mail.
Choose Send Feedback from the Help menu to conjure up a message addressed to
us, or just write to omnigraffle@omnigroup.com. We take support pretty seriously,
so you can expect a prompt response actually typed by human hands.

Getting help
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