OmniOutliner is every list-maker’s dream come true. It’s fast, easy, and simple. But beneath that simplicity is enough power to handle your lists, outlines, and ideas in ways you’ve never thought possible.

This manual will give you an overview of what you can do with OmniOutliner, but it isn’t intended to be comprehensive. OmniOutliner’s online help is your complete reference; use it for in-depth information on any feature we introduce here.
Step 1:
Insert the OmniOutliner CD into your Macintosh's CD-ROM drive. You should see a window similar to this one:

In addition to the OmniOutliner application, your CD also contains some useful information for helping you get started (in case you forgot to look at this manual, but you're clearly smarter than that), and unlicensed versions of the Omni Group's other products for you to try out and fall in love with as well.

Step 2:
If you want, you can go ahead and run OmniOutliner now by double-clicking the OmniOutliner icon. But you probably don't want to run OmniOutliner from the CD, since you'd have to have said CD in your computer all the time. Instead, you should drag the icon to a folder on your local or network disk.

Where you put it is up to you; however, most Mac OS X applications work best if you put them in the main Applications folder on your hard disk. If you have multiple users on your computer, OmniOutliner will then be accessible to all of them. (Note that you'll have to be logged in as an administrator to write to the Applications folder.)

If you're the administrator of a Mac OS X network (you'd know if you were) and you've bought multiple copies of OmniOutliner, you may want to put OmniOutliner in the /Network/Applications folder so that it can be available to all network users.
Step 3:
Run OmniOutliner for the first time by double-clicking on its icon. You’ll be presented with a panel letting you know that you should enter your license key. Click Licenses…, and a new window will appear:

This is the Licenses window, in which you can keep track of any OmniOutliner license(s) you may own. For more information about its general use, see the online help.

Step 4:
Click Add License…, and a sheet will appear in which you can enter your license information as it appears on the CD sleeve. Also, here you can choose to install your license for Personal, Computer, or Network use. Once you’ve entered the license information, click Save to save it (as you might expect).

Personal, Computer, or Network? Huh?
When installing OmniOutliner, you’ll want to decide who else can use your license (see sidebar). There are three ways you can use your license:

- A Personal license is available only for you, the user who installed it. It’s stored in your home folder, so it is only available when you’re logged into your account.
- A Computer license is what you would usually choose: it’s available to any user who can log into your Mac.
- A Network license is available for any user on any machine on your Mac OS X network, and is generally only used if you have bought lots of licenses (for instance, at a university lab).

Feel free to copy OmniOutliner to other computers without its license: it will function in a limited mode as a document viewer when unlicensed.

OmniOutliner’s license terms:
Each OmniOutliner license you buy allows you to either:

- Have as many users you want use OmniOutliner on one machine, or
- Have one user use OmniOutliner on as many machines as she wants.

Note that doing both is not allowed — licenses aren’t “floating” and thus, if you have one license and two machines in your house, and your roommate also wants to use OmniOutliner, you can either decide that both you and the roommate can use OmniOutliner on one of your machines, or that you can use OmniOutliner on both machines and your roommate can buy her own copy.

So, in this example, you’d want to install your license as a Computer license if you’re trying to share OmniOutliner with your roommate on one machine, or as a Personal license if you want to use it on either machine and not share with her.

For companies and other institutions, a simplified way of saying this would be: “You should purchase as many licenses as you have either machines or total potential users, whichever is fewer.”
Why did we make an outliner? Because, when it comes down to it, everyone makes lists and outlines and tables. Paper lists are sub-optimal: if you’re like us, your handwriting is an illegible scrawl, plus lots of times you want to share your ideas with other people, and paper can’t be e-mailed or put on a web page. You could use a word processor or spreadsheet, but those tools are designed for other jobs, so most of your time would be spent reorganizing and reformatting your information instead of jotting down new thoughts.

We wanted a tool designed specifically for making lists and tables, so it wouldn’t get in your way. We wanted it to be simple, so you could just start writing down your ideas without thinking of how they’d be arranged. Yet its features needed to be deep and rich, so you could use color, styled text, or any other tool that made the information in your document more clear.

So we made OmniOutliner easy, fast, fun, and deep...
**Easy**
Lists are simple things. You don’t want to spend your time figuring out how to use a list-making program, or else you might as well have just used a piece of paper. OmniOutliner never leaves you scratching your head. Fire it up for the first time and you can immediately get down to business.

**Fast**
If you just had a great idea, you need to quickly jot it down. OmniOutliner is designed to let you enter information quickly — without your hands ever leaving the keyboard, if you like. That way, you’ll get your idea down before it flies out of your head.

**Fun**
Tedium is the enemy of productivity. We made OmniOutliner fun to use, instead of just a raw tool that’s boring at best. How do you make an outliner fun? Well, we made it responsive, with lots of visual feedback and slick graphics. Sure, it’s not a video game, but it should still be enjoyable to use.

**Deep**
Some people organize their entire universes into lists and outlines and tables, so we allow you to enhance and enrich your basic lists and outlines. From basic features like colors and fonts, to more complex features, like level-wide styles, item notes, hierarchies, multiple columns, calculated columns, pop-up columns, “hoisting,” and full AppleScript support, OmniOutliner can be exactly what you make of it.
Now that you have an idea of what OmniOutliner’s purpose is, we’ll walk you through making your first list. For this example, we’ll be making a common type of list: a shopping list for your weekly staples.

**Entering the first few items**

When you launch OmniOutliner, you'll be presented with a new, untitled document to work in. The first item should already be selected, so start your list by typing “Bananas”. Now press return. You'll see that a new item has been created and it’s already highlighted, ready for input. Next type “Apples” and press return again. Fill in a few more items so your list looks like the one to the left.

**Grouping items**

To make your shopping trip more efficient, it would be good to group items by the part of the store in which they’ll be found. So let’s fit each of your items into groups. Create a new item at the end of your list by pressing return. Name it “Fruit.” Now we want to move the fruits under this new item, so drag the dot next to “Bananas” to just underneath “Fruit.” You should see a black line in your outline as you drag “Bananas” around; this shows where “Bananas” will be placed when you drop it. Make sure to drop it under and little bit to the right of “Fruit.” (If it’s not indented when you drop it, click on the line and hit the **Indent** button in the toolbar.) Do the same thing for “Apples.” Your outline should look like the one on the left.
Marking items and groups as completed

Next to each of the items is an empty box. If you click on this box, you'll notice OmniOutliner puts a check mark in the box. Click again and the box becomes unchecked.

Let's say you have some of your staple foods left over from last week — your “Apples” and “Bananas” are still perfectly good. Check both of those items off. Notice that the “Fruit” item is now also checked off, since all of its subitems are checked off. (If you unchecked “Fruit,” all of the subitems would become unchecked. Check it again and the subitems will become checked again.)

Now you can clearly see that you can skip the fruit aisle this visit, because you're all fruited up for the coming week.

Adding another column for price

Let's say you want to keep track of how much your staples cost. The best way to do this is to add a new column. Click on the Add Column button in the toolbar; a new column should appear on the right, named “Untitled”. The column header is highlighted so you can change the name — type in “Price.” Now click in the price column next to each of your items and enter each price. Notice that, right now, you don't get an automatic total, because OmniOutliner thinks the prices are just words: it doesn't realize they are numbers. See the sidebar to the right to learn how to turn our new column into a number column, and automatically keep running subtotals.

Hey, is this a list or an outline?

This tutorial shows why we called our program “OmniOutliner” instead of “OmniLister” (well, besides the fact that “OmniLister” sounds totally dorky) — most lists start out as straight linear data, but quickly turn into outlines as you either group items together logically (as we did here) or expand on items you entered before.

It’s this ability to quickly rearrange, prioritize, group, and ungroup items that makes OmniOutliner so handy for so many real–time tasks: taking notes in class or at a meeting, brainstorming, writing up first drafts of contracts or plays, etc.

Running totals and column types

So far in this tutorial you haven't had to use the Info panel: OmniOutliner was designed so you can jump right in without learning anything.

But if you want to do something complicated like have your prices be totalled, you'll need to learn another panel. The Info panel is discussed in more detail on page 10, but if you can't wait until then, you can bring it forward now by clicking the Info icon on the toolbar.

Click in the “Price” column in your document and then make sure the Column Type section is showing on the Info panel (click on its button if it's hidden) and then change the Column Type pop–up's value to Number.

Set Summaries to be Calculated so that groups will total the values of their members, and set the Format to be $9,999.99 so the numbers you enter will be formatted as dollar amounts.

Now re–enter the prices for “Apples” and “Bananas,” and notice that the “Fruit” group’s total price is automatically updated.
OmniOutliner worked well for your basic outline, but let’s say you want a little more information than a shopping list usually has. Let’s explore some features to make your documents richer: notes, fonts, and colors.

**Notes**

Notes allow you to associate additional information with any row, without having to have that information take up space in the outline. At the bottom of the outline window is an empty space; if you click on a row and type something in this space, then whenever you select the row again its note will re-appear. The small piece of paper in the leftmost column tells you which items have notes associated with them. If you aren’t going to use notes in your document, you can save space by hiding this bottom section — either drag the bar down all the way or double-click on it to collapse the notes section.

**Fonts and colors**

OmniOutliner uses the standard Mac OS X Font and Color panels, so you should have no trouble using them. The only thing you should notice is that you can either change one cell (or even part of a cell) or an entire row at once. If you select a whole row and pick a font in the Font panel, all the text cells in that row are converted to the new font. If you’ve got some text in a cell highlighted and you pick a font, only that text will be changed.

The same is true of dragging colors from the Colors panel into your outline; depending on the selection it will either color the entire row or just the currently selected text.
Here are two functions that help you organize your data and your thoughts: hoisting lets you focus in on part of your document, and sorting lets you re-order your rows more logically.

**Hoisting**

Let’s say you are throwing a sushi party. You’ve got a list of everything you need to buy, but right now you and your friends are talking about just your favorite fish. You don’t care about the vinegar or rice right now. So select “Seafood stuff” and choose Hoist from the Outline menu. Your document now looks something like...

...the document pictured at right (note the change in the titlebar). You can then concentrate on just the fish. When you’re done with that, select Unhoist from the Outline menu. The document will return to its original state. Hoisting doesn’t actually change your document, it just changes your view on it.

Another popular use for hoisting is if you have an outline with a to-do list for your week: each day you’d hoist the current day to focus on your current activities, but you can always unhoist if someone gives you something which needs to be done later in the week.

**Sorting**

Using Reorganize » Sort, you can immediately sort your items by any column. If you select Reorganize » Keep Sorted an icon will appear in the column on which you are sorting to let you know that as you enter new items they will automatically be put in order. You can even click on this icon to change from ascending to descending sort and back.

---

**Keyboard Shortcuts**

Most keyboard shortcuts are listed in the menus. However, for super-bonus-power users, we’ve added some hidden keyboard shortcuts so you never have to use the mouse.

**Navigating**

You can use the up and down arrow keys to move between rows when you are editing text. The left and right arrow keys will move the cursor to the previous or next cell when it’s positioned at the edge of a cell.

**Creating rows**

To create a new row under the current one, simply press Return; to create a new row above the current one, use Shift-Return.

**Indenting rows**

If your outline only has one column, use Tab and Shift-Tab to indent and outdent the current row. In multi-column mode, this key normally moves the cursor between cells, although this can be changed in Preferences.

**Editing**

If you have a row selected and you want to type in its cell, press the E key. If you’re done typing and want to go back to row-selection mode, press the Escape (or esc) key.

**Manipulating groups**

You can expand the currently selected group by pressing Command–right arrow, and can collapse it by pressing Command–left arrow. Adding Shift to either of these shortcuts will completely expand or collapse the item and all items grouped under it.

To create a new untitled group from the selected rows, press the G key; to make all of a selected group’s children be its peers (e.g., ungroup it), press the U key.
After you’ve used OmniOutliner for a while you’ll probably want to customize your work. With the Info panel, you can change styles, automatically number rows, and even change the way data is entered, displayed, and calculated.

To show the Info panel, choose Format → Show Info. Each section of the panel controls a different aspect of the document, and can be expanded or collapsed by clicking its header.

**Row Levels**

Each line in the Styles table corresponds to a level of indentation in your outline. If you select Level 1 and change its font, color, or formatting, all top-level items in the outline will change to match, unless you’ve set a style for them already. For example, by making first-level items use a large font, and second- and third-level items use successively smaller fonts, you can easily call attention to the topical structure of your document.

Lawyers and students rejoice! The Numbering options provide for automatic numbering of all items on the same indentation level. For example, a “Harvard-style” outline could be easily produced by choosing “I, II, III, IV…” for the first level, “A, B, C, D…” for the second, “1, 2, 3, 4…” for the third, and so on, and entering a period (.) in the Suffix box for each level.

**Column Type**

Any new column contains rich text by default, but you can change its Column Type if you know it will be used for a more specialized kind of data.

The Summaries popup determines how group values behave in this column. For some kinds of data, it makes no sense for groups to have values, so you can set summaries to Hidden. For number types you may want groups to be the total of their children’s values, so you’d choose Calculated.

The controls below Summaries change based on what type you chose, providing options specific to that type:

- For Number and Date columns, a menu allows you to set their formatting options.
- For Pop-up List columns, the Options list allows you to define the choices in each row’s menu.
**Column Style**

This section contains controls which affect the visual appearance of a column and its data:

- Check the box next to the color well, and the **Background Color** for the column can be made different from the background color of the document window. Remember, sometimes less is more. And, sometimes more is more. So, really, “more” is a tricky concept.

- For the main column of the outline, the **Gutter Color** is the color of the background between the left edge of the column and the first cell in the row. Setting this color brings the structure of your outline into sharp contrast.

- Set the default **Alignment** of text in the column to left, center, or right-justified.

**Column Export Width**

You may never use this section, but if you need it, you’ll need it badly: when you export a document to a plain text format (or copy and paste items into an application which only accepts plain text), OmniOutliner uses spaces to make sure all the columns line up. In this section you can customize how many characters wide each column will be when exporting, and ensure that your exported document will fit within a given total character width if necessary.

**Outline Style**

In this section are options which affect the appearance of the document as a whole:

- The **Background** color for the document window. Set it to hot pink; annoy your friends!

- If **Alternate Rows** is checked, every other row will have an alternate background color, which can make some documents easier to read, and some harder, depending on your particular tastes.

- OmniOutliner is often used for documents like to-do lists in which it’s useful to have a checkbox for marking each row as complete. But since that just gets in the way for other documents, you can uncheck **Show status checkboxes** to hide them all.

**More about Column Types**

Any new column starts out as **Rich Text**, but you can change its type if you want a more specialized kind of behavior:

**Checkbox**

Your column will contain a single checkbox in each row. If you choose **Calculated Summaries** any group’s checkbox will automatically be checked, unchecked, or mixed-state depending on the values of all its children.

**Date**

Anything you enter in the column that looks remotely like a date or time will be reformatted according to the **Format** you specify. You can even enter phrases like “next Tuesday” or “noon” and OmniOutliner will convert them into dates and times.

**Duration**

Each row contains a number with a time unit after it, like “2h” for 2 hours. The options for this setting allow you to set how many hours there are in your day. Setting **Calculated Summaries** tells groups to sum up their sub-items’ durations, which can be handy for, say, project scheduling.

**Pop-up List**

You get to set what items will appear in the pop-up list for each row. You could use this to assign tasks to different people in your company.

**Number**

The options allow you to set how the number is displayed, which can be especially useful for amounts of money.

**Rich Text**

The default: each cell can have multiple fonts and styles in its text.

**Text**

Each cell can only have one font and style, for the entire cell. Useful if you want to absolutely enforce level styles, and not accidentally set styles on a cell-by-cell basis.
OmniOutliner’s toolbar provides shortcuts for commonly-used actions. The ease and flexibility found throughout the program extend to this toolbar; you can customize it to contain as many or as few buttons as you like, or just hide it to reclaim some space.

Below is the default toolbar, which contains some of the most commonly used functions in OmniOutliner. To change it, choose **Customize Toolbar...** from the View menu.

- **Outdent**: Clicking **Outdent** will move the currently selected item left one level of indentation.
- **Indent**: Clicking **Indent** will move the currently selected item right one level of indentation.
- **Add a new row under the current one (the same as pressing return), or delete the current row.**
- **New columns are added on the right side of your outline, and start out containing rich text. You can change their type with the Info panel (see page 10).**
- **These buttons bring up the standard Font and Color panels. These can change the currently selected text, the currently selected row, or the whole selected level if the Info panel’s Level Styles table is the current selection.**
- **Show the Info panel. For more information, please see page 10.**
Other Awesome Toolbar Items

Scripts
You can put AppleScripts onto your toolbar to make them available at the touch of a button. Either write your own scripts, or try some of the examples from the OmniOutliner CD or our website. Any scripts you put into your Library/Application Support/OmniOutliner/Scripts folder will be available when you customize the toolbar.

Group & Ungroup
Select a bunch of rows and press Group to create a new row and make all the selected rows into its children. Ungroup makes all the currently selected row’s children become its peers.

Move Up, Move Down
Clicking Move Up will cause the currently selected item to trade places with the item immediately above it (but on the same outline level). You can also add Move Down, Move Left, or Move Right. Move Left and Move Right are similar to Indent and Outdent, but operate differently when multiple items are selected. Try each to see what suits you best.

Spaces and Separators
Want your toolbar to look just so? You can add separators, spaces, and flexible spaces (which push items after them all the way to the right) until your toolbar is organized just the way you like it.

Customize
Change your toolbar a lot? Put this button on your toolbar and the customization panel is just a click away.

Toolbar Shortcuts
- Choose View ▸ Hide Toolbar or click the lozenge in the upper–right corner of a window’s title bar to hide and show the toolbar.
- Choose View ▸ Customize Toolbar... or Option–Command–click the lozenge to customize the toolbar.
- Command–click the toolbar lozenge to select a different display mode (Icon and Label, Icon Only, or Label Only).
- Command–drag a toolbar item to move it (or remove it) without having to enter the customize mode first.
- Control–click on a toolbar item to get a context menu which lets you do all of the above and more.

OmniOutliner uses the standard toolbar mechanism from Mac OS X’s Cocoa frameworks — so most of these shortcuts will also work in other Mac OS X applications which have toolbars, including Mail, Project Builder, and (of course) OmniWeb and OmniGraffle.
In addition to general preferences for what new documents should look like, OmniOutliner has preferences for which keyboard shortcuts it uses and how your data looks when exported for use in other programs.

**General**

When OmniOutliner starts up, should it open a new document?  
How big should the note area be by default?  
Set the default text color using the color panel...  
...but make sure it doesn’t clash with the background color.

**Keyboard**

In a document with only one column, should pressing tab make the current item a subitem of the item above or skip to the next row?  
Should pressing return in the middle of editing a cell end editing in that cell or split that cell before it creates a new row?  
In a document with multiple columns, should pressing tab make the current item a subitem of the item above, or should it go to the next column?  
When a new row is created, should it be at the same level as the current row, or should it automatically be indented if there are already subitems?  

*Alternating row colors make it easier to figure out what’s on your row.*  
*Keep your mind in the gutter, highlighting the structure of your outlines.*
Text Export

When you copy a section of your outline into a non-rich text document, or when you use the Plain Text file format for File > Export..., OmniOutliner tries to duplicate the look of your outline using basic ASCII text. This preference panel lets you set how OmniOutliner simulates graphical elements and tab stops when exporting to raw text.

- What plain text equivalents should be substituted for graphical bullets?
- What plain text equivalents should be substituted for checkboxes?
- How much space, in inches, should there be between columns, so they don’t run together?
- How much space, in inches, should each tab stop be for each level of indentation?
- How many spaces should be used for each level of indentation?
- What Unicode equivalents should be substituted for our graphical bullets?
- What Unicode equivalents should be substituted for checkboxes?
- What width should bullets have when exported? (Cannot be less than the minimum.)
- What width should checkboxes have? (Cannot be less than the minimum.)
- How many spaces should there be between columns, so they don’t run together?
- What width should checkboxes have? (Cannot be less than the minimum.)

RTF Export

When you copy a section of your outline into a rich text document, or when you use the RTF file format for File > Export..., OmniOutliner tries to duplicate the look of your outline using rich text and Unicode characters. This panel lets you set how OmniOutliner simulates graphical elements and where it sets tab stops when exporting to rich text.

- What plain text equivalents should be substituted for graphical bullets?
- What plain text equivalents should be substituted for checkboxes?
- How much space, in inches, should there be between columns, so they don’t run together?
- How many spaces should be used for each level of indentation?
- What Unicode equivalents should be substituted for our graphical bullets?
- What Unicode equivalents should be substituted for checkboxes?
- What width should bullets have when exported? (Cannot be less than the minimum.)
- What width should checkboxes have? (Cannot be less than the minimum.)
- How much space, in inches, should each tab stop be for each level of indentation?

Software Update

All Omni applications can now check for new versions of themselves when you are connected to the internet, and inform you when patches or new releases become available. (This requires an internet connection.)

There’s an Update preferences panel that lets you control this, modelled after Apple’s Software Update in System Preferences. On this panel you can set how often you want OmniOutliner to check for new versions, or, if you’re really compulsive, you can use the Check for Updates Now button to check as often as you like.

And, if for some reason you don’t even want to be told about new versions, you can simply change the Check for updates pop-up to Manually and checking will never happen unless you click the aforementioned button.

If you ever want to reset your preferences to the original settings, just hit the Default button, and the current preference panel will revert back to the way it was when you first ran OmniOutliner.
OmniOutliner is a good Mac OS X citizen, so **mais naturellement** it can share data with many other programs:

### Import other file formats

To import a file, simply use **File ▶ Open...** or drag the file onto OmniOutliner’s icon. OmniOutliner can view a bunch of different file types, although if you modify these files remember that you can only save in OmniOutliner format. Some of the formats it can import include More™, Concurrence™, plain text with tabs, rich text with tabs, exported iTunes song lists, and, for programmers, “sample” files, “strings” files, and “plist” files. If you have a type you’d like to use, please write us — we’re always eager to add more.

### Export to other file formats

Select **File ▶ Export...** OmniOutliner can export to many different formats. We use the HTML option to generate our product release notes for our website, and the RTF option when we’re mailing documents to underprivileged people who don’t own OmniOutliner.

### OmniGraffle integration

OmniOutliner 2.0 files can be opened in OmniGraffle 2.0. OmniGraffle will then lay out a graph that corresponds to the outline. OmniGraffle has an entire preference panel dedicated to what styles it will assign shapes when importing from OmniOutliner; see its documentation for more details.
What are the bullets next to each item for? Can I hide them?
The round bullets which appear next to items without children are handles by which you can drag items (to reorder them, to group them under other items, or to drag them into other documents or applications). They can’t be hidden; otherwise it’d be impossible to drag items around.

Is there a way to set a default configuration for new documents? Number and type of columns, level formatting, and so on?
OmniOutliner supports “Stationary Pad” documents; once you’ve set up a document with the configuration you’d like new documents to use, save it to whatever location on your hard drive you’d like it to occupy. Next, select the file in the finder, and bring up the Show Info window (You can do so under the File menu). If you check the Stationery Pad box in this window, you’ll be able to open the document in OmniOutliner and get a new untitled document with all of the attributes set up just the way you like them.

Can I synchronize OmniOutliner with my PalmOS organizer?
At the moment, we’re concentrating our efforts on creating a really cool desktop–based outliner, but we do know we’ll need to address Palm compatibility in the future. At the time of this writing, we have an AppleScript that converts an OmniOutliner document into a BrainForest Professional (a popular PalmOS outliner) document. Check out http://www.omnigroup.com/omnioutliner/extras for more information.
(We’d love to be compatible with other PalmOS outliners, so pay special attention when you’re reading the next item!)

How can I import all of the documents I created in some other application you didn’t mention on the previous page?
If you have running copies of both applications, you may be able to write an AppleScript that moves information over into a new OmniOutliner document. If the other application isn’t AppleScriptable, use that “Send Feedback...” item we’re always recommending to let us know what application you need support for. We can’t make any promises, but we’ll certainly take a look. Including a simple document created by the other application is a big help.