Contents

Chapter 1  5  Hello
Some info about OmniPlan and this manual

Chapter 2  7  Introduction to the Interface
An overview of OmniPlan’s windows and views

Chapter 3  13  Quick Tutorial
Step-by-step creation of a simple project from scratch

Chapter 4  27  Details
27  Setting the project start date
27  Creating tasks and resources
28  Creating milestones
28  Deleting items
29  Connecting tasks with dependencies
31  Types of dependencies
32  Tracking assignments with the resource timeline
33  Grouping tasks and resources
35  Characteristics of task groups
36  Editing tasks with the Task Information inspector
38  Using columns in the task and resource outlines
38  Special columns
40  Assigning resources to tasks
43  Using the calendar view to set up working hours
47  Customizing time and currency units with the Project Formatting inspector
48  Rounded time values
48  Duration versus effort
50  Resolving violations
51  Editing resources with the Resource Information inspector
52  Characteristics of resource groups
Chapter 5  77  Getting Help

Where to go when you need to know more
Welcome to OmniPlan
You have a big mess of stuff that needs to get done, a bunch of people and things you can call on to get stuff done, and some kind of outcome you want to reach as a result of doing all that stuff. Then project management happens. Now you have tasks, resources, and milestones. You have an idea of when things need to happen. You know who’s responsible for which assignments, and you have a clue of what will happen if any given part of the plan slips. You even have a chart you can show people, point at a little bar, and say, “this right here is critical”.

Okay, that’s cool. But what’s really cool is that OmniPlan is here to make the whole process as simple and accessible as it can be. We think that managing projects as big and complicated as a major software release, or as small and personal as organizing a camping trip with your friends, should be feasible and enjoyable for everyone.

Welcome to This Manual
A good way to get familiar with OmniPlan is to run through the Introduction to the Interface and the Quick Tutorial here in the manual. Then, as you use the application on your own, come back to the Details section and the Glossary for guidance and ideas.

There’s also an onscreen help book you can get at by choosing OmniPlan Help from the Help menu. It’s searchable, and it includes some more about the technical intricacies of the software, so check that out too, if you like.
Introduction to the Interface

The Main Window

Toolbar
Like in many other Mac applications, the toolbar has buttons for commands you might want to use frequently. Some of the buttons change depending on whether you have the task view, resource view, or calendar view open. Use the Customize Toolbar command in the View menu to set up the controls however you like.

Task View
If you click the first button in the view switcher, you’ll see the task view.

You can type in the task outline to create, edit, and group tasks. The Gantt chart is a visual representation of tasks’ durations and relationships.
Resource View
If you click the second button in the view switcher, you’ll see the resource view.

You can use the resource outline to manage staff, equipment, and materials. The timeline shows the same tasks as the task view’s Gantt chart, split up by which resource they are assigned to.
Calendar View
If you click the third button in the view switcher, you’ll see the calendar view.

You can edit the working calendar for the whole project, and for individual resources. Green blocks in the week calendar represent working hours. You can move blocks around, double-click a block to edit its values directly, or drag in an empty area to create a new block.
View Options
Open the View menu and choose View Options to see the various ways you can customize what kind of information is displayed in each of the task, resource, and calendar views.

For example, in task view, you can choose which columns are visible in the task outline and what kind of information to show on the Gantt chart side.
Inspectors
The inspectors are floating windows which contain information and controls related to what’s selected in the main window. If you don’t see them, click the Inspect button in the toolbar, or pick one from the Inspectors menu. You can show and hide an inspector’s various sections by clicking the icons at the top of each inspector window. Hold Command while clicking to open an inspector section without closing the ones already open.

The Project inspector has information about the document as a whole.

- **Project: Information**
  General info about the project as a whole, such as its title and when it begins.

- **Project: Styles**
  Change the style of tasks and resources. See page 64 for more about styles.

- **Project: Colors**
  Change the color of backgrounds, rows, columns, and separators in the various outlines and charts.

- **Project: Formatting**
  Configure your time and currency units. See page 47 for more about formats.

- **Project: Custom Data**
  Store any kind of miscellaneous data about the project.

Continued on next page
The Task inspector has information about the currently selected tasks or milestones, so it’s available only when the main window is in task view.

**Task: Information**  
General info about the selected task, such as when it’s scheduled and how long it’ll take.  
(See page 36.)

**Task: Assignments**  
A list of the resources assigned to this task.  
(See page 40.)

**Task: Dependencies**  
A list of the dependencies this task is involved in.  
(See page 29.)

**Task: Custom Data**  
Store any kind of miscellaneous data about the task.  
(See page 55.)

The Resource inspector has information about the currently selected resources, so it’s available only when the main window is in resource view.

**Resource: Information**  
General info about the selected resource, such as how much of it is available and how much it costs. See more about this inspector on page 51.

**Resource: Assignments**  
A list of the tasks this resource is assigned to.  
See page 40 for more about assignments.

**Resource: Custom Data**  
Store any miscellaneous data about the resource.  
(See page 55.)
Quick Tutorial

About the Tutorial
This tutorial introduces the basic steps involved in putting together a really simple project—building a model airplane—in OmniPlan. When you’re done, you should be able to put together your own more complex projects. Some of the finer points are saved for later, so if you want to know more, check the Details section starting on page 27.

Creating a Project

1. Create a File
From the File menu, choose New.

You get a fresh project document with one task.
2. Choose a Start Date
In the Project Information inspector, choose whether you want the project to start on a specific date, or on some undetermined date (called T-day).

3. Create Milestones
Milestones are a project’s important moments. They don’t take up time like tasks do; they just mark certain points in the project cycle.

In task view, use the action menu to add a milestone, or just use the Task Information inspector to change an existing task’s Type to Milestone.

The milestone appears as a diamond on the Gantt chart. In this example, the milestone represents the completion of a model airplane.
4. Create Tasks
A task is anything that needs to get done in order for the project to move toward completion. Each task has attributes such as start and end dates, a completion percentage, and resource assignments; these show up in the various columns of the task outline, and in the Task Information inspector. Tasks can be grouped together, and a task can be dependent on other tasks.

For now, just create the tasks and name them. Press the Return key once (or twice, depending on how your keyboard preferences are set) to create a new task.

Each task in the outline corresponds to a bar on the Gantt chart. Here we’ve listed all of the tasks needed to build our airplane.

5. Edit the Work Week
Switch to calendar view. You can move, resize, or type in the green blocks to adjust the working hours for the project.

Here is a work week of 6 PM to 9 PM, 5 days a week.

Then, if your average work day is not 8 hours, you should visit the Project Formatting inspector and change the hours per day setting, so that your task durations will make sense.
6. Set Schedule Exceptions
Still in calendar view, choose Work Schedule for Project from the pop-up menu below the resource list, then choose a week in the calendar that appears. You can change the work hours for a specific week, to account for exceptions such as holidays or overtime.

Here Wednesday the 15th is an off-day. You can see the normal work week’s schedule in gray for comparison.

7. Set Task Durations
Each task takes a certain amount of time to complete. You can set a task’s duration by typing in the Effort column of the task outline, or by clicking and dragging the ridges on the right end of a bar in the Gantt chart.

The length of the bar in the Gantt chart represents the duration.
8. Group Tasks
You can associate related tasks together into groups. Select some tasks and use
the action menu to group them. Or just press Command-] to indent the
selected tasks as children of the task immediately above them in the outline.

Grouped tasks are indented in the outline.
9. Connect Tasks with Dependency Lines

Of course, most tasks require some other task to be finished before they can begin. You can represent this by connecting tasks with dependency lines. There are several types of dependency line, but the most common is a Finish→Start dependency.

Select two tasks which need to be connected, and click the Connection button in the toolbar. A Finish→Start dependency line appears between the tasks, starting from the task which comes first in the outline.

As you connect tasks, they automatically reschedule to respect the dependencies. Notice how the start date set up in the Project Information inspector (Nov 14) puts the project near the day marked as an off-day in the calendar view (Nov 15), so no work is scheduled on that day.
10. Create Resources
Resources are the people and things necessary to make your project happen.

Creating resources works much like creating tasks. Switch to resource view , which contains the resource outline. Create a few resources and name them. Then click the Type icon for each one and choose whether it is Staff, Equipment, or Material. Resources can be grouped in the same way as tasks.

A timeline appears on the right side for each resource you create, but it is empty until you assign the resource to some tasks.
11. Assign Resources
You can assign resources to tasks from task view or from resource view.

In task view, you can select the task and then use the Task Assignments inspector to select which resources should be assigned to it.

Using the Task Assignments inspector to assign three resources to the selected task.

Or you can just pop open the menu on the Assignment button in the toolbar.

Using the Assignment toolbar menu to assign a resource to the selected task.
Because the icon is turned on for the tasks’ Duration field, assigning multiple resources to a task can change its duration. If you’d rather the duration didn’t change, you can click the icon by the Effort field instead.
12. Level Resources
Resource leveling analyzes your project and figures out the most efficient way to arrange it, taking into account things like dependencies and the amount of resources available.

If you make some manual changes to the schedule, like rescheduling incomplete tasks, setting up dependencies, or changing resource assignments, you should then level the project again to make sure your resource usage is balanced out.

Two tasks are assigned to use the resource *Me* and the resource *Glue* at the same time.

Click the Level button in the toolbar, then deselect the Don’t schedule any task before date checkbox and click OK.

The second task moves to avoid the resource usage conflict.
13. Set the Baseline
When you have a schedule set up and balanced properly, and the project is ready to begin, choose Set Baseline from the Project menu. This copies the schedule you created into the baseline schedule. The baseline schedule remains unchanged as you update the actual schedule; as the project goes on you can keep track of how closely it is following the original plan.

You can choose Split from the Baseline/Actual menu on the toolbar to compare the baseline schedule to the actual schedule. In this picture, the schedule has slipped a bit compared to the original plan.

14. Resolve Violations
If there are any logical inconsistencies in your schedule, they are marked with red icons in your task outline and in the status bar at the bottom of the window. Click one of them to see the Violations window, which explains what the problems are and how to fix them.
## Maintaining a Project

### 15. Check the Critical Path

The **Critical Path** button in the toolbar highlights the series of tasks and dependencies which determine the project’s end date. If any of the tasks on the critical path ends up taking more or less time than planned, then the end date of the project as a whole will change as well. Usually, these are the tasks you most need to make sure are on track.

Most of the tasks in this project are on the critical path, because they are almost all in one continuous chain.

### 16. Update Task Completion

As a project progresses, you can keep track of how far along each task is. You can update the percentages in the **Completed** column or the Task Information inspector. Or, just drag the completion handle on a bar in the Gantt chart.

Type a percentage in the **Completed** column (or the Task Information inspector)... Or just drag the white handle on the task bar.
17. Catch Up or Reschedule
If everything is going as planned, you can click the **Catch Up** toolbar button to bring the completion percentage of every task (or just the selected tasks) to today’s date.

If you have tasks which were planned to be complete by now, but aren’t, you can click the **Reschedule** toolbar button to move them forward. Afterwards, remember to level the project.
Setting the project start date
If you know when the project is going to start, you can enter a date in the Project Information inspector. Then all of the working hours and work schedule exceptions as set up in the calendar view can be applied properly, and real dates appear in the interface.

If you don’t know when the project will start, you can mark the start date undetermined in the Project Information inspector. For the purposes of applying the work week, the project is assumed to start on the first day of the week. The normal work week for the project and for the individual resources is respected, but work schedule exceptions such as holidays are ignored.

In a project with an undetermined start date, all dates are represented in the format “T day”, for the first day of the project, or “T + x”, where x is some time duration. For example, “T+2w 1d” means 2 weeks and 1 day after the start of the project.

When you change the start date of an existing project from an undetermined date to a real date, the project may shift as the new position of weekends, off-days, and other exceptions are taken into account.

Creating tasks and resources
There are several ways to create new items in task or resource view:

• Select an item in the task outline or the resource outline and press Return (or Command-Return, depending on the Keyboard Options in OmniPlan’s General preferences).

• Click the Add button below the outline.

• Click the Add button— or —in the toolbar above the outline.

• Drag an Address Book card into the Resource outline to create a Staff resource which collects its contact information from the Address Book.
Creating milestones
There are several ways to make a new milestone in task view:

• Create a new task, then use the Task Information inspector change its Type to Milestone.

• Click the Add Milestone button in the toolbar.

• Choose Add ▶ Milestone from the action menu below the task outline.

Deleting items
• Select an item in the outline, such as a task, milestone, resource, or group, then press the Delete key.

• Select the item, then click the Remove button below the outline.

• Select the item, then click the Remove button—or—in the toolbar above the outline.
Connecting tasks with dependencies

When you have a task which requires something from another task, you can represent their relationship with dependency lines. A dependency line is drawn from the beginning or end of one task (or group, or milestone) to the beginning or end of another.

When you create a dependency, the dependent task automatically reschedules itself to respect the dependency. With further changes to the schedule and leveling, the tasks continue trying to follow the dependencies. If a dependency becomes impossible or you manually make a task stop obeying its dependencies, a violation occurs, and you should resolve it with the Violations window (See page 50 for more about violations).

There are a few ways to connect tasks:

- Select two or more tasks in the outline view or the Gantt chart, then click the Connection button to create a Finish→Start dependency.

- Select two or more tasks in the task outline or the Gantt chart, then click the triangle in the corner of the Connection button—or click and hold the Connection button—to summon a menu of dependency types; choose the type you want.
• Put the mouse pointer over a task bar in the Gantt chart, then drag one of the lines that appears at the beginning or end of the bar. It becomes a dependency line, which you can then drop onto the start or end of another task, group, or milestone. Whether you drag from the start or the end of the prerequisite task, and whether you drop onto the start or end of the dependent task, determines the type of dependency.

• In the Dependencies column of the dependent task (not the prerequisite task), type a dependency code. These codes combine the IDs of the tasks involved and the type of dependency like so:

A Start→Finish dependency from task ID 1

A Start→Start dependency from task ID 1

A Finish→Start dependency from task ID 4.1. FS is the most common type of dependency, so a task ID by itself without any letters is assumed to be FS.

A Finish→Start dependency from task ID 4.2, with a lead time of 1 day. Lead time is extra padding between tasks.
**Types of dependencies**

**Finish→Start:** The first task must end before the second task can start; the tasks must not overlap except at the instant the first one ends. This is the most common type of dependency, and the kind that you get when you connect two selected tasks by clicking the **Connection** button in the toolbar.

![Diagram](image)

**Finish→Finish:** When the first task ends, then the second one can end; the tasks may overlap.

![Diagram](image)

**Start→Start:** Once the first task has started, the second one can start; the tasks may overlap.

![Diagram](image)

**Start→Finish:** Once the first task starts, the second one can finish; the tasks must overlap at least at the instant the first one starts.

![Diagram](image)
Tracking assignments with the resource timeline

Click this button to show or hide the resource allocation graph beneath each resource’s timeline.

The chart shows a timeline of tasks for each resource you select in the outline. If you select no resources, the chart shows all resources’ timelines.

You can zoom the timeline the same way you zoom the Gantt chart. Just choose a scale from this menu or drag in the header area.

A blue bar in the load graph represents time when the resource is being used at less than 100% of its available units.

A green bar in the load graph represents time when the resource is being used at exactly 100% of its available units.

A pink bar in the load graph represents time when the resource is being used at over 100% of its available units. You can level the project to clear up such problems.

Below the resources’ timelines, an Unassigned timeline shows the tasks which aren’t assigned to any resource. You can drag tasks between timelines to change their assignments.
Grouping tasks and resources

There are a few ways to approach grouping.

Select an item

Add Child
Command-}

Item becomes a group

Add more items to the group

Select some items

Indent
Command-]
(or Tab, depending on preference setting)

Items become children of previous item
Select some items

Group
Command-Option-L

Items become children of new group

Select some items

Drag them beneath an item
Note that the horizontal positioning determines the tasks’ indentation level

They become children of that item
Characteristics of task groups
A task group determines most of its characteristics from the tasks it contains, rather than having characteristics of its own.

Name: Of course, a task group has its own name.

Type: A task group can contain Tasks, Milestones, and other Groups, but its own type is always Group.

Effort: The effort of a group is the sum of the effort of all tasks it contains.

Duration: The duration of a group is the amount of time between the beginning of its first task and the end of its last task, not the sum of the durations of all its tasks. If a group contains three one-hour tasks all happening at the same time, the group has a duration of one hour, not three hours.

Scheduling: A group can have a specific start date, which can then affect the start dates of tasks inside it.

Reserve: A group can have reserve time, which is extra time allowed in case the tasks inside end up taking longer than they are scheduled to take.

Dependencies: A group can have dependencies just like a regular task.

Resource Assignments: If you assign a resource to a task group, the resource gets assigned to all tasks in the group. The group itself can’t have any resources assigned.
Editing tasks with the Task Information inspector

Tasks have a lot of details to keep track of. When you select one or more tasks in the task outline, the Task Information inspector shows the task details.

The task **Name** is the same as the one that appears in the task outline.

**Effort** is how much total work it will take for this task to be complete. **Duration** is how much time it will take to get that work done. These can differ based on how many resources are assigned to the task, and the efficiency of the assigned resources. The icon sets which value should change when you assign more resources (see page 48).

The task **Cost** is how much money the task takes to complete. This is just the cost of the task itself, distinct from the per-use or per-hour costs of resources assigned to the task.

The **Actual** start and end dates are when the task really happened during the execution of the project. These can be locked against accidental editing, changes from dependencies, and leveling.

**Constraints** indicate the earliest a task may begin and the latest it may end.

The **Baseline** start and end dates indicate when the task is expected to start and end, according to the original plan. These appear once you use the Set Baseline command on a project.
You can change the **Type** from a normal **Task** to a **Milestone** (a zero-length event which represents an important moment in the project’s life) or a task **Group**, which can contain child tasks. See page 35 for more about groups.

**Reserve** is an extra buffer of time added to task groups, in case the tasks in the group take longer than expected. Note that there is a difference between no reserve (the checkbox is deselected) and 0 reserve (the checkbox is selected, but the field says 0 because all of the reserve time has been used up).

The amount **Completed** is a percentage of how far along the task is. This is also displayed as shading on the task bar in the Gantt chart.

The **Schedule** method sets when in the schedule OmniPlan should try to place a task: as soon as possible, on a certain date, or whenever resources become available. For lots more about how this works and scheduling in general, see page 56.

Editable date fields have this calendar icon; click it to summon a mini calendar window you can use to choose a date and time.

The **Variance** shows how much the actual dates differ from the baseline dates. This is calculated automatically; you don’t have to enter it yourself.
Using columns in the task and resource outlines

Various columns are available in the task outline and the resource outline; set which columns are visible by choosing View Options from the View menu, or Control-clicking the column headers.

Some of the values in the columns (such as Task Cost) can be edited directly in the outline; others (such as Total Cost) are calculated automatically. Generally, values you can edit in the outline are also editable in the Task Information or Resource Information inspectors.

Use the Arrow keys, or Tab and Shift-Tab (depending on the Keyboard Options in OmniPlan’s General preferences), to move between cells.

Drag column titles left and right to rearrange the columns.

Each key you set up in the Task and Resource Custom Data inspectors becomes available as a column in the outline.

You can sort the selected items in the outline, or all items (if nothing is selected), by using the Sort commands in the Structure menu.

Special columns

Violations (in task view)

This column displays an icon for each task which has a violation. You can click the icon to summon the Violations window and see what the problem is.

Status (in task view)

This column shows alarm clock icons for tasks that are incomplete and due in the next few days, or in the past. Note that these icons won’t appear if your project has an undetermined start date in the Project Information inspector. Each color of alarm clock has a meaning:

- This task is incomplete and due in the next 3 work days.
- This task is incomplete and due in the next work day.
- This task is incomplete and past due. Try panicking.
Priority (in task view)
You can manually set a priority on a task, to control the order in which tasks are leveled. Priority can be any integer, so you are welcome to make up your own convention (1 to 3, 0 to 999, or whatever you like). During leveling, if two tasks are assigned to one resource at the same time, the task with higher priority gets to use the resource first. See the Scheduling and Leveling section on page 56 for more information.

Assigned (in task view)
This column lists the resources that are assigned to the task. See the Assigning Resources to Tasks section on page 40 for information about how assignments work.

Dependencies (in task view)
This column lists the other tasks on which this task depends. See the Connecting Tasks with Dependencies section on page 29 for information about how dependencies work.

Notes
You can click the note icon in the selected row to show or hide the row’s note, or to create a note if there isn’t one yet. Rows with notes show a note icon even when they are deselected.

Unique ID
The unique ID is a number assigned to each task or resource to identify it unambiguously, even if its name or position in the outline changes. A unique ID won’t ever change, and each new task or resource you create gets a new unique ID number. These numbers are useful for matching up items when you are importing and exporting projects between OmniPlan and other applications.

IM (in resource view)
If a Staff resource is associated with an Address Book card, and that card has instant messaging account information, this column shows when the resource is available to chat. You can double-click the IM status icon to start a chat with that person.
**Custom Work Week (in resource view)**

An icon appears in this column if a resource has a work week that differs from its default work week; the default work week for a resource is defined by its parent (if it’s a member of a group) or the project (if it’s not). You can click the icon to see the resource’s work week, and from there you can always click the button in the upper right of the week view to revert to the default.

**Schedule Exception (in resource view)**

An icon appears in this column if a resource has a work schedule that differs from its work week, such as when someone goes on vacation. You can click the icon to see the resource’s work schedule, and from there you can check the orange-highlighted dates to see where its exceptions are. You can click the button in the upper right corner of any week view to clear the resource’s exceptions for that week.

**Assigning resources to tasks**

Most tasks require some kind of resources in order to complete. Software development needs programmers, excavation needs heavy machinery, and construction needs lumber. Tracking which resources are assigned to which tasks helps you to see how long the tasks will take to complete, and when your resources are going to be busy or idle.

**There are several ways to assign a resource to a task:**

- Select the task in task view, open the Task Assignments inspector, and check the resources you’d like to assign. You can then edit the amount to assign, if it’s different from the default amount.

- You can also see all of a resource’s assignments, and adjust their amounts or clear them, in the Resource Assignments inspector.
• Edit the Assigned column of the task outline, or the assigned resources area in the Gantt chart.

Enter resource names in the Assigned column to assign them to the task.

You can also double-click resource lists in the Gantt chart and edit them directly there.

Follow a material or equipment resource name with a number in curly braces to assign an amount other than 1 unit.

Separate multiple resource names with semicolons.

Follow a staff resource with a percentage inside curly braces to assign an amount other than 100%.

• Drag tasks around between resources’ lanes and the Unassigned lane in the resource timeline chart. While dragging a task from one resource to another, you can hold the Option key to assign the task to the second resource without unassigning it from the first.

• Drag a card from Address Book to a task in the task view. If the project doesn’t yet have a resource associated with that card, a new one is added.
Assigning groups
Task groups and resource groups behave specially when you use them in assignments.

If you assign a resource to a group of tasks, the resource becomes assigned to every task in the group. The group itself can’t have a resource assigned to it.

If you assign a group of resources to a task, OmniPlan provisionally labels the task as having the whole resource assigned. Then, when you level resources, one member of the group is chosen to work on that task.

Assign a resource group to a task
Level Resources
OmniPlan chooses an available member of the group
If that member becomes unavailable, leveling again assigns a different member
Using the calendar view to set up working hours

The Normal Work Week is a general set of working hours to be followed in a typical week. This set of hours is applied to every week in the project, thus determining how many hours of effort can be completed in each day. Resources inherit their work week schedules from the project, but you can customize them individually if they work different hours. To set up exceptions to the work week, for events such as half-days, holidays, and overtime, see the next diagram, about customizing the work schedule.

When you select a resource in the outline, you can edit that resource’s working hours. If nothing is selected, you can edit the working hours for the whole project.

If a resource’s work week is customized from the whole project’s normal work week, the icon appears in the Custom Work Week column.

You can switch to customizing the work schedule for specific days, rather than the normal work week, with this pop-up menu. See the next diagram for more information about customizing the work schedule.
Using the calendar view to set up working hours

The green blocks represent blocks of working time. Drag them around the week, or double-click them to type a day and time range.

Click a block to select it; you can then press the arrow keys to move it, or press the Delete key to remove it.

Drag any edge of a time block to resize it.

Drag or double-click in an empty area to create a new time block.

If the work week is customized, you can always revert it back to the default by clicking the button.
The **Work Schedule** is a calendar of the working hours for specific days. You can set up holidays, half-days, overtime, and other such exceptions to the normal work week. Just like the normal work week, there is a work schedule for the whole project, which the resources follow, but you can also customize resources individually.

Select a resource in the outline to edit its work schedule, or select nothing to edit the work schedule for the whole project. If a resource has any exceptions to its normal work week, the 🗓️ icon appears in the Schedule Exception column.

Choose a week to edit from the mini calendar. Days which differ from the standard work week are highlighted in orange. Click the arrows to move between months; Option-click to move a year at a time.
Using the calendar view to set up working hours

You can edit the time blocks here in the same way as when editing the normal work week.

If the selected week contains any exceptions, you can click the to revert to the normal work week.

The normal work week appears in gray, so you can see how this week’s schedule differs.
Customizing time and currency units with the Project Formatting inspector

Units selected here are used to display durations and effort amounts. You can plan in hours, days, or whatever works best for you. Your work day may be any number of hours. These conversion factors determine how to add up hours into the larger units.

Choose a standard currency format from the list, or just type the number 1234.56 in the format of your choice. The preview shows what your durations look like with the current units and conversion factors.

The effort conversion factors don’t actually change the working hours for the project, just the way durations are entered and displayed. To change the working hours, visit the work week section of the Calendar view.

Duration and effort values have the following abbreviations. Which units are displayed, and how hours add up into bigger units, is determined by the Formatting inspector above.

s — second    w — week
m — minute    mo — month
h — hour    y — year
d — day

Note that the date headers in the Gantt chart and resource timelines can also be customized, with the Display preferences. See page 63 for more information about date headers.
Rounded time values

If a value contains some amount of time that is not visible based on your units settings, you may see a rounded value. For example, if you have turned off the display of minutes in the Project Formatting inspector, and you have a task that starts at 9:00 and ends at 9:55, the value you see is “< 1h”. If you want to know the actual value, you can turn on the smaller units in the Project Formatting inspector, or just check the start and end times. If you want to make the value conform to your units, you can just delete the greater than or less than sign and the value updates.

Duration versus effort

Duration is how long a task takes in actual working hours in the schedule. If the task begins at 8:00 and ends at 12:00, that’s a duration of 4 hours. Note that non-working times don’t count; if a task starts one afternoon and doesn’t complete until the next morning, or spans a lunch break, only the working hours are counted. Also note that the resources assigned to a task may have different working hours than the project as a whole, and thus the displayed duration of a task may not match up exactly with the amount of effort it takes.

Effort is the total amount of working time put into a task by all assigned resources. A task with a duration of 4 hours, with 2 resources assigned at 100%, has an effort value of 8 hours. Note that Material resources don’t contribute to effort, only Staff and Equipment resources do.

The duration and the effort of a task can change depending on the resources you assign, and depending on the state of the icon in the Task Information inspector.

Determining which value to recalculate

The Effort and Duration fields in the Task Information inspector share an icon of two little resources .

When you assign or unassign staff and equipment resources, the field with the darkened icon re-calculates its value; the other field stays the same. Click either icon to swap them. Regardless of which value is calculated, you can always edit either value manually.

All of the examples in the next section assume that the icon is on the Duration field, thus allowing the duration to be recalculated. Otherwise, the effort would be recalculated.
What Makes Duration and Effort Change

**Number of Assigned Resources**
Assigning more resources to a task generally causes the task to take less time, because the required effort gets completed sooner.

<table>
<thead>
<tr>
<th>Task</th>
<th>Duration</th>
<th>Effort</th>
</tr>
</thead>
<tbody>
<tr>
<td>1) Task 1</td>
<td>8h</td>
<td>8h</td>
</tr>
</tbody>
</table>

Assigning less-efficient resources to a task causes the duration to be longer than the effort, because the resource takes more time to achieve the same amount of effort.

<table>
<thead>
<tr>
<th>Task</th>
<th>Duration</th>
<th>Effort</th>
</tr>
</thead>
<tbody>
<tr>
<td>1) Task 1</td>
<td>4h</td>
<td>8h</td>
</tr>
</tbody>
</table>

Assigning fewer units of a resource to a task causes the duration to be longer than the effort, because less of the resource’s time and energy is being spent on that task. This situation is common when a resource is split between multiple tasks at one time.

<table>
<thead>
<tr>
<th>Task</th>
<th>Duration</th>
<th>Effort</th>
</tr>
</thead>
<tbody>
<tr>
<td>1) Task 1</td>
<td>8h</td>
<td>4h</td>
</tr>
</tbody>
</table>

The amount of a resource you can assign to tasks depends on the resource’s available Units (set in the Resource Information inspector or the Units column of the Resource outline). Assigning more of a resource than is available causes a violation and shows up as overutilization in the Resource timeline.
Resolving violations

A violation is some kind of problem with the project, such as an impossible dependency loop, a task which starts before the project start date, or a task which is outside its start or end constraints. When a task has such a problem, the violation symbol 🟥 appears in the Violations column of the task outline.

You can click the little violation symbol, or the Violations button 🟥 in the toolbar, to open the Violations window.

![Violations window]

This window lists all of the violations in the project. Most violation explanations include links you can click to immediately resolve the problem.
Editing resources with the Resource Information inspector

The resource **Name** is the same as the one that appears in the resource outline.

A staff resource can be assigned an email **Address**. If the resource is associated with an Address Book card, you can use the pop-up menu to pick which address to use. Or, you can always just type an address.

The resource **Type** can be Staff, Equipment, or Material.

The **Units** value means how much of the resource is available. For materials, this measures the amount required instead.

The **Cost per Use** is an amount of money for each time the resource is assigned to a task.

**Total Uses** means the number of times this resource is assigned to a task.

**Total Cost** is the combined cost of all uses and all hours for this resource.
Characteristics of resource groups
A resource group is just a way to organize several resources together, so it doesn’t have a lot of the same characteristics as an individual resource, like Efficiency and Cost.

Name: Of course, a resource group has its own name.

Address: You can assign an e-mail address to a group, in case you have a mailing list or some address which goes to all of the members in the group.

Type: A resource group can contain resources of any type (   📚 Staff,   🎫 Equipment, or   🎯 Material), but its own type is always   ⭕ Group.

Cost/Use, Cost/Hour, and Efficiency: These are shown as averages of the values of all members of the group. If you enter a new value, it is applied to all members of the group.
Visual planning in the Gantt chart
Many attributes of tasks can be edited directly with the mouse in the Gantt chart. When you put your mouse pointer on a task bar, controls appear for manipulating the task.

Rescheduling tasks by dragging
Grab the middle of a task bar, any part of it away from the controls.

Drag sideways to move the task in time. A help tag appears to let you know the new start and end times. Hold Shift while dragging to snap to round values.

Drop the task at the new date and time. When you move a task like this, its Scheduling method in the Task Information inspector changes to “on specific date” and the task tries to maintain its new manually-set start date.

Changing the duration of a task by dragging
Grab the little traction pad at the right end of a task bar.

Drag the end of the bar left or right to change the task’s duration. A help tag appears to let you know the new duration and end date. Hold Shift while dragging to snap to round values.
Adjusting task completion by dragging

Grab the white, house-shaped handle on a task bar.

Drag the handle to update the completion. A help tag appears to let you know the completion amount and the remaining time.

Drawing dependency lines between tasks

Put the mouse pointer over a task bar in the Gantt chart to see the mini dependency lines.

Drag a mini dependency line from the beginning or end of one task.

Drop the line onto the beginning or end of another task to create a dependency.

Drawing constraints on tasks

Hold Shift and drag from the beginning or end of a task to create a start or end constraint.

Hold Shift and double-click an existing constraint to remove it.

Locking start or end dates

Command-click a task’s start or end to lock or unlock it.
**Using notes**

The task outline and the resource outline both have a Notes column, which you can use to store extra text about any item.

To edit the selected item’s note, press Command-’, press the Enter key, or click the Add Note icon in the Notes column.

Once an item has a note, you can move in and out of the note field by pressing Command-’ (which hides the note after you stop editing it) or Enter (which leaves the note open).

The font style of notes can be set up in the Project Styles inspector; see page 64 for more about styles.

**Using the Custom Data inspectors**

Each of the three main inspector windows (Project, Task, and Resource) has a Custom Data inspector. You can use this to keep your own information about the project or about individual tasks and resources.

Custom data is stored as key/value pairs. The **Key** is like a label for what type of information you are storing, and the **Value** is the information itself.

For example, here’s how you could keep track of staff members’ phone numbers:

Select a staff resource in the resource outline, and open the Resource Custom Data inspector.

Then click the plus button at the bottom of the inspector to create a new key/value pair.

Name the key “Phone Number”.

Continued on next page
Enter a number as the value for the selected resource.

Now that you’ve created the key for this resource, every other resource has the same key, ready for you to enter a value.

You can show custom data as a column in the task and resource outlines by choosing View Options from the View menu.

How scheduling and leveling work
The Task Information inspector’s Schedule method indicates how OmniPlan should determine when a task is to occur in the project.

By default, new tasks are scheduled as early as constraints allow. This means the task is placed at the very earliest time possible, taking into consideration start and end constraints, and dependencies on other tasks. Resource availability is not taken into consideration, so resources may end up overutilized.

Tasks scheduled as early as possible.
If you manually set the date for a task (by typing it in the Task Information inspector, or dragging a task bar in the Gantt chart), its scheduling changes to **on specified date**. A task scheduled in this way will remain so unless you select it and click the Schedule Reset button on the Task Information inspector. Then it reverts back to scheduling **as early as constraints allow**.

![Tasks scheduled on specified dates.](image1)

When you **level** the project, OmniPlan rearranges tasks which have resources assigned, to make sure no resource is being used at more than 100% of its availability. Tasks moved back by resource leveling have their scheduling method changed to **by resource availability**. A dotted dependency line appears between the task which gets access to the resource first, and the task which waits on the resource.

![Tasks scheduled by resource availability. The dotted lines show resource-based dependencies.](image2)

During leveling, OmniPlan has to make an educated decision about which task should get access to a resource first, and which tasks should be pushed back by a dotted resource-dependency line. In judging which task to put first, the following criteria matter, in this order:

- Requirements to end by a certain time, such as locked end dates, constraints, or being a prerequisite to a task with such a requirement.
- Task Priority, as set in the Priority column of the task outline.
- Position in the task outline; tasks with lower ID numbers are scheduled earlier.
Comparing the baseline and actual schedules
Once you have finished setting up a project and you’re ready to start implementing it, you can set a baseline schedule. The baseline represents the original intentions of the project, for comparison with the actual schedule. For example, consider this simple project:

Choose Split Schedule or Both Schedules to see the baseline and actual schedules together, so you can compare them.

Once you click the Set Baseline button, the baseline schedule is decided and any further changes are applied to the actual schedule instead.

The “Set Up Equipment” task took less time than expected. When you change the Actual task, the Baseline task remains visible below it for comparison.

The Showtime milestone has updated its time. You can check the original time by switching to the Baseline schedule, or looking in the Task Information inspector.
To revise the baseline schedule after it’s already been set:

Select the tasks to revise.

Click the **Set Baseline** button.

Select the **Set only on selected tasks** checkbox and click **OK**.

The selected tasks’ Baseline schedule updates to match its Actual schedule.

You can also modify individual tasks’ baseline dates in the Task Information inspector.

---

**Catching up task completion to the present**

If everything is going according to plan...

Click the Catch Up button.

Choose a date and time (today by default), whether to allow tasks to be marked partially complete, and whether to update all tasks or just the selected ones.

The tasks’ completion percentages are updated to the specified date and time.
**Rescheduling incomplete tasks**

Some tasks are not as complete as they were scheduled to be.

Click the Reschedule toolbar button.

Choose a date and time to reschedule the incomplete tasks, and whether to update all tasks or just the selected ones.

The incomplete tasks move, and the whole schedule updates, so that work can continue from here.

**Automatically opening or saving documents with the General preferences**

The General preferences are the first pane in the preferences window, available by choosing **Preferences** from the **OmniPlan** menu.

When OmniPlan starts up, it can summon whatever documents you were working on the last time you quit, and it can create a new document if you don’t have anything else open. These settings are both in the General preferences pane.
OmniPlan automatically saves a backup version of your document as you work on it, in case there is a crash, power failure, or some other misfortune. The setting for how often to save a backup is in the General preference pane. You can always get back to the last deliberately saved version of a document by choosing **Revert To Saved** from the **File** menu. If you close a document and choose not to save it, the automatically saved backup version is discarded.

When a document is saved to the disk, the red close button is empty.

When you have unsaved changes, a dot appears in the close button.

Something bad happens.

When you reopen the document, the last auto-backed-up version appears as a document with unsaved changes. You can continue working with the backed up version, or you can choose **Revert To Saved** from the **File** menu to go back to the saved version.
Customizing keyboard behaviors with the General preferences

The way that the Tab and Return keys work can be customized to suit the way you work. These options are in the General pane of the preferences, available from the OmniPlan menu.

When pressing Tab

You can set the Tab key to do one of two things:

• Indent the currently selected item in the outline, thus making it a child of the item above it; pressing Shift-Tab outdents the selected item.

• Move to the next cell in the outline; pressing Shift-Tab moves to the previous cell.

Either way, the Indent and Outdent commands in the Structure menu (and their keyboard shortcuts, Command-[ or Command-] by default) will always work.

You can always press Option-Tab to type a tab character at the insertion point.

When pressing Return in a cell, create a new row

When you are done editing the contents of a cell in the outline, you might press Return to finish editing. If this preference is turned on, a new item is then created. Otherwise, the editing just ends and the current item becomes selected.

Whether this setting is on or off, pressing Return while not editing a cell always creates a new item.

You can hold Command while pressing Return to temporarily change the setting; for example you could press Command-Return to finish editing and create a new item, even if the setting was turned off.
Customizing date headers with the Display preferences

The Display preferences are the second pane of the preferences window, available from the OmniPlan menu.

You can customize the format of dates and date ranges that appear at the top of the Gantt chart, the resource timelines, and the work week chart.

Here’s where you can assemble a date format. Drag tokens from the well below, and type spaces or characters wherever you want them to appear.

Some tokens offer information about the date at the beginning or end of a week or quarter. This is so that you can, for example, create a week format which indicates the first and last days of the week. The week format shown here shows the month and date at the beginning of the week, followed by the month and date at the end of the week.

The pop-up menu determines which scale you are editing. The different time scales appear in headers based on the zoom scale.

Tokens can be dragged to the format field above to construct a date format. Click the triangle on the right side of a token to change the display of the token. For example, this token represents the month; you can choose to display the month as a full word (January), an abbreviation (Jan), a two-digit number (01), or a one-digit number (1).
Adding style with the Project Styles inspector

**Structural Styles**: Styles that apply to all items of a certain type.

**Named Styles**: Custom styles you can apply wherever you like.

**Task Bar Color Controls**: Of course, these are only available for tasks, groups, and milestones.

You can use styles (like different fonts, bold or italic text, or colors) to make a project plan that’s clear and beautiful.

**Structural Styles: Styling many items at once**
You can change the style of a lot of items at once, based on what they are. For example, you could change the font size for the whole project, make all resource names italic, or make all completed tasks gray.

**How to set up structural styles**
In the list of Structural Styles, select the one you want to change.
Use the style controls on the right side of the inspector to change the default style for everything of the selected type.
Available Structural Styles

Whole Document — Everything throughout the entire document; it can be overridden by the more specific styles listed below it.

Column Titles — The headers above the outline views and charts, and the sideways resource names in the resource timeline.

Notes — Notes attached to tasks and resources.

Tasks — All tasks, but not groups or milestones. Note that the Completed Tasks and Overdue Tasks styles can override this.

Completed Tasks — Any task whose completion is at 100%. You could, for example, make tasks’ Gantt bars turn gray when they are finished.

Overdue Tasks — Tasks which were scheduled to complete in the past, but are not complete. You might like to turn these bright red so that you can see where your project is getting behind.

Task Groups — All groups of tasks. By default, their titles are in bold text to distinguish them from single tasks.

Milestones — All milestones. By default they are styled the same as regular tasks.

Resources — All resources, how they appear in the resource outline and as assignments on the Gantt chart.

Precedence
Structural styles are the most general type of style, so named styles or ad-hoc styles can override them.
**Named Styles: Creating your own reusable styles**
You can make up your own styles and reuse them throughout the document.

**How to set up named styles**
Click the plus button + at the bottom of the styles list to create a new named style.

Then, while you have the named style selected, use the controls on the right side of the inspector to change its attributes.

Once the style is set up how you want it, apply it to an item in the main window by either dragging it and dropping it on the item, or by selecting the item and then pressing the appropriate function key.

You can keep applying the named style to items, and any further changes you make to the named style will get applied to every item that has it applied.

**Precedence**
Named styles take precedence over structural styles; if a structural style and a named style are both applied to the same item, the named style wins.

**Ad-hoc styling: Styling items individually**
If you just want to apply a style to something without any special logic or updating, you can use an ad-hoc style.

**How to apply an ad-hoc style**
In the main window, select the items, or the part of a note, you want to style. Use the right side of the Project Styles inspector to style the selected items.

**Precedence**
Ad-hoc styles have the highest precedence. If an item has an ad-hoc style applied to it, that style wins over any named styles or structural styles.
The Style Attributes Inspector

The Style Attributes inspector lists all of the styles applied to your selection, and their order of precedence. You can drag styles from here onto other items, or click the little button to remove a style.

Styles specific to this task (ad-hoc styles) have the highest precedence.

Structural styles (in this case, the style for all tasks) come next.

The Whole Document style is the most general.

You can drag these style chits onto other items or onto entries in the Project Styles inspector to apply them there.
Customizing Gantt chart colors with the Project Colors inspector

The background color of the whole document. This also affects the “Whole Document” background color in the Styles inspector.

A color for every other item; set this to a nice low-opacity color to keep your rows distinctive.

The color for non-working hours. But only if you’ve set up the View Options to show off-hours.

Today’s date in the chart. But only if you have a specific start date set in the Project Information inspector.

The base color for lines between time spans. They fade in and out as you zoom.

The color of all dependencies between tasks.

The color of the glow around critical tasks. You can turn the glow on and off from the View menu or the toolbar.

Using templates
A template is a file set up just right to be a starting point for a new project. For example, there might be certain resources you use for every project, a common task structure, certain named styles you like to use, and a standard set of working hours for your company. You can configure all of these things once, then create new documents from that template.

Creating a template
Create a new document normally by choosing New from the File menu.

Set up the document however you like. Everything about a document, including its contents, the state of the Project inspector, the view options, and so on, can be saved to a template.

Once the document is ready, choose Save As Template from the File menu.
Enter a name for the template and save it to the ~/Library/Application Support/OmniPlan/Templates/ folder, which is the default location. Note that you can also save to the same location in the Library of the computer you are using, or the Library of the network you are on, to make the template available to others.

**Starting a new document from a template**
When you create a document using the File ▸ New command, your new document follows the default template. To use a different template, use the File ▸ New From Template submenu instead.

**Managing templates with the Templates preferences**
Choose Preferences from the OmniPlan menu, then click the Templates icon at the top of the preferences window.

A list of available templates and their locations appears. The default template is listed in bold type; this is the template that is used when you choose New from the File menu. Unless you choose a different one, the Empty Plan document included inside the OmniPlan application is the default template.

Templates in any of the Library/Application Support/Templates/ folders appear in the list; these can be in the Library of your user folder, the Library of the computer you are using, or the Library of the network you are on.

From the action menu below the list, you can:

- **Edit**: Change the selected template. You can also just double-click the template’s name in the list. When you save your changes, the template is updated.

- **Edit a Copy**: Make a different version of the selected template. Select this command, type a title for the new template, then change the document and save it as usual.

- **Make Default**: Use the selected template from now on when making new documents with the File ▸ New command. The template’s entry in the list changes to bold type.

- **Rename**: Change the title of the selected template.

- **Move to Trash**: Get rid of the selected template by putting it in the trash. From there, you can still recover it if you need it. Otherwise, it will be deleted the next time you empty the trash.

Continued on next page
Importing from other formats

OmniPlan understands several other applications’ file formats. You can open files of these types in OmniPlan the same way you would open an OmniPlan document. The file is imported into a brand new OmniPlan document, which you can then edit, save, or export.

Microsoft Project (.xml, .mpx, .mpp, and .mpt)
Documents created in Microsoft Project XML, MPX, or MPP formats can be opened by OmniPlan, with a few limitations. Note that while OmniPlan can read MPP files, it can’t write them. For the best compatibility going back and forth between OmniPlan and Microsoft Project, use the XML format. For more information, see the Microsoft Project support section of OmniPlan’s onscreen help.

Comma-Separated Values (.csv) and Tab-delimited text files (.txt)
OmniPlan can read comma-separated or tab-delimited values from a plain-text file. To see how the data in a CSV file should be formatted, export an OmniPlan document as a CSV file and open the result in any text editor. Tab-delimited files are formatted like CSV files, except that tab characters are used instead of commas to separate fields.

OmniOutliner 3 (.oo3 and .ooutline)
Task lists can be imported from OmniOutliner files. A column mapping dialog appears, where you can choose which outline column should correspond to which field of task information. If the outline has multiple levels of hierarchy, task groups are created.

OmniGraffle (.graffle)
Task lists can be imported from OmniGraffle diagrams. The title of an object becomes the task title, and the hierarchy of connection lines determines the hierarchy of task groups.
Exporting to other formats
OmniPlan can write files in several formats, for use with other applications. To export an OmniPlan file, choose **Export** from the **File** menu. When you export, a new file is created, leaving your original document as it is on the screen. Of course, not all aspects of an OmniPlan document can be represented in all file formats.

When exporting, you can define filtering criteria so that only certain tasks are included in the exported file.

**OmniPlan**
Of course, OmniPlan can export to its own format. This is useful when you want to use the filtering feature to make a new OmniPlan file of tasks matching certain criteria.

**iCalendar**
This is the calendar format used by Apple iCal and many other calendar applications. You can choose to export the tasks as calendar events or as items on a to-do list.

**Comma Separated Values (CSV)**
CSV is a common, plain-text format that can be read by many different applications.

**Microsoft Project Exchange (MPX)**
MPX is an older compatibility format that can be read by Microsoft Project 2002 and earlier, and written by Microsoft Project 98 and earlier.

**Microsoft Project (XML)**
Microsoft Project 2002 and newer can read and write this format. This is the best choice for compatibility, if you have a version of Microsoft Project that supports it.

**PNG Bitmap Image, PDF Vector Image, TIFF Bitmap Image, JPEG Bitmap Image**
You can export a picture of the task view or the resource view, whichever one is open in the main window. In the Export panel, you can choose whether the image should include the outline, the chart, or both.
OmniOutliner 3
The task outline is exported as an OmniOutliner file, with a column corresponding to each column in the OmniPlan document.

OmniGraffle
There are several ways to export to an OmniGraffle diagram.

Work Breakdown Structure
Tasks and groups are represented by a tree of objects. The connection lines in this diagram type represent the hierarchy of the task outline; dependency lines are not represented.

Activity-on-Node PERT Chart
Tasks are represented by objects, connected by dependency lines. While a Gantt chart emphasizes durations, this type of chart emphasizes the path of dependencies.

Activity-on-Line PERT Chart
Tasks are represented as lines between objects, with the title and duration of the task as a label on each line. Like the Activity-on-Node PERT Chart, this diagram type emphasizes dependencies.
When exporting to a Work Breakdown Structure or an Activity-on-Node PERT Chart, you can choose whether to represent tasks with basic objects (which just show the task name) or with tables (which show the task name, assigned resources, start date and end date).

If you own an OmniGraffle license, you can style and edit exported diagrams. But even if you don’t own it, you can use an unlicensed copy of OmniGraffle (available at www.omnigroup.com) to view, print, or export the diagrams.

**HTML Full Report**
A folder is created containing a full report of the project, including:

- An overview index page
- A task list
- A resource list
- A Gantt chart
- A resource timeline
- An iCalendar file of the project milestones
- iCalendar files with each resource’s tasks as events
- iCalendar files for each staff or equipment resource’s tasks as to-do list items

If you know HTML and CSS, you can also make your own HTML templates: Choose **Customize HTML Templates** from the **File** menu.

Enter a name for the template and save it to the `~/Library/Application Support/OmniPlan/HTMLTemplates/` folder, which is the default location. Note that you can also save to the same location in the Library of the computer you are using, or the Library of the network you are on, to make the template available to others.
The new template opens in Finder; it is a folder of HTML and CSS files that you can customize to your liking. For more information, see the Customizing HTML Templates section of OmniPlan’s onscreen help, available from the Help menu.

**HTML Task List**
This is just the task list part from the HTML Full Report; it exports as a single HTML page.

**HTML Resource List**
This is just the resource list part from the HTML Full Report; it exports as a single HTML page.
Printing

Page Setup
OmniPlan supports the standard Mac OS X Page Setup dialog; choose Page Setup from the File menu to see it. You can set the paper size, orientation, and scale; this information is saved with the document.

Print-Time Options
Choose Print from the File menu to see the standard Mac OS X print dialog.

Select OmniPlan from the pop-up menu to see OmniPlan’s print options.

You can print the Task view or the Resource view, whichever one is open in the main window. You can then choose whether to print the outline, the chart, or both.

Or, you can choose to print an HTML report of the project. This works just like exporting to a web page, and uses the same HTML templates.

Type in margin widths, or use the buttons to adjust them step by step.
If you want to print a header and footer on each page, you can type them in here.

The preview shows what your project will look like on paper. Use the buttons to step through the pages and get an idea of the scale and layout.

Note that like in any application that uses the Mac OS X printing system, you can “print” to a PDF file instead of to real paper.

The dimensions are calculated based on the size of the project and the scale set in the Page Setup dialog. When you change the width or height, the other one changes accordingly. Note that this overrides the Scale setting in the Page Setup dialog.
Getting Help

Onscreen Help
OmniPlan comes with an extensive onscreen help system, which covers some more technical details and is updated for new versions of the application. Just select OmniPlan Help from the Help menu and you’ll find a searchable, browsable bounty of OmniPlan knowledge.

Web Site
The OmniPlan web site is a good place to find the latest information about OmniPlan.

http://www.omnigroup.com/applications/omniplan/
Forum
The Omni Group maintains online forums for all of our products, and you’re invited! Come share your questions and ideas with other users and Omni staff.

http://forums.omnigroup.com/

E-mail Support
If you’re stuck, or if you just want to let us know how we’re doing, go ahead and send us an e-mail. Choose Send Feedback from the Help menu to conjure up a message addressed to us, or just write to omniplan@omnigroup.com. A real human reads and replies to every message we get. We’ll do our best to help you out.
Actual schedule 13, 58
The actual schedule, in contrast to the baseline schedule, is the way a project turns out in real life. Before the baseline is set for a project, the baseline and actual schedules are the same. After the baseline is set, further editing changes the actual schedule only.

Assignment 20, 40
Assigning a resource to a task means that the resource is expected to be actively busy with that task throughout its duration. Assignment amounts are expressed as the percentage of the resource’s time being spent on the task.

Baseline schedule 13, 58
The baseline schedule, in contrast to the actual schedule, is the way a project is originally planned. Before the baseline is set for a project, the baseline and actual schedules are the same. After the baseline is set, further editing changes the actual schedule only.

Calendar View 43
The mode of the main window in which you can set up working hours and work schedule exceptions for individual resources or for the project as a whole. It contains a replica of the resource outline on the left, and a week view, with green time blocks, on the right.

Child 33
A member of a group is considered the group’s “child”; this is common terminology for outlining software.

Cost 30, 51
A task or a resource can have a monetary cost. The total cost of a task is the sum of the task cost and the costs of the resources assigned to it. A resource can have a per-use cost and a per-hour cost.
**Critical path** 24, 68
The critical path is the series of dependent tasks which, if any of their durations change, will cause the whole project’s duration to change.

**Custom data** 55
Data you can attach to any project, task, or resource, for your own purposes.

**Dependency** 18, 29, 54
The relationship by which one task must start or finish before another task can start or finish. For example, the task “Buy paint” must finish before the task “Paint fence” can begin.

**Duration** 16, 36, 53
Duration, in contrast to effort, is how long a task takes to complete in actual working time (that is, not including off-time). For example, a task which takes 4 hours of effort, and is assigned to 2 resources, has a duration of 2 hours.

**Efficiency** 49, 52
The measure of how much work a resource can get done in a certain amount of time. 100% efficiency means the resource can contribute 1 hour of effort for every hour of work; 50% efficiency means it can contribute 1 hour of effort for every 2 hours of work; and so on.

**Effort** 36, 48
Effort, in contrast, to duration, is how much work time a task takes to complete, considering all of the resources assigned to it. For example, a task which has a duration of 4 hours, and has 2 resources assigned to it, has an effort of 8 hours.

**Equipment** 19, 51
Equipment is a type of resource. It represents some kind of reusable asset, such as some special computer hardware. It can also be useful to consider things like meeting rooms to be “equipment”, if you need to balance their use between different tasks.

For equipment resources, “Units” means how many of the resource are available. The number of available units can affect resource leveling.

Equipment can have Efficiency, Cost per Use, and Cost per Hour values.
**Gantt Chart 7, 53, 68**
The Gantt chart is a chronological representation of the project, shown on the right side of the task view. Each task is represented by a bar, corresponding to a row in the outline, and possibly connected to other tasks by lines representing dependencies.

**Group 17, 33, 35, 52**
Items in the task outline or the resource outline can be grouped together. The members, or “children”, of the group appear indented from the group itself in the outline. In the Gantt chart, a task group appears as a bracket enclosing its members.

**Item 27, 28**
A single row in either the task outline or the resource outline. General outlining commands like Indent and Outdent, Expand and Collapse, work on items in either outline.

**Level 56-57, 22**
“Leveling the project”, or “leveling resources”, means automatically rearranging the project to make sure the resources are being used as efficiently as possible. This means not allowing a resource to be assigned at more than 100% of its available units at any time, and finding the best order for resources to work on tasks in order to complete them more quickly.

You should level your project after making changes like updating task completion or changing resource assignments.

**Material 19, 51**
Material is a type of resource, representing consumable supplies.

For material resources, “Units” means how many of the resource are being used throughout the project. This value updates as the resource is assigned to more tasks.

Material resources can have Cost per Use and Cost per Hour values.

**Milestone 14, 28**
A milestone is like a task, except that it has no duration and requires no effort. Its purpose is to mark some important point in time. Based on dependencies and work schedules, a milestone may shift in time; you can keep track of your project’s milestones in the Project Information inspector.
**Parent** 33
A group is considered the “parent” of all its members; this is common terminology for outlining software.

**Reserve** 35
Reserve is extra time allocated to a task group, in case its tasks take longer than expected. If the duration of tasks in the group increases, the reserve is used up accordingly, until there is no reserve time left.

**Resource** 12, 19, 20, 27, 32, 39-42
Resources are the people and things needed to get a project done. Resources are listed in the resource outline, and can be assigned to tasks. The three types of resources are Staff, Material, and Equipment.

**Resource load / Resource allocation** 32
A resource’s load is the amount of effort it is assigned to do at various times throughout the project. If a resource is assigned at more than 100% of its availability all at once, it is said to be “overloaded” or “overutilized”. Resource leveling tries to alleviate overload of resources. You can see each resource’s load by turning on the resource allocation graphs in the resource timeline.

**Resource timeline** 21, 32, 41
On the right side of the resource view is a timeline of the tasks assigned to each resource. It provides a more vertically-compressed, resource-oriented look at the project.

**Resource view** 8, 32, 40
The mode of the main window in which you create, edit, and examine resources. It contains the resource outline on the left and the resource timeline on the right.

**Staff** 19, 51
Staff is a type of resource, representing people who work on the project.

Staff units are measured as percentages. A person who is fully available to the project has a units value of 100%; someone who is spending part of their working hours on other projects would have lower available units. Note that this is not the same as having fewer working hours (which can be set in calendar view), or being less efficient (which can be set in the Resource Information inspector).
Staff can have Address, Efficiency, Cost per Use, and Cost per Hour values.

**T day 14, 27**
The first day of a project that has an undetermined start date. Until the start date is set, all dates are represented by an amount of time after T day, such as “T+2w 1d”

**Task 7, 12, 15, 27, 36-37, 38-39**
Some item of work that needs to be done for the project to progress. A task is represented by a row in the task outline, and by a corresponding task bar in the Gantt chart.

**Task View 7, 38-39, 53-54**
The mode of the main window in which you create, edit, and examine tasks. It contains the task outline on the left and the Gantt chart on the right.

**Template 68-69**
A template is a file you can use as a starting point for new documents. There are also HTML templates, which are used for creating a web report of a project.

**Units 49, 51**
Units measure amounts of resources in various contexts. For a staff resource, the units value is a percentage representing how much of the person’s time is available to be assigned to tasks. For equipment and material resources, the units value is a number representing a physical quantity.

**Variance 37**
Variance is the amount of time by which the an actual date differs from the baseline date.

**Violation 23, 50**
A violation is some sort of problem in the project that prevents it from working out properly. Such problems are things like tasks that start before the project start date, tasks that don’t have enough time to complete before their dependent tasks need to start, or dependencies that cause a task to be prerequisite to itself.