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Welcome to OmniFocus
What OmniFocus is
OmniFocus is a place for you to keep all of the stuff you’re meaning to 
do, whether it’s the stack of paperwork sitting on your desk that’s due 
now now now, or the marble monolith in your garage you’ve been 
meaning to sculpt one of these years.

Of course, you could just make a big list on paper or in an ordinary text 
editing application. But OmniFocus is carefully crafted to understand 
task lists: it can show you just what you need to know right now in order 
to make progress on your many projects. It can remember which 
projects you are putting off for later, which projects you claim are 
important but which you haven’t touched in weeks, and which projects 
may blow up if you don’t do something about them right away.

The really, really cool thing about OmniFocus is that once you get the 
hang of it, you can really trust your system and know that nothing is 
slipping through the cracks. The reward is certainty that you’re doing 
exactly what you need to be doing right now, or even that you don’t 
need to be doing anything at all.
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Quick Start Video
We’ve put together a few introductory videos about OmniFocus with the 
help of our friends at ScreenCastsOnline; watching them is probably the 
best way to get acquainted with the software. And then if you want to 
learn more, this help will still be here when you’re done!

http://www.omnigroup.com/products/omnifocus/videos/
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A Quick Tutorial
Tutorial 1: Create projects

OmniFocus starts out with a couple of projects already in the library. In 
this tutorial, we’ll assume that you’ve looked them over and deleted 
them, but you can leave them around if you want.

Think of something you’re working on, or that you’d like to start working 
on, that will require several steps to complete. In OmniFocus, that’s 
called a project. To create a project, click the plus button at the bottom 
of the blue sidebar and type a name.

Each project you create in the 
sidebar also appears in the main 
outline. Make a few different 
projects to begin with.
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Tutorial 2: Add actions

Select a project in the main 
outline and then press Return to 
add an action to it. Try to be as 
specific as you can with your 
action titles; you should be able 
to know immediately upon 
looking at an action exactly what 
needs to be done.

Keep pressing Return and typing 
names to add as many actions as you want. You don’t need to include 
every action between now and the completion of the project; you can 
always add new actions later.
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Tutorial 3: Create and assign contexts

Contexts are central to the way OmniFocus helps you find out what to 
do next: they represent the place, the tools, or the person you need in 
order to get something done. The contexts included in OmniFocus 
should give you an idea of what this means: any project you create may 
contain some things to do while you’re out running Errands, some 
Phone calls, some things to do at your Office, some things to talk to 
your Boss about, and so on.

Switch to context mode by clicking the Contexts button on the toolbar:

While the planning mode’s blue sidebar holds your projects, the context 
mode’s purple sidebar holds your contexts.

OmniFocus comes with a few contexts 
already created for you. Add some new 
contexts by clicking the plus button below 
the sidebar, or double-click an existing 
context’s name to change it. Make as 
many contexts as you need for the various 
places and modes you have for doing 
work: Home, Office, Mac, Errands, Phone, 
and so on. You can always add more 
contexts later on when you find that you 
need them.

7



Now, go back to your projects by clicking the Projects icon on the 

toolbar: 

Open the pop-up menu 
on each action (where 
it says No Context), and 
choose from the 
contexts you just saw 
in context mode to 
assign a context to 
each action.
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Tutorial 4: Action status

You might have noticed that some of your actions are colored 
differently from others. Actions are styled based on their status, to give 
you an idea of their availability.

The next action in each project is colored purple. This represents what 
you can do to make progress on the project.

In your sequential projects, that is, projects whose actions need to be 
completed in order, only the next action is considered available. The 
rest are colored gray to show that they are unavailable until you 
complete the next action.

If you change one of your projects to be parallel by clicking the twin 
arrows to the right of the project’s name, you’ll see the actions after the 
next action turn black. These actions are all available, because you 
don’t need to do them in any particular order.
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Tutorial 5: Use the view bar

Once you have a significant amount of information in your OmniFocus 
database, it can start to get overwhelming. The view bar can help you 
whittle down all that data into something meaningful and manageable.

For instance, say you’re ready to get some work done. Staying in the 
Projects view with all of your projects and actions all over the place 
won’t do. Try this:

Switch to context mode, 
where actions roam free of 
their project headings.

Click an empty area in the 
sidebar to deselect all 
contexts; all of your actions 
become visible in the main 
outline.

From the View menu, choose Show View Bar (there’s also a 
corresponding button you can add to your toolbar); a row of pop-up 
menus appears.

From the action status menu (with the checkbox icon), choose Next 
Action. Everything but your next actions disappears from the view.

As you mark things complete, the view updates to keep giving you stuff 
to work on.
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This is just one way the view bar can show you exactly what you’re 
looking for. For more about how to use it, see the view bar section of 
the help.

If you ever get the view bar into a wacky state that doesn’t show what 
you want, you can always choose Revert to Default View from the 
Perspectives menu.
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Tutorial 6: Drop things in the inbox

When some new chunk of work comes along, you don’t necessarily 
want to go find the right project, add the action, and assign a context. 
For the time being, you can put newly-arrived stuff in the inbox.

Click the Inbox button in the 
toolbar.

Press Return to create a new 
inbox item.

Type as descriptive a title as you want to give the item for now.

Keep pressing Return and adding whatever bits of work come to mind.

That’s it. You can add as much information to the inbox as you need, 
using it as a kind of holding area for stuff you haven’t yet gotten around 
to fully adding to your library of projects. For extra-speedy brain-
dumping action, try the quick entry window.

Whenever you’re ready, you can reword the items into proper actions, 
assign a project and a context to each item, then click the Clean Up 
button in the toolbar. The items shuffle off to where they belong. If you 
want to turn an inbox item into a project instead of an action, drag it to 
the sidebar.
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Tutorial 7: Review projects

Periodically, you should review your projects to make sure they’re in 
good shape. For this example, imagine you’ve been using OmniFocus 
for a while now, long enough to reach the one-week review period for 
some of your projects.

From the Perspectives menu, choose Review (there’s also a 
corresponding button you can add to your toolbar, if you like). In this 
view, your remaining projects are grouped in order of when they’re due 
to be reviewed.

Look at each project and 
decide whether it’s in the 
state it needs to be in. Are 
there new actions you 
need to add to it? Is it 
something you still plan on 
doing for sure, or should 
you change its status to On 
Hold? Is it something you 
should give up on, and 
change its status to Dropped? If it’s already on hold, should you set it 
back to Active status? Once you’re satisfied with the state of the project 
you’re reviewing, choose Mark Reviewed from the Edit menu (or use the 
corresponding toolbar button) and move on to the next one.

This regular evaluation of each project can be a huge help; when you’re 
planning well, you work well.
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Using OmniFocus
Projects and actions: planning what needs to be done

How projects, actions, and contexts work together

Actions

In OmniFocus, the things you need to do are 
represented by actions. Ideally, an action is a 

distinct chunk of work, described by a name that starts with an 
unambiguous verb. This makes things less intimidating to start, and 
easier to finish: a list of ten actions such as “Carry boxes out to the 
recycling bin” and “Assemble bookshelf” is much more approachable 
than the nebulous “Finish moving in”. Of course, you should find the 
level of specificity that works best for you. As you create actions and 
move them around, OmniFocus keeps track of which ones are available, 
waiting on something else, or complete.

Projects

Related actions are grouped into projects, which 
represent a set of actions working toward a 
common goal. Anything you want to do that 

requires more than one action, like “Finish moving in” or “Get novella 
published”, are good candidates for projects. Projects can then in turn 
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be organized into folders, for keeping track of your broader areas of 
work.

Single-Action Lists

Some actions, like “Get a haircut”, don’t really fit 
into any particular project; they’re just individual 
little things you need to do. You can keep this 

kind of action in a single-action list. These lists are similar to projects, 
but they don’t assume that the actions they contain have anything to do 
with one another.

Contexts

It’s handy (or, for some people, crucial) to assign 
a context to each action. A simple way to think of 
contexts is as the place or mode you need to be 

in to do a given task: you can only make phone calls when you’re near 
a phone, you can only buy groceries when you’re out running errands, 
and you can only do research on the web when you’re at your Mac. If 
you think about it, almost any task requires you to be in a certain 
context to do it. You can use the Projects view and the Context view to 
look at your actions in terms of what project they belong to or what 
context they require.
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Creating a project
Make a project any time you realize you have something you need to 
do which requires more than one step.

To create a project:

Make sure you are in planning mode; an easy way to get there is by 

clicking the Projects button in the toolbar: 

Click the plus button at the bottom of the sidebar.

Type a title for your new project.

Regardless of which view mode you are in, you can also create a new 
project by clicking the Add Project button in the toolbar, choosing Add 
Project from the File menu, or typing Command-Shift-N. OmniFocus 
switches to planning mode automatically.

Adding actions to a project

Add actions to a project whenever you think of something that you need 
to do in order to move the project forward. Most of the time you’ll 
probably want to add actions using the inbox or the quick entry window, 
but of course you can also add to the project directly.

To add an action to a project:
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Make sure you are in planning mode; an easy way to get there is by 

clicking the Projects button in the toolbar: 

Select the project, either in the sidebar or in the main outline, by 
clicking the index-card icon next to its name. Or, select an already-
existing action in the project.

Press Return or click the Add Action button in the toolbar; the new 
action appears immediately after the item you selected.

Type a name for your new action.

You can move an action between projects by clicking its bullet and 
dragging it to its new location. You can even turn an action into a 
project by dragging it to the top level of the outline or the sidebar.

Attaching files and notes to actions and projects

You can use the notes area of an action or a project to store extra 
information or materials about the item.

When you have an action or a project selected, click the notes icon  
on the far right side of the row (or press Command-apostrophe). You 
can type, paste, or drop plain text, rich text, links, images, or other files 
in this area. Click the notes icon again to hide the notes and 
attachments.
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Another way to attach a file to an item is to select the item and then 
choose Attach File from the Edit menu.

By default, OmniFocus creates links to the files you attach, rather than 
adding the files to your OmniFocus database. This keeps your database 
from growing needlessly (which is especially important if you are 
syncing your data), but the link will break if you delete the file or put it 
somewhere OmniFocus can’t find it. To make OmniFocus copy a file 
into its database for safekeeping, hold the Option key as you drop the 
file, or select Embed the file in the document in the Attach File dialog.

If you suspect that your database has some attachments that you don’t 
need, check the attachment list. 

An item with notes or attachments shows its notes icon all the time; 
others only show it when you select them or put the mouse pointer over 
them.

Keeping track of the next action in each project

Any active project keeps track of the next action that you have yet to 
complete, and styles it differently from the other actions—by default, 
the next action is purple. This is useful for figuring out what you ought 
to do to keep your projects moving forward.

When you are only interested in next actions, you 
can hide everything else. Show the view bar by 
clicking its icon in the toolbar, then choose Next 
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Action from the action filtering pop-up menu.

For sequential projects, where you need to do one thing before 
another, the next action is the only thing you can do right now to make 
progress on the project. For parallel projects, where you can do the 
actions in any order, the next action is just the first action in the list, and 
acts as more of a suggestion of what you might want to do next.

Making a project sequential or parallel

Some projects consist of actions that can be done in any order, like 
picking up items at a few different shops; these are parallel projects. 
Other projects require one action to be done before the next one starts, 
like building a papier-mâché pterodactyl; these are sequential projects. 
In a parallel project, all incomplete actions are available, and the “next 
action” is just the first one in the list. In a sequential project, only the 
next action is available.

Whether a project is sequential  or parallel  is shown by the pair of 
arrows by the right side of its row in the outline. To switch to the other 
type, just click the icon. You can also choose a type from the inspector. 
If you find yourself using one type much more often than the other, you 
can change the default setting in the Data preferences.

Using groups

The actions in a project can be organized hierarchically. This is useful 
for keeping track of complicated projects, or breaking actions into 
smaller actions without creating a whole separate project. Groups, just 
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like projects, can be parallel or sequential. This means you can put 
parallel groups inside of sequential projects and vice versa, to 
represent complicated dependencies.

To give an action some child actions, thus turning it into a group: 

Select the action you want to be the parent of the new group.

Choose Add Child from the Edit ▸ Outlining menu, or press Command-}.

To create a group from some existing actions:

Select all of the actions you want to group.

Choose Group from the Edit ▸ Outlining menu, or press Command-
Option-L.

Also, you can indent some actions to make them children of the action 
immediately before them in the outline:

Select the actions you want to indent, making sure that there’s an 
action before them in the outline.

Choose Indent from the Edit ▸ Outlining menu, or press Command-], or 
click one of the items’ handles and drag to the right.

When you create a group, the parent will adopt a bold style. While in 
Context Mode, you can differentiate your groups from your actions by 
those that appear bold (group parents) and those that do not (actions).
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If you mark an action group complete, all of its child actions are also 
marked as complete.

You can even nest groups within other groups, but that can get pretty 
ridiculous pretty quickly. If you have more than two levels of hierarchy in 
one project, you might want to consider splitting things up into separate 
projects.

Organizing projects into folders

Folders are a convenient way of organizing your projects, the same way 
you use folders to organize files on your Mac. For example, you could 
keep folders for each area of your life: perhaps Home, Work, Health, 
Education, Recreation, and Papier-Mâché Pterodactyls. That way, when 
you’re concentrating on one area, you can keep just that folder 
expanded in the sidebar, or use the Focus feature to hide the others 
completely.

To create a folder:

Make sure you are in planning mode; an easy way to get there is by 

clicking the Projects button in the toolbar: 

In the sidebar, select the item just above where you want the new 
folder to appear.

Click the Add Folder button below the sidebar.
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Name your new folder.

To put something (a project or another folder) inside your folder, just 
drag its icon onto the folder in the sidebar. You may have as many 
layers of folders as you can stand.

Setting Start Dates and Due Dates

Actions and projects can have start dates and due dates. A start date 
determines when an action or project becomes available, while a due 
date determines when something is considered overdue. You can also 
use the Dates & Times section of the Data preferences to set how long 
before its due date an item should be considered “due soon”.

Also in the Dates & Times section of the Data preferences, you can 
choose which time of day to use for when you enter a due date with no 
time. By default it is 12:00 AM, the very beginning of the day; you could 
for instance enter 11:59 PM to make new items due at the very end of 
the day, or 5:00 PM to make new items due at the end of the workday.

Start and due dates can be entered either in the main outline (if you 
have the date columns turned on in the View menu) or in the inspector. 

To group and sort by start or due dates, use the grouping and sorting 
menus in the view bar.

You can be pretty creative with the way you enter dates; OmniFocus is 
rather smart about guessing what you mean. For example:
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2d, -3w, 1h, 1y1m, and so on — Relative dates and times put the date at 
a certain amount of time from right now. Negative numbers represent 
times in the past.

2 days, -3 weeks, 1 hour, 1 year 1 month, and so on — You can use the 
full names of units too.

yesterday, tomorrow, next thursday, last month, this friday, and so on — 
You can refer to relative dates using common words. “This”, “next”, and 
“last” have specific meanings: this friday always means the Friday in this 
week, next friday always means the Friday in the next week, and last 
friday always means the Friday in last week, regardless of what day 
today is. Other units work in the same way.

september, fri, 2019, and so on — If you enter the name of a specific 
time period, the date will be at its beginning. So september means 
September first.

5/23/08 10a, 9.30.09 2:00 PM, and so on — You can use the short date 
format as defined in your International system preferences.

2w sat, 4d @ 5p, mon 6a, aug 6 tue 5p, and so on — Mix the available 
formats however you like.

now, 9, 14:00, tom, and so on — OmniFocus makes its best guess at 
things like bare numbers, times, and word fragments. If you think 
something might work, give it a try.
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Setting up repeating actions and projects

When you have something that needs to be done more than once, you 
can set it up as a repeating item.

• Select the item you want to repeat.

• Open the inspector from the Inspectors menu or by clicking the 
Inspectors button in the toolbar. 

• Choose a Repeat type from the list. You can have it repeat at a 
specified interval after its completion, its start date, or its due date.

• Enter a repeat interval. This can be any number of minutes, hours, 
days, months, or years.

To schedule an action on specific weekdays, enter a repeat interval in 
weekly increments and then select the days on which you'd like to 
repeat the item from the buttons below.

For example:

Start Tuesday 5:00 PM; due Tuesday 10:00 PM; repeat every 1 week: 
take out the trash. This repeats on a fixed schedule because it is 
necessary to do it at the same time every week, regardless of when you 
last did it.
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Start today 12:00 AM; due today 6:00 PM; start again in 5 days: clean 
the kitchen. This repeats from the completion date because the next 
time you need to do it depends on the last time you did it.

When you mark a repeating item as complete, the next instance of it is 
created with its start and due dates pushed forward as indicated by the 
Repeat interval. If you want an item to stop repeating, just turn off the 
Repeat setting in the inspector.

Estimating action duration

If you like, you can note how long you expect actions to take. Then, 
when you’re looking for something to do, you can choose based on 
how much time you have on hand.

To display the time estimate column in the main outline, choose View ▸ 
Columns ▸ Estimate.

To assign a time estimate, click in the estimate column for an action, 
then type a duration. By default, the numbers you type are interpreted 
as minutes (5m and so on). You can also type larger units, like hours (h) 
and days (d). 

To group and sort by time estimates, use the grouping and sorting 
menus in the view bar.
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Marking actions complete

When you’ve finished an action, just click its checkbox; its status 
changes to “completed”. If it was the project’s next action, and the 
action that follows it is available, that action becomes the next action.

Another way to mark something complete is to select the whole row 
and press Space. You can also right-click any number of selected items 
and choose “Complete” from the contextual menu, or click the 
Complete toolbar button.

If you mark a group complete, all of its child actions become complete 
too.

If you’re marking an action that you actually completed a while ago, you 
can adjust the completion date so that your records are accurate. Just 
select the item, open the inspector, and edit the Completed field.

By default, projects and groups stay active until you decide that there 
are no more actions to be added and you mark the project complete, 
unless you've specified otherwise in the project inspector. If you would 
like to have your project or group marked complete by default, click the 
When completing the last item: Mark the project or group complete 
check box in data preferences.

Flagging projects and actions

On the right end of any project or action row, there’s a little flag that 
you can turn on or off. The flag has no inherent meaning of priority or 
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anything special like that, so you can use it however you like. You 
could, for example, mark all of the things you’d like to get done before 
lunch, topics for a meeting you’re about to present at, or projects to 
reconsider the next time you have a chance to think about them. It’s 
entirely up to you.

To flag a project or action, click the little flag on the right side of the 
project or action row in the main outline. You can also select any 
number of actions and projects and then choose Set Flag from the Edit 
menu, or click the Flag toolbar button.

If you flag a project or an action group, all of its actions get an implicit 
“ghost” flag, and are treated as if they were flagged themselves. You 
can still flag them individually, if you want them to stay flagged when 
you remove the flag from the containing item.

To see only items that are flagged, use the Flag State menu in the view 
bar.
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Keeping track of single actions

Sometimes you need to do something that doesn’t really fit into a 
project. “Make rosemary lemonade” or “Buy a new cowboy hat”, for 
example, probably don’t contribute to the completion of any particular 
project. To keep track of such actions, you can use single-action lists.

To create a single-action list:

• Make sure you are in planning mode; an easy way to get there is by 

clicking the Projects button in the toolbar: 

• Choose Add Single-Action List from the File menu or from the action 

menu  below the sidebar.

• Enter a name for your new list, and drag it to wherever you’d like to 
keep it.

You can keep any number of single-action lists; some people like to 
make one for each top-level folder in their library. Others make a 
“Reading” list, a “Shopping” list, and so on. Single-action lists are 
similar to projects; you can drag them into folders, add actions to them 
from the Inbox, and so on. They are different in a couple of ways, 
though:

Single-action lists are always parallel; the actions in them don’t block 
each other from becoming available.
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All single actions count as “next actions”, since each one is kind of a 
little tiny project in itself.

Single actions appear in a unique style—blue text by default.
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Contexts: where the 
work happens
Assigning contexts to actions, projects, and groups

In addition to the hierarchical ways of organizing your actions, you can 
also assign each action, project, or group a context. This indicates 
where you need to be or what you need to have available in order to 
complete the item.

Once your items have contexts assigned, you can selectively view your 
items by context, to see just the ones that are actually available to you 
wherever you are now.

To create a new context:

Make sure you are in context mode; an easy way to get there is by 

clicking the Contexts button in the toolbar: 
Click the plus button at the bottom of the sidebar.
Type a title for your new context.

To assign a context to an action in planning mode:

Click in the Context column for the action.
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Type part of the name of the context you want to assign; OmniFocus 
tries to match what you typed with the names of your existing contexts.
If you see the context you want, select it. Otherwise, you can finish 
typing the context name and then press Command-Return to create it 
as a new context.

To assign a context to a project or group in planning mode:

Select the project or action.

Show the inspector by clicking the toolbar button or pressing 
Command-I.

OmniFocus will automatically display the appropriate inspector for your 
selection. Use the context drop-down to add a context to your project.

Any actions added to the project or group will have the parent's context 
assigned automatically.

To assign a context in context mode, just drag an item into the context’s 
entry in the sidebar.
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Organizing contexts hierarchically

You can nest a context inside another context, creating a hierarchy as 
deep as you like. Just drag any context in the sidebar inside of any 
other context.

When you select a parent context, you can see all of the actions inside 
that context or inside any of its descendants. This way you can look at 
your actions assigned to a more general context (like Office) or a more 
specific one (like Office : Mac). You can also keep identically-named 
contexts inside of different parent contexts (like Office : Mac and 
Home : Mac).

Viewing actions by context

When you’re at the office and ready to get some work done, you 
probably don’t care to see actions that require you to be at the store, at 
home, or at your cottage in Wisconsin. So it’s useful to selectively view 
just the actions that fit your context right now.

To view the items assigned to a particular context:

Make sure you are in context mode; an easy way to get there is by 

clicking the Contexts button in the toolbar: 

In the sidebar, click the context you are interested in. As you select it, 
only actions assigned to that context appear in the main outline.
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If you like, Command- or Shift-click other contexts to select them at the 
same time.

When you find yourself using a certain set of contexts, focus, and view 
bar filters pretty often, you might want to save them as a perspective.

To see everything in the main outline again, deselect all contexts by 
clicking in an empty area of the sidebar or by Command-clicking all of 
the selected contexts.

Using on-hold or "waiting" contexts

You can set a context’s status to “On Hold” with the inspector; actions 
assigned to an on-hold context are considered unavailable, and they 
block the progress of sequential projects. There are two main situations 
in which you might want to use on-hold contexts:

First, you might create one or more “waiting” contexts for keeping track 
of actions that you’ve delegated to other people. You can’t actually do 
anything until you hear back from that person; all you can do is wait for 
them to finish it, and maybe nudge them about it every now and then. 
So an action like “get annotated pterodactyl brochure draft back from 
Dennis” might go in your “Waiting : Dennis” context.

Second, you might have some contexts that you don’t expect to be 
available to you any time soon. You could put your “Frankfurt” context 
on hold when you’re in London, or put your “Boss” context on hold until 
she comes back from vacation, and any actions assigned to them would 
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become unavailable. This helps you see which actions and projects 
aren’t likely to make progress until your situation changes.

Dropping contexts

If there’s a context you don’t intend to use anymore, such as the office 
for a job you left, or a person who transferred to a different department, 
you can drop it. All of your old actions that were assigned to it stay 
assigned to it, but the context doesn’t appear in your Remaining 
contexts sidebar. Any remaining actions still assigned to a dropped 
context become unavailable and move to the No Context group of the 
context mode sidebar.
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Collecting Stuff as it 
Appears
Adding stuff to the Inbox

The inbox is a kind of intermediary area between your brain and your 
OmniFocus library. Whenever you have something important that you 
don’t want cluttering up your mind, but you’re not quite ready to 
meticulously file it away in the right place in your OmniFocus structure, 
just put it in the inbox. Later on, when you process the inbox, you can 
decide whether each item is a new project or an action in an existing 
project, what its context is, and so on.

To create a new inbox item, just select the inbox (in the sidebar or in the 
main outline; a quick way is with the Inbox toolbar button) and press 
Return. Type whatever’s on your mind, forget about it for now, and get 
back to whatever you were doing! For extra bonus productivity-
streamlining finesse, don’t even switch to OmniFocus to do this; use the 
quick entry window or the clipping service instead.

You can create hierarchy in the inbox by using the Edit ▸ Outlining 
menu commands, if you already know that something is going to have 
sub-items. Later, you can add these groups to an existing project or 
make them into full-fledged projects themselves.
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When you are ready, you can process your inbox items by assigning 
them projects and contexts.

Using the Quick Entry window

So the inbox is a quick way to get things off of your mind. But there’s an 
even quicker way, if you’re in the middle of something else and you 
don’t want to switch your brain to a different mode: the quick entry 
window.

In the OmniFocus preferences, there’s a setting for the quick entry 
keyboard shortcut. This is a key combination which, as long as 
OmniFocus is open, no matter what else you’re doing on your Mac at 
the time, summons up a little window where you can send things to 
OmniFocus.

To collect stuff in the quick entry window:

Press the quick entry keyboard shortcut as you have set it in the 
preferences. By default, it’s Control-Option-Space. The quick entry 
window appears.

Type in the quick entry window as if you were typing in the OmniFocus 
inbox. Create as many items as you want, with as much hierarchy as 
you want (you’ll need to press Control-Return to create more than one 
item, as Return dismisses the window — you can change this in the 
General preferences). You can assign projects, contexts, dates, notes, 
and so on for each item; click the button with the gear icon to choose 
which columns are visible.
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When you’re done, click the Save button or press Command-S. The 
items are whisked off to your database and you can keep on doing 
whatever you were doing. If you don’t want to put the items in your 
database yet, press the quick entry shortcut again; the items will still be 
there the next time you open the quick entry window. If you want to get 
rid of the items entirely, click the Cancel button or press Command-
Period.

Processing inbox items

Items you put in the inbox stay there until you assign them a project or 
context (by using the inspector or by typing in the Project and Context 
columns). If you assign both a project and a context, then the item is 
filed away where it belongs. Depending on your settings in the Inbox 
Processing section of the Data preferences, an inbox item with a project 
but not a context assigned, or vice versa, may stay in the inbox or may 
be automatically filed where it belongs.

Inbox items have both a Project column and a Context column. To 
assign a project or a context, you can click the pop-up button next to 
the appropriate cell to see a menu of all available projects or contexts. 

Alternatively, you can type directly into the cell. With each letter you 
type, OmniFocus guesses which of your projects or contexts you might 
mean. Most of the time you can get the right one with just a couple of 
key presses. For example, if you type aak or ado into a project cell, 
OmniFocus would find your “Adopt a Kitten” project. Once the correct 
project or context is highlighted, you can just leave the cell.
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If you need to create a new project or context, just type its name into 
the cell and press Command-Return instead of Return. OmniFocus 
creates the new project or context for you, and assigns the action to it.
To move inbox items to your library:

For an individual action, just assign a project and a context to it, then 
use the Clean Up command in the Edit menu or the Clean Up button on 
the toolbar to move it to its proper place. 

For any inbox item, including groups, you can click its handle and drag 
it to the sidebar or the main outline wherever you would like it to go. 
Drop it inside a project to add it to that project, or drop it anywhere else 
to turn it into a project.

Clipping material from other applications

You may come across an email 
message, a web page, a 
newsreader article, or some other 
scrap of info that you’d like to turn 
into an OmniFocus action. In the 
olden days you might heft your 
mouse, highlight the text, copy it, 
summon up the OmniFocus quick 
entry window, and paste. But no, you’re living in the future. You use the 
OmniFocus Clippings service.
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To clip content from another application:

Highlight some text in any application (that is, any application that 
supports Mac OS X Services, which should be all applications these 
days, ahem).

Press the Clipping keyboard shortcut (if you have set one in OmniFocus 
Clippings preferences), or open the application menu and then the 
Services submenu, then choose OmniFocus: Send to Inbox.

A new item, with the highlighted 
content (rich text and embedded 
images) as its note, lands in the 
quick entry window for you to 
revise and save.

You can change some details of how clippings work with the 
OmniFocus Clippings preferences. From the OmniFocus menu, choose 
Preferences, then click the Clippings tab.
To change the Clippings Shortcut, click in the field and type a key 
combination. To clear the shortcut, click the X button.

With the Copy Clippings to setting, you can choose whether to clip 
material into the quick entry window for review and revision, or to drop 
it straight into the Inbox.

OmniFocus processes material differently depending on which 
application it was clipped from, using application-specific plug-ins. For 
example, when you clip content from Mail, the new action has the 
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message’s subject line as a title, and its note has a link to the original 
message. You can select an application in the plug-in list to see details 
about how it will process clipped content. You can also turn off plug-ins 
you don’t intend to use, or for which you’d rather use the “Any 
Application” plug-in.

The OmniFocus Mail Clip-O-Tron 3000 is a little tool that adds the ability 
to clip the entirety of the selected message in the Mail message list. To 
install it, open the Clippings preferences and then click the button in the 
lower-right corner. If you don’t install it, you can still clip content 
highlighted in Mail’s message content area. 

Processing Mail messages into actions

When it’s not convenient for you to put data directly into OmniFocus 
(like when you’re sitting at a someone else’s computer), you can send a 
specially-formatted email to yourself and OmniFocus will process it 
later. To set it up, use the OmniFocus Mail preference pane.
To turn on Mail processing, select the Add Mail Rule to create 
OmniFocus actions checkbox.

Once the Mail Rule has been added, you can tell OmniFocus what kind 
of messages to look for. One way is to look for messages that have 
+omnifocus before the @ sign in the destination address, as in cornelius
+omnifocus@example.com. If your mail service is properly set up for 
this type of addressing, the message arrives in the correct mailbox as if 
the plus sign and the extra word were not there, but they act as a label 
for special handling. The other way is to look for messages whose 
subject line begins with certain characters, -- by default.
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If you want to keep the messages that OmniFocus processes in a 
certain mailbox, select Archive processed messages and choose a 
mailbox. Otherwise, they are deleted.

The Allowed From addresses list is automatically filled with any email 
addresses on the “Me” card in Address Book. You can add more 
addresses, if you expect to be sending yourself OmniFocus actions from 
any other accounts.

The way that messages are processed is pretty detailed, and you have 
a lot of power in how you can format your items:

The subject and body of the message are joined into a single block of 
text.

The first line and any other lines starting with -- (double-hyphens) 
become new actions. Other lines become notes for the preceding 
action.

To specify a project, use > (greater-than sign) or :: (double-colons), 
followed by a project name or abbreviation. The colons are nicer for the 
iPhone because they are on the first shifted keyboard rather than the 
less-accessible math keyboard. The project string is matched exactly as 
if it was entered in a project cell in OmniFocus.

To specify a context, use @ (at sign), followed by a context name or 
abbreviation. Like project names, the context name is matched exactly 
as it would be in OmniFocus.
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To enter start or due dates, use # (number sign), followed by some date 
expression. The same expressions you use in OmniFocus (tomorrow, 
9-30-2008, 2w, and so on) can be used in mail messages. If there is 
only one date, it becomes the due date. If there are two (each with its 
own number sign), the first becomes the start date and the second 
becomes the due date.

To enter a time estimate, use $ (dollar sign—time is money) followed by 
some duration expression (like 5m, 1h, and so on); you can use the 
same duration expressions that you use in OmniFocus.

To flag the action, use ! (exclamation point) at the end of the action title.
You can also add a note on the same line as an action title by 
separating them with // (double-slashes). Anything after the double-
slashes becomes a note, but double-slashes in a URL like 
omnigroup.com don’t count.

Here are some examples of actions you could send to yourself:

-- Action
Note note note note note la la la
note la la
-- Another Action > Project 2 @ Context 3
Note wheeeeeee

I have empty lines in my note

It’s great
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-- Action 3 > Project 1 @ Context 1 // Same-line notes too, if you are into 
that kind of thing
-- Action 4 #friday // Due Friday, because I only entered one date
-- Action 5 #monday #friday // Starts Monday; due Friday.
-- Action 6 #monday # // Starts Monday; no due date.
-- Action 7 :: Project 3 // Written on my iPhone; colons work in place of 
greater-than sign.

--Action8>p2@c2#2d$5m//no spaces needed, nor full names
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Cleaning Up
The grouping, sorting, and filtering settings in the view bar control what 
parts of your database are visible and how they’re arranged. For 
instance, most of the time you don’t care to see actions you’ve already 
completed, so you use the action filter to show only remaining actions. 

Sure, that’s handy, but you also don’t want OmniFocus pulling stuff out 
from under you as you’re working on it. For instance, if you mark an 
action complete, you probably don’t want it to disappear that very 
moment; you may still change your mind and want to uncheck it, or 
copy its notes into an e-mail, or just double-check that you clicked the 
right thing. Likewise, you probably don’t want an inbox item to be 
spirited away the instant you assign a context to it.

So, OmniFocus has a command called Clean Up. You can clean up 
manually by clicking the Clean Up toolbar button, or choosing Clean Up 
from the Edit menu.

Cleaning up puts everything where it belongs: items that don’t match 
the filter settings disappear, visible items move into the appropriate 
groups, inbox items move to their assigned projects, and so on. After 
you change some items, you can Clean Up to make sure that your view 
is up to date.
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Searching, focusing, and 
reviewing
Focusing on certain projects or folders

If you know that you want to concentrate for a while on a particular 
project, folder, or combination of items, the Focus feature can get 
everything else out of your way.

To focus:

Select a project or folder (or any combination of projects and folders) in 
the sidebar.

Click the Focus toolbar button, or choose Focus on (Selected Items) 
from the View menu. Everything outside your selection disappears from 
the sidebar, and the title at the top of the window changes to Focusing 
on (Selected Items). (You can also hold option while double-clicking an 
item in the sidebar.)

As you work in planning mode, or switch to context mode, OmniFocus 
ignores everything outside of your focus, as if the items you’re focusing 
on are the only items in your library.
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When you’re done focusing, choose Show All Projects from the View 
menu, or click the Show All toolbar button. Your library comes back as if 
nothing ever happened!

When you find yourself using a certain set of contexts, focus, and view 
bar filters pretty often, you might want to save them as a perspective.

Using the view bar to filter and arrange items

The view bar is a powerful way to filter and rearrange the items in your 
window. It has one pop-up menu to control what appears in the sidebar, 
and five pop-up menus to control what appears in the main outline. The 
various filters work together, so that you can come up with quite 
expressive combinations of settings, like Flagged next actions in active 
projects, that I can do in less than 15 minutes, sorted by due date.

Project Filter

This appears above the sidebar in planning 
mode; click it to choose what kind of projects 
to show in the sidebar. You’ll probably want 

this to be Active most of the time, so you can see only the projects 
you’re working on now. You can also choose Remaining (projects that 
haven’t been completed or dropped), Stalled (projects without any 
available actions), Pending (projects with start dates in the future), On 
Hold, Dropped, Completed (projects you have marked with these 
statuses), or All.

Context Filter
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This appears above the sidebar in context 
mode; click it to choose what kind of contexts 
to show in the sidebar. You can choose 

Remaining (contexts which haven’t been dropped), Active (contexts that 
have actions assigned to them), Stalled (contexts without any actions), 
On Hold (contexts you’ve indicated should not allow their actions to 
become available), Dropped (contexts that are no longer in use), or All.

Grouping

Click this to choose how to group the projects in 
the Planning view outline, or the actions in the 
Context view outline. You can Ungroup everything, 

or group by Folder (for the same structure as you see in the sidebar), 
Due date, Start date, Completed date, Next Review date, Added date, 
or Changed date. Each group shows up as a collapsible bar in the main 
outline. Remember that in Planning view, the grouping applies to whole 
projects, not to the individual actions inside them.

Sorting

Click this to choose how to order the projects in the 
Planning view outline, or the actions in the Context 

47



view outline. If you have a grouping selected, the sorting happens 
inside the groups but the groups themselves stay in the same order.

In planning mode, you can leave projects Unsorted, or sort them by 
Name, whether they are Flagged, their Due dates, Start dates, 
Completed dates, Next Review dates, Added dates, Changed dates, or 
by their Duration.

In context mode, you can sort individual actions by the order of the 
Project they belong to, the Context they belong to, whether they are 
Flagged, their Name, their Due dates, Start dates, Added dates, 
Changed dates, Completed dates, or their Durations.

Availability Filter

Click this to choose what kind of actions show in the 
main outline. You can choose to see actions with 
Any Status, Next Actions (just the next thing to do in 

each eligible project), Available actions (things you can actually do, 
because they aren’t blocked by earlier actions in a sequential project), 
Remaining actions (anything that’s not completed), or Completed 
actions (things you’ve already done).

Status Filter

Click this to show projects or actions based on 
whether they have flags or due dates set on them. 
This is a good way to narrow down your actions to 
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see what's important right now. You can choose to see items with Any 
Status, Flagged items, Unflagged items. In context mode, you will also 
be able to filter items that are Due Soon, items that are either Due or 
Flagged, or items that are both Due and Flagged. Note that flagging an 
action puts a kind of ghost flag on its parent project, making the project 
count as flagged too, and flagging a project ghost-flags all of its 
contained actions. 

Estimated Time Filter

Click this to show actions whose time estimates fall 
within a certain range. You can choose to find All 
actions (regardless of their time estimates), or 

actions that are estimated to take less than 5 minutes, less than 15 
minutes, less than 30 minutes, less than 1 hour, more than 1 hour, or an 
Unknown amount of time (for actions you haven’t estimated).

Searching for actions or projects
The OmniFocus toolbar includes a Search field for filtering the main 
outline down to items that contain a certain string of text. As you type in 
it, items that don’t match disappear dynamically. You can search based 
on action names, notes, context names, or project names. When you’re 
done, click the clear button on the right side of the field and everything 
reappears.

OmniFocus also has a Find and Replace panel like many other 
applications; from the Edit menu, choose Find ▸ Find to summon it. You 
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can find and replace text in the visible columns of any items that are 
visible in the main outline. Even dates and assigned contexts can be 
replaced, though the context you’re replacing with has to match the 
name of an existing context.

Using the built-in view settings
OmniFocus includes several preset view configurations, similar to 
perspectives. These view settings appear in the Perspectives menu and 
they are also available on the default toolbar. (If you customized your 
toolbar prior to OmniFocus version 1.5, you may need to choose 
Customize Toolbar from the View menu again to add them to your 
toolbar.)

Inbox — This takes you directly to your inbox, where you can enter new 
items.

Projects — The most basic view of planning mode, showing your 
remaining actions organized by project.

Contexts — The most basic view of context mode, showing your 
remaining actions organized by context. 

Due — Remaining actions that are either due soon or overdue, grouped 
by due date.

Flagged — Actions you have marked with a flag, organized by context.
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Review — Your remaining projects, organized by their next review 
date.

There are also a couple of very inclusive settings that are available in 
the Perspectives menu, but not as toolbar items. These are handy if you 
think something you created has gone missing:

Completed Items — All of the items you’ve already finished.

All Items — Everything in your database, except for things you have 
archived. This may take a while to load.

Using perspectives to store your OmniFocus 
window settings

You may find certain ways of setting up your OmniFocus window that 
are useful enough to make you want to come back to them again and 
again: your morning glance at what’s due today, your weekly review, or 
your retrospective of what you’ve gotten done lately. With perspectives, 
you can save view settings and get back to them whenever you like.

To create a perspective:

• Set up an OmniFocus window with the view mode, columns, focused 
items, sidebar selection, and view bar settings just the way you like 
them.

• From the Perspectives menu, choose Show Perspectives Window.
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• Click the plus button at the bottom of the Perspectives window.

• Type a name for your new perspective.

To assign an icon to a perspective:

• In the Perspectives window, if the settings are not visible, click the 

Expand Settings button  at the bottom of the window.

• At the top of the settings area is the selected perspective’s current 
icon. 

• To choose a different icon, click the arrow to the lower-right of the 
icon. 

• Or, drag any image and drop it on the icon to replace it.

There are several ways to open a perspective:

• Double-click the perspective’s icon in the Perspectives window.

• Choose the perspective from the Perspectives menu.

• Choose Customize Toolbar from the View menu, and add the 
perspective to your toolbar as a button; then click it.

To replace an existing perspective with new window settings:
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Get a window looking the way you want (possibly by opening the 
existing perspective and then changing a couple of things).
From the Perspectives menu, or the gear menu in the Perspectives 
window, move the mouse to Save Window As, then choose the 
perspective you want to replace. You can also choose Take Snapshot if 
you already had that perspective open.

The Perspectives window’s settings area, available by pressing the 

Expand Settings button , gives you a lot of power. Here is a 
rundown of what all of its bits and bobs are for.

Shortcut Recorder — Right below the icon area is a place for you to 
assign a keyboard shortcut to the selected perspective. Just click in the 
field, then type the keyboard shortcut you want to use. You can choose 
any shortcut as long as it contains the command or control key, in 
conjunction with another key. (You can also use a function key if you'd 
rather not use control or command.)

View Mode — Use this to choose whether the perspective should open 
in Planning mode, where actions are assembled together in their 
projects, or in Context mode, where actions can be grouped however 
you like. This affects which other settings are available.

Restore Focus — If you select this, the focus in effect on the window 
you saved will come back when you open the perspective. (You can 
check the focus at the top-right of the Perspectives window.) Leave it 
deselected if you want to be able to open the perspective while 
maintaining your focus. Note that having no focus counts, so you can 
have a perspective that always returns you to a non-focused state.
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Restore Layout — Select this to make the perspective remember the 
window size, window position, and columns of the window you saved. 
Otherwise, your existing window will keep its layout when you open the 
perspective.

Restore Expansion — Select this to make the perspective go back to 
the particular expanded and collapsed state of all the little triangles in 
your sidebar and outline as they were when you saved it. Deselect it if 
you don’t care what the expansion state was.

Restore Selection — If you select this, opening the perspective will 
select all of the things that were selected in the sidebar and the outline 
when you saved it. If you had nothing selected, it will deselect 
everything. Otherwise, opening the perspective won’t change your 
selection state.

Restore Settings from a Planning / Context Mode Perspective — 
Because a perspective only applies to either Planning mode or Context 
mode, you might want to open two of them at once, one for each view 
mode. Turn on this setting and choose a perspective that applies to the 
other mode. Then any time you open this perspective, the 
complementary perspective will open in the other mode. You can 
switch back and forth between the two modes with the View menu or 
the View Mode toolbar button. If none of that makes any sense to you, 
you probably don’t need this feature anyway.

The right side of the settings area shows the focus and View Bar 
settings for the selected perspective. You can change the filtering, 
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sorting, and grouping here immediately rather than setting them in the 
View Bar and saving the perspective again.

To quickly print a perspective without even having to open it, click the 
gear menu at the bottom of the Perspectives window and choose Quick 
Print. If your print options are already as you like them, you can hold 
Command while choosing Quick Print and bypass the Print window 
entirely. You may find this handy for dashing off a copy of your errands 
perspective onto some note cards before you run out the door, for 
instance.

To delete a perspective, just select it and press the Delete key.

Reviewing projects
Reviewing is a good way to make sure all of the projects in your library 
are in good shape and are ready for you to take action. If you have 
projects that need more actions added to them, or projects that aren’t 
relevant anymore, or projects you don’t mean to do any time soon, 
following a regular review process can help you keep them from falling 
through the cracks.

Each project has an interval for how often you intend to review it and a 
date when the next review is planned. You can change the default 
review interval in the Data preferences, and you can change the review 
interval and next review date of individual projects with the inspector.
To review your remaining projects:
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From the Perspectives menu, choose Review (there’s also a 
corresponding button you can add to your toolbar, if you like). In this 
view, your remaining projects are grouped in order of when they’re due 
to be reviewed.

For each project in the Review Today group (or earlier groups), check 
whether the project is in the state it needs to be in: Should you revise 
its actions, or add new ones? Should you put it on hold, drop it, or 
complete it? Or is it just fine?

Once you’re satisfied with the state of the project, select it and click the 
Mark Reviewed toolbar button or choose Mark Reviewed from the Edit 
menu. The project’s next review date moves forward and you can go on 
to review another project.

Marking a project complete

Eventually, oh frabjous day, you’re going to reach the successful end of 
a project. When you’re sure that you’ve really accomplished “Move in to 
new house”, “Carve Halloween pumpkins”, or “Write pterodactyl 
novel”, you can mark the project complete. Select the project and then 
either click the Complete toolbar item, choose Edit ▸ Status ▸ 
Completed, or just press the Space bar. The project’s status changes to 
Completed, and it is filed away in your library for safekeeping.

Putting a project on hold

If you’re not quite sure whether you want to start (or continue) a project, 
you can put it on ice for a while. It disappears from your Active list in the 
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sidebar, and its actions likewise stay hidden. Every now and then, you 
can set the project filter in the view bar to show On Hold projects (or All 
Projects), and review which ones you’d like to make active, which ones 
you’d like to drop, and which ones you’d like to keep on hold.

There are several ways to put a project on hold:

Select the project in the main outline, then use the Status control in the 
inspector to choose On Hold.

Select the project in the sidebar, then choose On Hold from the gear 
menu at the bottom of the sidebar.

Right-click or Control-click the project in the main outline or in the 
sidebar, then choose On Hold from the contextual menu.

To make an on-hold project active again:

Choose On Hold from the view bar’s project filter pop-up menu.

Find the project, then use one of the same techniques as above to set 
the project’s status back to Active.

Dropping a project or folder

If you’ve decided not to work on a project any further, you can drop it 
completely. It disappears from your Active list in the sidebar, and its 
actions likewise stay hidden. Of course, you could just delete the 
project, but then you wouldn’t have any record of it or its actions ever 
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having existed. Keeping them around in a dropped state means you can 
go back and check on how often you give up on projects, check which 
actions you’ve completed regardless of whether they’re from still-
relevant projects, and so on.

In the same way, you can also drop folders — perhaps a major move, a 
new job, or some other event has rendered a whole category of 
projects irrelevant.

There are several ways to drop a project:

Select the project in the main outline, then use the Status control in the 
inspector to choose Dropped.

Select the project in the sidebar, then choose Dropped from the gear 
menu at the bottom of the sidebar. (This also works for folders.)

Right-click or Control-click the project in the main outline or in the 
sidebar, then choose Dropped from the contextual menu. (This also 
works for folders.)

To make a dropped project or folder active again:

Choose Dropped from the view bar’s project filter pop-up menu, above 
the sidebar.

Find the project, then use one of the same techniques as above to set 
the project’s status back to Active.
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Getting data in and out 
of OmniFocus
Synchronizing between Macs and mobile devices

OmniFocus has the ability to synchronize your database with a server or 
a disk, so that all of your Macs, and your iPhone or iPod touch, will stay 
up to date.
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To get to the Sync preferences, just choose Preferences from the 
OmniFocus menu, then click the Sync button.

By default, OmniFocus is set to sync with Nothing — in this case, the 
database in your Library folder is the only one that matters.

Step 1: Archive old data

If you have been using OmniFocus for more than a couple of months, 
you may want to archive your old, unused items before setting up 
synchronization. Choose Move Old Data to Archive from the File menu; 
your database will be slimmer and faster to sync, especially on iPhone 
or iPod touch.

Step 2: Choose a sync method

In order to synchronize, you need to keep a “server” or “sync” copy of 
your database somewhere, and let OmniFocus check up on it 
periodically. There are several types of places you can keep the sync 
copy, each represented by a button on the Sync pane:

Omni Sync Server — Our recommended default sync option. Omni's 
own sync solution is a reliable and fully supported way to share your 
database of tasks with your other OmniFocus-enabled devices, 
including seamless integration with OmniFocus for iPhone and iPad. 
Best of all, it's free! Click the sign up button to get started or the 
account info button to log into an existing account.
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Bonjour — If you'd like to sync over a local network, this is a solution 
that lets Macs and devices on your local network discover and sync with 
a copy of your OmniFocus database.

Disk — Anything that you can mount and edit as a disk in Finder, such 
as a portable USB drive, a Time Capsule on your local network, or a file 
server that you access over the internet, can be used to synchronize 
your OmniFocus database. Note that iPhone and iPod touch can’t 
mount disks over the network like a Mac can, so this sync method won’t 
work with them.

Advanced (WebDAV) — This is a type of server for sharing files on the 
web, offered by some hosting providers. Check with your hosting 
provider to find out whether you can set up your own WebDAV space. 
Be aware that providers which don’t fully comply with the WebDAV 
standard may not work properly.

Step 3: Choose a sync location

Omni Sync Server — The sign up (or account info) button will take you 
to https://www.omnigroup.com/sync/, where you can set up and access 
your account details or retrieve a backup of your data.

Bonjour — Click Keep the sync database on this Mac, then enter a 
password to protect your database. OmniFocus then makes a sync copy 
of your database available to other Macs and devices on your network.

Disk — When you choose to synchronize to a disk, a sheet appears for 
you to choose a location. Make sure the disk is mounted, browse to the 
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location on the disk you want to use, and then click the Set Sync 
Location button.

Advanced (WebDAV) — Enter your WebDAV address in the Location 
field. If your provider supports it, you can use https for a semblance of 
security while transmitting your data; otherwise, ordinary http also 
works.

Step 4: Sync

Click the Sync Now button to start your first sync. Since you don’t have 
a sync database yet, this first sync will consist of creating one and 
copying all of your OmniFocus data into it.

Step 5: Set up other Macs and devices

Once you’ve fully synchronized your database to the server for the first 
time, you’re ready to tell your other Macs and portable devices about it.
Setting up another Mac — Follow steps 1, 2, and 3 again on that Mac, 
using the same settings. (If you are using Bonjour, click Connect to an 
existing sync database and select the Mac that you set up before.) 
When you synchronize that Mac, it finds the existing database on the 
server.

Setting up an iPhone, iPod touch, or iPad — OmniFocus is available for 
the iPhone, iPod touch, and iPad from the App Store. If your device is on 
the same wireless network as your Mac, you can open OmniFocus on 
that device and choose to get the sync settings from your Mac by name. 
Otherwise, click the Send Settings button on your Mac’s OmniFocus 
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Sync preferences pane to email a special link to yourself. (If you don't 
see these settings, click the disclosure triangle on the bottom-left, next 
to the "OmniFocus for iOS..." text, to show those options.)  Open the 
email on your mobile device and tap the link; OmniFocus does the rest.

Step 6: Stay in sync

One minute after you make any change, OmniFocus automatically 
synchronizes with the server. Even if you don’t change anything, 
OmniFocus syncs once an hour. You can also manually sync by 
choosing Synchronize with Server from the File menu, or by clicking the 
Sync toolbar button. As long as OmniFocus synchronization is enabled 
on all of your computers and handheld devices, and they can all reach 
the database on the server, they will all be up to date with one another.

Synchronization Clients

A client is a Mac or handheld device that is set up (or registered) to sync 
with your database. To view a list of your clients and each client's sync 
status, just choose Preferences from the OmniFocus menu, then click 
the Sync button, followed by the Show Clients button.

To synchronize changes between clients, OmniFocus has to keep a 
history of those changes which might not have been seen yet by every 
client. The more history OmniFocus has to maintain, the slower syncing 
becomes on every machine—so it's a good idea to try to synchronize 
every client on a regular basis.
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If you're not going to use a particular client for a while and aren't 
worried about preserving sync history for it, you can unregister it to 
make syncing faster for all the other clients. To unregister a client:

Select the client from the list in the clients sheet.

Click the Unregister button.

If you unregister a client, OmniFocus has no way to know whether 
outstanding changes on that out-of-sync client might be newer or older 
than the changes made on other machines (since they no longer have a 
record of what's newer and older). The upshot of this is that the next 
time you sync that client, you'll be asked to make a choice between the 
data on the server or the data on that client.

Synchronizing with iCal
(For OS X 10.6 and 10.7 only)

An excellent way to liberate your data from OmniFocus and 
communicate with lots of other applications and devices is to 
synchronize with iCal. Once your data is in iCal, you can share it in the 
iCalendar format understood by scads of calendar and to-do 
applications.

To synchronize OmniFocus with iCal:

Choose OmniFocus ▸ Preferences, then click the iCal icon.
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Select the Unsynchronized group in the Calendar list; all of the contexts 
you’re not synchronizing appear in the Contexts list.

Drag context names into the calendar name you’d like to synchronize 
them with. For instance, if you drag your “errands” context to your 
“Home” calendar, any actions assigned to your errands context will get 
corresponding to-do items in your Home calendar in iCal.

From the File menu choose Synchronize with iCal. For each context that 
you dragged into a calendar, its actions are synchronized to iCal.

Whenever you like, choose Synchronize with iCal to bring iCal and 
OmniFocus back in sync. New OmniFocus actions in synchronized 
contexts are copied to the associated calendars in iCal. New iCal to-dos 
in synchronized calendars are copied to the OmniFocus inbox. Changes 
to actions on either side are applied to the corresponding items on the 
other side.

In the iCal preferences, you can change how the synchronization 
process works:

Add blocked actions to calendars — if this is selected, even actions that 
aren’t available (because another action needs to be completed first, 
for instance) are copied to iCal.

Add completed actions to calendars — if this is selected, even actions 
that you have already marked complete are copied to iCal.
If actions are deleted from calendars, delete them from OmniFocus — If 
you want to delete actions in iCal and have them be deleted from 
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OmniFocus too, select this checkbox. Otherwise, you can be sure that 
synchronizing will never delete any of your actions in OmniFocus.

Include each action’s context in its calendar item title — This prepends 
your action titles with the assigned context name, like @Office: 
alphabetize paperweights.

For all versions of OS X:

If you're syncing your OmniFocus database with Omni Sync Server or 
WebDAV, you can also publish a calendar for your due reminders. This 
can be created in Sync preferences.
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Archiving old data
After a while of using OmniFocus every day, your database may 
become quite large, and especially if you synchronize with a mobile 
device, things could get quite slow. Most of the items are probably 
completed or dropped items that you rarely or never need to review, so 
OmniFocus includes a command to archive those old items to a 
different file, keeping your main database sprightly and nimble.

To archive your old data, choose Move Old Data to Archive from the File 
menu. A sheet appears with a date field; any items completed before 
that date, or dropped items that haven’t been changed since that date, 
will be moved to the archive.

OmniFocus saves your archive file in the same place as your main 
database: ~/Library/Application Support/OmniFocus/, where ~ is your 
home folder. If you ever want to look at your archived data, just choose 
Open Archive from the File menu; your archive opens in its own 
window.

Checking the attachment list
The attachment list gives you quick access to all of the files attached to 
your database. This can be handy for finding the little pieces of 
reference material you have added to your actions and projects. It is 
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also useful for clearing out old attachments, thus slimming your 
database and making it faster to sync.

To open it, just choose Attachment List from the Window menu. You are 
presented with a list of all of your attachments, the item that they are 
attached to, their size on the disk, and the date they were added.

To reveal an attachment in your OmniFocus database, double-click it in 
the attachment list.

To delete an attachment that you don’t need anymore, select it in the 
list and then click the Delete button.
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Page Setup and Printing
Printing your OmniFocus data is pretty straightforward: set up a window 
that contains exactly the data you want by focusing, selecting items in 
the sidebar, or expanding and collapsing rows in the main outline. Then 
choose Print from the File menu. OmniFocus resizes the content to fit 
horizontally on the paper you’ve chosen.

For more control over how your data is printed, choose Page Setup 
from the File menu, then choose OmniFocus from the Settings pop-up 
menu for OmniFocus-specific settings.

Completion checkboxes — you can choose to print the checkbox for 
each action (to differentiate between completed and incomplete 
actions, or if you like to have the box to mark off with a pen).

Completion style — you can choose to print completed actions with 
their completed action style applied (a strikethrough by default).

Window title — Add the title of the window to the top of your printed 
document.

Date and Time — Add the date and time of printing to the top of your 
printed document.

Convert to black & white — Ignore OmniFocus’s color styling and 
draw all text in black on a white background.
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Rows — You can collapse all to show just the top level of the hierarchy, 
leave as displayed to use the expansion as it is in the window on your 
screen, or expand all to expose the collapsed rows.

Notes — You can hide all to put away the notes regardless of their 
visibility on the screen, leave as displayed to use the note visibility as it 
is on the screen, or show all to expose the notes for everything 
regardless of their visibility on the screen.

To print on unusually-sized paper:

Choose Page Setup from the File menu.

Make sure the Settings pop-up menu says Page Attributes.

Choose your printer from the Format for pop-up menu.

See if the paper you want to use is listed in the Paper Size pop up 
menu. If it is, choose it and print normally. If it isn’t, choose Manage 
Custom Sizes to create it.

If you change the Page Setup for a window with a perspective open 
(you can tell because the perspective’s name appears in the window’s 
title bar), those settings are saved with the perspective. This means you 
can print your errands perspective on index cards in black and white at 
120% scale and with no extra columns, print your weekly review 
perspective in full color on landscape-orientation letter paper, and so 
on.
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The Perspectives window has a special Quick Print command in its gear 
menu. Just select a perspective and choose Quick Print to bring up the 
Print panel; then you’re just a click away from your printed perspective. 
If you trust that the settings are right, hold Command while choosing 
Quick Print to skip the panel and print right away.
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Importing data from 
other applications
If you have some data in an OmniOutliner document, especially a 
Kinkless GTD document, you can import it into your OmniFocus 
database.

To import an OmniOutliner document:

If the file you want to import is not a kGTD document, make sure it has 
the hierarchy you want and has a column for each kind of value you 
want to import (title, start date, due date, and so on).

From the File menu, choose Import.

Choose the OmniOutliner file you’d like to import. If it is a kGTD 
document, OmniFocus automatically figures out how to import it 
properly and you’re done. If it’s an ordinary OmniOutliner document, 
you’ll have to help it along a bit; carry on to the next steps.

A column mapping dialog appears. For each column in the original file, 
choose an OmniFocus column to receive the data.

All of the data is imported as a single new project. If you want the top-
level items of the outline to become their own projects, just select all 
the contents of the new project and choose Edit ▸ Outlining ▸ Outdent.
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Backing up your 
database
We’ve made OmniFocus err on the side of obsessive, paranoid data 
preservation, just in case something bad happens to your database. 
After all, we’re asking you to put your whole life into this app.

OmniFocus automatically backs up your database once a day, in the 
folder ~/Documents/OmniFocus Backups/. To change when the 
automatic backups happen, or where they are saved, choose 
Preferences from the OmniFocus menu and use the General pane. You 
can choose to back up once or twice a day, and also to back up 
whenever you quit OmniFocus.

To manually back up your database, choose Back Up Database from the 
File menu. You can choose where to put the backup.

To restore a backed-up version of your database, choose Revert to 
Database Backup from the File menu, then choose a backup file to use. 
Your entire database is replaced by the version in the file; if you’re not 
sure that the backup is what you want, you can double-click the backup 
file in Finder to open it in its own window first and make sure it’s right.
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Exporting your data to 
different formats
Your data belongs to you; if you want to send it to other applications, 
run scripts on it, publish it on the web, or do other exciting stuff with it 
that we haven’t even thought of, you’re more than welcome to write it 
out to the format of your liking and do so!

To export your database, choose Export from the File menu, then 
choose a format and a location. The available formats are:

OmniFocus Document — This is an ordinary OmniFocus document, 
just like the one that you use as your database. If you open such a file in 
OmniFocus, it appears in its own window and you can work with it 
normally, but application-wide settings such as preferences and 
perspectives don’t come along with it.

Plain Text (TaskPaper) — This is a plain-text representation of your 
data, and it happens to be compatible with the light to-do application 
TaskPaper from Hog Bay Software. Of course, you don’t need 
TaskPaper to use your plain text export; you can just give it a .txt 
extension and open it in the text editor of your choice.

Simple HTML — This is a single-file HTML representation of your data; 
the stylesheet and even the icons are embedded in the HTML. If you are 
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proficient with CSS, you should be able to restyle the result however 
you like.

Comma Separated Values (CSV and CSV UTF-16)  — CSV is a kind of 
lingua franca for applications old and new on all platforms, as it’s just all 
of your data in a plain text file with its columns separated by commas. 
Once you have your data in CSV format, it’s easy to run scripts on it, 
convert it to some other format, or open it in applications that 
understand it (like OmniPlan!). If you’re having trouble persuading other 
applications to read the non-ASCII characters in your CSV file, such as 
accented letters or non-Roman characters, try exporting with the UTF-16 
CSV option, and importing that into the other application. This makes it 
easier for some applications to detect the correct encoding and 
interpret your characters properly.
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Getting help
The OmniFocus web site is a good place to find the latest information 
about OmniFocus: http://www.omnigroup.com/products/omnifocus/
The Release notes, available from the Help menu, list all of the changes 
to OmniFocus for each version. Check them out if you’d like to keep up 
with what’s new.

The Omni Group maintains online forums for all of our products, and 
you’re invited! Come share your questions and ideas with other users 
and Omni staff: http://forums.omnigroup.com/

If you’re stuck, or if you just want to let us know how we’re doing, go 
ahead and send us an e-mail. Choose Send Feedback from the Help 
menu to conjure up a message addressed to us, or just write to 
omnifocus@omnigroup.com. A real human reads and replies to every 
message we get. We’ll do our best to help you out.
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Reference
Menu commands - OmniFocus menu

About OmniFocus — Find out some details about your copy of 
OmniFocus. This is good for checking exactly which version you’re 
using.

Buy OmniFocus — This menu item only appears if you haven’t licensed 
OmniFocus; choose it to visit the Omni Store on the web. We encourage 
you to buy OmniFocus and keep our coffee grinder full.

Check for Updates — See if there is a new version of OmniFocus 
available to download. You can also set up automatic checking in the 
Update preferences.

Preferences — Open the OmniFocus preferences window, where you 
can customize how the application works for you.

Licenses — Open the Licenses window, where you can add OmniFocus 
licenses you’ve bought, or check your existing licenses.

Services — Access system-wide Mac OS X services offered by other 
applications.

Hide OmniFocus — Temporarily hide all of OmniFocus’s windows.
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Hide Others — Temporarily hide windows of all other applications so 
you can concentrate on OmniFocus.

Show All — Show all windows of all applications.

Quit OmniFocus — Stop using OmniFocus and put it away for now. 
Your database is automatically saved.

File menu

Show Quick Entry — When OmniFocus is running, show Quick Entry 
and add an action.

Add Project — Create a new project.

Add Folder — Create a new folder for organizing projects.

Add Single-Action List — Create a new list for keeping track of 
individual actions that don’t fit into projects.

New Window — Open a new window just like the frontmost one.

Close — Close the frontmost window. Even if you close the last 
remaining OmniFocus window, you can always just open a new one.

Import — If you used the Kinkless task-management system, you can 
move all of your projects into OmniFocus and say goodbye to the Sync 
button forever. If you have no idea what Kinkless is, you can safely 
ignore this command.
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Export — Make a copy of your OmniFocus database somewhere on the 
disk. The copy can be opened by anyone with OmniFocus, without 
affecting that person’s own main OmniFocus database.

Synchronize with Server — If you have set up synchronization in the 
Sync preferences, coordinate with the server database and make sure 
that both sides have all of the recent changes you’ve made.

Replace Server Database — Replace the server database with the 
local database.

Synchronize with iCal — Take your contexts and synchronize them 
with the calendars you’ve set up in the OmniFocus iCal Sync 
preferences.

Back Up Database — Consolidate all of the entries in your OmniFocus 
database as one compact file, and save it somewhere for safekeeping. 
You can set up automatic database backups in the General 
preferences.

Revert to Database Backup — If you run into trouble with your 
OmniFocus database, you can always go back to an older, backed up 
version. Just choose the backup file you want, and your entire database 
is reverted to how it looked at the time you made the backup.

Rebuild Database — Analyze and consolidate all of the entries in your 
OmniFocus database to make sure they are consistent. This is 
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essentially equivalent to backing up and then restoring your database. If 
you are having problems with your database, this may help.

Compact Database — Take the database changes OmniFocus has 
logged and condense them. If OmniFocus doesn't feel as fast as it used 
to, this may help.

Move Old Data to Archive — Store away some of your completed or 
dropped items in an archive, thus keeping your database slim and 
making OmniFocus faster.

Open Archive — See the old data you’ve archived.

Page Setup — Open the standard Mac OS X Page Setup window, 
where you can change some settings for printing (or exporting to a PDF 
file). These settings are saved even if you quit OmniFocus.

Print — Open the standard Mac OS X Print window, with a variety of 
options for printing (or creating a PDF file).

Edit menu

Undo — Reverse the most recent change you made. You can keep 
stepping backwards like this if there are more changes you want to 
undo.

Redo — Reenact the last change you undid. You can keep stepping 
forward through however many Undo commands you made.
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Cut — Remove the selected text or items, putting them on the clipboard 
so you can paste them somewhere.

Copy — Put a copy of the selected text or items on the clipboard, so 
you can paste them somewhere.

Copy As Link — Put a link to the selected items on the clipboard; when 
you paste it, you get an address for each item.

Paste — Take whatever’s on the clipboard and insert it at the current 
selection. If the clipboard contains just text (not whole items), and you 
are editing the text of an item, the text is pasted at the insertion point. 
Otherwise, the contents of the clipboard are pasted as new items.

Paste and Match Style — Ignore any styles on the text you’re pasting 
and just use the style already there at the place you’re pasting into. Of 
course, this only makes a difference in notes, since that’s the only place 
where you can have special styles anyway.

Delete — Get rid of the selected text or items.

Select All — Select everything in the outline, or if you are editing an 
item’s text, all text in the cell.

Deselect All — Clear the selection completely so that nothing is 
selected.

Duplicate — Make another item just like the selected one, immediately 
after it.
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Outlining — These commands change the hierarchical structure of the 
selected items. If you’re used to outlining applications, they may come 
in handy.

Add Child — Create a new item belonging to the selected item; for 
instance if you have a project selected, this adds an action to the 
project.

Add Aunt — Create a new item at the same level as the selected item’s 
parent; for instance if you have an action selected at the top level of a 
project, this creates a new project.

Move — These commands rearrange the currently selected item in the 
outline hierarchy without affecting deselected items. Move Up and 
Move Down change an item’s location in relation to its siblings. Move 
Right and Move Left increase or decrease an item’s indentation level. 
When items move, their descendants move with them.

Indent — Move the selected item to the right, turning it into a child of 
the item before it in the outline.

Outdent — Move the selected item to the left, making it a sibling of 
what was its parent. This turns any of its siblings that came after it into 
its children.

Group — In the sidebar, group projects into folders or group contexts 
into supercontexts. In the main outline, group actions into projects or 
action groups.
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Ungroup — Move all of the child items out of the selected item, and get 
rid of the selected item completely.

Sort — Perform a one-time sort of the selected items in the sidebar or 
the main outline, as long as you’ve selected something that can be 
reordered.

Edit Note — Move from the item text to the note area of an item, or 
move back from the note area to the item text.

Toggle All Notes — Show or hide all note areas with content.

Attach File — Choose a file to insert in the note area of the selected 
item.

Insert Time Stamp — Automatically type the current date or time, as 
defined by the Short Date, Long Date, and Time formats set up in 
System Preferences’ International pane.

Context — This submenu contains your contexts; choose one to assign 
it to the selected actions, or to set the default context for the selected 
project or group.

Status — Choose from this submenu to change the status for the 
selected project (Active, On Hold, Completed, or Dropped).

Mark Reviewed — Indicate that you’ve reviewed the selected project, 
thus resetting its next-review date.
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Set/Clear Flag — Put flags on the selected items, or remove the flags if 
the selected items already have them. 

Clean Up — Make OmniFocus tidy up after itself, so that all items obey 
your view settings. Also, take any inbox items you’ve assigned projects 
or contexts to and move them to where they belong in your library.

Find — This submenu contains the standard Find commands included in 
many Mac OS X applications: Find (which opens a window where you 
can use regular expressions and search-and-replace), Find Next, Find 
Previous, and Enter Selection (which enters the selected text as the text 
to search for).

Spelling — This submenu contains the standard Spelling commands for 
the Mac OS X spell checking system: Spelling (which opens the Spelling 
window), Check Spelling (which checks spelling in the document once), 
and Check Spelling As You Type (which turns the automatic spell 
checking on or off).

Speech — This submenu contains the Start Speaking and Stop 
Speaking commands, which you can use to make the Mac OS X text-to-
speech system say the selected text out loud.

Special Characters — Open the Mac OS X Character Palette, where 
you can find characters not easily accessible from the keyboard, like ♆ 
and ☺.
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View menu

Planning Mode — Switch the front window to planning mode.

Context Mode — Switch the front window to context mode.

Inbox — Switch the front window to planning mode and select the 
Inbox.

Show in Planning Mode / Context Mode — Switch to the other view 
mode and select the same items you have selected in the current 
mode. This is handy for, say, switching from context mode to planning 
mode for a moment to examine the project that an action belongs to. 
Other methods of switching the mode don’t preserve your selection.

Go To Sidebar / Main Outline — This is one of those menu items that 
you won’t ever need to click; the idea is just to give you a keyboard 
shortcut for going back and forth between the sidebar and the main 
outline without having to touch that dreadful rodent.

Focus on — / Show All Projects — Focus on the selected projects or 
folders; that is, make OmniFocus temporarily act like those items are 
the only things in your whole database.  Or, stop focusing and go back 
to being able to see everything in your database.

Expand All — Show all descendants of all currently collapsed items in 
the sidebar or the main outline.
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Collapse All — Collapse everything in the sidebar or the main outline to 
the top level only.

Expand Rows — Show the children of the selected items.

Collapse Rows — Hide the children of the selected items.

Collapse Row Text When Not Editing / Always Show Full Row Text 
— Choose whether the text in a multi-line item should always be visible, 
or should be folded down to one line when you’re not editing it.

Show/Hide View Bar — Show or hide the view bar. How about that.

Columns — Choose which columns are visible in the frontmost window. 
You can save this setting in a perspective.

Sidebar Filter — This submenu works just like the sidebar filter menu 
in the view bar, setting which projects or contexts are visible in the 
sidebar.

Grouping — This submenu works just like the grouping menu in the 
view bar, setting how to group the projects and actions in the main 
outline.

Sorting — This submenu works just like the sorting menu in the view 
bar, setting how to order the projects and actions in the main outline.
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Availability Filter — This submenu works just like the status filter menu 
in the view bar, setting what kinds of actions are visible in the main 
outline.

Status Filter — This submenu works just like the flag filter menu in the 
view bar, showing actions based on whether they are flagged or not.

Estimated Time Filter — This submenu works just like the time filter 
menu in the view bar, showing only actions whose time estimates fall 
within a certain range.

Show/Hide Toolbar — Show or hide the toolbar. Awesome.

Customize Toolbar — Choose which controls appear in the main 
window’s toolbar.

Inspectors menu

Show/Hide Inspectors — Summon up the inspector window, or put it 
away.

Reset Inspector Locations — This is just in case your inspector 
window somehow ends up in a weird offscreen location and you need 
to get it back.

Action, Group, Project, Context — Switch to the corresponding 
section of the inspector window. You may never need to do this, as the 
inspector does a pretty good job of automatically switching to the right 
section as you select things.
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Perspectives menu

Show / Hide Perspectives — Summon or dismiss the Perspectives 
window, where you can manage your custom perspectives.

Save Window as New Perspective — Store the frontmost window’s 
view settings as a perspective. The Perspectives window appears so 
that you can give the perspective a name and change its settings.

Take Snapshot of — Overwrite the perspective that the foremost 
window came from, using the current settings of the window.

Revert to Default View — If you’re not currently in a perspective, 
choose this to return the frontmost window to its original view settings 
(showing the remaining actions of active projects).

Clear Perspective — If you are in a perspective, choose this to get out 
of it and return to the default window state.

Remaining Items — A built-in perspective that shows only the actions 
that remain to be done in active projects.

Due Items — A built-in perspective that shows actions in order of when 
they are due.

Completed Items — A built-in perspective that shows actions you’ve 
already completed.
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All Items — A built-in perspective that shows every single project, 
action, and context in your database. If you have been using OmniFocus 
for very long, this may take a while.

At the end of the Perspectives menu is a list of all of your custom 
perspectives; choose one to switch the front window to it.

Format menu

Copy Style — Copy the style of the selected text, so that you can apply 
it elsewhere with the Paste Style command. This uses a special style 
clipboard, so you don’t lose the data in the normal clipboard.

Paste Style — Apply the style in the style clipboard (gotten by using the 
Copy Style command) to the selected text.

Clear Style — Remove all styling from the selected text, thus reverting 
it to the default style. This is useful for getting rid of weird styles in 
notes that you pasted from other applications.

Font — This submenu contains standard commands for changing the 
appearance of the selected text. You can freely style notes, but to 
customize the appearance of other items, use the Style preferences.

Text — This submenu contains standard commands for adjusting the 
alignment and spacing of the selected text, which can be nice for 
formatting notes.
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Window menu

Minimize Window — Shrink the frontmost window down into the Dock.

Zoom — Switch the frontmost window between the biggest size 
possible and the last size you set.

Attachment List — Open a list of all attachments in your database.

Bring All to Front — Get all of the OmniFocus windows up in front of 
other applications’ windows.

Toggle Quick Entry Window — Show or hide the Quick Entry window; 
note that you can customize a keyboard shortcut for this, and use the 
shortcut from within any application.

At the bottom of the Window menu is a list of all of your OmniFocus 
windows; choose one to bring it to the front.

Help menu

OmniFocus Help — This brings up the help documentation available in 
the in-app help viewer.

Release Notes — Check out what’s new since the last version of 
OmniFocus.
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OmniFocus Product Page — Visit the OmniFocus page on the Omni 
Group web site.

Add Welcome Template — When you first open OmniFocus, there are 
a few sample projects and contexts to help you get started. If you want 
those back, choose this command to recreate them.

Send Feedback — Compose an email to the OmniFocus support team. 
We’d be happy to give advice, answer questions, or just listen to your 
feedback.

Regular expression syntax

OmniFocus’s Find dialog supports the use of some simple regular 
expressions. A regular expression is a single string that represents a set 
of possible strings. The syntax is as follows:

a* — zero or more instances of a (matches the longest string possible)
a*? — zero or more instances of a (matches the shortest string possible)
a+ — one or more instances of a (matches the longest string possible)
a+? — one or more instances of a (matches the shortest string possible)
a? — zero or one instance of a
^ — beginning of a line
$ — end of a line
. — any character
[a-z] — all characters between a and z
[abc-] — a, b, c, or -
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(abc) — matches abc and stores it as a group. Use the Select or Replace 
pop-up menu in the Find dialog to select or replace only one of these 
groups rather than the whole expression.
\1 — text of first matched group
a|b — a or b
\n — newline
\r — carriage return
\t — tab character
\d — digit
\D — non-digit
\w — word character (alphanumeric or underscore)
\W — non-word character
\s — whitespace
\S — non-whitespace
\ — escape the next character

Regular expressions are very popular, so you should be able to find 
plenty of information about them on the internet or in a good library or 
bookstore. Here are a few examples to get you started:

\s*$ — matches whitespace at the end of a line.
<.*?> — matches strings that begin with < and end with >, such as XML 
tags.
\S+@\S+ — very liberally matches things that resemble e-mail addresses 
(anything@anything).
(19|20)\d\d-\d\d?-\d\d? — matches dates in the format YYYY-MM-DD, 
between 1900 and 2099

92



Using the inspectors
The inspector window is a central place for setting the attributes of 
actions, groups, projects, and contexts. You can use it to examine or 
change one or many selected items. When you select something in the 
sidebar or the outline, the inspector window automatically switches to 
the applicable inspector.

Each inspector has controls that are relevant to the type of item you 
have selected, and some of these controls overlap between different 
types of items.

Project — This sets which project an action or group belongs to. You 
can use this as an alternative to finding the destination project in the 
sidebar and dropping the item there.

Type — You can choose whether the selected group or project’s 
contained actions should become available sequentially or in parallel; 
that is, one at a time or all at once. You can also turn a project into a 
single-action list, for containing unrelated one-time actions.
Status — For projects, the status can be Active (a project you’re still 
working on), On Hold (an on-hold project is one you’ve set aside for 
some day in the future), Completed (a completed project is one you’ve 
successfully finished), or Dropped (a dropped project is one you’ve 
decided not to pursue anymore). For contexts, the status can be 
Available (a context you still intend to use), On Hold (an on-hold context 
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is one whose actions aren’t available for you to work on), or Dropped (a 
dropped context is one you don’t expect to use anymore).

Context — This sets the selected action’s assigned context, just like 
choosing one in the Context column of the main outline.

Default Context — This assigns a context to be automatically assigned 
to any new actions added to the selected group or project. This is 
handy if you have a project that you know is going to take place mainly 
in one context.

Estimated Time — This is the amount of time you expect the selected 
action or group will take to complete. See estimating action duration for 
more information.

Mark Complete — Check this box to automatically set a project or 
group's status to complete upon completion of its actions.

Start and Due — An action, group, or project’s start date determines 
when it becomes available; if you can’t start working on something until 
later, give it a start date so that it will stay out of your way (in Pending 
status) until then. If your action, group, or project has a deadline, enter 
a due date. As the due date approaches, the item appears in the due 
soon style, and if it becomes overdue, it appears in the overdue style. 
Completed — The date that an action, group, or project was completed 
is recorded here. You can edit the completion date, in case you actually 
completed something a while back but didn’t get around to telling 
OmniFocus about it until just now.
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Added and Changed — OmniFocus keeps track of when each item 
was added to your database and when you last changed it. Sometimes 
it’s useful to check these values to see just how long you’ve been 
meaning to do something.

Repeat — If you have an action, a group, or a project that needs to be 
done regularly, you can set up a repeat interval. The Next Start and 
Next Due dates show how the next repetition of the item would be 
scheduled if you completed this one right now.

Next Review — This indicates when the selected project is due to be 
reviewed. You can let OmniFocus determine this based on the review 
interval (see Review Every below) and the last time you marked it as 
reviewed, or you can enter your own date.

Review Every — The default interval between reviews is set in the Data 
Preferences, but you can change the interval on a per-project basis if 
there are projects you want to keep a closer eye on or leave alone 
longer.

Last Reviewed — This is the last time you marked the project as 
reviewed (or the date it was created, if you have never reviewed it).
Customizing columns

There are a few columns you may or may not want to see in the main 
outline:

Context
Estimate
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Start Date
Due Date
Completion Date

You can use the View ▸ Columns submenu to choose which of these 
columns are visible.

To customize column widths, first show the view bar by clicking its icon 
in the toolbar or choosing it from the View menu. Then drag the edges 
of the column headers that appear.

Your column visibility and width settings can be saved with your 
perspective if you select the Restore Layout option, so you can keep 
different settings for different situations.

To set the default column widths and visibility:

Have just one OmniFocus window open.

Set up column visibility and widths to your liking.

Close the window; OmniFocus remembers your column settings.
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General preferences
To get to the General preferences, just choose Preferences from the 
OmniFocus menu, then click the General icon if it is not already 
selected.

The New Windows section of General preferences controls whether 
new windows will open with the last-used settings or a Perspective of 
your choice.

The Quick Entry section of General preferences is where you can 
specify a keyboard shortcut, modify preferences for the Return and 
Escape keys, as well as the behavior for cleaning up the actions created 
by Quick Entry.

In the Backups section, you can specify where your backups will be 
stored and how often they'll be created.

There’s also a setting for how hierarchical project and context names 
should be displayed in the main outline. Say you have contexts called 
“Home” and “Office”, each with another context called “Mac” inside it. 
When you see those contexts in planning mode’s context column, you 
might want to see their hierarchy in order to tell them apart. You might 
also want to see the folder hierarchy for projects in context mode. 
When you turn on the Show full hierarchy setting, the contexts appear 
as Home : Mac and Office : Mac. If you’re not a fan of the colon, you can 
choose or enter a different separator in the field to the right; this is used 
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in the grouping headers and smart match cells whether you turn on the 
full hierarchy setting or not.

Data preferences

To get to the Data preferences, just choose Preferences from the 
OmniFocus menu, then click the Data icon.

The Clean Up section of the Data preferences controls exactly how 
items should be handled when you perform a Clean Up.

You may want to require that an inbox item has A Project, A Context, 
Both, or Either before it is automatically moved out of the inbox.

If you process items with a project but no context, they move into the 
appropriate project but also appear in the No Context group of context 
mode so that you can assign them a context at some point.

If you process items with a context but no project, they move into the 
Default List for Single Actions as indicated below; you can choose a 
single-action list for holding your projectless actions, or let OmniFocus 
create a “Miscellaneous” list when it’s needed.

You can also choose whether Clean Up completed Inbox items. If you 
want OmniFocus to file away inbox items you’ve marked complete, 
regardless of whether they have a project or context, turn this setting 
on. If you still want to go back and assign projects or contexts to your 
completed inbox items, so that they get filed away in the right place, 
turn this off.
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In the Dates & Times section, you can control how OmniFocus handles 
time-related stuff.

The "Due Soon” setting controls how long before an item’s due date it 
should start appearing in the special style for almost-due items. By 
default, items start turning orange 2 days before they are due.

The Show item counts settings determines whether you should see 
colored counters next to items in the menu bar, the OmniFocus Dock 
icon, or both and what kinds of items are displayed. If you choose to 
show an indicator in the menu bar, you can click it to see how many due 
soon, overdue, or flagged items you have in your inbox and your 
individual perspectives; choose an item from this menu to open an 
OmniFocus window with the featured item.

You can set the review interval for new projects; by default each project 
is to be reviewed every week.

Below that, you can choose which day is considered the start of the 
week, for the purposes of entering dates like “next week”. If you 
choose Default, the week starts on whichever day is normal for the 
region chosen in the International System Preferences pane.

The Default Time for Due Dates setting controls the time of day 
assigned to due dates that you enter without specifying a time, as 
described in the Setting start dates and due dates section of the help.
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The settings in the Projects & Action Groups section determine whether 
newly created projects and groups should be parallel or sequential and, 
upon completion of all their actions, if a project or group should also be 
marked completed. Check Show Projects and Actions Groups to view 
those items while working in Context Mode.

Style preferences

OmniFocus uses font styles to differentiate types of items and to 
highlight items’ statuses. For instance, overdue actions appear in red. 
You can customize these automatically-applied styles, but in order to 
avoid confusion with them, you can’t change the style of individual 
items.

To get to the Style preferences, just choose Preferences from the 
OmniFocus menu, then click the Style icon. As you adjust the styles, 
keep in mind that you can always click the Reset button at the bottom 
of the pane to return to the default settings.

At the top of the pane is a pair of buttons for changing all of your font 
sizes at once; this is a shortcut if you just want bigger or smaller text in 
general. Each press increases or decreases all font sizes by 1 point. You 
can also select particular styles and specify a font size for each one.

On the left side is an outline of all item types that you can style, 
organized by how they inherit from one another. For example, Next 
Actions are a type of Actions, and Actions appear in the Main Outline. 
Each item type uses its parent’s style attributes unless you specifically 
change them.
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You can change the appearance of the following types of items:
Sidebars — Everything that appears in the planning mode or contexts 
mode sidebars, on the left side of a window.

Top-Level Items — The Inbox, Library, No Context, and Contexts items 
in the sidebar.

Contexts — The individual contexts listed in the sidebar. The 
background color for this style fills the entire contexts mode sidebar.

Projects — The individual projects listed in the sidebar. The 
background color for this style fills the entire planning mode sidebar.

Folders  — Folders listed in the sidebar.

Main Outline — Everything that appears in the planning mode or 
contexts mode outline, on the right side of a window.

Groupings — The headers that group together items when you set a 
grouping in the view bar; larger and bold by default.

Projects — The items that represent projects and single-action lists in 
planning mode; bold by default.

Actions — Ordinary available actions.

Next Actions — Purple by default.
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Single Actions — Blue by default.

Action Groups — Bold by default.

Notes — Smaller and gray by default, but in individual notes you can do 
as much rich-text styling as you want.

In addition, you can customize the following Status-Based Styles. These 
styles override any other styles that may be on an item:

Completed — Items that have been marked as complete; gray and with 
strikethrough by default.

Due Soon — Items whose due date is within the “soon” duration as set 
in the Data preferences; orange by default.

Overdue — Items whose due date has passed; red by default.

Blocked — Stalled projects and unavailable actions; gray by default.

Below the style list is an Action pop-up menu for resetting the selected 
styles to their default attributes, copying the selected styles, or pasting 
onto the selected styles. You can also save your especially lovely style 
settings to a theme file for safekeeping, or load style settings from 
already-existing themes.

The controls on the right affect the selected style:
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Font Preview — This identifies the selected font and acts as a preview 
of what the font looks like. Note that this only represents the settings 
that you change with the Choose Font button, not the other attributes 
below. Click the preview to open the standard Font panel, where you 
can specify a font family, style, and size.

Text Color — The color for the font itself. For example, next actions 
appear in purple.

Background Color — A color to draw behind the item. In the case of 
the Main Outline style or the sidebars’ Projects and Contexts styles, this 
color fills the entire view.

Shadow — A sharp shadow one pixel below the text; this is most 
effective in white, for the etched look that many elements in Mac OS X 
have these days.

Strikethrough — A line drawn through the text, like the default style for 
completed actions. We’re not sure why you’d want to cross out anything 
else, but hey, you’re the boss.

Underline — A line drawn under the text, in the color and pattern of 
your choice.

Row Spacing — This number specifies, in points, how much vertical 
space the item should have before it. So, essentially, adjacent items get 
farther apart when you increase this number.
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Child Spacing — This number specifies, in points, how much vertical 
space should appear between the item and its child items. So, for 
instance, you could make actions in a project appear closer to or farther 
from the project row itself.

Child Indent — This number specifies, in points, how far to the right to 
indent children of items of this style. So if you increase this number for 
projects in the main outline, then the actions inside each project will 
move further to the right.

AppleScript support

OmniFocus has quite comprehensive AppleScript support. So if there’s 
something you wish it did, you may be able to make it. Open 
OmniFocus’s AppleScript dictionary in the Script Editor application for 
the relevant documentation.
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Licensing
Select the Licenses menu item from the OmniFocus menu to see the 
Licenses dialog. From here you can review and edit your OmniFocus 
licenses, which verify that you’ve actually paid for the software. 
(Thanks!)

To buy a license:

Click the Buy Licenses button and you will find yourself magically 
transported to the Omni Group’s store on the web. Naturally, this only 
works if you have a live Internet connection.

If you’re considering buying a Family Pack license, note that a Family 
Pack licenses up to five members of a private household. If you’re 
buying for a company or some other organization that’s not a private 
household, you can’t use a Family Pack. Also, if you’re just planning on 
using OmniFocus on a couple of different machines by yourself, and you 
don’t intend to have more than one copy running at a time, you can just 
buy a single license.

To add a new license:

Click the Add License button.

If you have a license key in an e-mail message, copy and paste both the 
Owner name and the License Key into the appropriate fields. If you 
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can’t copy and paste the information, you’ll have to type it in; make sure 
you copy everything exactly as it appears in your license message. Also, 
double-check that the license you’re entering really is a license for 
OmniFocus; licenses for other Omni Group products won’t work.
Use the drop-down menu to select the type of license you would like to 
use. (Keep reading to learn about license types.)

Click the Save button.

OmniFocus has three different types of licenses:

Personal: This license is for your personal use, and will only be available 
on this computer when you are logged on as the user who installed the 
license. You can install this license on more than one computer, but 
only for your personal use. If a personal license is available, the 
application will use it instead of other types of license.

Computer: You can use this license on this computer, and so can any 
other user of this computer. However, you should not install this license 
on more than one computer. If both a network license and a computer 
license are available, the application will prefer the computer license.

Network: This license sits on your network and is available to any user 
on the network. However, only a certain number of users (indicated by 
the number of “seats”) can use the license at one time. OmniFocus will 
only use a network license if neither a personal nor a computer license 
is available.

To remove a license:
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Select the license you want to remove.

Click the Delete License button.

Software Update preferences

OmniFocus can automatically use your internet connection to check for 
new and updated versions of itself; you can get to the automatic update 
options by choosing Preferences from the OmniFocus menu, then 
clicking the Update button.

If the Check for Updates checkbox is selected, you will be notified when 
there is a new version of OmniFocus ready for you to enjoy. Click the 
Check for Updates Now button to look for the newest version once right 
away.

You can select the Include system information checkbox to volunteer 
some information about your computer’s configuration when you check 
for updates. For details about what kind of information we collect and 
how we use it, click the Learn More button on the preference pane. To 
see the statistics we have collected from users, visit http://
update.omnigroup.com.
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