
   
      
   



		

Flagged


Another great way that OmniFocus helps you accomplish things is with the option to flag important actions and projects. For example, you can use flags to highlight all of the actions you’d like to complete today, or assemble a quick set of talking points for a meeting.





[image: Flags help draw your attention to things that need immediate attention]


To flag a selected item, click on the upper-right corner of its status circle, choose the Flagged status in the inspector, or use the keyboard shortcut Shift-Command-L. (You can also use Shift-Command-L to unflag an item.) When you flag an item, its status circle changes from gray to orange to help catch your eye and let you know that something important is going on.



[image: After flagging an item, the Status Circle turns orange]


Another way for items to become flagged is by inheriting the flagged status of a parent project or group. If a project or group is flagged, all of the actions within it  automatically receive an inherited flag as well: this is noted by a hollowed-out (white) flag icon attached to the action’s status circle.


Flags gained in this way can’t be directly removed; the parent item must be unflagged, or the action moved elsewhere, to lose the inherited property.



[image: A flagged action group shows how one of its actions has inherited the flag.]


To view all of the items you’ve flagged, visit the Flagged perspective. OmniFocus conveniently brings all of your flagged items together in a nice little bundle so you can tick them off as you go.



[image: Choose the Flagged perspective when you want to view all of the flagged items on their own]

		




		

Glossary


The following is an alphabetical list of terms you’ll encounter throughout this manual, some of which may be unfamiliar or have special uses particular to OmniFocus.





	Action

	An item that’s part of a project, or part of a group within a project.


	Active

	The status for an item that’s planned for completion, or a context that’s currently in use.


	Archive

	A database of jettisoned items that you’ve decided aren’t relevant to your current plans by virtue of their age and dropped or completed status. Using an archive helps keep your main database easy to sync and search, while providing a historical document that’s easy to access for reference when necessary.


	Available

	A view setting that displays items that aren’t blocked, deferred, or on hold.


	Backup

	A copy of your database automatically generated by OmniFocus and stored for safekeeping should something go amiss with your main database. Backups are automatically created every two hours while OmniFocus is open, and up to 100 are kept before the oldest is discarded.


	Blocked

	The status of an action in a sequential project that is ordered to come after the first available action.


	Clean Up

	A clerical process that tidies the views on your database when you switch between them, or when it’s triggered with a menu item or toolbar button. Usually this involves hiding completed items or moving actions into their proper places; you can fine-tune how clean up works in Preferences ▸ Organization.


	Complete

	The status assigned to an item when you’ve finished it, or finished all the actions that comprise it (in the case of a project or group).


	Context

	The person, place, thing, state of mind, or other factor most relevant to the completion of a given action or project. These exist outside the project hierarchy and represent another axis from which to view the items you’ve accumulated in your database.


	Defer Date

	A date and time assigned to an item that you don’t want to (or can’t) consider for completion until later. When the defer date is reached, the item becomes available for further execution.


	Due Date

	A date and time assigned to an item by which the item must be completed.


	Due Soon

	A status for items whose due dates are approaching. Items that are due soon are styled in amber for greater visibility. The exact meaning of Due Soon is configurable in OmniFocus ▸ Preferences ▸ Dates & Times.


	First Available

	A view setting that affects how actions in projects are displayed. A sequential project has one available action and one first available action. A parallel project has one first available action and many available actions. A single action list potentially has many “first available” actions.


	Flag

	A mark of privileged, eye-catching status bestowed on an item. What this special status denotes is completely up to you, but it’s a great way to keep important things from falling through the cracks. Items that are flagged are styled in orange for greater visibility.


	Focus

	A feature of OmniFocus Pro that applies to projects and folders (focusing on an action brings the project that contains it into focus). When focused, OmniFocus excludes all items in your database from view other than those in the projects or folders you have selected. Browsing between perspectives retains focus on these items, so you can attack them from multiple angles without distraction.






	Focus Bar

	A horizontal bar that appears beneath the toolbar to denote that you’re focused (in OmniFocus Pro) or viewing a database other than your current primary one (such as a backup, an archive, or someone else’s database they sent you to take a look at).


	Group

	A collection items nested hierarchically within another item. Groups created from inbox items are item groups, while groups created within projects are action groups (also sometimes called sub-projects).


	Hidden

	Items that live in your database but aren’t exposed by the View options of your current perspective are considered hidden. OmniFocus lets you know if you’re about to delete hidden items accidentally; see the Cleaning Up section for details.


	Inbox

	The built-in perspective designed to hold tasks and to-dos that you’ve entered into OmniFocus as items, prior to processing them into projects, actions, and groups. Once an item becomes a project or an action it’s moved out of the inbox at the next clean up.


	Inspector

	The pane on the right side of the OmniFocus window that provides editable details about your current selection in the sidebar or the main outline.


	Item

	Items are representations of tasks and to-dos in an OmniFocus database. Types of items include: Inbox Items, Actions, Projects, and Groups.


	Main Outline

	The central portion of an OmniFocus window, where a hierarchical view of your database is (usually) displayed. Specific perspectives (such as Contexts and Forecast) have specialized ways of displaying your data that eschew or modify the typical project hierarchy.


	OmniFocus Window

	A viewport onto an OmniFocus database, including several subsections: the main outline, sidebar, inspector, toolbar, bottom bar, and (occasionally) the focus bar.


	On Hold

	A status for projects and contexts that aren’t relevant to your plans right now, but may be in the foreseeable future.


	Overdue

	A status for items whose due dates are past. Items that are overdue are styled in red for greater visibility.


	Parallel

	A project or group that doesn’t place particular emphasis on the order in which its actions are completed. All actions are considered available, though the topmost action is still considered the first available action for the purposes of view settings.


	Pending

	An item with its defer date set for some time in the future. Pending is a synonym for deferred; this particular term is only found in OmniFocus Pro as a filtering option for projects in custom perspectives that use the project hierarchy.


	Perspective

	A view on your OmniFocus database, displayed in an OmniFocus window. OmniFocus 2 comes with six built-in perspectives and two transient reference perspectives (Completed and Changed), and custom perspectives can be added in OmniFocus Pro.


	Perspective Tabs

	The vertical column of tabs on the leftmost side of an OmniFocus window, displaying a list of persistent perspectives for your browsing pleasure. The six built-in perspectives are included here by default (perspective tabs can be hidden, revealed, and rearranged in OmniFocus Pro).


	Perspectives Window

	A window in OmniFocus Pro that’s split into two parts: the perspectives list (where perspectives are added, renamed, reordered, and have their tab visibility set) and the perspectives editor (where perspectives are created and customized).


	Project

	A to-do item that’s larger in scope or permanence than a simple action, potentially containing several actions and groups within it that must be completed before the project can be marked complete.


	Remaining

	A view setting that displays all items that haven’t been completed or dropped.


	Sequential

	A project or group whose actions must be completed in a specific order. The first action in the list is the only one available for completion.


	Sidebar

	The vertical space to the left of the main outline that’s displayed by default along with all perspectives but the Inbox. It contains the project hierarchy in perspectives that use it; otherwise it shows the context list or a special customized view (as with Forecast).


	Single Action List

	A project whose actions are unrelated to a sequence of any sort, or one that’s maintenance-oriented as opposed to completion-oriented. All actions in a single action list are considered equally available.


	Stalled

	A project with no remaining actions (all of its actions have been completed). This status is used primarily as a filter for custom perspectives in OmniFocus Pro.


	Sub-Project

	A term synonymous with action group; a group of actions nested hierarchically within a project.


	Status Circle

	A graphical display of an item’s status (due soon, overdue, flagged, or repeating), as well as a target to click to mark an item completed (hooray!) or to flag it.


	Task

	In the context of this manual, a task is something you’d like to accomplish in the real world that you’d capture with OmniFocus (where it would then become an item). To-do is another word with the same meaning.





		





		

Forecast


With Forecast view, you can keep an eye on the progress of your projects, check upcoming due dates, and schedule OmniFocus actions alongside important events in your Mac or iOS Calendar. With the ability to check for past due tasks and look ahead to the future, you’ll never miss a beat.





[image: Forecasts are your crystal ball to everything thats on your plate]


One way to think of OmniFocus’s Forecast perspective is to think of the weather (which is something we do often here in Seattle)—you want to know what it’s going to be like outside so you can plan ahead. The Forecast view gives you that same perspective by showing you how many tasks are on your plate for the week ahead. When you switch to the Forecast perspective, the sidebar lets you see what’s past due, what’s due over the next 30 days, and what is further off on the horizon.


Each date button displays the number of actions associated with that date. For due items, the count is color-coded according to the most urgent item: amber indicates that an item is due soon, and red indicates an item is due or past due. To create a new action that is due on a particular day, go to the appropriate date button, followed by the new item button.


The Forecast Sidebar


A range of dates spanning the next month is displayed in a convenient grid in the forecast sidebar, letting you know at a glance what’s on your plate in the coming weeks.



[image: Use the Forecast perspective to see how many items are due each day]



Note

You can toggle the range of dates displayed in the sidebar in the Forecast perspective’s View options.





The forecast sidebar has a bunch of nifty interactions that make assigning due dates and viewing your upcoming plans a breeze.



	Click and drag on a range of dates to select them, bringing items due on those dates to view in the main outline.



[image: Select a range of dates by clicking and dragging on the calendar in the sidebar]



	Command-click to select discontiguous dates—Each Saturday in the coming month, for example, to see whether your next few weekends are clear.



[image: Command-click the dates you want so you can see what&#8217;s happening on those days]



	Drag and drop an action from the outline onto a date in the sidebar to make it due that day.



If you hold down the Command key while dragging, OmniFocus sets the Deferred Date to any dragged items. Similarly, if you hold down Option-Command while dragging, OmniFocus sets the Deferred Date and Due Date for the dragged items.







Adding Your Calendars to OmniFocus


OmniFocus also plays well with your calendars, including those you might sync through Apple’s iCloud from Calendar on OS X or iOS, Google Calendar, or any CalDAV servers to which you have subscribed. The calendars which you can view in OmniFocus are based upon the calendars that the Calendar app on your Mac can see; to add to, remove, or modify the calendars available on your Mac, use the Calendar app.



Note

The first time you launch OmniFocus, you’ll receive a prompt informing you that the app would like to access your calendar. Choose OK to connect the app with your calendars. If you previously chose Don’t Allow, your Forecast calendars will come up blank. If that’s happened, no need to fear — you can always go back and change this setting.


Head to System Preferences ▸ Security & Privacy ▸ Privacy ▸ Calendars, then click the lock to make changes and allow OmniFocus to access your calendars.





Events on your calendar show up interspersed with the daily events you’ve scheduled in OmniFocus. To view an event on your calendar, just click it for a popover that contains the details of that event. In that popover, you can also click View in Calendar to open the Calendar app on your Mac and go directly to that event.



[image: Click View in Calendar to open calendar events in OS Xs Calendar app]



Note

While OmniFocus is great at talking with Apple’s Calendar, we can’t guarantee compatibility with other calendar apps that may be on your Mac. Calendar is considered the default go-to resource when OmniFocus seeks out calendar information to display alongside your OmniFocus items in Forecast view.





To modify what you see in the list or to adjust the time shown for the Calendar events, click View in the toolbar. Forecast View options also include a Calendars section that lets you customize which external calendars are shown, including those stored in iCloud and more.



[image: Use View options to select which of your Calendars will also appear in OmniFocus]

		




		

Focusing


If you’re using OmniFocus Pro and you want to concentrate for a while on a particular project, folder, or combination of items, the Focus feature can get everything else out of your way.




To Focus:



	Select a project or folder (or any combination of projects and folders) in the sidebar or main outline.


	Click the Focus toolbar button, choose View ▸ Focus on (Selected Items) (Shift-Command-F).





Everything outside your selection disappears from the sidebar, the title at the top of the window changes to Focusing on (Selected Items), and the focus bar appears beneath the toolbar to indicate that you’re in a special view of your database.


As you move between perspectives, OmniFocus ignores everything outside of your focus, as if the items you’re focusing on are the only items in your library.


When you’re done focusing, choose View ▸ Unfocus (Shift-Command-F), or click the Unfocus button in the focus bar. Your library comes back as if nothing ever happened!



Tip

When you find yourself using a certain set of contexts, focus, and view options pretty often, you might want to save them as a custom perspective.


Focusing inside a custom perspective that includes a focus as part of its parameters will display the intersection of the two focus areas.




		



		

Welcome to OmniFocus


Welcome to OmniFocus 2!




Throughout this manual you’ll find information to help you get the most out of an app designed from the ground up with your productivity in mind. OmniFocus is a great way to organize, plan, and accomplish the goals in your life, and with OmniFocus 2 for Mac there’s never been a better time to dive in and see what it’s all about. We’re glad to have you with us!



[image: OmniFocus 2.3 for Mac on MacBook Pro and a Thunderbolt display.]


What is OmniFocus?


It all starts with a basic idea. You have something that needs to get done, and you know you’d better make a note about it somewhere, but that sticky note on your desk isn’t going to cut it anymore. You’re ready to try a more reliable system, one that can keep track of all the things going on in your head, and maybe even help them feel a bit more simple in the process.


OmniFocus is the personal task management tool that helps you keep track of all the goals, plans, errands, and aspirations that come up in your life. Whether the task at hand is something small, such as setting a reminder to swing by the bike shop after work, or the tasks are part of a bigger goal, such as making plans for that long overdue vacation, OmniFocus helps you keep track of everything you need to do throughout your day.


Available on your Mac, iPhone, iPad, and Apple Watch, OmniFocus is packed full of tools to help you prioritize steps within complex projects or simply jot a quick to-do list for a weekly meeting. OmniFocus works great as a standalone productivity aid or in conjunction with whatever time- and task-management scheme suits your personal style.



Note



	OmniFocus for Mac (the subject of this manual) is available both on the Mac App Store and directly from The Omni Group.

	OmniFocus for iOS is available on the App Store, and works on all of your iOS devices as well as your Apple Watch (through the OmniFocus for Apple Watch extension).







OmniFocus for Mac complements OmniFocus for iOS, serving as your base of operations for productivity that extends well beyond the screen of your Mac.


For a video tour of the features of OmniFocus, check out:


http://www.omnigroup.com/video/omnifocus


Inside OmniFocus is another great resource to help you get up to speed with the wide variety of ways OmniFocus can be used to help you get things done.




Migrating Your Database


If you are updating from an earlier version of OmniFocus, you may be prompted to migrate your database to a format capable of supporting the features of the latest version of the app.




When you first launch a version of OmniFocus that's compatible with the new database format, or choose Migrate Database... from the File menu, you'll see the Migration window that lists any clients that still need to be updated to the latest version to allow for the database migration to work.




If you're running a very old version of OmniFocus on a device that syncs with your current database, it may not be eligible for migration to the new database format. If this is the case, it will be indicated in a separate section of the Migration window. You'll be asked to disconnect any ineligible clients (choose Show Devices and Unregister those that aren't eligible) before proceeding with the upgrade.



Note

If you prefer to maintain sync compatibility with a very old version of OmniFocus, you can choose not to update to the new database format. However, newer features of OmniFocus that require the updated format will not be available on any devices that sync with that database.





When all of your Macs and iOS devices with OmniFocus are at versions that support the latest database format, the Migration window gives the green light to make the transition to the new, improved format. Choose Migrate Database, and voila! OmniFocus syncs your database in the new format to all of your devices. If you choose Later, you'll be prompted to migrate again in one day (and you can always use the Migrate Database... File menu item to migrate sooner).




On the small chance that something goes missing during the migration process, before changing formats OmniFocus automatically makes a backup of your database that you can revert to if needed. We've prepared support articles with more detail on the migration and backup restoration process, and you can always contact us with any additional questions.





Making the Transition: OmniFocus 1 to OmniFocus 2


If you’re a user of OmniFocus 1 for Mac, you probably have an existing database that you’d like to bring over to OmniFocus 2. Due to changes in the way OS X handles files associated with specific apps (sandboxing), you’ll need to migrate your database as the first step to using OmniFocus 2 with your existing data.





Importing your Database


Syncing OmniFocus 2 to your existing OmniFocus database is the recommended method for migrating from other versions. It provides a straightforward pathway for keeping your data in the up-to-date state you want, and keeps all versions of OmniFocus playing nicely together if you’re running the app on multiple devices.




However, if you choose not to sync the first time you launch OmniFocus 2, you’ll have the option to migrate an existing database from OmniFocus 1. This doesn’t remove your old database (it just copies it over), so again, we recommend syncing to avoid later confusion and conflicts between multiple versions of your database.


Importing your Archive


After you’ve used OmniFocus 2 for a while, you’ll be prompted to archive parts of your database that aren’t relevant to your current set of projects (you can also create an archive manually by choosing Move Old Data to Archive from the File menu). If you have OmniFocus 1 installed on your Mac, OmniFocus 2 will check the default location for an OmniFocus 1 archive, and if it finds one, ask if you’d like to move it into OmniFocus 2’s sandbox and add your new archive data to it.


Changing Terminology


To help better represent their function, a few things have changed about how OmniFocus describes certain features of the app.



	Start dates are now defer dates. This is to more accurately capture the intent that an item shouldn’t be considered until a later time—it’s been deferred.


	Next actions are now first available actions. This helps explain view options more clearly, and helps further disambiguate sequential projects, parallel projects, and single action lists.


	Project and Context-based perspectives have become Use Project Hierarchy and Don’t Use Project Hierarchy, respectively. This is to better reflect the role this choice plays in affecting other aspects of a custom perspective’s view settings.





To get started with OmniFocus you can continue browsing the help, or dive right in to the app. If you’re starting fresh with a blank slate, you’ll see the tutorial project ready to offer some initial pointers. You can add the tutorial to your database at any time with the Help ▸ Add Tutorial Project menu item.


Standard and Pro


OmniFocus 2 gives you the power to engage with OmniFocus in ways even more uniquely tailored to your needs. We made the Standard edition of OmniFocus 2 for Mac with the idea that it has everything you need to get started “out-of-the-box”, including the vast majority of features covered in this manual.


In OmniFocus 2 Standard, you’ll:



	Use the powerful set of built-in perspectives to manage your projects and contexts, see what’s coming up with Forecast, set up regular project reviews, and more.


	Add to and access your actions anywhere in the app with Quick Entry and Quick Open, use the redesigned sidebar and inspector to easily select and edit your data, and see the state of your items with a glance at their status circles in the main outline.


	Switch between the standard fluid layout and a customizable set of columns to show just what you need in the main outline.


	Extend the capabilities of OmniFocus with email input from Mail Drop, sync between your devices with Omni Sync Server (or another WebDAV server), view external calendars alongside your to-dos, and add all manner of notes and file attachments.





In the following chapters you’ll get a full look at everything OmniFocus 2 Standard offers. It’s a heck of a lot!


In addition to the Standard feature set there are some specialized tools that appeal to users who’d like more increased view flexibility and workflow customization, and that’s why we made OmniFocus Pro.


When you try OmniFocus Pro, you’ll be able to:



	Create custom perspectives, and completely configure the sidebar to display just the perspectives you want, in the order you want.

	Focus on individual projects and folders that require your undivided attention.

	Configure the layout of your perspectives to show just the data that’s most relevant. Show and hide columns on a case-by-case basis, defer to the original fluid layout, or set an app-wide default view.

	Incorporate AppleScript into your workflow to automate common tasks, or extend the inter-app functionality of OmniFocus even further.




How to Try Pro


You can download the trial version of OmniFocus from our website. At any time throughout the trial period you can switch between Standard and Pro using Free Trial Mode ▸ Try Pro/Standard Edition in the OmniFocus menu to compare features and see which is the right fit for your needs.


Likewise, if you purchased OmniFocus 2 Standard from the Mac App Store you can download the trial version and run it side by side to compare features.


If you own a Standard license from the Omni store and would like to try Pro, if you’re still within the trial period you can temporarily delete your license (Licenses in the OmniFocus menu) to revert to trial mode and give Pro a try. If you’re outside the trial period, contact us and we’ll be happy to provide a Pro trial license.



Note

Unsure whether you have Pro installed? Check About OmniFocus in the OmniFocus menu for details on the current version and licensing status of the app; with Pro installed you’ll see a purple bar below the Omni address indicating your purchase.






Using This Book


One of the beauties of having OmniFocus’s documentation available in electronic form is that it’s always available whenever you need it. We have built the documentation right into the Help menu. We have put all of the documentation on our website where it can be searched and bookmarked. And we’re continuing the ongoing trend of creating EPUB versions of the docs and making them freely available on the iBooks Store.






Get the EPUB

[image: The iBooks application icon]
Our preferred method of delivering the Help docs is via the iBooks Store in EPUB format. The documentation there is the same documentation you’ll find on our website and bundled within the app.




The advantage of downloading the OmniFocus 2.12 for Mac User Manual from the iBooks Store is that whenever we update the docs for a new version of OmniFocus, you’ll receive a notification in iBooks telling you that there’s an update waiting for you. And the big win of EPUB over PDF is that any notations or bookmarks you make in the book carry forward to new versions of the documentation.





Tell Us What You Think


We’re constantly working on updates for our documentation. Whether it’s CSS work, correcting the occasional typo (yeah, they do sometimes slip through), or adding details or clarification for a specific feature based on something we’ve heard from a customer, we’re always trying to make our documentation better and more useful for you.




If you have any specific comments you’d like to send us about the documentation, please do. You can drop us an email message via our Support queue, or you can ping us on Twitter; we’re @OmniWranglers.


Finally, we’d like to thank you for taking the time to read the docs.


		




		

Dates and Times


When you have tasks to complete by a deadline, OmniFocus can help weave actions and projects into your day.




By design, the items you collect in OmniFocus aren’t the same sort of thing as events or agenda items you’d list on a calendar. You’d generally use a calendar for anything that takes place at a specific time: meetings, dentist appointments, and dinner reservations would do best in your calendar because you can’t act on them until that moment.


Setting Defer and Due Dates


Actions and projects can have due dates and “defer until” dates with a less specific notion of time constraint than items in your calendar. The defer until date is the date when an action or project becomes available; until that date arrives, the item remains grayed out. The due date is the date when an action or project needs to be completed.


For example, to make progress on your Colonize Mars project, you need to know when Mars is in opposition so you can schedule a date during the launch window. A quick online search shows that the next window is from January 2016 to April 2016, so you decide to launch your spacecraft on January 6 to commemorate your birthday. To keep track of this, you might create a Launch Window action with a defer until date of January 1, 2016 and a due date of April 30, 2016.


While you’re at it, you also create a Launch Spacecraft action with a defer until date of January 6, 2016 and a due date of April 30, 2016. So why not just a due date for Launch Mission? Well, because weather conditions for a launch could be bad that day, or there could be some sort of mechanical failure that delays the launch. Regardless, that is the day you know you’d like to launch the rocket, and if that date passes, OmniFocus reminds you until you’re past the due date and off to explore the Red Planet.


Items that have not reached their defer until date are not considered available so they won’t clutter your view until you can work on them. To see all of the actions in your Colonize Mars project, choose Remaining in View options (All includes completed and dropped items). Actions with a future defer date are in gray. When the defer date arrives, the action’s text appears in black to let you know it is available and the clock is ticking.


When due dates are approaching, OmniFocus considers actions and projects to be Due Soon and represents them as such by changing their color from black to amber and adding them to the Forecast (see Forecast). By default, actions become “due soon” two days before the specified due date. To change this, go to the OmniFocus ▸ Preferences ▸ Dates & Times tab and choose a different value for “Due Soon”.


Also in the Dates & Times section of preferences, you can choose which time of day to use for when you enter a due date with no time. By default it is 5:00 PM; you could for instance enter 11:59 PM to make new items due at the very end of the day, or 9:00 AM to make new items due at the beginning of the workday.



Note

New in OmniFocus 2, you can also (in OmniFocus > Preferences > Dates & Times) customize the default time for actions and projects with defer dates to become available. The starting default is 12:00 AM, but you could change it to a time that’s better suited to when you habitually check OmniFocus for newly available actions, for example. 





Defer and due dates can be entered either in the main outline or in the inspector.


Actions that have reached their due date are styled in red. This serves as a warning to you that you should either get that task done, or reschedule its due date. In the case of the Mars mission, if you miss the launch window, you’ll have to wait another 24 months for your next opportunity.


Supported Date Formats


You can be pretty creative with the way you enter dates; OmniFocus is rather smart about guessing what you mean. For example:



	2d, –3w, 1h, 1y1m, and so on — Relative dates and times put the date at a certain amount of time from right now. Negative numbers represent times in the past.


	2 days, –3 weeks, 1 hour, 1 year 1 month, and so on — You can use the full names of units too.


	yesterday, tomorrow, tonight, next thursday, last month, this friday, and so on — You can refer to relative dates using common words. “This”, “next”, and “last” have specific meanings: this friday always means the Friday in this week, next friday always means the Friday in the next week, and last friday always means the Friday in last week, regardless of what day today is. Other units work in the same way.


	september, fri, 2019, and so on — If you enter the name of a specific time period, the date will be at its beginning. So september means September first.


	5/23/08 10a, 9.30.09 2:00 PM, and so on — You can use the short date format as defined in your Language & Region system preferences.


	2w sat, 4d @ 5p, mon 6a, aug 6 tue 5p, and so on — Mix the available formats however you like.


	now, 9, 14:00, tom, and so on — OmniFocus makes its best guess at things like bare numbers, times, and word fragments. If you think something might work, give it a try.






Note

In cases where due dates vary between actions and the projects that contain them (such as an action being part of a group that’s nested within a project, all with different due dates), the soonest due date is considered the effective due date for all items that are its children in the hierarchy.


For example, if you have a project due on the 4th of the month and actions within that are due on the 2nd and 3rd, but circumstances change and you need to complete the project on the 1st, the actions also become due on the 1st.


Likewise, when defer dates vary between projects and the actions and groups within them, child items will inherit defer dates of their parents if they are later than the child’s defer date.


For example, if your Launch Sequence actions are part of your Mars Expedition project but you miss the first launch window and have to reschedule, deferring the entire project to a later date will cause the Launch Sequence actions to also be deferred (they would have otherwise become available with no actual launch imminent).





Repeating Items


Some tasks occur on a regular basis. Instead of creating a new item every time you need to take out the recycling, you can set that task up so that you’re reminded every Thursday night to put the recycling bins by the road for pickup Friday morning.
Repeating actions can occur regularly—every few hours, days, weeks, or months—based on when the item was first scheduled, or rescheduled to be deferred until (or be due again) based on a set time after you mark it completed.


To set an item up to repeat:



	Select the item you want to repeat.


	Choose a Repeat type from the list in the Repeat pane of the inspector.



	Repeat Every—With the initial due date as its starting point, the item will come due again at the lapsing of each repeat interval, like clockwork. This is useful for repeating items that are locked to the calendar, like paying the rent. This is the repeat type for most common uses.


	Defer Another—When the item is completed, it’s deferred for another instance of the repeat interval. This is useful for repeating items that can’t be considered again until a specific amount of time has passed—when your scheduling has to be flexible because it’s regulated by some external constraint. If your insurance covers dentist check-ups every six months, for example, you’ll want to make an appointment later in the year based on the date of your previous one.


	Due Again—When the item is completed, it’s due again after the repeat interval has elapsed. This is most useful for items with internally set constraints based on the time they take (or require) to complete. Refilling a 30-dose medical prescription every 30 days is an example of this type of repeat.






	Enter a repeat interval. This can be any number of minutes, hours, days, months, or years.


	To schedule an action on specific weekdays, enter a Repeat Every interval in weekly increments and then select the days on which you’d like to repeat the item from the buttons below.





For example:



	Defer until Tuesday 5:00 PM; due Tuesday 10:00 PM; repeat every 1 week: take out the trash. This repeats on a fixed schedule because it is necessary to do it at the same time every week, regardless of when you last did it.


	Defer until today 12:00 AM; due today 6:00 PM; defer another 5 days: clean the kitchen. This is deferred from the completion date because the next time you need to do it depends on the last time you did it.


	Defer until 4:00 PM; due 6:00 PM; repeat every 1 week on Monday, Tuesday, and Thursday: bring Sarah to soccer practice. This repeats on certain weekdays, available toward the end of the workday so you aren’t distracted by it until you need the reminder.


	Defer until today 7:00 AM; due today 7:00 PM; due again in 10 days: water the cactus. This prickly fellow risks drowning if watered too frequently, and using “due again” ensures this won’t happen even if the action becomes overdue before you complete it (“repeat every”, by contrast, would prompt you to do it again sooner than would be safe).





When you mark a repeating item as complete, the next instance of it is created with its start and due dates pushed forward as indicated by the repeat interval. If you want an item to stop repeating, just turn off the Repeat setting in the inspector.

		






Contexts


In addition to the hierarchical ways of organizing your actions, you can also assign a Context to each action, project, or group. A Context can be anything you want, such as a place (the hardware store or work), a person (you, your boss, or a coworker), or a thing (your trusty MacBook Pro or a torque wrench). Contexts indicate where you need to be or what you need to have available to complete the item.





[image: Contexts are the persons, places, or things (nouns) you need to complete a project or action]


When you have multiple projects in the works simultaneously, Contexts help you organize actions that have something in common, regardless of which project they’re in.


For example, let’s say you’re tweaking the rocket engine you’ve been building in the backyard, and you’re stuck because you need a specific wrench. To make matters worse, the light in your workshop went out when you went searching for that wrench. You’ve added the wrench as an action in your Colonize Mars project, and you just added the lightbulb to your Household Errands project. But what’s to keep you from forgetting one or the other the next time you go to the hardware store? The answer is that while they’re part of different projects, you can associate these items with a Context.



Assigning a Context


There are many ways to assign a context to an item, be it an action, a project, or a group.




In a perspective that uses the project hierarchy (such as the built-in Projects perspective), the simplest way to assign a context is to select the item in the outline and choose a context from the drop-down menu in the inspector — or select the Context field for the item in the main outline, if you’ve chosen to show it. Typing a context here presents options that auto-complete based on existing contexts, or offer the option to create a new one if the desired context doesn’t exist.



[image: Assigning contexts in OmniFocus 2 for Mac.]


When in the Contexts perspective, it can be just as quick to select items in the main outline, and click and drag them to the item in the contexts list where you’d like them to reside.



Note

After a context is assigned to a project, new actions added to that project are assigned that context by default when they are created. However, the context isn’t truly inherited; it can be freely removed from any action within the project.


This works differently from project due dates and flags, which are attributes that a project’s actions acquire by virtue of being part of the project (unless those actions are assigned a higher priority: either flagged themselves, or assigned an earlier due date than the project as a whole).







Managing Your Contexts


As with Projects and Action Groups, Contexts can be nested within one another to provide levels of specificity when needed. For example, you could organize a list of contacts at the office by department, or break down chores across the various rooms of your house. Just drag and drop to nest a context within another.





[image: Drag similar actions ]


Contexts, like Projects, also have a Status:



	Active

	On Hold

	Dropped





Note

If you’ve used OmniFocus on your iPhone or iPad, you’re probably familiar using location-aware contexts. Context location data isn’t accessible in OmniFocus for Mac, but don’t worry—it’s safely preserved when you sync your OmniFocus data between devices.




		




		

Notes and Attachments


Notes are a great way to enrich the actions and projects you’re working on. Instead of cluttering an action title with a list of instructions for completing it, try adding them in the note field instead—note text is fully searchable, so there’s no worry about the minutiae getting lost in a hidden field.




To add a note to an item, click the note icon in the main outline near the item’s title, edit the note field in the inspector, or use the Command-’ keyboard shortcut.


When a picture is worth a thousand words, try adding an attachment! With an action or project selected, choose Edit ▸ Attach File. This opens a file selection dialog, where you can browse to find the file you’d like to attach. You can choose whether to link to the file on your system, or embed it into your database (the Embed option is chosen by default). Note that if you want access to the file on your other devices you’ll want to embed it so it can sync properly (see Creating and Syncing Attachments, next).


Creating and Syncing Attachments


When adding attachments in OmniFocus for Mac, there are two ways to ensure the attachments make it across to your iPad or iPhone (or your other Macs with OmniFocus installed). The important theme here is to embed the attachments, as simply linking to them won’t work. Due to the file formats supported on iOS, not all attachments added in OmniFocus for Mac are visible in OmniFocus for iPad or iPhone.



Note

The reason why linking to attached files won’t work is because filesystem links on OS X are just that—they are links to files on that system. When you sync OmniFocus for Mac, those filesystem links no longer work because iOS filesystems are different from the one on your Mac.


However, when you embed an attachment and sync OmniFocus, that file is copied into your OmniFocus database and is stored on the sync server where it can easily be pulled down on either platform.




Option 1: Attaching Files from the Edit Menu


With OmniFocus open on your Mac, select the item to which you’d like to attach something, and then select Edit ▸ Attach File in the menu bar. In the Open sheet that slides down, select the file you would like to attach, and then make sure you select the Embed the file in the document radio button before you click Select.



[image: Attaching Files from the Edit Menu]



Note

The Embed the file in the document option is selected by default. This makes syncing your attachments the default state of affairs; if you’d prefer not to sync an attachment (for bandwidth or database efficiency reasons), choose Create a link to the file instead.





Option 2: Attaching Files from the Finder


To attach a file from the Finder (it’s the blue smiley-faced icon on the far left edge of the Dock on your Mac) you will need to Option-drag the file from the Finder to the note field of your item in OmniFocus. Make sure the note field is open and selected, then place the Finder window next to the OmniFocus window and select the file you want to attach by clicking on it. Hold down the Option key while pressing the mouse button. You’ll notice that when you press the Option key, the mouse pointer changes to a green circle with a plus sign inside. This is exactly what you want! Now drag that file onto your OmniFocus item, let go of the mouse button, and the file is attached.



[image: Attaching Files from the Finder]


After you have attached the file in OmniFocus on your Mac, be sure to click Sync in the toolbar. Then, when you switch to OmniFocus for iPad or iPhone, tap Sync to bring the attachments over to your other device.



Note

Your Mac supports all kinds of different file types, mainly because of the wide variety of apps that can run on OS X. Conversely, iOS doesn’t support nearly as many file types by default. The rule of thumb to keep in mind is that in most cases, if you have compatible versions of an app on your Mac and iPad, you should be able to open those attachments in OmniFocus on either platform.





The Attachment List


The Attachment List (Window ▸ Attachment List) gives you quick access to all of the files attached to your database. This can be handy for finding the little pieces of reference material you have added to your actions and projects.



[image: The Attachment List shows all of the files attached to your OmniFocus database]


The Attachment List displays a list of all of your attachments along with a thumbnail image, file size, and the date they were added. Click any of the column headers to sort the list by that attribute (in ascending or descending order). Click the disclosure triangle on the left of an attachment row to reveal its associated database items, or double-click the attachment to go straight there.



The Attachment List can also be used for clearing out old attachments, thus slimming your database to take up less space on your devices (especially useful when syncing).



[image: The Attachment List shows all of the files attached to your OmniFocus database]


To delete an attachment that you don’t need anymore, select it in the list and  click the Delete button in the window’s lower left corner. The Delete dialog indicates how many attachments are selected for deletion, and how many individual database items those attachments are associated with.



Tip

Select multiple attachments at once by Command-clicking them, Shift-click to select a range, or use the Command-A keyboard shortcut to select all attachments in the list.





If you would like to retrieve attachments from your database (perhaps prior to a big deletion), select them in the list and click Export. An Export panel appears where you can choose a location on your Mac to store the attachments. Navigate to the directory you would like to use as the export destination, and click Export to save copies of the files to your drive.




		

Inbox, Items, and Actions


When you first start using OmniFocus, you might be thinking “Where do I start?”. The best place to go is your Inbox, since this is the place where you’ll do most of your initial work in OmniFocus.




The Inbox is the hub of all activity, and is the catch-all space for depositing just about everything that’s on your mind, no matter how big or small. The things that you’d like to do—tasks, to-dos, aspirations, plans, chores, life goals—all have a home in OmniFocus. You can throw any stray thought into your Inbox.



[image: As with Mail, OmniFocus’s Inbox is a general catch-all for any new items you create]


One of the best ways to get familiar with OmniFocus is to sit down and do a “brain dump” into your Inbox. Let OmniFocus be your “brain away from brain” for when you can’t remember that really important thing you need to do by next Monday.


Inbox Items


The things you create are placed in your Inbox, and are known as Inbox items. Some of these Inbox items are so simple that you can knock them off while they still reside in your Inbox. For example, let’s say you create an Inbox item to remind you to change the lightbulb in your workshop. That’s a simple enough task that you can do it at any time. 


This Inbox item doesn’t need to be part of the Household Chores project, and adding the Home context seems like overkill. Instead, you just leave this item in your Inbox as a constant reminder to yourself that you need to change the lightbulb in your workshop, especially before you plan to use any power tools.


Some items, though, are worth categorizing and providing fine details so that you have all the information you need at hand when you’re in a particular place or focusing on completing a particular project.


Actions


Most of the Inbox items you create ultimately end up as actions. This happens when you decide that an item is part of a larger goal—a Project—and you file it away with similar to-dos (more on this in the Projects and Contexts sections).


Each action has a Status Circle on its right edge for marking it complete. When you check an item as completed, it’s moved from the list of available items to the list of Completed items and becomes invisible under the default View options.




Once you’ve assigned an Inbox item to a project, it becomes an action that you can see in the Projects or Contexts views, or in any custom perspective you’ve assigned it to.


To edit the details of an action, select it and add data right in the main outline. You can also use the Inspector for even greater control.



[image: Actions can be edited in the main outline, or using the Inspector (at right)]


You can enrich the information you include with an action by adding Notes and attachments, such as images and audio recordings. You’ll find more information about these in Notes and Attachments. You can also set due dates, defer dates, and repeat intervals for actions—for the details, see Dates and Times.


Cleaning Up


When you mark an item complete by clicking its Status Circle, the item doesn’t immediately disappear. Rather, it appears checked off until you do something that tells OmniFocus to “clean up”, such as switching to the Projects or Contexts perspective. You can choose what causes OmniFocus to clean up automatically in the Organization preferences.


If you find that checked items are getting in your way (look at you, completing things!), you can either click the Clean Up button in the toolbar, or by using the Command-K keyboard shortcut.



Note

Fans of Terminal.app may recognize Command-K as the keyboard shortcut you use to clear the Terminal window’s view.






[image: Click the Clean Up icon in the toolbar to remove completed items from your view]


If a completed item doesn’t disappear even after you’ve cleaned up your current view, check View Options. It’s likely that the view is set to All. Try setting the View options to Remaining or Available to tidily hide those completed items.



[image: Use a perspective&#8217;s View Options to set the visibility of completed or overdue items]



Note

Clean Up hides certain items based on your View options, which is different from deleting them entirely. If you mark an action complete that belongs to a project or context you later want to delete, OmniFocus pops up an alert to warn you that the action you’re about to take will remove some of the hidden items unintentionally. To see the items you’ve completed, change the current perspective’s View options to All, or switch to the Completed perspective.






				





		

Archiving and Backup


When your database grows large, unwieldy, or full of obsolete items, or when you need to refer back to versions of your data from days gone by, the archiving and backup features of OmniFocus for Mac here here to lend a hand.




Creating an Archive


After a while of using OmniFocus every day, your database may become quite large, and especially if you synchronize with a mobile device, things could get quite slow. Most of the items are probably completed or dropped items that you rarely or never need to review, so OmniFocus includes a command to archive those old items to a different file, keeping your main database sprightly and nimble.


To archive your old data, choose Move Old Data to Archive from the File menu. A sheet appears with a date field; any items completed before that date, or dropped items that haven’t been changed since that date, will be moved to the archive.


OmniFocus saves your archive file in the same place as your main database.



	Omni store version: ~/Library/Containers/com.omnigroup.OmniFocus2/Data/Library/Application Support/OmniFocus/



	Mac App Store version: ~/Library/Containers/com.omnigroup.OmniFocus2.MacAppStore/Data/Library/Application Support/OmniFocus/





Where ~ is your home folder. If you ever want to look at your archived data, just choose Open Archive from the File menu; your archive opens in its own window.


To retrieve items from an archive you’re browsing, just drag and drop them into the desired location in your main database (copy and paste works too). In either case, a copy remains behind in the archives; the archived copy can be retained as a record or manually deleted to keep things tidy.


Restoring from a Backup


We’ve made OmniFocus err on the side of obsessive, paranoid data preservation, just in case something bad happens to your database. After all, we’re asking you to put your whole life into this app. OmniFocus automatically backs up your database once every two hours, in the folder:



	Omni store version: ~/Library/Containers/com.omnigroup.OmniFocus2/Data/Library/Application Support/OmniFocus/Backups/



	Mac App Store version: ~/Library/Containers/com.omnigroup.OmniFocus2.MacAppStore/Data/Library/Application Support/OmniFocus/Backups/





OmniFocus keeps up to 100 backups of your database at a time, which comes to about 2 weeks worth if you run OmniFocus continuously (more for most people, since a backup can’t happen if OmniFocus isn’t open).


To restore a backed-up version of your database, choose Show Backups from the File menu, then double-click to choose a backup file to view. It’ll open in its own separate OmniFocus window so you can browse it and determine if it’s the one you want; if so, choose Revert to this backup in the focus bar and it’ll replace your current database.


		



		

Managing Your Omni Licenses





Note

This chapter refers to licenses purchased from the Omni Store. If you bought OmniFocus from the Mac App Store, you can manage your purchase through the App Store app for OS X.





From the menu bar, choose OmniFocus > Licenses to see the Licenses dialog. From here you can review and edit your OmniFocus licenses, which verify that you’ve actually paid for the software. (Thanks!)


To purchase a license:



	Click Buy Licenses and you will find yourself magically transported to the Omni Store, where you can purchase a license for the Mac versions of our software. (Naturally, this only works if you have an Internet connection.)




To add a new license:



	From the menu bar, choose OmniFocus > Licenses to see the Licenses dialog.


	Click Add License.


	If you have a license key in an email message, copy and paste both the Owner name and the License Key into the appropriate fields. If you can’t copy and paste the information, you’ll have to type it in; make sure you enter everything exactly as it appears in your license message, including the dashes. Also, double-check that the license you’re entering really is a license for OmniFocus 2, and that it is for the correct edition (Pro or Standard); licenses for other Omni products or earlier versions of OmniFocus won’t work.


	The Type drop-down menu is grayed out by default, which limits the license type to Personal for the current user account on your Mac. OmniFocus has two different types of licenses:



	Personal: This license is for your personal use, and will only be available on this computer when you are logged in as the user who installed the license. You can install this license on more than one computer, but only for your personal use. You should not use the software on two different computers at the same time with this kind of license. If a personal license is available, the application will always use it.


	Computer: You can use this license on this computer, and so can any other user of this computer. However, you should not install this license on more computers than it has license seats for.





If there is more than one user account on your Mac, and you’d like everyone on your Mac to discover the awesomeness that is OmniFocus, you’ll need to jump through a couple of hoops. To set up a Computer license, follow these steps:



    	Quit OmniFocus 2.

    	Open a new Finder window.

    	Switch the Finder’s view settings to Column, by choosing View > as Columns (or use Command-3. This will make it easier for you to traverse the folder hierarchy on your Mac.

    	Choose Go > Computer.

    	Choose your Mac’s hard drive (if you haven’t renamed it, it should be named Macintosh HD), and then traverse through the following folders:
    
        	Library

        	Application Support

    

    

    	In the Application Support folder, create a new folder (choose File > New Folder, or use Shift-Command-N) and name it Omni Group. You will need to enter your admin password to create a new folder at this level.

    	In the Omni Group folder, create a new folder and name it Software Licenses.

    	Open OmniFocus 2 again, and then choose OmniFocus > Licenses.

    	Click Add License.





When you click Add License, you’ll notice that the Type drop-down menu is no longer grayed out, and the Computer option is available for selection. Now just enter the Owner and License Key information you received from us, click Save, and you should be set.







To remove a license:



	Select the license you want to remove.

	Click Delete License.




To move a license from one Mac to another:



	First, find the license file on the old computer. OmniFocus license files are located in the folder Library/Application Support/Omni Group/Software Licenses, where Library is either at the top level of your system disk (for computer licenses), or in your Home folder (for personal licenses). The file you are looking for has a name such as OmniFocus–123456.omnilicense. Move this file to the new computer.


	On the new computer, choose OmniFocus > Licenses from the menu bar and then click Add License.


	On the sheet that appears, click Import License File.


	Locate and select the license file that you want to import.


	Click Open. If the license file is compatible—meaning, it is for the same version of OmniFocus—the license will be added to OmniFocus on your other system.






Note

If you don’t see your license files in the location described in (1) above, another possible location for your Omni licenses is: Users/Username/Library/Containers/ com.omnigroup.OmniFocus2/Data/Library/ Application Support/Omni Group/Software Licenses.





Again, the thing to remember here is that license keys are version-specific; the license key you have for OmniFocus 1 is not compatible with OmniFocus 2 (and vice versa).

		




Copyright © 2008-2018 The Omni Group. All rights reserved.

OmniPlan, Omni Presence, Omni Sync Server, OmniGraffle, Graffle, OmniFocus, the OmniFocus icon/logo, and the Omni logo are trademarks of The Omni Group.




AirDrop, AirPrint, Apple, the Apple logo, Apple Watch, iBooks, iPad, iPhone, iPod touch, Mac, Multi-Touch, OS X, and Safari are trademarks of Apple Inc., registered in the U.S. and other countries. iBooks Store is a registered service mark of Apple Inc., registered in the U.S. and other countries.




IOS is a trademark or registered trademark of Cisco in the U.S. and other countries and is used under license.




EPUB is a registered trademark of the IDPF.





		

Review


Reviewing is a good way to make sure all of the projects in your library are in good shape and are ready for you to take action. If you have projects that need more actions added to them, or projects that aren’t relevant anymore, or projects you don’t mean to do any time soon, following a regular review process can help you keep them from falling through the cracks.




Each project has an interval for how often you intend to review it and a date when the next review is planned. You can change the default review interval in OmniFocus ▸ Preferences ▸ Dates & Times, and you can change the review interval and next review date of individual projects with the inspector.



[image: Use the Dates &#38; Times preference to adjust how frequently you plan to review your projects]



[image: You can also use the Review inspector to adjust how frequently you plan to review your projects]



Tip

To change the review interval and next review date of multiple projects at once, select them in the sidebar or main outline and edit the corresponding fields in the inspector.





To review your remaining projects:



	Choose the Review perspective in the sidebar (there’s also a corresponding button you can add to your toolbar, if you like). In this view, your remaining projects are grouped in order of their next-scheduled review date.


	For each project, check whether it is in the proper state (Active, On Hold, Completed, or Dropped). Do you need to revise its actions, or add new ones? Should you put the project On Hold, drop it, or mark it as Completed? Or is everything moving along just fine?



[image: When reviewing your projects, be sure to look at every tiny detail to help keep you on track]



	Once you’re satisfied with the state of the project, select it. You’ll see that some review-specific handy controls appear at the top of the main outline—click Mark Reviewed, choose Edit ▸ Mark Reviewed, or Control-click and choose Mark Reviewed from the contextual menu. The project’s next review date moves forward and you can go on to review another project.



[image: When reviewing, OmniFocus places a bar above the outline that includes a Mark Reviewed button]






Common results after reviewing your projects include:



	Determining that it’s on course with no changes required; or,

	Adding, removing, rearranging or completing actions within the project to adapt to changes in circumstance since the last review.




You may also find you’re able to mark a project as Completed (huzzah!), decide that now’s not the time to be working on it and put it On Hold, or realize that it’s something you won’t be acting on for the foreseeable future and mark it as Dropped. For more on changing a project’s status, see the Projects chapter.

		



		

Preferences



Preferences in OmniFocus govern ways the app behaves on its own and how you interact with it, and can be customized to suit your needs and workflow. Choose Preferences from the OmniFocus menu, or use the keyboard shortcut (⌘,) to open the Preferences window.





General


The General tab of the Preferences window includes settings for common interactions you’ll have with OmniFocus.





[image: OmniFocus 2 for Mac General Preferences.]



	Outlining


Users of OmniFocus 1 will be familiar with “Classic Mode” outlining, governing the behavior of common keyboard actions when items in the main outline are selected. OmniFocus 2 brings an alternative mode, and you can switch between them here.


	Capture


Set a custom keyboard shortcut for Quick Entry here (the default is Control-Option-Space). Use the Clippings Shortcut button to open System Preferences and set up your system-wide keyboard shortcut for Clippings (more info is available in the Clippings section).






Organization


The Organization tab of the Preferences window includes settings for keeping your database views tidy, and defaults affecting how projects and perspectives are organized.





[image: OmniFocus 2 for Mac Organization Preferences.]



	Clean up inbox items which have:


You can choose Organize ▸ Clean Up (Command-K) to help keep your view tidy by moving items with changed status or metadata to their correct locations. This preference governs which changes to an item’s data cause it to be swept up in the cleanup process.


	Clean up items completed on this Mac:


If you’d prefer that items be cleaned up as soon as they are marked complete, choose Immediately. Otherwise, completed items will be cleaned up when you switch between perspectives or when you invoke a cleanup manually.


	New projects and action groups are:


Choose Sequential if you tend to create projects whose actions must be completed in a specific order, or choose Parallel if your projects and groups are often closer to basic lists.


	In perspectives without project hierarchy:


If you’d prefer to display items completely detached from the projects or groups they belong to when you’re looking at Contexts or a custom perspective without project hierarchy, uncheck the box for this preference.






Note

Sometimes after cleaning up, a project named Miscellaneous will appear in your Projects perspective. What’s up with that?


The Miscellaneous project is a single action list that OmniFocus automatically creates whenever items are cleaned up that don’t have a project assigned. Since removing items from the inbox requires that they be assigned a project, if your clean up preferences are context-based the Miscellaneous project becomes their home until you assign them another.


Since the Miscellaneous project is automatically created by the app based on how you’ve chosen for clean up to work, it can’t be permanently removed; if you’d prefer not to use it, try cleaning up based on project assignment instead.





	In the Projects perspective:


Choose Show Inbox to display the Inbox as the first item in your Projects list (unlike other items, this one cannot be reordered in the list). This option is available for convenience of interaction between your Inbox and Projects perspectives, and does not otherwise change the behavior of the Inbox.








Layout


The Layout tab of Preferences controls how data is displayed in OmniFocus’s main outline.





[image: OmniFocus 2 for Mac Layout Preferences.]



	Fluid


The fluid layout option is the classic OmniFocus 2 layout, displaying information related to items in your OmniFocus database in a row beneath the item title.




	Custom Columns


The custom columns option provides configurable presentation of your data based on just what’s relevant to you. Data is displayed in columns on the same line as item titles, and these columns can be selectively shown or hidden with the check boxes in this section.







With OmniFocus Pro, you can use individual perspectives’ View options (or the Perspectives Editor) to choose whether Layout preferences affect that particular perspective. If you like, you can also customize individual perspectives’ column layouts to only show the data most relevant to the perspective.



[image: Additional view options available in OmniFocus Pro for custom columns individually tailored to each perspective.]







Style


The Style pane of Preferences controls the fonts and colors used throughout OmniFocus.





[image: OmniFocus 2 for Mac Style Preferences.]



	Font collection


Choose the font package that applies to text in views on your OmniFocus database. Proxima Nova is the default sans serif collection; Georgia is included as an alternative with serifs, as is the System Font (San Francisco).


The slider beneath the selection menu offers scaling font size for easy readability or higher data density.




	Color palette


Choose a themed set of colors to apply to your OmniFocus interface. Two styles (OmniFocus Light and OmniFocus Dark) are included by default.




	Sharing


Choose Import Style to bring custom .ofocus-style themes into OmniFocus, where they will be added to the dropdown font collection and color palette menus where appropriate.


Choose Export Current Style to create an .ofocus-style file representing the currently selected font collection, color palette, or both. This file can be used as a base for custom edits, or imported to add additional user-created themes to OmniFocus.







Note

Modifying OmniFocus themes requires some coding knowledge and isn't part of the core OmniFocus experience. We've created a support article for anyone interested in exploring under the hood, but we're unable to provide direct support for the myriad of custom states possible when altering existing themes.






Dates & Times


OmniFocus starts with an educated guess at some default parameters for what it means for items to be due, due soon, and deferred, as well as an interval for project reviews. You can change these settings in the Dates & Times pane of Preferences.





[image: OmniFocus 2 for Mac Dates & Times Preferences.]



	“Due Soon” is in the next:


OmniFocus displays actions and projects that are due soon with an amber title and status circle. What “due soon” means is up to you—the default is two days away from the present, but you can pick a different value here.


	Default time for defer dates:


When you create an action or project with a “deferred until” date but no specific time, OmniFocus helpfully provides one for you. Use this preference to pick a default time for defer dates that most suits your needs.


	Default time for due dates:


As with the previous preference, you have free reign over the time that your actions and projects come due by default (when only a date is assigned).


	By default, review projects every:


While you can set custom review intervals for specific projects, it’s good to have a default setting for when you’d like to review new schemes that you’ve added to OmniFocus. This preference governs when and how often projects will show up in your Review queue by default.







Notifications


OmniFocus can operate in complete stealth mode, or it can alert you each and every time an action is due. The Notifications pane of Preferences holds settings for fine-grained control over when and how the app tells you what’s up next.





[image: OmniFocus 2 for Mac Notifications Preferences.]



	Show reminders:


How visibly do you want OmniFocus remind about items you’ve decided are relevant? This preference adds some visual oomph to let you know what’s going on, by:



	Badging the OmniFocus icon in your dock with a number equal to the items you’ve chosen to be reminded about (based on the Remind about section below).


	Equipping the OmniFocus sidebar with badges displaying due soon and overdue items in projects and contexts (for any perspective that displays them).


	Sending notifications to Apple’s OS X notification center to appear as you’ve configured System Notifications to behave (notifications are sent based on your choices in Remind about below).





	Highlight perspectives:


When there are items asking for your attention in one of the built-in perspectives, OmniFocus can give you a subtle reminder by adding a colored bar to the left edge of the perspective’s tab. Use this preference to choose which perspectives can be highlighted when something relevant comes up.



	Remind about:


Use this preference to choose the types of events you’d like to be alerted to. (this choice is applicable to the badge count in your OmniFocus dock icon and the notifications sent to Notification Center).


You can choose to be reminded about items that are overdue, due soon, or flagged.



	Show in Today:


With the Today extension turned on, you can fine-tune the list of items you see when you look at Today in Notification Center. Control your workflow by choosing one or more criteria for actions that appear in Today. Items that can be shown include Overdue, Due Today (the default), Deferred Until Today, Flagged, and Inbox Items.








With OmniFocus Pro, you also have the option of choosing a custom perspective to display in Notification Center via the Today extension. Choosing Show a Custom Perspective reveals a dropdown menu from which you can pick the existing custom perspective that you’d like to display.



[image: Choosing a Custom Perspective to display with the OmniFocus Today extension in Notifications Preferences.]






	Publish due items as calendar alarms:


If you’d like to be notified about due items on a device without OmniFocus but with the ability to subscribe to calendars, you can set up OmniFocus to publish a calendar to your database’s sync server location that you can then subscribe to in any app that supports iCalendar files with an ‘.ics’ extension.


Upon choosing a setting other than Off, a calendar containing alarms corresponding to the due dates of your actions and projects will be created in the same remote sync folder that contains your database. This may take a little while; you can verify that it’s in place (or subscribe to the calendar on your Mac) by clicking Subscribe. The address that appears is the one you’ll want to use when subscribing from other devices as well.






Warning

When choosing a location to store a subscribed calendar, you may see iCloud as an available location (this is the default location in OS X’s Calendar app, for example). Storing a calendar in iCloud that syncs with your OmniFocus database can lead to some annoying and repetitive password prompts, so we recommend storing it locally on the device where you’d like to receive the alerts instead.






Note

When OmniFocus publishes due items as calendar alerts, it looks for actions and projects that are due within the next two weeks and no further. This is to prevent inaccuracies based on predictions of future activity from creeping in to your calendars. For important occasions outside of this timeframe, scheduling regular calendar events is advised. 






Warning

The OmniFocus 2.6 Mac/2.15 iOS updates bring a new, more secure database format to OmniFocus. After migrating to the new format, if you're set up to publish due items as calendar alarms, a portion of your data corresponding to the two weeks noted above will be unencrypted while stored as part of the .ics file on the sync server.






Synchronization


As explained in Getting Synced, establishing a cloud-connected copy of your database is a great way to keep OmniFocus in harmony across all your devices. The Synchronization pane of Preferences has the options you need to set up your sync account.





[image: OmniFocus 2 for Mac Synchronization Preferences.]



	Don’t Sync


This setting isn’t recommended, but if you plan to use OmniFocus exclusively on your Mac and syncing to a remote server is prohibitive, you can choose to disable OmniFocus’s sync features. In all other cases, having a cloud-based copy of your data is a great way to rest at ease that your work won’t be lost in a local catastrophe.


	Omni Sync Server


Omni maintains a set of servers designed to interface cleanly with OmniFocus, providing unique features like Mail Drop and support for your needs as an OmniFocus user. We recommend this as the best sync solution for most users, since it’s the one we can provide the most support for; it also happens to be free!





	Advanced (WebDAV)


If you choose to entrust your data with the Omni Sync Server, we’ll treat it with utmost care and responsibility (see our Terms of Service and Privacy Policy). That said, if you have exceptional security needs or other privacy concerns, you may want to use a third party WebDAV server (or set up your own). That’s great! Find out more about syncing to a custom WebDAV server in Other WebDAV Options.





When you’ve chosen a sync preference, a field appears beneath the sync choices for entering the server address. You can sync immediately with the Sync Now button, and view a list of devices registered to sync with the chosen database by clicking the gear button. Choose Send Settings via Email to create a handy message that’ll help configure sync on your other devices.



With OmniFocus sync set up on your Mac, choose Show Sync Details... for advanced information about the connected sync account, including:
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A list of Devices currently syncing to the account. Selecting a device shows how recently it synced to your OmniFocus database, and provides the option to unregister it as an approved sync client.



	Push-triggered sync options, with push enabled by default. Technical details of your push connection are shown here, along with advanced options (primarily used for troubleshooting). The Learn More link connects to a support article with details on how push works, and why even the most data security-conscious users will likely want to leave it enabled.


	A sync Log with a list of all your recent OmniFocus database sync activity, and the reasons for each sync event along with their durations. If anything seems strange here, you can copy the log for use when contacting Omni support.


	Details about the Encryption status of your data on the sync server. With OmniFocus 2.6 for Mac and later (and OmniFocus 2.15 for iOS and later), OmniFocus uses an upgraded database format that encrypts your data on the server. Verify the encryption status of your sync data here, and (optionally) set up a separate passphrase for decrypting your database.








Update


OmniFocus can operate completely offline without a problem, but if you’d like the security of automatic updates you can set them up here in the Update pane of Preferences. There’s also the option to help Omni improve future versions of OmniFocus by sending us anonymous data about your Mac.





[image: OmniFocus 2 for Mac Update Preferences.]



	Check for updates (Omni Store Only):


OmniFocus is naturally curious about when updates are available for itself. If you’d prefer for the app not to check for updates automatically, uncheck the box for this preference; otherwise, you can choose an interval that suits you best (it’s not a very intrusive or bandwidth-heavy process). You can check for updates manually using the Check Now button, or with Check for Updates in the OmniFocus menu.


	Send anonymous system information to The Omni Group


If you’d like to help us improve future versions of OmniFocus for you and others, you can choose to send us anonymous information about your system when you check for updates to the app. Click Learn more about what kind of information is sent to see a list of exactly what info is collected, and learn how it’s used.




		





		

Perspectives


When you look at a representation of your collected items in an OmniFocus window, you’re looking at a perspective on your data. OmniFocus comes with a bunch of built-in perspectives that have been painstakingly designed to help you get the most out of your OmniFocus experience. These include:





	Inbox

	Projects

	Contexts

	Forecast

	Flagged

	Review

	Completed

	Changed




The first six of these form the foundation of interacting with OmniFocus, and offer tons of power and flexibility for accomplishing things in ways that suit your needs.


The final two standard perspectives—Completed and Changed—are transient views that appear temporarily in your sidebar when chosen from the Perspectives menu and are a great way to find items in your database that may have been filed away by mistake or otherwise disappeared under mysterious circumstances.


Once you’ve been exploring OmniFocus for a while you may find there are even more specialized ways that you’d like to view your tasks, whether through a specific search term, a group of projects in your sidebar, or a special sort criteria you’d like to apply to actions in a single action list. Or maybe there’s a specific productivity method you’d like to try that the default perspectives don’t fully support.




In OmniFocus Pro, you can create custom perspectives that reflect ways of setting up your OmniFocus window that you want to come back to again and again. Upgrading to Pro provides access to the Perspectives window (Perspectives ▸ Show Perspectives, or Control-Command-P), a powerful tool for organizing and customizing your perspectives to suit your unique workflow.



[image: Use the Perspectives window to create and edit perspectives]


The Perspectives window has two main sections: the Perspectives List on the left, where you’ll edit the names, order, and sidebar visibility of your perspectives, and the Perspectives Editor on the right, where you can configure a wide range of view attributes for each perspective.


Perspectives List


The perspectives list shows a list of your perspectives (imagine that!). You’ll notice that some are accompanied by lit stars on the right—these are designated as persistently visible in the perspective tabs in the sidebar, including the six default perspectives.



[image: The Perspectives List]


The new perspectives that you create won’t have a keyboard shortcut (but you can set one) and they’ll be unstarred. You can make these perspectives persistent by toggling the star to its lit state. Likewise, unstarring one of the built-in perspectives removes it from the sidebar.


Unstarred perspectives are still accessible by double-clicking the perspective’s name in the perspectives list, or choosing it from the Perspectives menu; a perspective opened this way appears in the sidebar while you’re viewing it, and disappears when you navigate away.


In addition to toggling perspectives’ persistent visibility in the sidebar, you can also reorder perspectives using the perspectives list. Want Forecast to show up before Projects? Just click and drag it up above the Projects perspective.



[image: Reordering of perspectives]


To delete a perspective, select it in the list and then choose Delete Perspective from the gear menu in the bottom bar.



[image: Deleting a custom perspective]



Note

If you find that a built-in perspective has gotten completely out of control, you can use Revert Perspective to Default Settings in the gear menu to bring it back to factory-sealed condition.





Using the Perspectives Editor


The perspectives editor enables you to customize your perspectives’ view settings in nigh-countless ways (these settings are also available from View Options in the toolbar when viewing the perspective in the main outline).



[image: The Perspectives Editor]


Here is a rundown of what all of its bits and bobs are for:



	Icon—Click the arrow in the corner to choose from among a bunch of custom icons to represent your perspective, or add your own—just drag an image from outside OmniFocus onto the perspective icon, or add one with Choose File. Transparent PNGs are recommended. 


	Name—Edit the name of your custom perspective here.



Note

The built-in perspective names—Inbox, Projects, Contexts, Forecast, Flagged, Review, Completed, and Changed—cannot be edited. You can, however, choose another icon for the Completed and Changed perspectives.






	Shortcut Recorder—Beneath the icon area is a place for you to assign a keyboard shortcut to the selected perspective. Just click in the field, and then press the keys for the keyboard shortcut you want to use. You can choose any shortcut as long as it contains the Command or Control key, in conjunction with another key. (You can also use a function key if you’d rather not use Command or Control.)


	Project Hierarchy—There are two fundamental types of perspectives: those that rely on the project structure to display your database hierarchically, and those that eschew hierarchy in favor of grouping by other parameters. The grouping and sorting functions in Presentation will govern projects in the former case, and actions in the latter.


	Presentation—If you’d like to group or sort projects or actions based on specific criteria, select them here. You can also choose to have the perspective open in a new window when it’s called upon from the Perspectives menu or the perspectives list.


	Layout—If your perspective uses particular data fields to the exclusion of others, setting up a layout of custom columns for can provide more visual efficiency. The fluid layout is OmniFocus 2’s classic default, or you can choose to use your app-wide Layout preferences for the perspective.


	Filtering—Granular options for filtering what appears in the perspective are available here, including filtering based on flagged status, availability, duration, project or context status (based on the mode chosen in Project Hierarchy), or based on a text search.


	Focus—To save a focus on a project or folder as part of the perspective, choose it from the dropdown menu here.


	Sidebar Selection—For selections in the sidebar that you’d like to have displayed in the main outline every time you open the perspective, choose the items in the sidebar that you want and then click Add Current Sidebar Selection. Click the X next to items that appear beneath to remove them from your selection.





If there is a particular arrangement of folders that you’d like to preserve as part of your custom perspective, you can save a set of folder expansion states as follows:



	Open the perspective you would like to customize.

	Open and close folders until they’re in the desired expansion states (or choose View ▸ Expand All/Collapse All to make changes en masse).

	When the folders are set the way you like, click the View button in the toolbar and choose Save.

	Your folder expansion state is now saved along with the other settings for the perspective.






Tip

If you’d like to create a variant of a currently existing custom perspective, select the original in the perspectives list and choose Edit ▸ Duplicate to add an identical copy.







		




		

Menus and Keyboard Shortcuts


This chapter explains the function of each of the items found in OmniFocus’s drop-down menus, and lists default keyboard shortcuts for them where they exist.





OmniFocus Menu


The OmniFocus menu holds commands related specifically to the administration of the OmniFocus application itself. Check for updates, view and modify your preferences, and enter new license information here.





	About OmniFocus


Find out some details about your copy of OmniFocus. This is good for checking exactly which version you’re using. 



	Check for Updates (Omni Store Only)


See if there is a new version of OmniFocus available to download. You can also set up automatic checking in the Update preferences.



	Preferences (Command-,)


Open the OmniFocus preferences window, where you can customize how the application works for you.



	Licenses (Omni Store Only)


Open the Licenses window, where you can add OmniFocus licenses you’ve bought, or check your existing licenses.


	Free Trial Mode


If you’re running a trial version of OmniFocus, these commands switch between the Pro and Standard versions of the app so you can compare features.




	Services


Access system-wide Mac OS X services offered by other applications.



	Hide OmniFocus (Command-H)


Temporarily hide all of OmniFocus’s windows.



	Hide Others (Option-Command-H)


Temporarily hide windows of all other applications so you can concentrate on OmniFocus.



	Show All


Show all windows of all applications.



	Quit OmniFocus (Command-Q)


Stop using OmniFocus and put it away for now. Your database is automatically saved.



	Upgrade to Pro (Mac App Store Only)


Open the in-app purchase dialog to unlock the Pro features of OmniFocus 2.






File Menu


The File menu contains commands related to OmniFocus on a database level. Add new items or Quick Open others; importing, exporting, archiving, and restoring your database also happen here.





	New Action (Command-N)


Create a new action in the currently selected project, or create a new item in the inbox.



	New Project (Shift-Command-N)


Create a new project in Projects or in a perspective that uses project-based hierarchy.



	New Folder


Create a new folder for organizing projects.



	New Single-Action List


Create a new list for keeping track of individual actions that don’t fit into projects.



	New Context (Control-Command-N)


Create a new context in Contexts or in a perspective that doesn’t use project-based hierarchy.



	New Window (Option-Command-N)


Open a new window just like the frontmost one.



	New Tab (Option-Command-T)


Open a new tab in the current window, displaying the same content as the current tab.



	Quick Open (Command-O)


Open the Quick Open dialog to seek out and display a specific perspective, folder, project, or context in your database.



	Close (Command-W)


Close the frontmost window. Even if you close the last remaining OmniFocus window, you can always just open a new one.



	Import OmniOutliner Document


Import the content of an OmniOutliner (.oo3) document to your OmniFocus database, with its rows converted to OmniFocus items and columns to metadata fields associated with those items.



	Export


Export your OmniFocus database in a variety of formats.


	Synchronize with Server Command-S


If you have set up synchronization in the Sync preferences, coordinate with the server database and make sure that both sides have all of the recent changes you’ve made.



	Replace Server Database


Replace the version of your database stored on the sync server with the one stored on your Mac. This the tool to use when you encounter a sync conflict and you’re sure that the version of your database you have now is the one you want going forward.



	Show Backups


If you run into trouble with your OmniFocus database, you can always go back to an older, backed up version. With this command you can browse to the backup file you want, then open and inspect it. If it looks good, click Revert to this backup in the focus bar and your entire database is reverted to how it looked at the time you made the backup.



	Rebuild Database


Analyze and consolidate all of the entries in your OmniFocus database to make sure they are consistent. This is essentially equivalent to backing up and then restoring your database. If you are having problems with your database, this may help.



	Compact Database


Take the database changes OmniFocus has logged and condense them. If OmniFocus doesn’t feel as fast as it used to, this may help.



	Move Old Data to Archive


Store away some of your completed or dropped items in an archive, thus keeping your database slim and making OmniFocus faster.



	Open Archive


See the old data you’ve archived.



	Page Setup (Shift-Command-P)


Open the standard OS X Page Setup window, where you can change some settings for printing (or exporting to a PDF file). These settings are saved even if you quit OmniFocus.



	Print (Command-P)


Open the standard OS X Print window, with a variety of options for printing (or creating a PDF file).






Edit Menu


The Edit menu holds commands related to modifying the contents of actions, projects, contexts, and groups. Cut, Copy, Paste, and Undo are all found here.





	Undo (Command-Z)


Reverse the most recent change you made. You can keep stepping backwards like this if there are more changes you want to undo.



	Redo (Shift-Command-Z)


Reenact the last change you undid. You can keep stepping forward through however many Undo commands you made.



	Cut (Command-X)


Remove the selected text or items, putting them on the clipboard so you can paste them somewhere.



	Copy (Command-C)


Put a copy of the selected text or items on the clipboard, so you can paste them somewhere.



	Copy As Link


Put a link to the selected items on the clipboard; when you paste it, you get an address for each item.



	Copy As TaskPaper


Copy the selected items with the tag syntax used by Hog Bay Software’s TaskPaper to-do list app.


See Copy as Taskpaper for a list of supported tags and further details on the feature.




	Paste (Command-V)


Take whatever’s on the clipboard and insert it at the current selection. If the clipboard contains just text (not whole items), and you are editing the text of an item, the text is pasted at the insertion point. Otherwise, the contents of the clipboard are pasted as new items.



	Paste and Match Style (Option-Shift-Command-V)


Ignore any styles on the text you’re pasting and just use the style already there at the place you’re pasting into. Of course, this only makes a difference in notes, since that’s the only place where you can have special styles anyway.



	Delete


Remove the selected item(s) or text from your database.



	Select All (Command-A)


Select everything in the outline, or if you are editing an
item’s text, all text in the cell.



	Deselect All (Shift-Command-A)


Clear the selection completely so that nothing is selected.



	Duplicate (Command-D)


Make another item just like the selected one, immediately after it.



	Edit Note (Command-’)


Move from the item text to the note area of an item, or move back from the note area to the item text.



	Convert to Project (Command-!)



	Status


Choose from this submenu to change the status for the selected project (Active, On Hold, Completed, or Dropped).



	Mark Reviewed (Shift-Command-R)


Indicate that you’ve reviewed the selected project, thus resetting its next-review date.



	Set/Clear Flag (Shift-Command-L)


Put flags on the selected items, or remove the flags if the selected items already have them.



	Attach File


Choose a file to insert in the note area of the selected
item.



	Add/Edit Link


Create or edit a hyperlink to an item within OmniFocus, or beyond. 



	Insert Time Stamp


Automatically type the current date or time, as defined by the Short Date, Long Date, and Time formats set up in System Preferences’ Language & Region pane.



	Short Date


	Short Date and Time


	Time


	Long Date


	Long Date and Time






	Find


This submenu contains the standard Find commands included in many Mac OS X applications: Find (which opens a window where you can use regular expressions and search-and-replace), Find Next, Find Previous, Use Selection for Find (which enters the selected text as the text to search for), and Jump to Selection.



	Go to Search Field (Option-Command-F)


	Find (Command-F)


	Find Next (Command-G)


	Find Previous (Shift-Command-G)


	Use Selection for Find (Command-E)


	Jump to Selection (Command-J)






	Spelling


This submenu contains the standard Spelling commands for the Mac OS X spell checking system: Spelling (which opens the Spelling window), Check Spelling (which checks spelling in the document once), and Check Spelling While Typing (which turns the automatic spell checking on or off).



	Show/Hide Spelling and Grammar (Command-:)


	Check Spelling (Command-;)


	Check Spelling While Typing





	Speech


This submenu contains the Start Speaking and Stop Speaking commands, which you can use to make the Mac OS X text-to- speech system say the selected text out loud.



	Start Speaking


	Stop Speaking





	Transformations


This submenu contains commands that apply to selected text in the outline, sidebar, and inspector, to convert it to completely upper case, lowercase, or capitalize each selected word, respectively.



	Make Upper Case


	Make Lower Case


	Capitalize





	Start Dictation (fn fn)


With dictation enabled in  ▸ System Preferences ▸ Dictation & Speech, select an editable text field and use this command to enter text via the spoken word.



	Special Characters (Control-Command-Space)


Open the Mac OS X Character Palette, where you can find characters not easily accessible from the keyboard, like ♆
and ☺.






Organize Menu


The Organize menu is for commands that manipulate items in your database based on their hierarchical position. This is primarily useful when working with nested projects and groups.





	Clean Up (Command-K)


Make OmniFocus tidy up after itself, so that all items obey your view settings. Also, take any inbox items you’ve assigned projects or contexts to and move them to where they belong in your library.



	Add Inside (Shift-Command-])


Create a new item belonging to the selected item; for instance if you have a project selected, this adds an action to the project.



	Add Outside (Shift-Command-[)


Create a new item at the same level as the selected item’s parent; for instance if you have an action selected at the top level of a project, this creates a new project.



	Move


These commands rearrange the currently selected item in the outline hierarchy without affecting deselected items. Move Up and Move Down change an item’s location in relation to its siblings. Move Right and Move Left increase or decrease an item’s indentation level. When items move, their descendants move with them.



	Move Down (Control-Command-Down Arrow)


	Move Right (Control-Command-Right Arrow)


	Move Up (Control-Command-Up Arrow)


	Move Left (Control-Command-Left Arrow)






	Indent (Command-])


Move the selected item to the right, turning it into a child of the item before it in the outline.



	Outdent (Command-[)


Move the selected item to the left, making it a sibling of what was its parent. This doesn’t change the location of the item’s former siblings; only the selected item’s position in the hierarchy is affected.



	Group (Option-Command-G)


In the sidebar, group projects into folders or group contexts into supercontexts. In the main outline, group actions into projects or action groups.



	Ungroup (Option-Command-U)


Move all of the child items out of the selected item, and get rid of the selected item completely.



	Sort Once


Using one of the parameters in this submenu, perform a one-time sort of the selected items in the sidebar or the main outline (as long as you’ve selected something that can be reordered).



	By Name


	By Status


	By Date Added


	By Date Completed


	By Date Due


	By Defer Date









View Menu


The View menu contains options for configuring your database view on the fly. Show and hide various parts of the interface, and expand or collapse the details of items in the main outline here.





	Expand All (Control-Command-9)


Show all descendants of all currently collapsed items in the sidebar or the main outline.



	Collapse All (Control-Command-0)


Collapse everything in the sidebar or the main outline to the top level only.



	Expand Item (Command-9)


Show the children of the selected items.



	Collapse Item (Command-0)


Hide the children of the selected items.



	Show/Hide All Notes (Control-Command-’)


Show or hide all note areas with content.



	Show/Hide Note (Option-Command-’)


Show or hide the note of the selected item.



	Show Full Item Title Always/When Selected


Choosing When Selected from the submenu causes items with long titles to end with ellipses (...) rather than wrap to a new line when those items are not selected. Otherwise, the full item title will always be shown.



	(PRO) Focus on Selected Projects/Unfocus (Shift-Command-F)


Focus on the selected projects or folders; that is, make OmniFocus temporarily act like those items are the only things in your whole database. Or, stop focusing and go back to being able to see everything in your database.



	Show in Projects/Contexts (Option-Command-R)


Switch to either Projects Contexts and select the same items you have selected in the current perspective. This is handy for, say, switching from Contexts to Projects for a moment to examine the project that an action belongs to. Other methods of switching the mode don’t preserve your selection.



	Show/Hide Sidebar (Option-Command-S)


Show the sidebar complete with perspective tabs, or hide it away.



	Show/Hide Inspector (Option-Command-I)


Summon up the inspector, or put it away.



	Go to Sidebar (Option-Command-1)


This and the following two commands are menu items that you likely won’t ever need to click; the idea is just to give you a keyboard shortcut for going back and forth between the sidebar, the main outline, and the inspector without having to touch that dreadful rodent.



	Go to Outline (Option-Command-2)


Switch to navigate the main outline (tab, return, esc, etc. affect items and fields in the outline).



	Go to Inspector (Option-Command-3)


Switch to navigate the inspector (tab, return, esc, and so on affect fields in the inspector).



	Show/Hide View Options (Shift-Command-V)


Open the View options for the current perspective.



	Show/Hide Toolbar


Show or hide the toolbar. Awesome!



	Customize Toolbar


Choose which controls appear in the main window’s toolbar.



	Enter/Exit Full Screen (Control-Command-F)


View OmniFocus at the glorious full dimensions of your screen, or return it to a modest window.






Perspectives Menu


The Perspectives menu holds commands for quick navigation to all things related to both the default, built-in perspectives and the custom perspectives available in OmniFocus Pro. Keyboard shortcuts assigned to custom perspectives appear in this menu as well.





	(PRO) Show Perspectives (Control-Command-P)


Summon or dismiss the Perspectives window, where you can manage your custom perspectives.


	(PRO) Add Perspective


Open the Perspectives window with a new perspective created in the list, ready to be named and customized to your heart’s content.


	Inbox (Command-1)


Open the built-in Inbox perspective in the current OmniFocus window.


	Projects (Command-2)


Open the built-in Projects perspective in the current OmniFocus window. 


	Contexts (Command-3)


Open the built-in Contexts perspective in the current OmniFocus window.


	Forecast (Command-4)


Open the built-in Forecast perspective in the current OmniFocus window.


	Flagged (Command-5)


Open the built-in Flagged perspective in the current OmniFocus window.


	Review (Command-6)


Open the built-in Review perspective in the current OmniFocus window.


	Completed


Open the built-in Completed perspective in the current OmniFocus window to view your completed actions and projects. Unlike other built-in perspectives, Completed doesn’t stick around in your sidebar when you switch away from it; choose this menu item again to reopen it.


	Changed


Open the built-in Changed perspective in the current OmniFocus window to view recent changes you’ve made. Unlike other built-in perspectives, Changed doesn’t stick around in your sidebar when you switch away from it; choose this menu item again to reopen it.






Note (Pro)

At the end of the Perspectives menu is a list of all of your custom perspectives; choose one to switch the front window to it.






Format Menu


Styling of note text in OmniFocus is the domain of the Format menu, with options available for all common text styles you’re familiar with in OS X.




Formatting commands are only applicable in note fields.



	Copy Style (Option-Command-C)


Copy the style of the selected text, so that you can apply it elsewhere with the Paste Style command. This uses a special style clipboard, so you don’t lose the data in the normal clipboard.



	Paste Style (Option-Command-V)


Apply the style in the style clipboard (obtained using the Copy Style command) to the selected text.



	Clear Style (Control-Command-Delete)


Remove all styling from the selected text, thus reverting it to the default style. This is useful for getting rid of weird styles in notes that you pasted from other applications.



	Show/Hide Fonts (Command-T)


Show and hide the Fonts window.



	Show/Hide Colors (Shift-Command-C)


Show and hide the Colors window.


	Bold (Command-B)


Embolden the selected text.


	Italic (Command-I)


Italicize the selected text.


	Underline (Command-U)


Underline the selected text.


	Bigger (Command-+)


Increase the size of the selected text.


	Smaller (Command-–)


Decrease the size of the selected text.






Window Menu


When you have multiple database windows open in OmniFocus, use the Window menu to choose between them. This menu also access Quick Entry and the Attachment List, two of OmniFocus’s specialized window types.





	Minimize Window (Command-M)


Shrink the frontmost window down into the Dock.


	Zoom


Switch the frontmost window between the biggest size possible and the last size you set.


	Show/Hide Quick Entry


Show or hide the Quick Entry window; note that you can customize a keyboard shortcut for this, and use the shortcut from within any application.


	Attachment List


Open a list of all attachments in your database.


	Bring All to Front


Get all of the OmniFocus windows up in front of other applications’ windows.





At the bottom of the Window menu is a list of all of your OmniFocus windows; choose one to bring it to the front.



Help Menu


Access a variety of support resources using the Help menu in OmniFocus, including this documentation, release notes, and contact with our friendly Support Humans.





	Search


Filter commands across all of OmniFocus’s menus to find and select a specific command.


	OmniFocus Help


View the help documentation available in the in-app help viewer.


	Keyboard Commands


Open a PDF document containing a list of useful OmniFocus keyboard shortcuts.


	Release Notes


Check out what’s new since the last version of OmniFocus.


	OmniFocus Product Page


Visit the OmniFocus page on the Omni Group web site.


	OmniFocus Forums


Stop by the official OmniFocus forums to view and share insights with other users.


	(PRO) Open Scripts Folder


Open the designated Finder folder for stashing AppleScript scripts that you want to access from the toolbar.


	Add Tutorial Project


When you first launch OmniFocus a sample project is added to your database to help you get started. If you want it back, choose this command to recreate it (it’ll be added to your existing projects non-destructively).


	Anonymize Database


Create a copy of your current database with all identifying text and attachments converted to anonymous entities. This is useful for exchanges with Omni support, or for sharing your database with other OmniFocus users without divulging the details of your private goings-on.


	Contact Omni


Compose an email to the OmniFocus support team. We’d be happy to give advice, answer questions, or just listen to your feedback.






Tip

If you’d like to set up a keyboard shortcut for a menu item that doesn’t have one, open OS X System Preferences > Keyboard and choose the Shortcuts tab. Pick App Shortcuts from the list on the left, then press the plus button beneath.


Choose OmniFocus.app from the Application drop down list that appears, then enter the exact text of the menu command you’d like a shortcut for in the Menu Title field. Put your cursor in the Keyboard Shortcut field, then press the key combination you want for the shortcut. Finally, click Add to save your new custom shortcut.


Return to OmniFocus and give it a try!




		



		

Guided Tour


After you’ve set up your sync preferences and on subsequent launches of the app, you’ll be presented with an OmniFocus window that provides a view on all the tasks and to-dos you’ve accumulated. If you’re running OmniFocus for the first time, this will include the Tutorial Project and nothing else; if you’ve set up sync with an existing database, you’ll see your database contents spread before you.




What follows is a guided tour of the various parts of the app interface you’ll interact with regularly in the process of getting stuff done.


The Toolbar


The toolbar at the top of your OmniFocus window contains icons for commonly used app functions that you’d like to have accessible at the click of a button. The default toolbar includes buttons or fields for:



[image: The default toolbar in OmniFocus 2.]



	Showing and hiding the sidebar

	Adding a new action or a new inbox item

	Cleaning up the contents of your main outline

	Showing the Quick Open window

	Focusing on the currently selected project (Pro)

	Showing the View Options for your current perspective

	Sharing the current selection with another app via the share extension

	Searching in the main outline or across your entire database

	Showing and hiding the Inspector relevant to your current selection

	Prompting OmniFocus to Sync with a remote database




Customizing the Toolbar


Secondary click on the toolbar to reveal a contextual menu that contains the Customize Toolbar command, or choose it from the View menu. You’ll see a sheet with a multitude of buttons you can drag into place in the toolbar to suit your workflow.



Note

In OmniFocus Pro, this includes custom perspectives you’ve created in the Perspectives Editor, and any AppleScript scripts you’ve added to the scripts folder.





You can choose whether to display toolbar icons, text, or both, and toggle between large and small versions of the icons.


Perspective Tabs


All of your to-dos in OmniFocus live in a database behind the scenes. Perspectives are how you look at and interact with the contents of that database. OmniFocus 2 for Mac comes with six built-in perspectives that represent specialized, commonly-used view states specifically designed to help you organize, prioritize, schedule, and review your tasks.



Note

In OmniFocus Pro, you can change the order and visibility of perspective tabs and add custom perspectives using the Perspectives Editor.





You can browse your visible perspectives using the tabs on the left side of the OmniFocus window. By default this includes:



[image: The built-in perspectives in OmniFocus 2.]



	The Inbox, where you’ll stash all the tasks and to-dos that come to mind for later processing.

	Projects, where related tasks are grouped together into overarching plans and hierarchies.

	Contexts, the places, people, things, and states of mind most relevant or conducive to accomplishing your tasks.

	Forecast, where you can view your tasks chronologically and integrate them into your schedule.

	Flagged, where tasks designated with the most important priority or visibility are gathered.

	Review, the place to regularly check up on your progress and determine the status of projects.





Note

Completed and Changed are two additional perspectives, available from the Perspectives menu, that can help you recover misplaced items or review progress and recent changes to your database. These are designed as temporary views on your database, so switching away from them to another tab removes the tab from your sidebar (you can open them from the Perspectives menu again at any time).





The Sidebar


Nestled between the main outline and the perspective tabs lives the magical land known as the sidebar. It appears when viewing each built-in perspective other than the inbox, and provides a powerful, high-level means for surveying what’s on your plate. The function of the sidebar for each built-in perspective is discussed in the chapter for that perspective.



[image: Three of the various sidebars from the built-in OmniFocus 2 perspectives.]


The sidebar can be collapsed and hidden using the sidebar button in the toolbar, or by dragging the handle in the bottom bar to the left, with the View ▸ Hide Sidebar menu item, or with the shortcut Option-Command-S. 


The Focus Bar


When you’re in a special mode of the app where only a subset or nonstandard implementation of your database is visible, a bar will appear beneath the toolbar to indicate the mode that you’re in.



[image: The various permutations of the focus bar.]


The most common case in which the bar appears is when you’re focusing (in OmniFocus Pro). A bar also appears to notify you when:



	Viewing an archive

	Viewing a backup

	Viewing a foreign database




The Main Outline


This is where you’ll view, add, and manipulate the tasks you’re working on at a given moment. What you see here is based on which perspective you’re viewing, what you have selected in the sidebar, whether you’re focusing on something, and more—you can narrow your concentration on just a few things you’d like to accomplish in the near term, or get a broad overview of the tasks ahead across a number of projects.



[image: Items in the main outline.]


The main outline displays a list of items—inbox items, projects, actions, or groups—that fit the criteria you’ve established with your other view parameters. Each item displays associated information that’s the most relevant info you’ve entered about it.



How Items Are Ordered


Actions, projects, and other items are ordered based on the sequence in which you entered them, or how you’ve manually arranged them in the outline, with a couple of exceptions: when you’re in a context-based view with a different sort priority set, or in Forecast, where items are sorted by due date and time.


Other sorting parameters can also be applied with custom perspectives in OmniFocus Pro, or by using Organize ▸ Sort Once to sort of items selected in the sidebar or the main outline (as long as you’ve selected something that can be reordered).





Status Circles and What They Mean


Items you’re looking at in the main outline have circles next to them. These are called status circles. Some may be colored, have dots in the center, a jaunty little flag icon in the corner, or even appear solid with a check mark in the middle: these display the various states an item can be in for quick reference as you view your list of tasks. 



[image: The various permutations of the status circle.]


The figure above shows many common visual states of the status circle, including from top to bottom:



	Flagged—orange circle and corner flag

	Due Soon—amber circle

	Overdue—red circle

	Unstyled—grey circle

	Repeating—dots in center

	Flagged, Due Soon, and Repeating—halved amber/orange circle with flag and dots

	Completed—solid with check mark





Note

Status circles can display various combinations of states when more than one is applicable to the same item (as is the case with the action that’s Flagged, Due Soon, and Repeating, above).




The Inspector


The right side of the OmniFocus window is the domain of the inspector. This handy spot is where you view (“inspect”) the details of an item or context you’ve selected in the sidebar or the main outline.



[image: An overview of the inspector in OmniFocus 2.]


You can show and hide the inspector using the inspect button in the toolbar, dragging the right handle in the bottom bar, with the View ▸ Hide Inspector menu item, or with the keyboard shortcut Option-Command-I.


The Bottom Bar


The bottom bar contains tools for quick access to commands based on your current perspective, as well as a summary of the contents of your main outline.



	Handles to collapse and expand the sidebar and inspector.


	A summary of the contents of the main outline, letting you know at a glance how many projects, contexts, and actions are being displayed.


	When in Projects or Contexts, the plus button adds items relevant to your current perspective.


	The gear menu provides a host of tools for manipulating your sidebar selection, primarily in Projects and similar perspectives.




			






Projects


As you work through your Inbox, some of the items will stand out as larger in scope than a simple action. Planning a vacation or move, for example, are the sort of things that could benefit from being broken down into more manageable parts. Projects to the rescue!





[image: Projects help you organize multiple actions into a logical grouping]


A Project is an item that’s made up of multiple actions. Projects are typically more complex than actions, and can include several related actions.


Understanding Project Types


Projects can be as elaborate as necessary, and you can specify the project type to be either Sequential, Parallel, or as a logical grouping of Single Actions.


Sequential Projects [image: sequential project icon]


Some projects, such as building a papier-mâché pterodactyl, require one action to be completed before the next action starts. These are Sequential projects.


Sequential projects have actions that need to be completed in a predetermined order; the first item needs to be completed before you can move on to the next. Another example of a sequential project could be a checklist that an astronaut goes through during the launch sequence. Each item in the list is dependent on the previous item’s completion. 


Parallel Projects [image: parallel project icon]


Parallel projects consist of actions that can be completed in any order, such as picking up items at a few different locations. In a parallel project, all incomplete actions are available, and the First Available is just the first one in the list.



Note

The difference between parallel and sequential projects is most visible when the View option is set to show only Available actions. (Actions beyond the first available action in a sequential project are blocked, and therefore hidden.) In other View settings the distinction is there, but more subtle: future actions in a sequential project have their titles in gray text instead of black.





When viewing the Projects perspective, each project has an icon to its left that indicates the project type. These icons allow you to quickly scan a list of projects and tell which project is which type.



[image: When viewing the Projects perspective, each project has an icon to its left that indicates the project type]


If you find yourself using one type more often than the other, you can change the default setting in OmniFocus ▸ Preferences ▸ Organization.


Single Action Lists [image: single action project icon]


The final project type, Single Actions,  isn’t really a project—it’s a list of loosely-related actions that aren’t interdependent. A Shopping List project is a good example of a Single Action list because it contains a list of things that you need to pick up at the grocery store. You can gather these items and check them off as completed (or acquired) as you make your way through the store. The order in which you collect them is irrelevant—it doesn’t matter if you pick some of them up today or tomorrow; they’re just things you know that you need to grab.


A Single Action list is often more about a state you want to generally sustain (spoiled cat, non-spoiled food, functional household), rather than a state you want to achieve (ship an app, take a vacation, find a new apartment). Another way of looking at this is that Single Action lists rarely have due dates, and they rarely get checked off as completed. The items within the Single Action list may get checked off, but the project itself is ongoing.


Because of this, when setting up a Single Action list the Complete when completing last action control is unavailable in the Project inspector. This reflects its use as a container that exists regardless of whether it happens to have anything currently inside it or not. (You can still mark a Single Action project complete manually using the inspector's Status control.)



Project Status


When you think about the status of an Action or Group, the primary concern is whether the Action is complete. Projects are a bit different; they can be assigned one of four states:



	Active [image: active icon]

	By default, all new projects have their status set to Active. This means that the project is current and ongoing.



	On Hold [image: on-hold icon]

	You can place a project On Hold at any time using the inspector, or while conducting a Review of your projects. When you place a project On Hold, what you’re essentially doing is delaying the project and its actions. If you know when the project will resume, you can adjust the schedule in the Dates inspector, or you can wait until some point in the future to adjust the schedule.



	Completed [image: completed icon]

	When you change the status of a project to Completed, the project itself is marked as Completed. However, this does not affect the status of any Active actions within the project; they will remain Active until their statuses are set to Completed.



	Dropped [image: dropped icon]

	Every now and then, you’ll find that a project needs to be canceled or put off indefinitely. When that happens, you can set the project’s status to Dropped. When Dropped, the project and all of its actions are hidden, and won’t show up in any view setting other than All. This also notes that a project is slated for eventual archiving in a separate database.






[image: Use the Projects inspector to set the Status of a project]



Note

You can change a project’s status in the Project inspector, with the Action menu, or by choosing Edit ▸ Status menu.









Creating Action Groups


Groups can also be used to create a project within a project—an action group (also sometimes called a sub-project). If you find that you have an action that requires many steps of its own, you could split that action off as a separate project. However, a better solution could be to leave the action in its current project, and then move the related tasks underneath.


For example, when planning your move to Seattle, you realize that you need to make a house-hunting trip to find a place to live. You need to book your flights, rent a car, reserve a hotel room, and make appointments with real estate agents to find an apartment or that dream house in Alki Beach. You can create these tasks one by one, and then move the action into the Plan a house-hunting trip action.



[image: Action Groups afford you the flexibility to create subprojects]


Put another way, when you create an action group you’re creating a parent-child hierarchical relationship between an action and the actions nested within it. If the desired parent and children are actions that already exist, this can be done by selecting the soon-to-be child actions and:



	Dragging them on top of the parent action so the parent action is selected and shows a vertical insertion line indented beneath it, then dropping them inside, or


	Positioning them immediately below the intended parent action in the outline and choosing Organize ▸ Indent (Command-]).




If either the group’s parent action or its child actions have yet to be created, there are two other ways to create groups.



	To create a group from an existing action intended as its parent:


Create child actions from scratch by choosing Organize ▸ Add Inside (Shift-Command-]) with the intended parent action selected. A new action is created with the selected action as its parent.



	To create a group from existing actions with no existing parent action:


Select the items you’d like to group and choose Organize ▸ Group (Option-Command-G). A new untitled action is created to represent the group, and the selected items are indented to become its children.





Once you’ve created that action group, you can change its type from Parallel to Sequential so that the next task only becomes available when you tick off the previous task. And when you’ve completed the final action for that subproject, the parent action can be checked off, too.



Tip

For added flexibility in creating just the right dependencies for your project, consider making an Action Group parallel within a sequential project, or vice versa.






Grouping Projects with Folders


Occasionally, you’ll find that some of your projects are similar enough that you want to keep them together so you can look at everything in one place. These projects might have different goals, timelines, or objectives, but they contribute to the greater whole. For projects such as this, you can use Folders in OmniFocus to group multiple projects together.



[image: Project folders offer a way for you to group similar projects together so they&#8217;re easier to manage]


To create a project folder, follow these steps:



	Select two or more projects in the Projects perspective:



[image: Project folders contain two or more projects of similar context]



	Choose Organize ▸ Group (Option-Command-G). This places the selected projects within a folder.



[image: The projects are moved into a folder]



	Enter a name for the folder to replace the New Folder text.



[image: Give the folder a name that reflects the overall scope of the projects within]



	Press Return to accept the new folder name.





Alternatively, choose New Folder from the Plus menu beneath the projects list, or choose File ▸ New Folder while in the Projects perspective.



[image: Adding a new folder with the Plus menu beneath the projects list in the Projects perspective.]



Tip

Folders can be created or moved inside other folders, to create a nesting hierarchy of projects that’s as deep — or wide — as you need it to be.





Marking a Project Complete


Eventually you’re going to reach the successful end of a project. When you’re sure that you’ve really accomplished “Move in to new house,” “Carve Halloween pumpkins,” or “Write pterodactyl novel,” you can mark the project complete.


Select the project and then choose Status ▸ Completed from its contextual menu, change its status in the inspector, click the Complete toolbar item, choose Edit ▸ Status ▸ Completed, or just press the Space bar. The project’s status changes to Completed, and it is filed away in your library for safekeeping.



[image: Control- or right-click on a project, and then choose Status &#x25b8; Completed from the contextual menu]


Placing a Project On Hold


If you’re not quite sure whether you want to start (or continue) a project, you can change the project’s Status from Active to On Hold. When you place a project On Hold, the project and its actions are removed from the project list in the sidebar (if you’ve chosen to show Active projects in View options).


Every now and then, you can switch the project View option to Remaining so you can review the projects you’d like to make active, drop, or keep On Hold.


There are several ways to place a project On Hold:



	Select the project in the main outline, open the Project inspector (Option-Command-I), and then change the Status to On Hold.



[image: Change the Status of a project to On Hold in the Project inspector]



	Select the project in the sidebar, and then choose Status ▸ On Hold from the gear menu at the bottom of the sidebar.



[image: Use the Action menu (the little gear) to place a project On Hold]



	Control- or right-click the project in the main outline or in the sidebar, and then choose Status ▸ On Hold from the contextual menu.






To switch an On Hold project to Active again:



	Choose Perspectives ▸ Projects (Command–2).


	Click View in the toolbar, or choose View ▸ Show View Options (Shift-Command-V) to open the View options popover menu.


	Choose the Remaining view option. Any projects that have been placed On Hold, have been deferred or blocked, now show up in the sidebar.



[image: Choose the Remaining view option so you can review projects that are on hold]



	Click away from the View options popover to make it disappear.


	Select the project in the sidebar, and then use one of the following techniques to set the project’s status back to Active:



	Select the project in the main outline, open the Project inspector (Option-Command-I), and then change the Status to Active.

	Select the project in the sidebar, and then choose Status ▸ Active from the gear menu at the bottom of the sidebar.

	Control- or right-click the project in the main outline or in the sidebar, and then choose Status ▸ Active from the contextual menu.









Tip

If you don’t want On Hold projects cluttering your Projects sidebar until they are active, you can leave the Projects View options set to Available, but then change the Review View options to Remaining. This way, anything that is On Hold, Deferred, or Blocked shows up in the sidebar whenever you review all of your projects, and you can decide then whether to reactivate a project or action.  





Dropping a Project


If you’ve decided not to work on a project any further, you can drop it completely. It disappears from the list in the sidebar, and its actions likewise stay hidden. Of course, you could just delete the project, but then you wouldn’t have any record of it or its actions ever having existed. Keeping them around in a dropped state means you can go back and check on how often you give up on projects, check which actions you’ve completed regardless of whether they’re from still-relevant projects, and so on.



Note

When you drop a project, OmniFocus archives it away for safekeeping and, when you choose, removes the project from your main database. See Archiving and Backup for more information.





There are several ways to drop a project:



	Select the project in the main outline or in the sidebar, and then choose Edit ▸ Status ▸ Dropped.


	Select the project in the main outline, open the Project inspector (Option-Command-I), and then change the Status to Dropped.



[image: Dropping a project using the inspector]



	Select the project in the sidebar, and then choose Status ▸ Dropped from the gear menu at the bottom of the sidebar.




	Control- or right-click the project in the main outline or in the sidebar, and then choose Status ▸ Dropped from the contextual menu.







To switch a Dropped project or folder to Active again:



	Choose Perspectives ▸ Projects (Command–2).


	Click View in the toolbar, or choose View ▸ Show View Options (Shift-Command-V) to open the View options popover menu.


	Choose the All view option. Any projects that have been Dropped now show up in the sidebar.



[image: Choose the All view option so you can review Dropped projects]



	Click away from the View options popover to make it disappear.


	Select the project in the sidebar, and then use one of the following techniques to set the project’s status back to Active:



	Select the project in the main outline and choose Edit ▸ Status ▸ Active.

	Select the project in the main outline, open the Project inspector (Option-Command-I), and then change the Status to Active.

	Select the project in the sidebar, and then choose Status ▸ Active from the gear menu at the bottom of the sidebar.

	Control- or right-click the project in the main outline or in the sidebar, and then choose Status ▸ Active from the contextual menu.












		

OmniFocus Extended


With extensions in OS X, there are a bunch of ways you can interact with OmniFocus while you’re doing other things on your Mac.




Sharing


As an alternative to Clippings or Quick Entry, you can use the Share Menu in apps that support it (such as Safari) to share content with OmniFocus. 


To add OmniFocus to the share menu of other apps that support the OS X share extension, visit Extensions in the System Preferences app and click the check box next to OmniFocus in the Share Menu extension. To make OmniFocus more visible, drag to rearrange it above other apps in the menu.



[image: Adding OmniFocus to the Share Menu]



Tip

OmniFocus supports sharing with other apps, too. With content selected in the main outline, click Share in the toolbar to send the desired items to a destination app.






Today Extension


You’ll see the OmniFocus Today extension listed in the Extensions section of System Preferences as well.





[image: The Today extension in System Preferences]


With the Today extension enabled, you can view items that are due soon and overdue at a glance in Notification Center, and when they’re complete, check them off right there — the items’ status updates in the app along with any changes you make.


Choose the items shown in the Today extension with OmniFocus’s Notification Preferences.



[image: OmniFocus as a Today widget]



Tip

Click Edit at the bottom of the Today pane of Notification Center to change the position of the OmniFocus widget in the column, and to add or remove other Today widgets.






Interactive Notifications


For things that really need your attention, you can add a bit more oomph to your notifications by requiring an interaction when they appear.




To set up interactive notifications, first visit OmniFocus Preferences and be sure that Show Reminders As Notifications is checked. Next, open Notifications in System Preferences and choose OmniFocus. Select Alerts as the type of notification you’d like to receive.



[image: Setting Up Interactive Notifications]


From now on, OmniFocus notifications you receive on your Mac will remain on screen until dismissed. You’ll have two options when dismissing the alert: to simply close it, or to show the location of the relevant item in OmniFocus. If you choose to show the item, it’ll be summoned in your currently active OmniFocus window (OmniFocus will launch if it was closed at the time).

		

Copy as TaskPaper


Most aspects of an OmniFocus item can be represented as tags in the plain text syntax used by Hog Bay Software’s to-do list app TaskPaper. The Edit ▸ Copy as TaskPaper menu item provides an easy way to bring items—and their properties, such as due date, context, or repeat type—from OmniFocus to any other app that supports the TaskPaper tag syntax.




OmniFocus also supports pasting plain text lists formatted in TaskPaper syntax into the open window of an OmniFocus database. So while Copy as TaskPaper can be used to share OmniFocus items with TaskPaper itself, its primary use is as an intermediary  between OmniFocus and other apps that support TaskPaper's tag system.


This can be used to (for example) batch process dozens or hundreds of OmniFocus items at once, round-tripping them out from OmniFocus in the TaskPaper syntax, performing the batch processing actions, and bringing them back to OmniFocus without loss of important metadata.



OmniFocus uses the following tags to represent item attributes when copied into the TaskPaper format:



	@autodone (boolean)

	Indicates whether the item automatically completes itself when its children are complete.

      
	@context (string)

	The context assigned to the item, if any.


	@defer (date)

	The date until which the item is deferred, e.g. 2016-04-19 5pm or next Thursday -3d.


	@done (date)

	The date on which the item was completed.


	@due (date)

	The date on which the item is due.


	@estimate (time span)

	The estimated time needed to complete the task, e.g. 2h for 2 hours or 3w for 3 weeks.


	@flagged

	Denotes flagged status if the item is flagged.


	@parallel (boolean)

	Indicates whether the item’s children are parallel (true) or sequential (false).


	@repeat-method (method)

	If the item is repeating, indicates the repeat method: fixed, start-after-completion, or due-after-completion.


	@repeat-rule (rule)

	An iCalendar spec (ICS) repeat rule, e.g. FREQ=WEEKLY;INTERVAL=1.






		

Printing and Exporting


If you need to get data out of OmniFocus and into another format — either physically or digitally — the options for doing so are outlined below.




Printing


Printing your OmniFocus data is pretty straightforward: set up a window that contains exactly the data you want by focusing, selecting items in the sidebar, or expanding and collapsing rows in the main outline. Then choose Print from the File menu. OmniFocus resizes the content to fit horizontally on the paper you’ve chosen.


To print on unusually-sized paper:



	Choose File ▸ Page Setup (Shift-Command-P).

	Make sure the Settings popup menu is set to Page Attributes.

	Choose your printer from the Format popup menu.

	See if the paper you want to use is listed in the Paper Size popup menu. If it is, choose that paper size and click OK to save your changes.

If the paper size you need isn’t available, choose Manage Custom Sizes from the Paper Size popup menu and then use the Custom Paper Sizes window to define the page specs you need.





Exporting


Your data belongs to you; if you want to send it to other applications, run scripts on it, publish it on the web, or do other exciting stuff with it that we haven’t even thought of, you’re more than welcome to write it out to the format of your liking.




To export your database, choose File ▸ Export, and then choose a format and a location. The available formats are:




	OmniFocus Document — This is an ordinary OmniFocus document, just like the one that you use as your database. If you open such a file in OmniFocus, it appears in its own window and you can work with it normally, but settings specific to your database (such as custom perspectives and view options) don’t come along with it.


	Plain Text — This is a lightweight plain-text representation of your data, able to be opened in the text editor of your choice.






Tip

OmniFocus’s plain text export is inspired by TaskPaper, the light to-do application from Hog Bay Software. As such the output should be roughly compatible and able to be imported to TaskPaper with a minimum of fuss. If that’s your jam you might want to give it a try!






	Simple HTML — This is a single-file HTML representation of your data; the stylesheet and even the icons are embedded in the HTML. If you are proficient with CSS, you should be able to restyle the result however you like.



	Comma Separated Values (CSV and CSV UTF–16) — CSV is a kind of lingua franca for applications old and new on all platforms, as it’s just all of your data in a plain text file with its columns separated by commas. Once you have your data in CSV format, it’s easy to run scripts on it, convert it to some other format, or open it in applications that understand it (like OmniPlan!). If you’re having trouble persuading other applications to read the non-ASCII characters in your CSV file, such as accented letters or non-Roman characters, try exporting with the UTF–16 CSV option, and importing that into the other application. This makes it easier for some applications to detect the correct encoding and interpret your characters properly.



	Backup Document (OmniFocus) — This export option creates a file in a format (.ofocus-backup) that is essentially the same as the standard OmniFocus database format, with one key difference.


Unlike a standard OmniFocus database file, when you open a Backup Document in OmniFocus, the option to Revert to This Backup appears as a button in the upper right of the document window. Click this button to replace your local default database with the database contained in the Backup Document.




		
		





		

Getting Synced


When you first launch OmniFocus 2 you’ll be asked to set up your sync settings. Syncing is important in OmniFocus as an additional layer of backup storage for your data, and enables several of the advanced features of the app such as Mail Drop. If you have OmniFocus for iPhone or iPad, syncing connects you to the latest changes made on any device.





[image: OmniFocus Sync Flow]


If you’re planning to sync, it’s recommended to do so as part of the app setup process to ensure as smooth a transition as possible between versions, and to provide that added layer of backup right away. If you choose to set up sync later, the same preferences you saw at first launch are available in OmniFocus ▸ Preferences ▸ Synchronization.



Omni Sync Server


The most straightforward sync option available is our very own Omni Sync Server. It’s free, reliable, and supported by Omni’s ace support team; we take care of managing the servers so your data is always available when you need it most.




Get started by creating a new Omni Sync account here:


https://manage.sync.omnigroup.com



Other WebDAV Options


Omni Sync Server is a great syncing solution for most OmniFocus users. If your sync needs require that your data be kept completely within a system you control, you can configure a private WebDAV server to sync your OmniFocus data. This can be a third party server (there are many fine providers out there) or one that lives on your own Mac.




While we’re not able to provide comprehensive support for WebDAV servers we don’t administrate (since it isn’t our software), we’re glad to help you get started with some pointers.


See this support article for a tutorial on setting up your own OmniFocus sync server using Server.app (included with Mac OS X Server).


Another option for self-hosting your own sync server is WebDAVNav Server, a free server application (see the corresponding support article). Please recall that we can't provide troubleshooting assistance for third party apps or services, so once again we recommend Omni Sync Server unless you're running OmniFocus in extraordinary circumstances.



Warning

When you expose files and folders on your computer to the internet (even with password protection), you assume some risk. Make sure you understand this risk before setting up a server, and be sure to keep your Mac up to date with the latest security patches. If you’d prefer not to host your own server, you can sign up for an Omni Sync Server account or use another standards-compliant WebDAV host to sync OmniFocus.




Also note that while services such as Dropbox are great for file sharing, they can’t handle OmniFocus data properly for syncing purposes. Using Dropbox as a place to store your OmniFocus data can corrupt it. Do not use Dropbox as a means of synchronizing your OmniFocus data.






How Synchronization Works


With sync turned on in OmniFocus, a server you designate keeps a copy of your database so that it’s always available wherever you are. With each subsequent sync, OmniFocus compares your local database with what’s on the server and applies any differences to the database on the server (or vice versa, bringing the latest changes from the server to your device).





We’ve also built in an automatic sync mechanism. With sync turned on, OmniFocus sends new changes to the sync server after one minute, or when opening or closing the app. At a bare minimum, OmniFocus checks in with the server every hour if nothing has changed on the device. This helps ensure that your data from OmniFocus is always safe, secure, and most importantly—up to date.



Tip

Devices with OmniFocus 2 (on any platform) that sync to the same server account and are connected to the same Wi-Fi network will prompt each other to sync when any new changes are pushed to the server. Nifty! 





If you’ve made changes you want to view immediately on other devices, you’ll want to perform a manual sync (by clicking the Sync button in OmniFocus) before switching to OmniFocus on another device. This pushes your latest changes up to the sync server, so that when you launch OmniFocus on the other system, all you have to do is click or tap Sync to ensure that all of your changes are there.



Note

In OmniFocus 2.4, synchronization is even more robust with the addition of push notification-triggered sync. This feature notifies your other devices with OmniFocus to update whenever you make a change, so manual syncing should rarely — if ever — be required. See this support article for more information on just how it works.



For options related to push-triggered sync, choose Show Sync Details... in the Synchronization Preferences pane of OmniFocus Preferences.





Encryption


OmniFocus sync has always used HTTPS to encrypt your data while in transfer to sync servers that support it (including Omni Sync Server). New with the release of OmniFocus 2.6 for Mac and 2.15 for iOS, all OmniFocus databases set up to sync with remote servers are also automatically encrypted prior to transit, and live encrypted on the server.





Note

Versions of OmniFocus with the database encryption feature also include an updated database format that requires migration from previous versions for compatibility between all your devices with OmniFocus.


After updating one device to a version that supports encryption, you'll see guidance on which other devices must be updated before the migration can take place.


For details on the migration process see Migrating Your Database.




Encryption is done by OmniFocus on your Mac or iOS device at the time the database is transmitted to the sync server. This means that regardless of the sync destination (Omni Sync Server or another WebDAV server), encryption-based security is preserved. OmniFocus doesn't actively encrypt data while in storage on your local device, instead deferring to any system-level encryption you have in place.


Technical details of the encryption scheme for OmniFocus can be found in this forum post.



Warning

After migrating to the new database format, if you're set up to publish due items as calendar alarms, a portion of your data  will remain unencrypted while stored as part of the .ics file on the sync server.






Setting a Separate Database Passphrase


By default, OmniFocus uses the password you chose when setting up your sync account to encrypt your database on the server. For an extra layer of security, you can use a distinct encryption passphrase by choosing Change Passphrase from the Encryption tab of Show Sync Details in Synchronization Preferences.





[image: Setting a separate password for encryption of your OmniFocus database.]


This section of Sync Details indicates whether your database is encrypted with your sync password, or a separate one. When you click Change Passphrase, you are prompted to enter your current passphrase (this is the same as your sync password). You can then set and confirm a new passphrase used to encrypt your database on the server.



[image: OmniFocus Encryption settings with a separate passphrase set for database encryption.]


After setting a new encryption passphrase the Encryption settings indicate that your sync and encryption passwords are distinct. You can unify them again by clicking Link Passwords, or change the encryption passphrase to something new with Change Passphrase.



Note

If you're syncing with OmniFocus on other Macs or iOS devices, after changing your encryption passphrase you will be prompted to enter the new passphrase on each of those devices before you can receive updates from the server.
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Quick Navigation


After you’ve used OmniFocus for awhile you’ll likely have amassed a colorful menagerie of projects, contexts, actions, and groups in various states of completion. Luckily, finding what you need is as easy as a click or keyboard command away! OmniFocus offers several handy features to help you access your data from anywhere in the app.




Quick Open


Command-O invokes Quick Open, the powerful way to access your perspectives, folders, projects and contexts with a few swift keystrokes. As you type, Quick Open narrows your results in real time and sorts them by relevance to the text you enter.



[image: The Quick Open Window]


Searching in the Toolbar


By default, entering a term in the toolbar’s search field combs through the current contents of your main outline (“Here”) and filters items with text that matches the terms of your search.


A toolbar search looks through text in the title, note, project, and context fields of everything in the scope of the search to find matching items.



[image: Searching in the Toolbar]


Click the magnifying glass icon to the left of the search field to change the scope of the search from the current view to either all Remaining items (things that haven't been completed or dropped), or Everything in your OmniFocus database regardless of completion status.


Find Dialog


Another way to locate a lost item in your current view is with the find dialog (Command-F). While search narrows what you see in the outline, the find dialog looks through all the fields currently visible in the main outline and highlights results instead, providing a setting for them which you can browse through until you find what you need.



Tip

OmniFocus’s find dialog supports regular expression syntax, a vocabulary for building a query that finds a range of possible results with a single find action. If you’re familiar with regular expressions feel free to try them out, or see this support article for some tips to get started.




		



		

Getting Help


When you’re in need of help—whether you’re puzzled by perspectives, having trouble syncing, or experiencing another issue with OmniFocus—it’s good to know that the Support Humans at The Omni Group are available to lend you a hand.




The OmniFocus Website


The OmniFocus website is always a good place to find the latest information about OmniFocus, complete with an ever-growing support section.


The Official Forums


The Omni Group maintains online forums for all of our products, and you’re invited! Come share your questions and ideas with other users and Omni staff.


Email Support


If you’re stuck, if you have a good idea for the next version of OmniFocus, or if you just want to let us know how we’re doing, go ahead and send us an email. Choose Help ▸ Contact Omni from the menu bar to conjure up a message addressed to us, or just send us an email with your thoughts. We take support pretty seriously, so you can expect a prompt response actually typed by human hands.




Release Notes


For really meticulously detailed information about what has changed in each minor version of OmniFocus, check out Help ▸ Release Notes from the menu bar.


Troubleshooting


Here are a few tips you can try with OmniFocus’s own built in self-help features:


Finding Misplaced Items



	Try using the Completed and Changed perspectives to track down errant actions.

	Check the Attachment List for images or other files that you may have appended to items tucked deep in your database.

	Open the Archive to look for items that may have been lost to time.

	If all else fails, you can revert to a recent backup for something you know you had access to just a day ago.




Improving Performance



	Sync all the things regularly! This reduces sync wait times and generally improves speed and performance across the board.

	Compact your database to remove unneeded edit histories.

	Archive projects long past. Jettison them now for a nimbler database, and future easy retrieval and reference.

	Delete unneeded attachments to lessen the sync load and disc space footprint of your database.




Resolving Sync Conflicts



	If you’re sure what you have locally is what you want, you can Replace the Server Database to get everything back in sync.

	If you’re unsure (about this, or anything else OmniFocus-related), please contact Omni support! We’re here to help—it’s what we do.




		




		

Scripting


With OmniFocus Pro you have access to powerful scripting tools using the built-in AppleScript library. To access the dictionary of scripting commands specific to OmniFocus, open AppleScript Editor and choose File ▸ Open Dictionary (Shift-Command-O), then choose OmniFocus.app from the list that appears.





[image: Locate OmniFocus.app in the Open Dictionary window and then click Choose]


You can add scripts that live in your OmniFocus toolbar by placing them in the directory accessible from the Help ▸ Open Scripts Folder menu item.


Check out the resources below to get started with ideas, tips, and help for adding automation to your OmniFocus workflow:



	AppleScript discussion on the official OmniFocus Forums.


	An AppleScript overview, tips, and an extended list of resources can be found at Inside OmniFocus.




		





		

Capture Methods


As you get the hang of entering tasks, creating projects, and moving through your perspectives to get things organized and completed, you’ll find that OmniFocus keeps getting more powerful and easier to use.




And to help you get things into your OmniFocus database, we’ve built in some handy methods to make it easier for you, including copying from plain text, Quick Entry, Clippings, Mail Drop, and even importing a list from OmniOutliner.


Copying from Plain Text


If you’ve written a list of items elsewhere that you’d like to copy into OmniFocus (say, a grocery list typed up in Notes), OmniFocus can use line breaks to determine where one item ends and the next begins.



[image: Copying a Grocery List from Notes into OmniFocus, as Actions]


Just select the text you’d like to add as items and copy it (Command-C). In OmniFocus, select an item without activating any of its text fields, then paste (Command-V) to add the copied text as a list of items below the one you have selected.



Note

The items will be pasted as peers of the one initially selected, so if you’d like to paste text as a list of actions in a project, you’ll want to select an existing action in the project first (selecting the project results in a pasted list of projects rather than actions).





Quick Entry


With an easily configurable keyboard shortcut, you can use Quick Entry from anywhere on your Mac to add items to your database as long as OmniFocus is running. Make sure the shortcut in OmniFocus ▸ Preferences ▸ General is what you want, and it’ll open the Quick Entry window no matter which app you’re viewing in the foreground.



[image: The Quick Entry Window]


When using Quick Entry, a couple of other keyboard interactions are affected by your Outlining choice in General preferences.



	If you decide against posting an item with Quick Entry, in Modern mode press Esc to close the window. In Classic mode, use Cancel (Command-.) instead.


	Press Return in Quick Entry to save the current item and close the window. To add another item before closing the Quick Entry window, hold down Shift and then press Return — twice if in Modern mode, once if in Classic mode.






With OmniFocus Pro, the option to customize your main outline extends to the Quick Entry window as well. Open the View options with the button in the lower left of the window to choose whether to use the style set up in Layout preferences, override it with the original fluid row style or use a custom set of columns for just the data you want when you’re adding items with Quick Entry.



[image: View options for the Quick Entry window in OmniFocus Pro.]







Clippings


You may come across an email message, a web page, a newsreader article, or some other scrap of info that you’d like to turn into an OmniFocus action. In the olden days you might heft your mouse, highlight the text, copy it, summon up the OmniFocus quick entry window, and paste. But no, you’re living in the future. You use the OmniFocus Clippings service.


To clip content from another application:



	Highlight some text in any application (that is, any application that supports Mac OS X Services, which should be all applications these days, ahem).


	Press the Clippings keyboard shortcut (instructions on setting one up are below), or open the application menu and then the Services submenu, then choose OmniFocus: Send to Inbox.


	A new item, with the highlighted content (rich text and embedded images) as its note, lands in the quick entry window for you to revise and save.




Setting Up a Clippings Shortcut


At the bottom of General Preferences in OmniFocus, you’ll find a setting for the Clippings Shortcut which opens these instructions as well as opening a window for the Keyboard section of System Preferences.



Note

Sandboxed apps aren’t allowed to customize the keyboard shortcuts for their own services—such as the OmniFocus “Send to Inbox” service—which is why you need to do the rest of this on your own.





In that window, you should see two panes: on the left is a list of shortcut categories, and on the right is an outline of items within that category. In the left pane, click on “Services”, and on the right scroll down until you see the group of Text services. In there, you should see an item for the OmniFocus “Send to Inbox” service. Click on that service, and an “add shortcut” button should appear which you can use to assign a keyboard shortcut.


If you have more than one copy of OmniFocus installed, you may see duplicate copies of this service—one for each installed copy of OmniFocus. You may wish to uncheck the service associated with other copies to disable them so that you don’t accidentally send your clipping to the wrong copy of OmniFocus.



Whither the Clip-O-Tron?


Due to sandboxing, the Clip-O-Tron Mail message clipping service formerly available from OmniFocus Preferences is now available as a separate download in a brand new incarnation: the Clip-O-Tron 3001! If you’d like to bring links to your Mail messages into OmniFocus, this is the tool for you. See this support article on the Omni website for details and a download link.





Note

Starting with macOS High Sierra (version 10.13), the Clip-O-Tron is no longer required for clipping messages from Mail. The latest update to the Clip-O-Tron app notifies upon launch  that it is no longer required, and offers to help uninstall it.



High Sierra users can use the Clippings shortcut set up in General Preferences to clip messages from Mail without the need of any other setup.






Email Capture (Mail Drop)


Mail Drop is a feature of Omni Sync Server which lets you send emails directly into your OmniFocus Inbox. You can create multiple private send-to addresses to give friends, family, coworkers, or classmates the ability to create actions that land in your OmniFocus Inbox. And, best of all, you can revoke those addresses at any time.


Some possible ways to use Mail Drop include:



	Forwarding actionable emails from your PC at work

	Processing emails on your iPhone or iPad

	Using if this then that to automate all kinds of Internet-y things

	Allowing a partner to delegate actions directly into your OmniFocus system




If you’re already using the Omni Sync Server to sync OmniFocus, you can log in to the sync server web interface and create your first Mail Drop address. After logging in, just click the Create Address button to automatically generate the email address (a combination of your account name and a random string of characters, for example).



[image: Creating a Mail Drop Address]


If you don’t have a Sync Server account yet, you can sign up here. The account creation process includes instructions for configuring OmniFocus to use your new account (it’s as simple as tapping or clicking a link in an email).


When you send an email message to Mail Drop, the subject line of that message becomes the name of the new Inbox item. The body of the message becomes the Note, which can contain text, attachments (such as images and files), and simple HTML (more complex formatting is removed).



Note

For Mail Drop to work, you should be syncing your OmniFocus database to the same Omni Sync Server account that you’ve used to set up Mail Drop.





Importing from OmniOutliner


OmniFocus integrates with OmniOutliner for Mac, so you can outline an agenda in OmniOutliner and then easily bring it into OmniFocus and take action. There are three ways to bring your OmniOutliner data into OmniFocus:



	Import a Document


	Using the File ▸ Import OmniOutliner Document menu command, OmniFocus imports an OmniOutliner outline of your choice into your OmniFocus database. The outline’s rows become OmniFocus items, and its columns become fields for those items (you can choose what OmniFocus item field corresponds to each outline column as part of the import process).


	Drag and Drop


	Drag a selection of rows from an OmniOutliner document onto a project or group in OmniFocus, and they’ll become actions within that project or group with hierarchy preserved. As with the Import menu command, when you release the drag OmniFocus will ask how you’d like data in the outline’s columns to be interpreted.


	Copy and Paste


	Select any number of rows in an Outliner document and copy them (Command-C). Paste them (Command-V) into the Inbox or into another selected OmniFocus item, and the copied rows will appear in place with hierarchy preserved. As with the Import menu command, when you paste in a valid location OmniFocus asks how you’d like data in the outline’s columns to be interpreted.
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