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Introduction


Welcome to OmniPlan 2.4!




Thanks for taking the next big leap in advancement on your path to being an awesome project manager. OmniPlan 2.4 is packed with a ton of great goodies, including a comprehensive refresh of our support for Microsoft Project import and export — there's never been a better time to dive right in.


The app you're about to explore brings the power of a comprehensive suite of project management tools to your fingertips. Use customizable task and resource outlines to visualize, maintain, and simplify your projects. Break down tasks, optimize the required resources, control costs, and monitor your plan — all at a glance. Collaborate with your colleagues and share every detail, accept and reject changes, and set up custom calendar schedules for the entire team. OmniPlan provides features like Gantt charts, summaries, milestones, and critical path highlighting to help you stay on top of all your activities — resulting in projects that are simple to understand, regardless of their complexity.



[image: OmniPlan 2.4.]


OmniPlan 2.4 includes updates throughout the app, bringing you an even better OmniPlan experience. Support for the Microsoft Project 2013 format is now available for the first time on Mac. The in-app help is updated to a new look and feel, and is now available in eBook and online searchable formats. Performance in OS X Yosemite has been improved to handle your biggest projects even more effortlessly. As you go through your workday with OmniPlan you’ll notice that, in dozens of little ways, the app is ready to work better right along beside you.


Created with love,


The Omni Group



How This Documentation is Organized


This manual that you have before you (either in OmniPlan itself, online, or in iBooks on your Mac or iOS device—or both) has been assembled in such a way that you’re provided with a complete tour of OmniPlan.




You’ll start out with an overview of OmniPlan’s interface. Don’t skip over this chapter, as you’ll find many nuggets of information and fine details about OmniPlan that you might otherwise miss. And, if you do decide to skip this chapter and later find yourself wondering, “Hey, what’s that doohickey do?”, you can always come back here to discover what it’s all about.


To help guide you through the documentation and better learn all the things you need to know about OmniPlan, here’s a list of all of the chapters in this book:



	Chapter 1, Getting to Know OmniPlan

	The first chapter dives right in and gives you a top-down overview of OmniPlan’s user interface. You’ll learn about the Task, Resource, and Calendar views, the Toolbar, and, of course, the Inspectors. Nothing too deep; just the basics to get you rolling.


	Chapter 2, Working in OmniPlan: A Tutorial

	If you’re eager to get your first OmniPlan project up and running, this is the place to start. The tutorial guides you through the process of setting up and maintaining a project, from creating your first task to reaching the last milestone. After you’ve worked through it you’ll have the tools you need to build your own project from the ground up.


	Chapter 3, Working with Tasks

	Understanding tasks and the relationships between them is key to using OmniPlan to the fullest. In this chapter you’ll learn — in detail — how to get OmniPlan to model the work you need to accomplish so you can monitor and update its progress with confidence, including sections on task groups, hammock tasks, mastery of the Gantt chart, and a deep dive into the task inspectors.


	Chapter 4, Working with Resources

	If tasks are the building blocks of a project, resources are its lifeblood. Accurately assessing and organizing your resources will help your project run at peak efficiency, and this chapter delves into how OmniPlan can help you do just that with sections on resource groups, project tracking in the resource view timeline, the resource inspectors, and the concepts of duration and effort.


	Chapter 5, Using the Calendar

	Tasks and resources are united in the calendar view, where schedules can be set for every aspect of the project to make sure goals are met on time. Establishing the working hours for your project, and universal and individual exceptions to them, are covered in detail here.


	Chapter 6, Configuring your Project

	OmniPlan includes powerful tools for getting your project set up to suit both the way you work, and the facts on the ground. In this chapter you’ll find details on customizing units of time and money, adding notes and custom data to tasks and resources, establishing a unique style for your project that shows your data exactly where and how you want it, and setting up templates to quickly reuse settings common to your projects.


	Chapter 7, Maintaining your Project

	After your project is up and running, OmniPlan helps you keep it carefully tended — like a bonsai tree — to help it mature into its final form. When unexpected circumstances arise, adjusting the project will keep it shepherded toward the goal. This chapter explains violations, scheduling and leveling, establishing and working with baseline schedules, catching up and rescheduling tasks, and sharing resources across projects by publishing and subscribing to a server repository.


	Chapter 8, OmniPlan Extended

	While OmniPlan works great as a standalone project management app, you can always take advantage of its flexible import and export options and other features to collaborate outside the box. In this chapter you’ll find details on importing and exporting to other formats, customizable printing options, using HTML templates to export, accessing items by URL from outside the app, and of course, Microsoft Project support.


	Chapter 9, Preferences

	This chapter covers a variety of customization options to get OmniPlan working the best for you. Within OmniPlan Preferences you’ll find custom controls for data entry, display of times and dates, document and HTML template management, server repository account settings (including a quick-start guide for getting synced to an existing server repository), and options for when and how OmniPlan should check for updates to itself.


	Chapter 10, Glossary

	The glossary contains an alphabetical list of special terms you’ll encounter throughout the app, this documentation, and other project management resources you might be familiar with. If you’re just starting out in project management or you’re curious about how OmniPlan implements certain concepts, this is a great chapter to check.


	Chapter 11, Managing Your Omni Licenses

	For the most part, you should never have to worry about your Omni license, particularly if you’ve purchased OmniPlan from the Mac App Store. If you purchased OmniPlan from our website, however, you need to enter specific information from the license email you received from us.


	
This brief chapter walks you through the process of adding your license info in OmniPlan, shows you how to remove a license, and even tells you where we “hide” the license on your Mac just in case you ever need to send that to us or transfer it to that brand new Mac you’ve purchased.



	Chapter 12, Getting Help

	There’s no shame in admitting that you need help. In fact, that’s what we’re here for. If you ever get stuck when working on something in OmniPlan, or if you have a problem with the app’s license, or you just want to tell our Support Humans and the DocWranglers what an awesome job they’re doing, feel free to get in touch. This chapter points you to all of the resources we have available: Support Humans, Support Articles, Videos, and Documentation.





Tip

If you're currently using other versions of OmniPlan (iOS or earlier Mac versions) and want to get up to speed as quickly as possible with projects already in progress, see the Accounts Preferences section of the manual for a quick start guide to getting synced.






Using This Book


One of the beauties of having OmniPlan’s documentation available in electronic form is that it’s always available whenever you need it. We have built the documentation right into the Help menu. We have put all of the documentation on our website where it can be searched and bookmarked. And we’re continuing the ongoing trend of creating EPUB versions of the docs and making them freely available on the iBooks Store.





Get the EPUB

[image: The iBooks application icon]
Our preferred method of delivering the Help docs is via the iBooks Store in EPUB format. The documentation there is the same documentation you'll find on our website and bundled within the app.


The advantage of downloading the OmniPlan 2 for Mac User Manual from the iBooks Store is that whenever we update the docs for a new version of OmniPlan, you'll receive a notification in iBooks telling you that there's an update waiting for you. And the big win of EPUB over PDF is that any notations or bookmarks you make in the book carry forward to new versions of the documentation.





Tell Us What You Think


We’re constantly working on updates for our documentation. Whether it’s CSS work, correcting the occasional typo (yeah, they do sometimes slip through), or adding details or clarification for a specific feature based on something we’ve heard from a customer, we’re always trying to make our documentation better and more useful for you.




If you have any specific comments you’d like to send us about the documentation, please do. You can drop us an email message via our Support queue, or you can ping us on Twitter; we’re @OmniWranglers.


Finally, we’d like to thank you for taking the time to read the docs.





Getting to Know OmniPlan


When you first launch OmniPlan you’re presented with a fresh new OmniPlan document, ready for cultivating to match the precise needs of the project at hand. What follows is an introduction to the various pieces of the app that you’ll be interacting with to craft a project to your specifications. To jump right in and get to work, see the Tutorial.





The Toolbar


Like most applications, the toolbar has buttons for command you use frequently. Some of the buttons change depending on whether you’re using the task view, resource view, or calendar view. Use the Customize Toolbar command in the View menu to set up the controls however you like.





[image: The default toolbar.]



Task View


Click the first button in the view control to see the Task view.





[image: The Task view.]


You can type in the task outline to create, edit, and group tasks.
The Gantt chart is a visual representation of tasks’ durations and relationships.



Resource View


Click the second button in the view control to see the Resource view.





[image: The Resource view.]


You can use the resource outline to manage staff, equipment, and materials. The timeline shows the same tasks as the task view’s Gantt chart, split up by which resource they are assigned to.



Calendar View


Click the third button in the view control to see your Calendar view. 





[image: The Calendar view.]


In the Normal Hours view, edit the working calendar for the whole project, and for individual resources (represented by green blocks). Use the Extra & Off Hours view to create hours for instances that deviate from the norm, represented by blue blocks.


Double-click or drag to add a new block or drag the edges of existing blocks to change their hours. Hold shift and drag in the Normal Hours view to create delete hours or mark hours as unavailable in the Extra & Off Hours view, represented by a red box.


To modify the calendars for an individual resource, select it in the outline.



View Options


Open the View menu and choose View Options (⌘J) to see the various ways you can customize the information displayed in the task, resource, and calendar views.





[image: View options.]


For example, in task view, you can choose which columns are visible in the task outline and what kind of information you’d like to show on the Gantt chart side.


In the task and resource views, you can customize which data to show for objects. Click the pop-up menus beside or inside the task bar, group bar, or milestone to choose which data appears there in the chart.



Inspectors


The inspectors are floating windows which contain information and controls related to what’s selected in the main window. If you don’t see them, click the Inspect button in the toolbar, or pick one from the Inspectors menu. You can show and hide an inspector’s various sections by clicking the icons at the top of each inspector window. Hold Command while clicking to open an inspector section without closing the ones that are already open.





The Project Inspector


The Project inspector has information about the document as a whole.





[image: The Project inspector.]



	Project Information — General info about the project as a whole, such as its title and if the document works form a start date or an end date. Also, home to the scheduling granularity setting.


	Project Milestones — Manage milestones and the display of their critical paths. The slack limit for a milestone determines how closely a task can come to pushing a milestone back before it is considered part of the critical path.


	Project Styles — Change the style of tasks and resources.


	Project Colors — Change the color of backgrounds, rows, columns, and separators in the various outlines and charts.


	Project Formats — Configure your time and currency units.


	Project Unit Conversions — Define the hours in a given work day, week, month, and year. Click the Edit Work Week button to go to Calendar View and make adjustments to your working hours.


	Project Custom Data — Store any kind of miscellaneous data about the project.


	Project Attachments — Link to important files related to the project.






The Task Inspector


The Task inspector has information about the currently selected tasks or milestones, so it’s available only when the main window is in task view.





[image: The Task inspector.]



	Task Information — General info about the selected task, such as when it’s scheduled and how long it’ll take.


	Task Schedule — Info about the selected task’s schedule, like its start and end dates, and how it should be affected by leveling.


	Task Dependencies — A list of the dependencies this task is involved in.


	Task Assignments — A list of the resources assigned to this task.


	Task Custom Data — Store any kind of miscellaneous data about the task.


	Task Attachments — Link to important files related to the task.






The Resource Inspector


The Resource inspector has information about the currently selected resources, so it’s available only when the main window is in resource view.





[image: The Resource inspector.]



	Resource Information — General info about the selected resource, such as how much of it is available and how much it costs.


	Resource Assignments — A list of the tasks this resource is assigned to.


	Resource Custom Data — Store any miscellaneous data about the resource.


	Resource Attachments — Link to important files related to the resource.






Style Attributes


The Style Attributes inspector displays information about any custom text styles applied to the current selection, and allows styles to be copied (drag the style chit from the inspector to an item in the sidebar) and removed (click the X to the right of the style in the inspector). It also indicates whether the style is applied to a class of items (such as Task Groups) or an individual item, and applies changes accordingly.





[image: The Style Attributes inspector.]


For more on custom styling in OmniPlan, see Structural Styles and the sections following.






Working in OmniPlan: A Tutorial


Welcome to the tutorial! Starting with a blank slate, we’ll build a project from the ground up to show all of the core features of OmniPlan in practical use.





Step 1: Create a Project


For the purpose of this tutorial we’ll be looking at the development process of a game being put together by an independent team of intrepid designers, coders, and testers.




To create a new project, choose New (⌘N) from the File menu.



[image: Creating a new project in the File menu.]


You get a fresh, untitled project document with one task. Save the file to a convenient location, and give it a name (we’ll call ours The Game Plan).



[image: Our new project saved and ready to begin.]



Step 2: Choose a Start or End Date


When setting out to build a project, one of the most important aspects is the timeframe. This, in turn, is dictated by any deadlines or start constraints that exist for the project.




In the case of our game development scheme, we don’t have a hard deadline for the project to be finished - we want it to be done when it’s ready (but as soon as reasonably possible). To indicate this, we’ll go to the project inspector and set the start date as today.



[image: The Project Information inspector with the default start date (the day the project is created).]


Conveniently, this is the default setting for any new project.



Note

If you're planning a project in the abstract without a fixed start or end date, you can change the dates from Specific to Undetermined until the timeframe is more set in stone. You'll get dates that display as T+1d, T +2d... instead.





If you’re planning a project with a specific do-or-die deadline, you’ll want to switch the direction from forward to backward and put the deadline date in the End field. Tasks will be scheduled back from this date, filling in the time from project completion to the present.



Step 3: Create Milestones


Milestones are the anchor points in your project that mark important shifts in focus or unlocking a new phase of the project. Clarifying these will help break a dauntingly large project down into more manageable sections, and help dictate the tasks leading up to and following the milestone.




To create a milestone, choose Add ▸ Milestone from the Structure menu or the Gear menu in the bottom bar of Task view, or use the keyboard shortcut ⌘⇧M.



[image: Adding a new milestone using the gear menu.]


Alternatively, click on the currently existing task (“Task 1”) to select it, then go to the Task Information inspector. You can change the task type from a regular task to a milestone here.



[image: Change a task to a milestone in the Task Information inspector.]


We’ll change the name of “Task 1” by clicking it in Task View or editing the name field in the Task Information inspector, create a few more milestones for our game plan, and then go on to reinforce our milestones with tasks.



Step 4: Create Tasks


Create a task by clicking the plus button in the bottom bar, pressing return with a task selected, or choosing Add ▸ Task from the Structure menu.




A task is anything that needs to get done in order for the project to move toward completion. Each task has attributes such as start and end dates, a completion percentage, and resource assignments; these show up in the various columns of the task outline, and in the Task Information and Task Scheduling inspectors. Tasks can be grouped together, and a task can be dependent on other tasks.


For now, just create some tasks and name them. Select your first task and press the Return key once (or twice, depending on how your keyboard preferences are set) to create new tasks. If you still have a “Task 1” hanging around, you can just delete it or change its name. When you’re done, if your milestone is not the last item, click the bullet to its left and drag it down to the bottom of the list.


Each task in the outline corresponds to a bar on the Gantt chart.


New tasks appear below the currently selected item in the Gantt view, or at the bottom of the list if no tasks, milestones, or groups are selected.



[image: A basic lists of tasks and milestones for our project.]


For our project we’ll create several tasks beneath each milestone that they’re related to.



Step 5: Edit the Work Week


Now that we’re starting to see the game plan come together, we’ll set tasks aside for the moment and start setting up the work schedule for our project.




Switch to calendar view. By default, working hours are Monday through Friday from 8:00 to 5:00, with an hour-long break for lunch at noon, but you can move or resize the blocks to adjust the working hours for the project.



[image: The default schedule for a work week in Calendar view.]


Drag a block to move it, or drag the edge of a block to resize it. Double-click and drag in an empty area to create a new block, or select a block and press the Delete key to get rid of it. The text inside each block updates to reflect the changes you make.


Since we’re working with a bunch of more nocturnal folks, let’s change the schedule to reflect that. Click and drag one of the time blocks on the calendar to bring it to a new position, or drag one of the edges to change the size of the block. We end up with a schedule that fits our needs:



[image: The work week updated to fit our needs.]



Note

If your average work day isn't 8 hours long, you should visit the Project Unit Coversions inspector and change the hours per day setting, so that your task durations will make sense.






Step 6: Set Schedule Exceptions


Even the most accommodating work week will occasionally have days that are out of the ordinary. Whether it’s a national holiday, a team-wide training seminar, an industry expo or conference, or just a patch of bad weather that keeps folks out of the office, setting exceptions to the regular work schedule can be key to keeping a project on track.




Still in calendar view, choose Extra & Off Hours from the toggle below the resource list. Here you can change the work hours for a specific week, to account for exceptions such as holidays or overtime.



[image: The project calendar overview.]


One that we know is in the future for our project is the upcoming Memorial Day. We can add that to our schedule right now. Use the arrows bracketing the current month to navigate to May, then click on the week of Memorial Day (the 25th) to access the exceptions calendar for that week.



[image: The week of May 24-30 in detail.]


To quickly remove working time from the schedule, you can Shift-drag, creating a red box that marks normal working time as unavailable.


To add extra hours, double-click and drag to create a blue box which represents available hours apart from the normal working hours.


We know we want to take Memorial Day off, but we can also predict that this week will be crunch mode for the team. We create a block of time that covers the 25th, and then replace that lost time with evening overtime hours through the rest of the week.



[image: The week of May 24-30 with exceptions added.]



Note

When making changes to the schedule for the whole project, be sure not to have any resources selected in the sidebar. Editing the calendar with a resource selected will change the schedule for that specific resource rather than the project as a whole (see Step 13: Set Individual Schedule Exceptions for more on how to do this).






Step 7: Set Task Durations


Now we can begin to scope out how long each task will take. 




Use the view switcher to get back to task view. Each task takes a certain amount of time to complete. You can set a task’s duration by typing in the Duration column of the task outline, or by clicking and dragging the ridges on the right end of a bar in the Gantt chart. If you’re typing durations, you can use unit abbreviations like 2d (2 days), 1w (1 week), and so on.


The length of the bar in the Gantt chart represents the duration.



[image: A task with its duration extended to two days.]



Step 8: Group Tasks


When tasks are closely related or interdependent it can be useful to put them in a group. Groups help organize a project conceptually, and also act as meta-tasks that can be linked via dependencies to other tasks or groups.





[image: Selecting multiple tasks for grouping.]


Select some tasks and choose Group from the Structure menu (⌥⌘L) to group them. Grouped tasks are indented in the outline, and represented by a parent task of the “group” type, which can be named like any other task.


With all of the tasks in the group selected, this would be a good time to add a bit of visual distinction to the group as well. Go to the Project Styles inspector and choose a color in the Task Bar Color section that will identify all of the tasks in the group.



[image: Styling a group's bar color with the task inspector.]


After organizing tasks and milestones into groups and estimating the time required to complete them, we’re starting to get a better picture of how our project will take shape. At this stage our Gantt chart looks something like this:



[image: The project with groups, color styles, and task durations.]



Step 9: Connect Tasks with Dependency Lines


We can’t complete all of our tasks simultaneously! Even if we had the resources to do so, some parts of the project can’t happen until others are finished. Thankfully, the pieces are now in place to establish the ways that those tasks are dependent on the status of others. There are four ways that dependencies can exist:





	Finish → Start dependencies are the most common type, indicating that when task A finishes, task B can start.


	Start → Finish dependencies indicate that when task A starts, task B can finish.


	Start → Start dependencies indicate that when task A starts, task B can also start.


	Finish → Finish dependencies indicate that when task A finishes, task B can also finish.





Select two tasks which need to be connected, and click the Connection button in the toolbar. A Finish → Start dependency line appears between the tasks, starting from the task which comes first in the outline. You can also draw dependencies right in the Gantt chart by clicking an arrow on the end of a selected task and dragging it to the beginning of the next.



Note

The type of dependency is based on the start- and end- points of the arrow: dragging an arrow from the completion of one task to the beginning of another will create a finish → start dependency, and so on.





As you connect tasks, they automatically reschedule to respect the dependencies.



[image: A finish-to-start dependency between two tasks, as illustrated in the Gantt view.]


Milestones, like other types of tasks, can be connected with dependency lines. If you find that your milestones (or other tasks) don’t look like they’re as well positioned in the Gantt chart as their dependencies would indicate, you can drag to rearrange them in the outline for a more natural flow.



[image: Milestones rearranged and tasks connected by dependencies throughout the project.]


Remove dependencies by selecting all the relevant tasks and choosing Disconnect Tasks from the Structure menu (⌃⌘-) or Disconnect from the drop-down Connection toolbar button menu.



Step 10: Create Hammock Tasks


A hammock task is one in which the duration is dependent on both when the previous task ends, and the next task starts. This type of task is useful when facing a hard deadline and deciding what can be compressed if the project is running behind schedule, or if external factors influence when parts of the project must happen.




In our example we realize that alpha testing for the game can’t begin until April 26th, since that’s when we receive our prototype testing hardware. We give the “Testing phase” group a “start no earlier than” constraint of April 26th by selecting it, going to the Task Schedule inspector, and setting Start No Earlier Than to April 26th 12:00 AM.



[image: Setting a start constraint for the Testing phase group.]



Note

A start no earlier than constraint can also be set by selecting a task and dragging it along the timeline by the left handle that appears at its edge.





We decide that the “combine art and code” task is the one that’s going to give if the going gets rough. To convert it from a task of fixed duration to a hammock task:



	First, make sure both the “coding” group and the “art” group are linked to “combine art and code” with finish → start dependencies.


	Then, create a start → finish dependency originating from the testing phase and linking to “combine art and code.”


	Finally, select the “combine art and code” task and open the task inspector. The fourth task type, Hammock, is available for selection.






[image: Selecting the Hammock task type in the Task Info pane of the task inspector.]



Step 11: Create Resources


Now it’s time to start adding the team members, equipment and materials we’ll be using to bring the project to fruition. Every person, piece of infrastructure, and raw ingredient that contributes to reaching the project’s goal is counted as a resource, so let’s get started.





[image: The single default resource that comes with a newly created project, as seen in resource view.]


Creating resources works much like creating tasks. Switch to resource view, which contains the resource outline. Create a few resources (as simple as pressing Return and name them. Then click the Type icon for each one and choose whether it is Staff, Equipment, or Material (like tasks, resources can also exist in hierarchical groups).


A timeline appears on the right side of the view for each resource you create, but it is empty until you assign the resource to some tasks.



[image: A list of resources created for our project.]



Note

When balancing workloads across multiple projects a staff member's email address is used as their unique identifier, so make sure their address is consistent across all the projects they're participating in.






Step 12: Assign Resources


You can assign resources to tasks from task view or from resource view.




In task view, you can select the task and then use the Task Assignments inspector to select which resources should be assigned to it.


Or you can just pop open the menu on the Assignment button in the toolbar.


In resource view, you can assign a task by dragging it from the Unassigned timeline (or the sidebar) into a resource’s timeline.



[image: Assigning resources to a task using the Task Assignments inspector.]


Customize the details of a resource with the Resource Information inspector (find more information in the Working With Resources chapter).



Note

When balancing workloads across multiple projects a staff member's email address is used as their unique identifier, so make sure their address is consistent across all the projects they're participating in.






Step 13: Set Individual Schedule Exceptions


Individual staff members may have personalized work schedules, and they’ll almost certainly have individual needs for time off. In the calendar view, choose a resource in the sidebar and create a regular weekly schedule for the resource just as you did for the project as a whole; then choose Extra & Off Hours from the toggle below the resource list and repeat the process for exceptions.





[image: Describing vacation time for an individual staff member in Calendar view.]



Step 14: Level Resources


Once we have a calendar of working hours, a set of established tasks and milestones, and a team of people with the tools they need to complete them, OmniPlan can optimize the efficiency of work that’s happening through a process called leveling.




Resource leveling analyzes your project and figures out the most efficient way to arrange it, taking into account things like dependencies and the amount of resources available.


If you make some manual changes to the schedule, like rescheduling incomplete tasks, setting up dependencies, or changing resource assignments, you should then level the project again to make sure your resource usage is balanced out.


To level the resource workload for your project, choose Level in the toolbar or Level Resources from the Project menu (⇧⌘L). The leveling dialog appears, with options to customize the leveling process; for now, leave these in the default configuration and click OK.


Unless your staff is already in the optimal configuration you’ll see the tasks in the Gantt view shift to accommodate the most efficient use of your resources’ time.



[image: Leveling resource loads using the Level button.]



Note

You can set OmniPlan to dynamically respond to updates in your project by automatically leveling resources every time you make a change. If you would prefer this, you can enable automatic leveling in the Project menu.






Step 15: Set the Baseline


With tasks set and resources assigned and leveled, the state the project is in now may be a glimpse at its fate in the best of all possible worlds — one where unforeseen hindrances don’t bog down progress, and where optimistic estimations rule the day.




This is the world that is captured when we set a baseline for progress, a feature used to compare how the project is actually doing against initial expectations, so milestones and resource allocation can be adjusted accordingly.


When you have a schedule set up and leveled properly, and the project is ready to begin, choose Set Baseline from the Project menu. This copies the schedule you created into a baseline schedule. The baseline schedules remain unchanged as you update the actual schedule; as the project goes on you can keep track of how closely it is following the original plans.



[image: Comparing split actual vs. baseline schedules.]


You can choose Split or Both from the Baseline/Actual menu on the toolbar to compare the baseline schedule to the actual schedule.



Step 16: Resolve Violations


Occasionally situations will emerge that break the rules of logic you’ve set up for your project. When one of these occurs, OmniPlan will let you know by indicating a violation related to the adjacent task.




If there are any logical inconsistencies in your schedule, they are marked with red icons in your task outline and in the status bar at the bottom of the window. Try creating a circular dependency in which two tasks both depend on each other. Because this is logically impossible, you should see a violation icon which you can click to resolve the problem.



[image: A violation appears! Use the violations window to identify and resolve it.]


Clicking on a violation icon displays the Violations window, which explains what the problems are and how to fix them. Most violations can be easily understood and solved here by clicking one of the provided links.



[image: Resolving a violation in the violations window.]



Step 17: Check the Critical Path


From the View menu, use the Customize Toolbar command to add the Critical Path button to your toolbar display.





[image: The critical path button added to the toolbar.]


The Critical Path button in the toolbar highlights the series of tasks and dependencies which determine the project’s duration (critical paths can also be charted to specific milestones rather than the project as a whole). If any of the tasks on a critical path ends up taking more or less time than planned, then the duration of the project as a whole will change as well. Usually, these are the tasks you most need to make sure are on track.



[image: The project's critical path is highlighted.]


Most of the tasks in a simple linear project will be on the critical path, because they are almost all in one continuous chain. Projects with multiple resources working in parallel, on the other hand, often have some tasks that can suffer a delay without affecting the deadline.



Note

Notably, in the case of our example project, only the final Testing Phase shows a critical path in the above screenshot. This is due to the presence of a hammock task prior to the Testing Phase group, which acts as a "shock absorber" to delays in earlier tasks. Until the duration of Combine art and code is reduced to zero by delays, tasks prior to it will not be considered part of the critical path for the entire project.






Step 18: Split Tasks


Whether because a key collaborator is on vacation or another part of the project has taken priority, suspending work on a particular task can be very helpful. When you want a resource or team member to devote time to something other than the task they’re currently assigned to, splitting the task into parts around the “time out” period is an ideal solution.





[image: A task ready for splitting via the contextual menu.]


To split a task:



	Select the task in the outline.


	From the Structure menu, choose Split Task.


	In the popover, adjust the duration of both sides of the split, choose the date and time you want the task to resume after the break, and click the Split Task button; the task is split for later completion.






[image: And now the task is split.]



Note

To rejoin a split task, click on one of its parts and drag it to the other. The two segments will merge back into a single task on the Gantt chart.





After splitting a task it’s always a good idea to level to be sure the split is the most efficient way to manage the task at hand given the project’s available resources and time constraints.



Warning

A split task may mysteriously re-merge after leveling. If this isn't what you want, make sure that Allow Splitting is checked in the leveling dialog.






Step 19: Update Task Completion


As progress on the project continues, inevitably some tasks will be completed outside the timeframe initially projected. It’s a good idea to review the project in OmniPlan periodically and update it to reflect the new situation.




You can update progress of individual tasks by editing the percentages in the Completed column or the Task Information inspector. Or, just drag the completion handle on a bar in the Gantt chart.



[image: Updating task completion using the task completion slider.]


If everything is going as planned, you can click the Catch Up toolbar button to bring the completion percentage of every task (or just the selected tasks) to a selected date.


If you have tasks which were planned to be complete by now, but aren’t, you can click the Reschedule toolbar button to move them forward. Afterwards, remember to level the project.



Step 20: Collaborate via Server Repository


On a large project, or one where the collaborators are spread across diverse geographic locations, you may want to have multiple team￼members able to update the project status remotely. OmniPlan makes this easy!





[image: Configuring publishing and subscriptions.]


To share the project you’re currently working on, choose Configure Publishing and Subscriptions from the Project menu, then use the plus button below the Publish & Update Actions list to add Sync entire plan with OmniPlan server repository to the list of actions.


You’ll need to choose a server account to sync to; if you don’t have one set up, click Account Info to visit the Accounts pane of Preferences and set one up. See Accounts in the Preferences chapter to get started.


The options beneath the pub/sub actions list define when and how the project is automatically published to the server and updated from the remote version. You can update from the server at any time by choosing Update (⌃⌘U) from the Project menu or toolbar, and publish your local version to the server with Publish (⌃⌘P) or the Publish toolbar button.


When you have your settings the way you want them, click Publish in the toolbar to bring your project to the cloud with its very first sync.



Step 21: Balance Multi-Project Resource Loads


If resources (usually human members of your team) are shared between multiple projects in the same repository, you’ll want to decide in the Configure Publishing and Subscriptions panel whether you’ll publish the current project’s resource loads to other projects and whether the current project will subscribe to the resource loads of others.





[image: Choose whether to publish the project's resource loads, subscribe to those of others in the same repository, or neither.]


Choosing to publish a project’s resource loads means that other subscribing projects will obey its workload information when leveling; if Julie is working on Project A on Wednesday and its loads are being published to Project B, after leveling Project B won’t schedule her to work on Wednesday.


Choosing to subscribe to resource loads means that the project will obey all constraints by projects in the repository that are publishing their loads. By using only the publish or subscribe option a hierarchy of priority can be established between simultaneous projects — a project that only publishes will always have its needs met first, while a project that only subscribes will be assigned resources only when they can be spared.


By both publishing and subscribing, projects are treated as equals — and if a project neither publishes or subscribes, it ignores external factors and syncs only with its own updates.



Note

Reminder: the key to balancing resource loads across projects is that individual resources be tagged and identified by a unique email address that is shared across all projects. This can be set using the Resource Information inspector.








Working with Tasks


Tasks are the building blocks of any project: the steps that must be completed on the road to an ultimate goal. OmniPlan provides a suite of powerful tools for customizing tasks — and the relationships between them — to match the exact parameters of your project.





Creating and Deleting Tasks


There are several ways to create new items in task view:





	Select an item in the task outline and press Return (or ⌘-Return, depending on the Keyboard Options in OmniPlan’s keyboard preferences).


	Click the Add button (plus button) below the outline.


	Click the Add button in the toolbar above the outline.


	Secondary-click and choose Add ▸ task type from the contextual menu.





There are a few ways to delete a task, milestone, or group:



	Select an item in the outline, then press the Delete key.


	Select the item, then click the Remove button (minus button) below the outline.


	Select the item, then click the Remove button in the toolbar above the outline.


	Select the item, then secondary-click to reveal the contextual menu and choose Delete.






Note

If you’re publishing and subscribing, new tasks and changes can come from other users of the project. Use the change tracking sidebar to accept or reject these changes.






Creating Milestones


There are several ways to make a new milestone in task view:





	Create a new task, then secondary-click on the task and use the contextual menu to change its Type to Milestone.


	Click the Add Milestone button in the toolbar.


	Choose Add ▸ Milestone from the action menu below the task outline.


	Use the keyboard shortcut ⇧⌘M.





Use the Project Milestone Inspector to manage your milestones and see the critical path leading to each one.



Connecting Tasks with Dependencies


When you have a task which requires something from another task, you can represent their relationship with dependency lines. A dependency line is drawn from the beginning or end of one task (or group, or milestone) to the beginning or end of another.




When you create a dependency, the dependent task automatically reschedules itself to respect the dependency. With further changes to the schedule and leveling, the tasks continue trying to follow the dependencies. If a dependency becomes impossible or you manually make a task stop obeying its dependencies, a violation occurs, and you should resolve it with the Violations window.


There are a few ways to connect tasks:



	Select two or more tasks in the outline view or the Gantt chart, then click the Connection toolbar button to create a Finish to Start dependency.


	Select two or more tasks in the task outline or the Gantt chart, then click the triangle in the corner of the Connection button—or click and hold the Connection button—to summon a menu of dependency types; choose the type you want.


	Put the mouse pointer over a task bar in the Gantt chart, then drag one of the arrows that appears at the beginning or end of the bar. It becomes a dependency line, which you can then drop onto the start or end of another task, group, or milestone. Whether you drag from the start or the end of the prerequisite task, and whether you drop onto the start or end of the dependent task, determines the type of dependency.


	In the Dependents or Prerequisites columns of a task, type a dependency or prerequisite code. These codes combine the IDs of the tasks involved and the type of dependency like so:



[image: An example set of possible dependency arrangements.]



	A Start to Finish dependency from task ID 1


	A Start to Start dependency from task ID 1


	A Finish to Start dependency from task ID 4.1. (FS is the most common type of dependency, so a task ID by itself without any letters is assumed to be FS.)


	A Finish to Start dependency from task ID 4.2, with a lead time of 1 day.









Types of Dependencies


OmniPlan supports four types of dependencies that describe the ways in which tasks relate to one another.





	Finish→Start


	The first task must end before the second task can start; the tasks must not overlap except at the instant the first one ends. This is the most common type of dependency, and the kind that you get when you connect two selected tasks by clicking the Connection button in the toolbar.


	Finish→Finish


	When the first task ends, then the second one can end; the tasks may overlap.


	Start→Start


	Once the first task has started, the second one can start; the tasks may overlap.


	Start→Finish


	Once the first task starts, the second one can finish; the tasks must overlap at least at the instant the first one starts.






Creating Hammock Tasks


A hammock task is a task where the amount of time it takes to complete the task is dependent upon the completion of the task that precedes it and the start of the task that comes after.




For example, if you were to prepare a written document, the time allotted for editing would vary depending on the completion of the document and its due date.


To create a hammock task, first create a finish→start dependency with the preceding task and a start→finish dependency with the task that comes after. (See more on Dependencies for how to create a Start to Finish dependency.)


Then select the the soon-to-be hammock task, and choose Type ▸ Hammock from the gear menu in the bottom bar (or the contextual menu). A task's type can also be changed using the Task Information inspector.



Grouping Tasks


There are a few ways to approach grouping, depending on whether you're starting with an existing set of items you want to add to a group, converting an existing item to a group, or creating a brand new group task.





	To convert a task to a group with new child tasks inside it:


	Select the item you want to grant sub-tasks.

	Choose Add Child Task — ⌘} from the Structure ▸ Add menu.

	The selected item becomes a group with one child task.

	Add more tasks to the group by pressing Return.





	To bring tasks into a group within a peer task above them in the outline:


	Select the items to be grouped.

	Choose Indent — ⌘] from the Structure menu (or Tab, depending on your preference setting).

	The items become children of the item above them in the outline.





	To bring tasks into a newly created group:


	Select the items to be grouped.

	Choose Group — ⌘⌥L from the Structure menu.

	The selected items become children of a newly created group.








	To create a new group with nothing inside it:


	Choose Add ▸ Group from the Structure menu.

	A new, empty group item is created.

	To add items inside the group, open it by clicking the disclosure triangle next to the group name (or its bar in the Gantt chart), and with the group selected, create new tasks as normal.








Characteristics of Task Groups


A task group determines most of its characteristics from the tasks it contains, rather than having characteristics of its own. A group's characteristics can be viewed (and in some cases defined) in the Task inspectors.





	Name — Of course, a task group has its own name.


	Type — A task group can contain tasks, milestones, and other groups, but its own type is always group. (An empty group has no effort or duration and can serve as a placeholder.)


	Effort — The effort of a group is the sum of the effort of all tasks it contains.


	Duration — The duration of a group is the amount of time between the beginning of its first task and the end of its last task, not the sum of the durations of all its tasks. If a group contains three one-hour tasks all happening at the same time, the group has a duration of one hour, not three hours.


	Scheduling — A group can have a specific start date, which can then affect the start dates of tasks inside it.


	Dependencies — A group can have dependencies just like a regular task.


	Resource Assignments — If you assign a resource to a task group, the resource gets assigned to all tasks in the group. The group itself can’t have any resources assigned.






Visual Planning in the Gantt Chart


Many attributes of tasks can be edited directly with the mouse in the Gantt chart. When you put your mouse pointer on a task bar, controls appear for manipulating the task.





Changing the Chart’s Scale


You can zoom the Gantt chart (and the resource timeline) in and out using the Magnifying Glass menu in the upper-right corner of the chart, or by putting the mouse pointer in the chart’s header area and dragging left or right, as if you were resizing a column.





[image: Changing the Gantt chart's scale with the Magnifying Glass menu.]



Changing the Duration of a Task


To change the duration of a task:





[image: Changing the duration of a task in the Gantt chart.]



	Grab the little traction pad at the right end of a task bar.


	Drag the end of the bar left or right to change the task’s duration. You can hold Shift while dragging to snap to round values.






Adjusting Task Completion


To adjust how much of a task has been completed:





[image: Adjusting task completion in the Gantt chart.]



	Grab the white, house-shaped handle on a task bar.


	Drag the handle to update the completion.






Drawing Dependency Lines


To draw dependency lines between one task and another:





[image: Drawing dependency lines in the Gantt chart.]



	Put the mouse pointer over a task bar in the Gantt chart to see the mini dependency lines.


	Drag a mini dependency line from the beginning or end of one task.


	Drop the line onto the beginning or end of another task to create a dependency.






Drawing Constraints on Tasks


To draw constraints on tasks:





[image: Drawing constraints on tasks in the Gantt chart.]



	Hold Shift and drag from the beginning or end of a task to create a start or end constraint.


	Hold Shift and double-click an existing constraint to remove it.






Locking Start or End Dates


To anchor a start or end date to a fixed point in time:





[image: Locking an end date in the Gantt chart.]



	⌘-click a task’s start or end to lock or unlock it.





Changing Item Labels


You can customize the data that appears on the sides and on top of tasks, groups, and milestones in the Gantt chart. Just choose View Options from the View menu and use the pop-up menus on the right side of the View Options panel.





Editing Tasks


Tasks have a lot of details to keep track of. When you select one or more tasks in the task outline, the Task Information inspector shows the task details.





Task Information Inspector


Key attributes that define the type and scope of a task can be edited using the Task Information inspector.





[image: The Task Information inspector.]



	The task Name is the same as the one that appears in the task outline.



	You can change the Type from a normal task to a Milestone (a zero-length event which represents an important moment in the project’s life), a task Group (which can contain child tasks), or a Hammock Task (one whose duration varies based on the completion of the preceding task and the start of the task that follows).



	Effort is how much total work it will take for this task to be complete. Duration is how much time it will take to get that work done. These can differ based on how many resources are assigned to the task, and the efficiency of the assigned resources. Note that if you enter a number without any units, OmniPlan assumes that you mean the smallest enabled unit in the Project Formatting inspector.



	The amount Completed is a percentage of how far along the task is. This is also displayed as shading on the task bar in the Gantt chart. You can adjust this manually by dragging the slider or entering a time in the field.



	The task Cost is how much money the task takes to complete. The resources are the per-use or per-hour costs of resources assigned to the task.






Task Schedule Inspector


The Task Schedule inspector describes where the task is positioned in time — both actually, and relative to the baseline — along with other temporal constraints and scheduling priorities.




[image: The Task Schedule inspector.]



	The Actual start and end dates are when the task really happened during the execution of the project. These can be locked against accidental editing, changes from dependencies, and leveling.


	Constraints indicate the earliest a task may begin and the latest it may end. Editable date fields have this calendar icon; click it to summon a mini calendar window you can use to choose a date and time.


	The Baseline start and end dates indicate when the task is expected to start and end, according to the original plan. These appear once you use the Set Baseline command on a project.


	The Variance shows how much the actual dates differ from the baseline dates. This is calculated automatically; you don’t have to enter it yourself.


	Use Scheduling to choose whether the task is scheduled as soon as possible (ASAP) or as late as possible (ALAP).


	When leveling, if Splitting is allowed the task may be divided into multiple parts to maximize efficiency of resource use. Otherwise the task will be scheduled as a contiguous time span.


	Use the Leveling controls to set a priority for the task; this determines the order in which tasks are assigned resources when leveling. Delay is a value set automatically in the leveling process that notes how long a task has been postponed to wait for resource availability.






Note

ASAP and ALAP scheduling can be set both for individual tasks and at the project level. This is also referred to as setting the direction of the task or project.


While tasks in most projects with defined start dates are scheduled to begin as soon as possible, individual tasks may benefit from ALAP scheduling when completing them later would be advantageous (some marketing work, for example, may benefit from a product being as fully developed as possible before it begins).






	Click the Splitting toggle to allow tasks to be automatically split when leveling.


	Assign the task a numerical Priority if you want to manually affect the order in which tasks are ordered when leveling. (Also see the priority section of Using Columns in the Task Outline.)


	Delay is the amount of time a task has been pushed back from its original scheduled time by leveling.






Using Columns in the Task Outline


Various columns are available for display in the task outline. Set which columns are visible by choosing View Options (⌘J) from the View menu, or secondary-clicking the column headers. Data in these columns corresponds to tasks on the same row in the Gantt chart.





[image: View Options for the task view.]


Some of the values in the columns (such as Task Cost) can be edited directly in the outline; others (such as Total Cost) are calculated automatically. Generally, values you can edit in the outline are also editable in the Task Information or Resource Information inspectors.


Use the Arrow keys, or Tab and Shift-Tab (depending the options you've chosen in OmniPlan’s preferences), to move between cells.


Drag column titles left and right to rearrange the columns.


Each key you set up in the Task and Resource Custom Data inspectors becomes available as a column in the outline.


You can sort the selected items in the outline, or all items (if nothing is selected), by using the Sort commands in the Structure menu.




	Violations

	This column displays an icon for each task that has a violation. You can click the icon to summon the Violations window and see what the problem is.


	Status

	This column shows alarm clock icons for tasks that are incomplete and due in the next few days, or in the past. Note that these icons won’t appear if your project has an undetermined start date in the Project Information inspector. Each color of clock has a meaning:





	Almost due: this task is incomplete and due in the next 3 work days.


	Due: this task is incomplete and due in the next work day.


	Past due: this task is incomplete and past due.






	Priority

	You can manually set a priority on a task, to control the order in which tasks are leveled. Priority can be any integer, so you are welcome to decide on the range (1 to 3, 0 to 999, or whatever you like). During leveling, if two tasks are assigned to one resource at the same time, the task with higher priority (expressed as a larger positive number) gets to use the resource first.





Note

When assigning priorities (regardless of the range chosen), the highest priority task is the one with the largest numerical integer assigned. Priority descends from the largest integer, and negative integers are of lower priority than positive.






	Assigned

	This column lists the resources that are assigned to the task.


	Attachments

	You can click the paper clip icon Attachment icon in the selected row to see a menu of the item’s attachments, or to link to a file if there isn’t one linked yet. Rows with links to files show a paper clip icon even when they are deselected.


	Notes

	You can click the note icon in the selected row to show or hide the item’s note, or to create a note if there isn’t one yet. Rows with notes show a note icon even when they are deselected.


	Unique ID

	The unique ID is a number assigned to each task or resource to identify it unambiguously, even if its name or position in the outline changes. A unique ID won’t ever change, and each new task or resource you create gets a new unique ID number. These numbers are useful for matching up items when you are importing and exporting projects between OmniPlan and other applications.


	Free Slack, Total Slack

	These columns display information derived from how the project is set up. Slack is the amount of time a task can be delayed before it must be completed for a subsequent task to begin, or for the project to be completed on time; free slack refers to slack between individual tasks and their subsequent tasks, while total slack refers to the time before an individual task would have an effect on the duration of the project as a whole.






Filtering the Task Outline


When you want to focus on a specific aspect of your project, you can view a subset of its tasks by creating filters for specific criteria. Possible filters include focusing on tasks that were completed in the past week, tasks that are behind the baseline target date by greater than three days, or as in the example below, tasks that are less than 50% complete.





[image: Filtering the Task Outline.]


Choose Filter Tasks (⌥⌘F) from the View menu, or click the Filter button in the toolbar. A sheet appears for setting up your filtering criteria. You can add as many criteria as you like by clicking the plus icon on the right side of the entry line, and filter the criteria themselves by option-clicking on the add button to create nested criteria within the filter hierarchy. When your criteria are set up the way you want them, click the Save Filter dropdown menu to save the current filter or restore a previously saved filter. (You can also use the View ▸ Restore Saved Filter menu item.)


When your filter is set, any tasks which match your criteria remain in the outline, while the rest of the project is hidden away. You can work with the project normally while it is filtered, but you can only edit the visible tasks. While your filter is in use the Filter Bar appears, providing options to edit or remove the filter and showing the number of tasks hidden.


If you export or print a project while a filter is on, only the visible tasks are included in the exported file.



Note

Filters are not included when exporting from OmniPlan 2 to the older 1.x version of the OmniPlan file format.





When you’re done, choose Remove Filter from the View menu or click the toolbar button again; all of your tasks reappear, no worse for the wear.





Working with Resources


Resources are the lifeblood of any project, without which an idea will never reach fruition. Effective management of personnel, equipment, and raw materials is key to bringing your project to a successful conclusion, and OmniPlan provides the tools you need to do just that.





Creating and Deleting Resources


There are several ways to create new items in resource view:





	Select an item in the resource outline and press Return (or Command-Return, depending on the Keyboard Options in OmniPlan’s keyboard preferences).


	Click the Add button (plus button) below the outline.


	Click the Add button in the toolbar above the outline.


	Drag a Contacts card into the resource outline to create a Staff resource which collects its contact information from the Contacts.


	Secondary-click and choose Add ▸ Resource from the contextual menu.





There are a few ways to delete a resource or resource group:



	Select a resource or group in the outline, then press the Delete key.


	Select the item, then click the Remove button (minus button) below the outline.


	Select the item, then click the Remove button in the toolbar above the outline.


	Select the item, then secondary-click to reveal the contextual menu and choose Delete.






Note

If you’re publishing and subscribing, new tasks and changes can come from other users of the project. Use the change tracking sidebar to accept or reject these changes.






Assigning Resources to Tasks


Most tasks require some kind of resources in order to complete. Software development needs programmers, excavation needs heavy machinery, and construction needs lumber. Tracking which resources are assigned to which tasks helps you to see how long the tasks will take to complete, and when your resources are going to be busy or idle.




There are several ways to assign a resource to a task:



[image: Assigning resources in the Task Assignments inspector.]



	Select the task in task view, open the Task Assignments inspector, and check the resources you’d like to assign. You can then edit the amount to assign, if it’s different from the default amount. You can also see all of a resource’s assignments, and adjust their amounts or clear them, in the Resource Assignments inspector.






[image: Dragging tasks between resource lanes in the resource timeline.]



	Drag tasks around between resources’ lanes and the Unassigned lane in the resource timeline chart. While dragging a task from one resource to another, you can hold the Option key to assign the task to the second resource without unassigning it from the first. 



	Drag a card from Contacts to a task in the task view. If the project doesn’t yet have a resource associated with that card, a new one is added.



	Edit the Assigned column of the task outline or the assigned resources area in the Gantt chart. The following are helpful hints:


	Enter resource names in the Assigned column to assign them to the task.



	You can also double-click resource lists in the Gantt chart and edit them directly there.



	Follow a staff resource with a percentage inside curly braces to assign an amount other than 100%.



	Follow a material or equipment resource name with a number in curly braces to assign an amount other than 1 unit.



	Separate multiple resource names with semicolons.










Grouping Resources


As with tasks, you can also group resources — and resources can be assigned to groups of tasks, as well.





Assigning Groups


If you assign a resource to a group of tasks, the resource becomes assigned to every task in the group. The group itself can’t have a resource assigned to it.




If you assign a group of resources to a task, OmniPlan provisionally labels the task as having the whole resource assigned. Then, when you level resources, one member of the group is chosen to work on that task. If that member becomes unavailable, leveling again assigns a different member.



Characteristics of Resource Groups


A resource group is just a way to organize several resources together, so it doesn’t have a lot of the same characteristics as an individual resource, like Efficiency and Cost.




Name — Of course, a resource group has its own name.


Address — You can assign an e-mail address to a group, in case you have a mailing list or some address which goes to all of the members in the group.


Type — A resource group can contain resources of any type (Staff, Equipment, or Material), but its own type is always Group.


Cost/Use, Cost/Hour, and Efficiency — These are shown as averages of the values of all members of the group. If you enter a new value, it is applied to all members of the group.



Editing Resources with the Resource Information Inspector


The Resource Information inspector contains all of the vital details about a staff member, piece of equipment, or raw material used in completing your project.





[image: The Resource Information inspector.]



	The resource Name is the same as the one that appears in the resource outline.



	A staff resource can be assigned an email Address. If the resource is associated with a Contacts card, you can use the pop-up menu to pick which address to use. Or, you can always just type an address.



	Click the Action button (gear menu) to associate this resource with a Contacts card, open the card in Contacts, or send an email.



	The resource Type can be Staff, Tool, Material, or Group.



	The Units value means how much of the resource is available. (For materials, this measures the amount required instead.)



	Efficiency is how much effort the resource can make compared to the amount of time it takes.



	The Start and End dates determine for which dates the resource is available.



	The Cost per Use is an amount of money for each time the resource is assigned to a task.



	Cost per Hour is an amount of money for each hour of effort the resource is assigned.



	Total Uses means the number of times this resource is assigned to a task.



	Total Hours is the sum of the effort of all tasks the resource is assigned to.



	Total Cost is the combined cost of all uses and all hours for this resource.






Tracking Assignments with the Timeline


When you want to manage your project from the point of view of the resources available, the timeline in Resource View will help you visualize and control your assets.





[image: An overview of resources in the resource timeline.]



	Click the bar graph button to show or hide the resource allocation graph beneath each resource’s timeline.



	The chart shows a timeline of tasks for each resource you select in the outline. If you select no resources, the chart shows all resources’ timelines. If the resource is unavailable during some normal working hours, because it has customized working hours, the unavailable times have a background of the Off-hours color (gray by default) as it is set in the Project Colors inspector.



	Below the resources’ timelines, an Unassigned timeline shows the tasks which aren’t assigned to any resource. You can drag tasks between timelines to change their assignments.



	A blue bar in the load graph represents time when the resource is being used at 100% of its available units.



	A pink bar in the load graph represents time when the resource is being used at over 100% of its available units. You can level the project to clear up such problems.



	You can zoom the timeline the same way you zoom the Gantt chart. Just choose a scale from this menu or drag in the header area.






Using Columns in the Resource Outline


As with task view, the resource outline can be customized to display columns with a wide variety of information about your resources. To show and hide columns, select them in View Options (⌘J) or secondary-click on the column header and toggle them in the contextual menu that appears.





[image: View options in resource view.]




	Attachments

	You can click the paper clip icon Attachment icon in the selected row to see a menu of the item’s attachments, or to link to a file if there isn’t one linked yet. Rows with links to files show a paper clip icon even when they are deselected.


	Notes

	You can click the note icon in the selected row to show or hide the item’s note, or to create a note if there isn’t one yet. Rows with notes show a note icon even when they are deselected.


	Unique ID

	The unique ID is a number assigned to each task or resource to identify it unambiguously, even if its name or position in the outline changes. A unique ID won’t ever change, and each new task or resource you create gets a new unique ID number. These numbers are useful for matching up items when you are importing and exporting projects between OmniPlan and other applications.


	Custom Work Week

	An icon appears in this column if a resource has a work week that differs from its default work week; the default work week for a resource is defined by its parent (if it’s a member of a group) or the project (if it’s not). You can click the icon to see the resource’s work week, and from there you can always click the X button in the upper right of the week view to revert to the default.


	Schedule Exception

	An icon appears in this column if a resource has a work schedule that differs from its work week, such as when someone goes on vacation. You can click the icon to see the resource’s work schedule, and from there you can check the orange-highlighted dates to see where its exceptions are. You can click the X button in the upper right corner of any week view to clear the resource’s exceptions for that week.






Duration and Effort


Duration is how long a task takes in actual working hours in the schedule. If the task begins at 8:00 and ends at 12:00, that’s a duration of 4 hours. Note that non-working times don’t count; if a task starts one afternoon and doesn’t complete until the next morning, or spans a lunch break, only the working hours are counted. Also note that the resources assigned to a task may have different working hours than the project as a whole, and thus the displayed duration of a task may not match up exactly with the amount of effort it takes.




Effort is the total amount of working time put into a task by all assigned resources. A task with a duration of 4 hours, with 2 resources assigned at 100%, has an effort value of 8 hours. Note that Material resources don’t contribute to effort, only Staff and Equipment resources do.


The duration and the effort of a task can change depending on the resources you assign.


Each task has a setting in the Task Assignments inspector which controls whether to keep the duration fixed, the effort fixed, or both.


When you assign or unassign staff and equipment resources, the value that isn’t fixed re-calculates its value; the other field stays the same. Regardless of which value is calculated, you can always edit either value manually.


If both values are fixed, then assigning resources changes the assigned percentage.



What Makes Duration and Effort Change


Multiple factors influence both duration and effort. The most common variables are described below; adjusting them can help bring a project in line with the desired timeline for completion.






	Number of Assigned Resources

	Assigning more resources to a task generally causes the task to take less time, because the required effort gets completed sooner.


	Efficiency of Assigned Resources

	Assigning less-efficient resources to a task causes the duration to be longer than the effort, because the resource takes more time to achieve the same amount of effort.


	Assigned Amount and Available Units

	Assigning fewer units of a resource to a task causes the duration to be longer than the effort, because less of the resource’s time and energy is being spent on that task. This situation is common when a resource is split between multiple tasks at one time. The amount of a resource you can assign to tasks depends on the resource’s available Units (set in the Resource Information inspector or the Units column of the Resource outline). Assigning more of a resource than is available causes a violation and shows up as overutilization in the Resource timeline.







Using the Calendar


With tasks and resources in place, the project begins to take shape; the calendar is what anchors the project in real time. OmniPlan’s calendar view helps ensure that your project is finished on time with an array of customizable scheduling controls.





Setting Up Working Hours


The Normal Hours are a general set of working hours to be followed in a typical week. This set of hours is applied to every week in the project, thus determining how many hours of effort can be completed in each day. Resources inherit their work week schedules from the project, but you can customize them individually if they work different hours. To set up exceptions to the work week, for events such as half-days, holidays, and overtime, read on.





[image: The normal work week for the whole project, as shown in calendar view.]



Editing the Work Week


When you select a resource in the outline, you can edit that resource’s working hours. If nothing is selected, you can edit the working hours for the whole project.




If a resource’s work week is customized from the whole project’s normal work week, the custom work week icon appears in the Custom Work Week column.



[image: Editing the normal work week for a single resource.]




The green blocks represent blocks of working time. Drag to set a day and time range.


Click a block to select it; you can then press the arrow keys to move it, or press the Delete key to remove it.


You can switch to customizing the extra and off hours for specific days, rather than the normal work week, with the switcher below the resource list.


Drag any edge of a time block to resize it.


Drag or double-click in an empty area to create a new time block. Shift-drag anywhere to draw a red block that erases working hours. These techniques are useful for breaking up blocks that span several days, so that you can adjust them individually.




Editing Exceptions


The Extra & Off Hours are a calendar of the working hours for specific days. You can set up holidays, half-days, overtime, and other such exceptions to the normal work week. Just like the normal work week, there is a work schedule for the whole project, which the resources follow, but you can also customize resources individually.




Select a resource in the outline to edit its work schedule, or select nothing to edit the work schedule for the whole project.


If a resource has any exceptions to its normal work week, the Custom Exceptions icon appears in the Schedule Exception column.



[image: Editing the schedule exceptions for a single resource.]




You can edit the time blocks here in the same way as when editing the normal work week. Shift-drag to create unavailable times.


The normal work week appears with a green dotted border, so you can see how this week’s schedule differs.


Choose a week to edit from the mini calendar. Days which differ from the standard work week are blue. Click the arrows to move between months; Option-click to move a year at a time.






Configuring your Project


When initially setting up your project there are many factors that might come into play. This chapter delves into the details of OmniPlan’s custom configuration for projects.







Setting a Start or End Date


If you know when the project is going to start or end, you can enter a date in the Project Information inspector. All of the working hours and work schedule exceptions as set up in the calendar view can then be applied properly, and real dates appear in the interface. When your project has a start date, the tasks are scheduled from that point on as soon as possible. When your project has an end date, they are scheduled from that date backwards, as late as possible. You can change a task’s dates and direction in the Task Schedule Inspector.





[image: Setting a start or end date in the Project Information inspector.]



Note

Setting a project's start or end date defines the project's direction: whether the schedule is built forward from a start date, or backward from an end date. In the former case all tasks in the project are scheduled for completion as soon as possible (ASAP), while in the latter case all tasks are scheduled as late as possible (ALAP). Changing the direction of individual tasks is covered in the Task Schedule Inspector section.


While tasks in most projects are scheduled for completion as soon as possible, it can be helpful to  plan a project with a defined "ship date" from that date backward to help determine when work on it should begin.





If you don’t know when the project will start or end, you can mark the start date undetermined in the Project Information inspector. For the purposes of applying the work week, the project is assumed to start on the first day of the week. The normal work week for the project and for the individual resources is respected, but work schedule exceptions such as holidays are ignored.



[image: Choosing whether the project is dealing with specific or undetermined dates.]


In a project with an undetermined date, all dates are represented in the format “T day”, for the first day of the project, or “T + x”, where x is some time duration. For example, “T+2w 1d” means 2 weeks and 1 day after the start of the project.



[image: A project scheduled with undetermined dates.]


When you change the start or end date of an existing project from an undetermined date to a real date, the project may shift as the new position of weekends, off-days, and other exceptions are taken into account.





Customizing Display of Time and Currency


You can use the Project Formats inspector to define how your project displays units of time and currency.





[image: The Project Formats inspector.]


Use the Dates section to choose whether to include seconds, the time of day, or both in your displayed dates.


Choose a standard Currency format from the list, or just type the number 1234.56 in the format of your choice.


Time Units selected here are used to display durations and effort amounts. You can plan in hours, days, or whatever works best for you. Note that, in duration fields, if you enter a number without any units, OmniPlan assumes that you mean the smallest unit that is enabled here. Units of time (Duration and effort) are designated throughout OmniPlan by the abbreviations below:



	s — second

	m — minute

	h — hour

	d — day

	w — week

	mo — month

	y — year




If you want to go further than just customizing the display of durations, you can force OmniPlan to schedule in whole hours or whole days with the scheduling granularity setting in the Project Information inspector. Note that the date headers in the Gantt chart and resource timelines can also be customized with the Display preferences.





Setting Definitions of Work Time Units


When you’re not using a standard 40 hour work week or eight hour work day, you can customize your project’s standard units of work-per-time using the Project Unit Conversions inspector.





[image: The Project Unit Conversions inspector.]


Your work day may be any number of hours. These conversion factors determine how to add up hours into the larger units.


The effort conversion factors don’t actually change the working hours for the project, just the way durations are entered and displayed. To change the working hours, visit the work week section of the Calendar view.





Duration Approximation


Choosing how task durations are expressed in terms of time units and their granularity affects not only the visual appearance of tasks in the Gantt chart, but also how they’re scheduled. You may find it more useful to provide greater or lesser degrees of specificity in assigning times to tasks in your projects.






Rounded Time Values


If a value contains a unit of time that is too small to be displayed, you may see a rounded value. For example, if you have turned off the display of minutes in the Project Formats inspector, and you have a task that starts at 9:00 and ends at 9:55, the value you see is “< 1h”. If you want to know the actual value, you can turn on the smaller units in the Project Formatting inspector, or just check the start and end times. If you want to edit the value to conform to your units, you can just delete the greater-than or less-than sign and the value updates.






Scheduling Granularity


Taking the duration rounding a step further, you can use the Granularity control on the Project Information inspector to force OmniPlan to round every duration up to the nearest whole hour or day. This setting is not just for display purposes, but actually changes how exact OmniPlan should be about scheduling tasks.





[image: Granularity in the Project Information inspector.]


By default, OmniPlan uses Exact Scheduling: if you have a task with an effort of 58 minutes, starting at 8:00, then it is drawn exactly 58 minutes long on the Gantt chart, dependent tasks start at 8:58, leveling makes the resource begin working on the next task at 8:58, and so on. The start and end times of tasks are exact down to the second.


With Hourly Scheduling, start and end times happen at the next whole hour mark. A task starting at 8:00 with an effort of 58 minutes (or even 1 minute), ends at 9:00; successor and resource leveled tasks begin at 9:00, and so on.


With Daily Scheduling, start and end times are always pinned to the beginning or end of work days. The 58-minute task ends at the end of the day, successor and resource leveled tasks begin on the next day, and so on. 


Regardless of the granularity setting, OmniPlan doesn’t forget any of the values you enter. You can still specify task effort and resource units with any amount of precision, and OmniPlan stores those values in case you switch back to exact scheduling.





Using Notes


The task outline and the resource outline both have a Notes column, which you can use to store extra text about any item.




To edit the selected item’s note, press ⌘-’ or click the Note icon note in the Notes column.


Once an item has a note, you can move in and out of the note field by pressing Command-’ (which hides the note after you stop editing it).


The font style of notes can be set up in the Project Styles inspector.





Using the Custom Data Inspectors


Each of the three main inspector windows (Project, Task, and Resource) has a Custom Data inspector. You can use this to keep your own information about the project or about individual tasks and resources.




Custom data is stored as key/value pairs. The Key is like a label for what type of information you are storing, and the Value is the information itself.



[image: Adding custom data to a resource using the Custom Data inspector.]


For example, here’s how you could keep track of staff members’ phone numbers:



	Select a staff resource in the resource outline, and open the Resource Custom Data inspector.


	Then click the plus button at the bottom of the inspector to create a new key/value pair.


	Name the key “Phone Number”.


	Enter a number as the value for the selected resource.





Now that you’ve created the key for this resource, every other resource has the same key, ready for you to enter a value.



[image: Showing custom data as a column in the resource outline.]


You can show custom data as a column in the task and resource outlines, or as a label in the Gantt chart and resource timeline, by choosing View Options from the View menu.





Linking Files to a Project


Each of the three main inspector windows (Project, Task, and Resource) has an Attachments inspector. You can use this to keep references to files that are relevant to your project or to particular items in it.




To link a file to an item in the task outline or resource outline:



[image: Attaching a file to a resource using the Resource Attachments inspector.]



	Click the item to select it.


	In the Task Attachments inspector or the Resource Attachments inspector, click the plus button below the attachment list, then choose a file in the dialog that appears. If you are showing the Attachments column in the outline, you could also click the paper clip icon and choose Attach File from the pop-up menu, then choose a file. Or, easiest of all, just drag a file into the attachments list.


	The file appears in the inspector’s attachments list.





To attach a file to the project itself:



	In the Project Attachments inspector, click the plus button below the attachment list, then choose a file in the dialog that appears. Or, just drag a file into the attachments list.


	The file appears in the inspector’s attachments list.





You can open an attached file by selecting it in the appropriate Attachments inspector and then clicking the Open button, or by choosing it from the pop-up menu in an item’s Attachment cell in the outline.



Warning

Every file attachment is a reference to the file elsewhere on your disk. If you move the files around, the references try to keep track of the new location. But if you are going to send a project to someone else, or otherwise move your project to another computer, the other files won’t automatically come along for the ride. In that case you should gather all of the attached files into one folder along with the OmniPlan file itself, and send the whole folder.





You can show attachments as a column in the task and resource outlines by choosing View Options from the View menu.





Using the Project Styles Inspector


The Project Styles inspector provides the ability to customize the appearance of your project as a whole, as well as individual elements inside it.





[image: The Project Styles inspector.]



	Structural Styles — Styles that apply to all items of a certain type in the OmniPlan interface.


	Named Styles — Custom styles you can apply wherever you like.


	Font Controls — Choose a font, a color for the text, and a color for the background.


	Task Bar Color Controls — Set up colors for incomplete and complete tasks. Of course, these are only available for tasks, groups, and milestones.







Structural Styles


You can change the style of a lot of items at once, based on what they are. For example, you could change the font size for the whole project, make all resource names italic, or make all completed tasks gray.




To set up a structural style, select the one you want to change from the list in the Project Styles Inspector.


Use the style controls on the right side of the inspector to change the default style for everything of the selected type.


The following structural styles are associated with various elements of OmniPlan's interface:




	Whole Document

	Everything throughout the entire document; it can be overriden by the more specific styles listed below it.


	Column Titles

	The headers above the outline views and charts, and the sideways resource names in the resource timeline.


	Notes

	Notes attached to tasks and resources.


	Tasks

	All tasks, but not groups or milestones. Note that the Completed Tasks and Overdue Tasks styles can override this.


	Completed Tasks

	Any task whose completion is at 100%. You could, for example, make tasks’ Gantt bars turn gray when they are finished.


	Overdue Tasks

	Tasks which were scheduled to complete in the past, but are not complete. You might like to turn these bright red so that you can see where your project is getting behind.


	Task Groups

	All groups of tasks. By default, their titles are in bold text to distinguish them from single tasks.


	Milestones

	All milestones. By default they are styled the same as regular tasks.


	Resources

	All resources, how they appear in the resource outline and as assignments on the Gantt chart.





Structural styles are the most general type of style, so named styles or ad-hoc styles can override them.





Named Styles


You can make up your own styles and reuse them throughout the document.





Setting Up Named Styles


Click the plus button at the bottom of the styles list to create a new named style.




Then, while you have the named style selected, use the controls on the right side of the inspector to change its attributes.


Once the style is set up how you want it, apply it to an item in the main window by either dragging it and dropping it on the item, or by selecting the item and then pressing the appropriate function key.


You can keep applying the named style to items, and any further changes you make to the named style will get applied to every item that has it applied.


Named styles take precedence over structural styles; if a structural style and a named style are both applied to the same item, the named style wins.





Ad-Hoc Styling


If you just want to apply a style to something without any special logic or updating, you can use an ad-hoc style.






Applying Ad-Hoc Styles


In the main window, select the items, or the part of a note, you want to style.




Use the right side of the Project Styles inspector to style the selected items.


Ad-hoc styles have the highest precedence. If an item has an ad-hoc style applied to it, that style wins over any named styles or structural styles.





The Style Attributes Inspector


The Style Attributes inspector lists all of the styles applied to the selection, in order of precedence. You can drag styles from here onto other items, or click the little X to remove a style.





[image: The Style Attributes inspector.]


Styles specific to this task (ad-hoc styles) have the highest precedence.


Structural styles (such as the style for all tasks) come next.


The Whole Document style is the most general.


You can drag these style chits onto other items or onto entries in the Project Styles inspector to apply them there.





The Project Colors Inspector


The Project Colors inspector provides tools to customize the colors seen throughout your project, including:





[image: The Project Colors inspector.]



	The background color of the whole document. This also affects the “Whole Document” background color in the Project Styles inspector.



	A color for every other item; set this to a nice low-opacity color to keep your rows distinctive.



	The color for non-working hours. Used only if you’ve set up the View Options to show off hours.



	Today’s date in the chart. Used only if you have a specific start date set in the Project Information inspector.



	The base color for lines between time spans (that fade in and out as you zoom).








Using Templates


A template is a file set up just right to be a starting point for a new project. For example, there might be certain resources you use for every project, a common task structure, certain named styles you like to use, and a standard set of working hours for your company. You can configure all of these things once, then create new documents from that template.






Creating a Template


Create a new document normally by choosing New from the File menu.




Set up the document however you like. Everything about a document, including its contents, the state of the Project inspector, the view options, and so on, can be saved to a template.


Once the document is ready, choose Save As Template from the File menu.



[image: Saving a document as a template.]


Enter a name for the template and confirm it.


When you create a document using the File ▸ New command, your new document follows the default template. To use a different template, use the File ▸ New From Template submenu instead.



Managing Templates


Choose Preferences from the OmniPlan menu, then click the Templates icon at the top of the preferences window.





[image: Managing templates in Template Preferences.]


A list of available templates appears. The default template is listed in bold type; this is the template that is used when you choose New from the File menu. Unless you choose a different one, the Empty Plan document included inside the OmniPlan application is the default template.


From the action (gear) menu below the list, you can:



	Edit: Change the selected template. You can also just double-click the template’s name in the list. When you save your changes, the template is updated.



	Edit a Copy: Make a different version of the selected template. Select this command, type a title for the new template, then change the document and save it as usual.



	Make Default: Use the selected template from now on when making new documents with the File ▸ New command. The template’s entry in the list changes to bold type.



	Rename: Change the title of the selected template.



	Move to Trash: Get rid of the selected template by putting it in the trash. From there, you can still recover it if you need it. Otherwise, it will be deleted the next time you empty the trash.






Note

If you'd like to reuse a specifically configured task multiple times within the same project, you can "template" tasks on the fly by selecting the task you'd like to duplicate and choosing the Project ▸ Set As Default For New Tasks menu item. Subsequently created new tasks will match the settings of the one you chose.









Maintaining your Project


The moment you’re ready to begin your project in earnest is the moment the real world starts to intrude on the ideal version of your plan. When variables begin to shift, adjusting aspects of the project to suit new circumstances is key to keeping things on track.





Resolving Violations


A violation is some kind of problem with the project, such as an impossible dependency loop or a task which is outside its start or end constraints. When a task has such a problem, the violation symbol appears in the Violations column of the task outline.





[image: A wild violation appears!]


You can click the little violation symbol, the Violations button in the toolbar, or use the keyboard shortcut ⇧⌘V to open the Violations window.



The Violations Window


This window lists all of the violations in the project, along with explanations of why they have occurred. Most violation explanations include links you can click to immediately resolve the problem (or hints for how to reconfigure the project to resolve the violation manually).





[image: Resolving violations in the Violations window.]



How Scheduling and Leveling Work


The Task Schedule inspector’s Scheduling method indicates how OmniPlan should determine when a task is to occur in the project.





[image: ASAP/ALAP toggle in the Task Schedule inspector.]


By default, new tasks are scheduled as early as constraints allow. This means the task is placed at the very earliest time possible, taking into consideration start and end constraints, and dependencies on other tasks. Resource availability is not taken into consideration, so resources may end up overutilized. Tasks can also be scheduled as late as possible or locked (with the lock icons above the Start and End dates in the Task Schedule inspector) so they are not affected. 


When you level the project (or whenever a change is made, if Automatically Level Resources is selected in the Project menu), OmniPlan rearranges tasks which have resources assigned, to make sure no resource is being used at more than 100% of its availability. Tasks moved back by resource leveling have their scheduling method changed to resource availability.



[image: Tasks scheduled by resource availability.]


During leveling, OmniPlan has to make an educated decision about which task should get access to a resource first, and which tasks should be pushed back by a resource dependency. In judging which task to put first, the following criteria matter, in this order:



	Requirements to end by a certain time, such as locked end dates, constraints, or being a prerequisite to a task with such a requirement.


	Task Priority, as set in the Priority column of the task outline.


	Position in the task outline; tasks with lower ID numbers are scheduled earlier.






Comparing the Baseline and Actual Schedules


Once you have finished setting up a project and you’re ready to start implementing it, you can set a baseline schedule. The baseline represents the original intentions of the project, for comparison with the actual schedule.







Setting the Baseline


Choose Split Schedule or Both Schedules to see the baseline and actual schedules together, so you can compare them.





[image: Comparing split actual vs. baseline schedules.]


Once you click the Set Baseline button, the baseline schedule is decided and any further changes are applied to the actual schedule instead.



Revising the Baseline


To revise the baseline schedule after it’s already been set:




Select the tasks to revise.



	Click the Set Baseline button.


	Select the Set only on selected tasks checkbox and click OK.





The selected tasks’ Baseline schedule updates to match its Actual schedule.


You can modify individual tasks’ baseline dates in the Task Information inspector.


You can also create multiple baselines for independent tracks within the project.



Catching Up Task Completion


If everything is going according to plan, just click the Catch Up button.





[image: Using the Catch Up button to bring task completion up to the chosen date.]


Choose a date and time (today by default), whether to allow tasks to be marked partially complete, and whether to update all tasks or just the selected ones.


The tasks’ completion percentages are updated to the specified date and time.



Rescheduling Incomplete Tasks


Some tasks are not as complete as they were scheduled to be.




Click the Reschedule toolbar button.



[image: Rescheduling incomplete tasks using the Reschedule button.]


Choose a date and time to reschedule the incomplete tasks, and whether to update all tasks or just the selected ones.


The incomplete tasks move, and the whole schedule updates, so that work can continue from here.


Note that this only moves tasks with incomplete work that was scheduled for before the date you specify; tasks in the future aren’t affected.



Managing Server Repositories


You can share projects by publishing them to an OmniPlan server repository. Choose Server Repository from the OmniPlan menu to see and manage shared OmniPlan projects.




The Account menu lists your Omni Sync Server and WebDAV accounts by name (as set up in Accounts Preferences); these are the types of account that can operate OmniPlan repositories. Choose an account in the pop-up to see the projects in its repository. To add to or edit your accounts, click the Account Info button.



[image: The Server Repository window.]


The list shows all projects that have been published to the repository, and the following information about them:



	Load — Indicates, by the presence of a vertical bar graph icon, whether these projects are sharing their resource load information with other projects in the repository for the purposes of leveling resources across projects.


	Last Modified — The date when the project was last modified by any user with shared access to it.


	Last Truncated — To optimize the speed of syncing on currently active projects, once a certain size threshold is exceeded in the sync log OmniPlan sets aside older changes on the server and “truncates” what is synced to only the newest set of changes. If OmniPlan sees that a project hasn’t been updated since the date the changelog was last truncated (shown here), it retrieves older changes from the archived logs on the server.


	Changelog, Total Size, File UUID — The file size of the changelog and total project respectively, and the unique ID assigned to the project on the server.





Publishing, Subscribing, and Change Tracking


Publishing and subcribing can be used to keep a project up-to-date between members of a team. Choose Configure Publishing & Subscriptions from the Project menu.





[image: Configuring publishing, subscribing, and change tracking settings.]


Click the Plus button below the Publish & Update Actions list to add an action. These changes can be published upon save and updated via Bonjour (or at a specified interval). If you’d rather update manually, you can choose to publish whenever the document is saved or leave both options unchecked and use the Project ▸ Update and Project ▸ Publish menu items.


If you have resources used by multiple projects hosted on the same server repository, you can choose to share information between them to avoid resource conflicts and overloads. Choosing Publish resource loads will broadcast the resource usage of the current project to all other projects that have chosen to Subscribe to other projects’ resources. Choosing both means the current project will both give and receive load information. When a project is leveled, resources will be reallocated to reflect their usage in other projects.


Resources are recognized by OmniPlan as identical across multiple projects on a server when they share the same unique email address.



Warning

Note that making changes to the Apple system clock while using Publish or Subscribe will result in an error, and should be avoided.





General actions:



	Execute a custom AppleScript upon publish or update.


	Export your document with one of the export options.





Use Subscribe actions to pull in changes from others. Be sure to set up sync accounts in OmniPlan ▸ Preferences ▸ Accounts, where you can set up and configure from among CalDAV, Google, Omni Sync Server, and WebDAV account syncing options to suit the needs of your project and team.


Note that due to limitations in Calendar sync, OmniPlan is able to fetch data out approximately 11 months from the present when subscribing to free/busy times from a Calendar server.



	Choose free/busy times from the Calendar Server to see available resource times and be notified of changes for particular resources or all of them.


	Choose offtime/overtime from iCal calendar to choose a calendar for the whole project or an individual resource. Specify whether events are extra or off hours.


	Choose offtime/overtime from web calendar and specify a URL, along with the schedule for a project or particular resource, and how events behave.





Use Sync to make changes to the project and pull in changes from others.



	Choose entire plan with OmniPlan server repository to sync all tasks, resources, and calendars—everything!—on a shared server.


	Choose to sync tasks to/from Calendar Server events to make changes and bring in changes from events on a calendar server.


	Choose to sync tasks to/from Calendar Server reminders to make changes and bring in changes from to-do items on a calendar server.


	Choose to sync tasks to/from iCal events to make changes and bring in changes from events in iCal.





Once you’ve specified the kind or kinds of subscribing you’d like to do, you can use change tracking to see your changes and accept or reject the changes of others.


To enable change tracking, use the Project ▸ Track Changes (⌥⌘T) menu item. A sidebar appears that logs the changes you make and shows the changes of your teammates.



[image: Change tracking with the Change Tracking sidebar.]


To accept or reject all changes, use the Accept All and Reject All buttons.


To accept or reject individual changes, use the Accept or Reject buttons on the individual changes in the list.



Balancing Resource Loads Across Projects


When multiple projects share the same personnel resources, you can ensure that they aren’t overloaded with work by sharing resource loads between projects in the same server repository.




To set up resource load sharing visit the Configure Publishing & Subscriptions screen in the Projects menu. There you can select whether this project’s loads will be published (causing other projects that subscribe to obey changes made to the current project’s resource allocation), whether the current project will subscribe to other projects (obeying their resource changes), or both. Once these settings are in place, future leveling of resources will take their use into account across all projects that publish and subscribe. For OmniPlan’s purposes a resource is designated as identical across projects by having the same email address assigned to it.



[image: Choose whether to publish the project's resource loads, subscribe to those of others in the same repository, or neither.]


Load sharing settings of the projects on your server account can be seen by visiting the Server Repository window via the OmniPlan menu. See Managing Server Repositories for more information.



Cleaning Up Stale Usage


When sharing projects on a server, in some cases resource load sharing information for deleted projects may be left behind on the server. This happens if someone removes a project that is sharing resource loads using a version of OmniPlan older than v2.1, or if someone deletes the file directly from Finder or Terminal.




If OmniPlan finds unused resource load information on the server, it detects the problem and prompts that you clean it up. Until you allow it to clean up, there may be misleading resource load information shared with your active projects.


The clean way to remove a project from a server repository is by opening the Server Repository window in OmniPlan v2.1 or newer and using the Delete Project button.






OmniPlan Extended


OmniPlan works great as a standalone app, but its capabilities don’t end there. OmniPlan interacts with other apps and services in a wide variety of ways.





Importing from Other Formats


OmniPlan understands several other applications’ file formats. You can open files of these types in OmniPlan the same way you would open an OmniPlan document. The file is imported into a brand new OmniPlan document, which you can then edit, save, or export.





[image: Be sure that Allow import of other recognized file types is checked in the Open dialog.]




	Microsoft Project (.xml, .mpx, .mpp, and .mpt)

	Documents created in Microsoft Project XML, MPX, or MPP formats can be opened by OmniPlan, with a few limitations. See the Microsoft Project support section for more information on Microsoft Project compatibility.


	Comma-Separated Values (.csv) and Tab-delimited text files (.txt)

	OmniPlan can read comma-separated or tab-delimited values from a plain-text file. To see how the data in a CSV file should be formatted, export an OmniPlan document as a CSV file and open the result in any text editor. Tab-delimited files are formatted like CSV files, except that tab characters are used instead of commas to separate fields.


	OmniOutliner 3 (.oo3 and .ooutline)

	Task lists can be imported from OmniOutliner files. A column mapping dialog appears, where you can choose which outline column should correspond to which field of task information. If the outline has multiple levels of hierarchy, task groups are created.


	OmniGraffle (.graffle)

	Task lists can be imported from OmniGraffle diagrams. The title of an object becomes the task title, and the hierarchy of connection lines determines the hierarchy of task groups.







Exporting to Other Formats


OmniPlan can write files in several formats, for use with other applications. To export an OmniPlan file, choose Export (⌥⌘E) from the File menu. When you export, a new file is created, leaving your original document as it is on the screen. Of course, not all aspects of an OmniPlan document can be represented in all file formats. (If you’re working in tandem with others, consider Publishing and Subcribing.)




If you export a project while a filter is on, only the visible tasks are included in the exported file.



	OmniPlan 2


	Of course, OmniPlan can export to its own format. This is useful when you want to use the filtering feature to make a new OmniPlan file of tasks matching certain criteria.


	OmniPlan 1


	OmniPlan 2 can export either the document as a whole or just the filtered contients to a format OmniPlan 1 can work with.


	iCalendar


	This is the calendar format used by Apple iCal, Apple Calendar, and many other calendar applications. You can choose to export the tasks as calendar events or as items on a to-do list. If you export calendar events, you can also choose whether each task should become to a single event, regardless of how long it may be (One event per task), or whether tasks should be broken into chunks when they span working and non-working hours (One event per work period).


	Comma Separated Values (CSV or CSV UTF–16)


	CSV is a common, plain-text format that can be read by many different applications.


	If you’re having trouble persuading other applications to read the non-ASCII characters in your CSV file, such as accented letters or non-Roman characters, try exporting with the UTF–16 CSV option, and importing that into the other application. This makes it easier for some applications to detect the correct encoding and interpret your characters properly.


	Microsoft Project Exchange (MPX)


	MPX is an older compatibility format that can be read by Microsoft Project 2002 and earlier, and written by Microsoft Project 98 and earlier. This format doesn’t support the Unicode character encoding standard at all, and is in general less reliable than the Microsoft Project XML format. See the Microsoft Project Support section for more information.


	Extensible Markup Language (XML) and Microsoft Project Plan (MPP)


	Microsoft Project 2002 and newer can read and write these formats. See the Microsoft Project Support section for more information.


	PNG Bitmap Image, PDF Vector Image, TIFF Bitmap Image, JPEG Bitmap Image


	You can export a picture of the task view or the resource view, whichever one is open in the main window. In the Export panel, you can choose whether the image should include the outline, the chart, or both.


	OmniOutliner 3


	The task outline is exported as an OmniOutliner file, with a column corresponding to each column in the OmniPlan document.


	OmniGraffle


	There are several ways to export to an OmniGraffle diagram.





	Work Breakdown Structure


Tasks and groups are represented by a tree of objects. The connection lines in this diagram type represent the hierarchy of the task outline; dependency lines are not represented.



	Activity-on-Node PERT Chart


Tasks are represented by objects, connected by dependency lines. While a Gantt chart emphasizes durations, this type of chart emphasizes the path of dependencies.



	Activity-on-Line PERT Chart


Tasks are represented as lines between objects, with the title and duration of the task as a label on each line. Like the Activity-on-Node PERT Chart, this diagram type emphasizes dependencies.


	AOL OmniGraffle export


When exporting to a Work Breakdown Structure or an Activity-on-Node PERT Chart, you can choose whether to represent tasks with basic objects (which just show the task name) or with tables (which show the task name, assigned resources, start date and end date).






	

	If you own an OmniGraffle license, you can style and edit exported diagrams. But even if you don’t own it, you can use an unlicensed copy of OmniGraffle (available at OmniGroup.com) to view, print, or export the diagrams.


	HTML Full Report


	A folder is created containing a full report of the project, including:





	An overview index page


	A task list


	A resource list


	A Gantt chart


	A resource timeline


	An iCalendar file of the project milestones


	iCalendar files with each resource’s tasks as events


	iCalendar files for each staff or equipment resource’s tasks as to-do list items






	

	If you know HTML and CSS, you can also make your own HTML templates.


	HTML Task List


	This is just the task list part from the HTML Full Report; it exports as a single HTML page.


	HTML Resource List


	This is just the resource list part from the HTML Full Report; it exports as a single HTML page.





Printing


OmniPlan supports the standard Mac OS X Page Setup dialog; choose Page Setup from the File menu to see it. You can set the paper size, orientation, and scale; this information is saved with the document.





Print-Time Options


Choose Print from the File menu to see the standard Mac OS X print dialog.




Select Show Details from the pop-up menu to see OmniPlan’s print options.



[image: OmniPlan print-time options for content display.]



	You can print the task view or the resource view, whichever one is open in the main window. You can then choose whether to print the outline, the chart, or both.



	Or, you can choose to print an HTML report of the project. This works just like exporting to a web page, and uses the same HTML templates.



	The dimensions are calculated based on the size of the project and the scale set in the Page Setup dialog. When you change the width or height, the other one changes accordingly. Note that this overrides the Scale setting in the Page Setup dialog.



	Notes and groups can also be printed expanded or collapsed, and task and resource groups can be printed as displayed in the project, or all expanded or collapsed.



	You can use the Cropping settings to chop off any part of the project you don’t need. An overview of your project is here. To define the area to print, resize the cropping box by draging its left or right edge, or move the box by draging its center. If you enter dates in the From and To fields, the cropping box updates to match.



	The preview shows what your project will look like on paper. Use the buttons to step through the pages and get an idea of the scale and layout.



	Note that like in any application that uses the Mac OS X printing system, you can “print” to a PDF file instead of to real paper.






[image: Header and footer customization options.]


Headers and footers can be customized extensively for printing by choosing Headers & Footers from the dropdown menu in the Print dialog's detail view.



	Use this menu to choose where custom headers and footers will appear in your printed document. Options include the Master Page (applied to every page printed, unless overridden by another page style), the First Page, Odd Pages, and Even Pages.



	The header and footer sections each have three fields that can be customized: left, right, and center-justified. You can enter custom text here, or:



	Use the Insert menu to add information automatically derived from your document to a header or footer field. These automatically generated attributes include:



	Page Number — The current page as scheduled to be printed based on other configuration choices.

	Print Time — The computer clock-derived time when the document goes to press.

	Last Modified — The date and time when the document was last modified.

	Absolute Path — The location of the document in your computer's file system.

	Page Count — The total number of pages in the printed document.

	Project Title — The name of the project file.






	As you update your custom headers and footers, changes are reflected in the print preview to give you an idea of how your document will look on paper.






Note

If you print the project while a filter is on, only the visible tasks are included in the printed copy.






Microsoft Project Support


OmniPlan is pretty good at working with Microsoft Project documents — up to and including the Microsoft Project 2013 .MPP format — and we’re always working to make it even better. There are a few things to take note of as you start working with Microsoft Project documents in OmniPlan:






	Assignments to task groups

	In Microsoft Project, a resource can be assigned to a group of tasks. In OmniPlan, this just assigns the resource to all tasks in the group, not to the group itself. When you import a Microsoft Project document with an assignment to a task group, a warning appears in the violations column to let you know that the assignment was not imported.


	Efficiency

	Microsoft Project doesn’t support the OmniPlan efficiency attribute for resources.


	Unequal assignments

	In Microsoft Project, if you assign more than one resource to a task you can specify how many hours of effort each assigned resource should contribute. If you don’t specify, it assigns however much work to each that will complete the task earliest (taking schedule and resource assigned units into account). OmniPlan always uses that same automatic method. So, a task with effort hours specified for its resources may take a different amount of time in OmniPlan than it did in Microsoft Project.


	Unicode characters

	The Microsoft Project MPX format doesn’t support the Unicode character encoding standard. If your project contains Unicode characters (say, some Chinese text for instance), you should use the more modern Microsoft Project XML or MPP format instead.







Customizing HTML Templates


If you know HTML and CSS, you can make your own HTML templates for exporting.




Choose Preferences from the OmniPlan menu, then click the HTML icon at the top of the preferences window.


To create a new template, select the Standard template (or another existing template) and choose Edit a Copy from the action menu below the list.


Enter a name for the template and save it in a convenient location.


The new template opens in Finder; it is a folder of HTML and CSS files that you can customize to your liking.


Due to security changes in OS X, HTML templates created in versions prior to OmniPlan 2.3 are automatically relocated and not available for direct editing. To change the contents of a migrated template, select it and choose Edit a Copy from the action menu.


The HTML templates use a special syntax for inserting data from the project. Open one of the HTML files in the text editor of your choice, and you’ll find standard XHTML interspersed with OmniPlan tokens that look like this:


{@Token Name@}


These tokens are placeholders for data about the project as a whole. When the template is used to export an OmniPlan file, each token is replaced by the data corresponding to the token name.


Project Tokens



	{@Date@} — The date of the export.


	{@Version@} — The version of OmniPlan that exported the report.


	{@Project Title@} — The title of the project, as set in the Project Information inspector.


	{@StartDate@}, {@EndDate@} — The start or end date of the project.


	{@StartTime@}, {@EndTime@} — The start or end time of the project.


	{@Duration@} — The duration of the whole project.


	{@Completion@} — The completion percentage of the whole project, as calculated from all tasks.


	{@Cost@} — The cost of the whole project.


	{@ResourceData@} — Place this at the tr level of a table; for each resource it creates a row of three cells, containing the resource name, a link to an iCalendar file of the resource’s assignments as events, and a link to an iCalendar file of the resource’s assignments as to-do items.


	{@ProjectCalendarLink@} — A link to the Project Milestones calendar, if there are any milestones.





Stylesheet Token



	{@ApplyStyleSheet include/style.css@} — This token applies a CSS stylesheet to the page, by specifying the path to the stylesheet. When the export happens, this token is replaced by one of two things:




If exporting a full HTML report, a link to the stylesheet as an external file. This lets all of the exported HTML files link to the same stylesheet.


<link rel="stylesheet" href="include/style.css"type="text/css" />


If exporting just one HTML page (a task list or resource list), an embedded copy of the stylesheet. This keeps everything in one HTML file.


<style type="text/css"> [...] </style>


Loop Tokens


These work like open/close HTML or XML tags. When the export happens, OmniPlan cycles through everything between the opening and closing tokens, inserting data about each task or resource. The Assignments loop has to happen inside the Resources loop, as it lists tasks that are assigned to a particular resource. Make sure that you include the closing token, and that your task-specific or resource-specific tokens are between the appropriate loop tokens.



	{@Tasks@} and {@/Tasks@} — Lists all tasks in the export; inside this loop you can use task-specific tokens.


	{@Resources@} and {@/Resources@} — Lists all resources in the project; inside this loop you can use resource-specific tokens and Assignments loops.


	{@Assignments@} and {@/Assignments@} — Lists all assigned tasks for a resource; this can only be used inside the Resources loop. Inside this loop you can use task-specific tokens.





Tokens for Tasks


These tokens can be used inside the Tasks loop or the Assignments loop of a resource.



	{@ID@} — The task’s number in the outline.


	{@Title@} — The task name.


	{@Start@}, {@End@} — Actual start or end time of the task.


	{@Time@} — Duration of the task.


	{@Effort@} — Effort value for the task.


	{@%Done@} — Completion percentage for the task.


	{@Dependencies@} — A list of the task’s dependencies, in the same format as the Dependencies column in the task outline.


	{@Cost@} — Cost of the task itself.


	{@Resources Cost@} — Cost of the assigned resources.


	{@Total Cost@} — Cost of the task and the assigned resources.


	{@Assigned@} — A list of assigned resources.


	{@Planned Start@}, {@Planned End@} — Baseline start or end time of the task.


	{@Start Variance@}, {@End Variance@} — Difference between the baseline and actual times for the start or end of the task.


	{@Constraint Start@}, {@Constraint End@} — Constraint on the task’s start or end time, if any.


	{@Notes@} — Text of the task’s note, if any.


	{@Priority@} — Task priority, just like the column in the task outline.


	{@Status@} — Some words to describe the task’s due or overdue state, like the Status icons in the task outline.


	{@Violations@} — Number of violations that involve this task.





*Custom data keys — If you include a token that exactly matches the name of one of your custom data keys, it is converted to the value of that key for the given task. For example, if you have a “Location” key for your tasks, you can use a {@Location@} token in your template.


Tokens for Resources


These tokens can be used inside the Resources loop.



	{@Resource@} — The resource name.


	{@Start@}, {@End@} — Actual start time of the resource’s earliest assignment, or end time of the resource’s latest assignment.


	{@Time@} — Total duration of all tasks assigned to the resource.


	{@%Done@} — Completion percentage of all tasks assigned to the resource.


	{@Resources Cost@} — Total cost of assigning this resource to its assigned tasks.


	{@Resource Type@} — The type of resource (Staff, Equipment, or Material).


	{@#@} — Total units value of the resource.


	{@Notes@} — Text of the resource’s note, if any.


	{@Efficiency@} — Resource’s efficiency value.


	{@Cost/Use@}, {@Cost/Hour@} — Cost per use and cost per hour values as defined in the Resource Information inspector.


	{@Total Uses@}, {@Total Hours@} — Total number of assignments, or total amount of effort assigned, for the resource.


	{@ResourceCalendarLink@} — A link to the resource’s assigned tasks as an iCalendar file of events, if it has any tasks assigned.


	{@ResourceToDoLink@} — A link to the resource’s assigned tasks as an iCalendar file of to-do items, if it has any tasks assigned.


	Custom data keys — If you include a token that exactly matches the name of one of your custom data keys, it is converted to the value of that key for the given resource. For example, if you have a “Phone Number” key for your resources, you can use a {@Phone Number@} token in your template.





Path Tokens


These provide the path to a particular page in the HTML export. You can use these to create links between pages; for example:


<a href="file:{@TaskReportPath@}">



	{@TaskReportPath@} — The file path to this HTML export’s Task Report page.


	{@ResourceReportPath@} — The file path to this HTML export’s Resource Report page.


	{@ResourceTimelinePath@} — The file path to this HTML export’s Resource Timeline image.


	{@GanttChartPath@} — The file path to this HTML export’s Gantt Chart image.


	{@ProjectCalendarPath@} — The file path to this HTML export’s Project Milestones calendar.






Accessing Items by URL


OmniPlan supports URLs (links) beginning with omniplan://. When you open such an URL, OmniPlan opens and highlights the specified item.




For example:


omniplan:/Volumes/Local/Users/someone/Desktop/Coffee%20Plan.omniplan opens the Coffee Plan project on the user’s desktop.


omniplan:/Volumes/Local/Users/someone/Desktop/Coffee%20Plan.omniplan/task/14 opens the project and highlights the task that has the unique ID of 14.


omniplan:/Volumes/Local/Users/someone/Desktop/Coffee%20Plan.omniplan/task/14,22,67 opens the project and highlights the tasks that have the unique IDs of 14, 22, and 67.


omniplan:/Volumes/Local/Users/someone/Desktop/Coffee%20Plan.omniplan/resource/2 opens the project and highlights the resource that has the unique ID of 2.


You can also make URLs which query for certain values other than ID: 


omniplan:/Volumes/Local/Users/someone/Desktop/Coffee%20Plan.omniplan/task?title=Clean%20Up opens the Coffee Plan project on the user’s desktop and highlights any task titled “Clean Up”.


omniplan:/Volumes/Local/Users/someone/Desktop/Coffee%20Plan.omniplan/task?name=Clean%20Up also opens the project and highlights any task titled “Clean Up”.


omniplan:/Volumes/Local/Users/someone/Desktop/Coffee%20Plan.omniplan/task?position=1.9.1 opens the project and highlights the task at outline position 1.9.1. Note that the URLs use hierarchical numbering regardless of whether you have hierarchical or flat numbering turned on in the View menu.


omniplan:/Volumes/Local/Users/someone/Desktop/Coffee%20Plan.omniplan/resource?name=Coffee%20Beans opens the project and highlights the resource named “Coffee Beans”.






Preferences


OmniPlan Preferences contain a variety of useful configuration options, and are accessible in-app from the OmniPlan menu or with the keyboard shortcut (⌘,).





General


The way that the Tab and Return keys work can be customized to suit the way you work. These options are in the General pane of Preferences, available from the OmniPlan menu.





[image: The General preference pane.]


When pressing Tab — You can set the Tab key to do one of two things:



	Indent the currently selected item in the outline, thus making it a child of the item above it; pressing Shift-Tab outdents the selected item.


	Move to the next cell in the outline; pressing Shift-Tab moves to the previous cell.





Either way, the Indent and Outdent commands in the Structure menu (and their keyboard shortcuts, ⌘[ or ⌘] by default) will always work.


You can always press Option-Tab to type a tab character at the insertion point.


When pressing Return in a cell, create a new row — When you are done editing the contents of a cell in the outline, you might press Return to finish editing. If this preference is turned on, a new item is then created. Otherwise, the editing just ends and the current item becomes selected.


Whether this setting is on or off, pressing Return while not editing a cell always creates a new item.


You can hold Command while pressing Return to temporarily change the setting; for example you could press Command-Return to finish editing and create a new item, even if the setting was turned off.



Display


The Display preferences are the second pane of the preferences window, available from the OmniPlan menu.





[image: The Display preference pane.]


In the Display preferences, you can customize the format of dates and date ranges that appear at the top of OmniPlan’s various charts.


	Choose which day OmniPlan should consider as the first day of the week.



	Turn on Fiscal Years and specify when they start or end.



	The pop-up menu determines which chart header scale you are editing. The different time scales appear in the headers of the Gantt chart, resource timeline, and work week chart, depending on the zoom scale.



	Click the plus button to add a summary header to the current scale; this makes an extra layer of headers above the normal one in the Gantt chart and the resource timeline. This extra layer gives you more room to show, for instance, the week above the day, or the month above the week. The summary header format can be customized in the same way as the regular date header format, by dragging tokens from the box below and by typing directly into the field. Here we have a summary format that displays the word “Week” followed by the number of the week. To get rid of the summary header, just click the minus button to the right of the field.



	Here’s where you can assemble a date format. Drag tokens from the box below, and type spaces or characters wherever you want them to appear. Some tokens offer information about the date at the beginning or end of a week or quarter. This is so that you can, for example, create a week format which indicates the first and last days of the week. Here we have a format that displays the short name of the month, followed by the date.



	Tokens can be dragged to the format field above to construct a date format. Click the triangle on the right side of a token to change the display of the token. For example, this token represents the month; you can choose to display the month as a full word (January), an abbreviation (Jan), a two-digit number (01), or a one-digit number (1).






Templates


The Templates pane of Preferences provides a list of included templates that you can use as the source for a new document. Two are included with the app by default (a completely empty plan and one set up with Automatic Leveling turned on), and you can create your own from a currently open plan by choosing Save as Template from the File menu.





[image: The Templates preference pane.]


Edit the list of available templates using the gear menu beneath the document list. If there are settings you use frequently for new project files, you can choose a template to set as the default; otherwise, create new projects from templates by choosing New From Template… from the File menu. For more on templates, see Using Templates.



HTML


Printing and export of OmniPlan files relies on a set of HTML and CSS files that describe how the destination document should look. A standard format for these is included with the app, but if you’d prefer to customize the appearance and presentation of your project when printing or exporting, you can create a new copy of the HTML template from the gear menu on this pane, save the copy in a folder you designate, and edit the HTML and CSS to suit your needs.





[image: The HTML preference pane.]



Accounts


Manage your WebDAV and Omni Sync Server accounts for publishing and subscribing on the Accounts pane of Preferences. A quick start guide for getting synced can be found below.





Creating a Sync Account


When multiple users will be contributing to and editing an OmniPlan project, you can easily keep everyone on the same page by storing the project in a server repository. 




First, set up a server account in the Accounts section of Preferences, found in the OmniPlan menu.



[image: Sync Account Creation in Preferences for OmniPlan 2 for Mac]


Click the plus sign under the accounts list to create a new account, then choose an account type from the dropdown: CalDAV, Google, Omni Sync Server (the default), and WebDAV. The Omni Sync Server option is recommended for users seeking a free and robust syncing solution, while a self-hosted WebDAV server may be preferred for confidential projects where data privacy is the highest priority.


To sync via Omni Sync Server, enter your account information or click Create Account to create a new account online. You’ll get feedback at every step of the process as your account data is validated.



Note

When adding an Omni Sync Server account in OmniPlan the user name field only requires the part of your email address that precedes the "@" symbol, and the directory field can be left blank.






Publishing and Subscribing


Next you’ll want to visit the Configure Publishing & Subscriptions screen, accessible via the Projects menu. Click the plus sign at the bottom of the Publish & Update Actions window to choose the type of syncing or subscription you’d like to set up for this project. Choosing Sync entire plan with OmniPlan server repository will make the project accessible to everyone else with access to the account you’ve just set up in Preferences, and updates to the project file will be synced for all users.





[image: Configuring Publication and Subscription options for a server repository in OmniPlan 2 for Mac]



Warning

Because OmniPlan relies partially on your system time to determine the scheduling of synced project updates, making changes to the Apple system clock when working on a project with publishing or subscription enabled will result in an error and should be avoided.






Update


OmniPlan can automatically use your internet connection to check for new and updated versions of itself; you can get to these options by choosing Preferences from the OmniPlan menu, then clicking Update.





[image: The Update preference pane.]


If the Check for Updates checkbox is selected, you will be notified when there is a new version of OmniPlan ready for you to enjoy. Click the Check Now… button to look for the newest version once right away.


You can select the Send anonymous system information to the Omni Group checkbox to volunteer some information about your computer’s configuration when you check for updates. For details about what kind of information we collect and how we use it, click the Learn More link on the preference pane.






Glossary


The following is a list of terms specific to OmniPlan or project management that you’ll encounter throughout this manual, defined and listed in alphabetical order for easy reference.





	Actual schedule

	The actual schedule, in contrast to the baseline schedule, is the way a project turns out in real life. Before the baseline is set for a project, the baseline and actual schedules are the same. After the baseline is set, further editing changes the actual schedule only.


	Attachment

	An attachment is a link to a file somewhere on your computer from inside your OmniPlan project. You can attach files to the project, to a task, or to a resource.


	Assignment

	Assigning a resource to a task means that the resource is expected to be actively busy with that task throughout its duration. Assignment amounts are expressed as the percentage of the resource’s time being spent on the task.


	Baseline schedule

	The baseline schedule, in contrast to the actual schedule, is the way a project is originally planned. Before the baseline is set for a project, the baseline and actual schedules are the same. After the baseline is set, further editing changes the actual schedule only. You can compare the baseline schedule and the actual schedule using the split or both view modes of the Gantt chart.


	Calendar View

	The mode of the main window in which you can set up working hours and work schedule exceptions for individual resources or for the project as a whole. It contains a replica of the resource outline on the left, and a week view, with green time blocks, on the right.


	Child

	A member of a group is considered the group’s “child”; this is common terminology for outlining software.


	Cost

	A task or a resource can have a monetary cost. The total cost of a task is the sum of the task cost and the costs of the resources assigned to it. A resource can have a per-use cost and a per-hour cost.


	Critical path

	The critical path is the series of dependent tasks which, if any of their durations change, will cause the whole project’s duration to change. You can check the critical path from the View menu or the Critical Path toolbar button. Critical paths can be charted to individual milestones as well as to the entire project duration; view a milestone’s critical path by toggling its checkbox in the Project: Milestones inspector.


	Custom data

	Data you can attach to any project, task, or resource, for your own purposes.


	Dependency

	The relationship by which one task must start or finish before another task can start or finish. For example, the task “Buy paint” must finish before the task “Paint fence” can begin.


	Duration

	Duration, in contrast to effort, is how long a task takes to complete in actual working time (that is, not including off-time). For example, a task which takes 4 hours of effort, and is assigned to 2 resources, has a duration of 2 hours. When you assign resources to a task, the duration or effort may change.


	Efficiency

	The measure of how much work a resource can get done in a certain amount of time. Efficiency can affect duration and effort: 100% efficiency means the resource can contribute 1 hour of effort for every hour of work; 50% efficiency means it can contribute 1 hour of effort for every 2 hours of work; and so on.


	Effort

	Effort, in contrast, to duration, is how much work time a task takes to complete, considering all of the resources assigned to it. For example, a task which has a duration of 4 hours, and has 2 resources assigned to it, has an effort of 8 hours. When you assign resources to a task, the duration or effort may change.


	Equipment

	Equipment is a type of resource. It represents some kind of reusable asset, such as some special computer hardware. It can also be useful to consider things like meeting rooms to be “equipment”, if you need to balance their use between different tasks.


	
For equipment resources, “Units” means how many of the resource are available. The number of available units can affect resource leveling.



	
Equipment can have Efficiency, Cost per Use, and Cost per Hour values.



	Gantt Chart

	The Gantt chart is a chronological representation of the project, shown on the right side of the task view. Each task is represented by a bar, corresponding to a row in the outline, and possibly connected to other tasks by lines representing dependencies.


	Group

	Items in the task outline or the resource outline can be grouped together. The members, or “children”, of the group appear indented from the group itself in the outline. In the Gantt chart, a task group appears as a bracket enclosing its members.


	Hammock

	A task of flexible effort whose duration changes based on constraints imposed by tasks scheduled before and after it. See Creating Hammock Tasks for more information.


	Item

	A single row in either the task outline or the resource outline. General outlining commands like Indent and Outdent, Expand and Collapse, work on items in either outline.


	Lead Time

	Lead time is a duration you can put on a dependency to mean that some amount of time is needed between the two moments involved. For example, a Start→Start dependency with a lead time of 1 day means that after the first task starts, the second task can start one day later.


	
Lead time can be negative; for instance a Finish→Start dependency with a –2 hour lead time will allow the second task to start once the first task is 2 hours from completion.



	
You can set up lead time by typing a duration (such as +3w or –2d4h) either a the end of a dependency code in the Dependencies column of the task outline, or in the Task Dependencies inspector.



	
Lead time can also be a percentage of the predecessor task’s duration; for example you could enter 100% for a lead time just as long as the task it comes after.



	Level

	“Leveling the project”, or “leveling resources”, means automatically rearranging the project to make sure the resources are being used as efficiently as possible. This means not allowing a resource to be assigned at more than 100% of its available units at any time, and finding the best order for resources to work on tasks in order to complete them more quickly.


	
Newly created projects are set to automatically level resources as they are allocated to tasks. You can disable automatic leveling in the Project menu.



	
When not leveling automatically, you should level your project after making changes like updating task completion or changing resource assignments.



	Material

	Material is a type of resource, representing consumable supplies.


	
For material resources, “Units” means how many of the resource are being used throughout the project. This value updates as the resource is assigned to more tasks.



	
Material resources can have Cost per Use and Cost per Hour values.



	Milestone

	A milestone is like a task, except that it has no duration and requires no effort. Its purpose is to mark some important point in time. Based on dependencies and work schedules, a milestone may shift in time; you can keep track of your project’s milestones in the Project Information inspector.


	Omni Sync Server

	Omni’s own (free!) sync storage solution. Create an Omni Sync Server account here to share your OmniPlan projects with other contributors; see Accounts Preferences and Managing Server Repositories for more information.


	Parent

	A group is considered the “parent” of all its members; this is common terminology for outlining software.


	Publishing

	When a project is publishing information about itself, it is telling other projects in a shared server repository what resources assigned to it are up to. If a resource is shared between projects (as indicated by an identifying email address), the load on that resource indicated by all publishing projects is taken into account when leveling across projects subscribing to the repository. See Balancing Resource Loads Across Projects for more information.


	Resource

	Resources are the people and things needed to get a project done. Resources are listed in the resource outline, and can be assigned to tasks. The three types of resources are Staff, Material, and Equipment.


	Resource load / Resource allocation

	A resource’s load is the amount of effort it is assigned to do at various times throughout the project. If a resource is assigned at more than 100% of its availability all at once, it is said to be “overloaded” or “overutilized”. Resource leveling tries to alleviate overload of resources. You can see each resource’s load by turning on the resource allocation graphs modeswitcher in the resource timeline.


	Resource timeline

	On the right side of the resource view is a timeline of the tasks assigned to each resource. It provides a more vertically-compressed, resource-oriented look at the project.


	Resource view

	The mode of the main window in which you create, edit, and examine resources. It contains the resource outline on the left and the resource timeline on the right.


	Slack

	Also known as float, in project management terminology slack refers to the amount of time a given task can be deferred until its duration to completion conflicts with the beginning of a subsequent dependent task (thereby causing a delay). Free slack refers to slack specific to a task and its successor, while total slack refers to a sum of all free slack in the project up to completion. Both values can be displayed as columns in task view; see Using Columns in the Task Outline.


	Staff

	Staff is a type of resource, representing people who work on the project.


	
Staff units are measured as percentages. A person who is fully available to the project has a units value of 100%; someone who is spending part of their working hours on other projects would have lower available units. Note that this is not the same as having fewer working hours (which can be set in the calendar view), or being less efficient (which can be set in the Resource Information inspector).



	
Staff can have Address, Efficiency, Cost per Use, and Cost per Hour values.



	Subscribing

	When a project is subscribing to a shared server repository, it is on the lookout for resource load data being published by other projects. When leveling loads, a subscriber will adjust resources based on usage information received from the published projects. See Balancing Resource Loads Across Projects for more information.


	T day

	The first day of a project that has an undetermined start date. Until the start date is set, all dates are represented by an amount of time after T day, such as “T+2w 1d”


	Task

	Some item of work that needs to be done for the project to progress. A task is represented by a row in the task outline, and by a corresponding task bar in the Gantt chart.


	Task View

	The mode of the main window in which you create, edit, and examine tasks. It contains the task outline on the left and the Gantt chart on the right.


	Template

	A template is a file you can use as a starting point for new documents. There are also HTML templates, which are used for creating a web report of a project.


	Units

	Units measure amounts of resources in various contexts. For a staff resource, the units value is a percentage representing how much of the person’s time is available to be assigned to tasks. For equipment and material resources, the units value is a number representing a physical quantity.


	Variance

	Variance is the amount of time by which the actual date differs from the baseline date.


	Violation

	A violation is some sort of problem in the project that prevents it from working out properly. Such problems are things like tasks that start before the project start date, tasks that don’t have enough time to complete before their dependent tasks need to start, or dependencies that cause a task to be prerequisite to itself.







Managing your Omni Licenses


From the menu bar, choose OmniPlan ▸ Licenses to see the Licenses dialog. From here you can review and edit your OmniPlan licenses, which verify that you’ve actually paid for the software. (Thanks!)




To purchase a license:



	Click Buy Licenses and you will find yourself magically transported to the Omni Store, where you can purchase a license for the Mac versions of our software. (Naturally, this only works if you have an Internet connection.)




To add a new license:



	From the menu bar, choose OmniPlan ▸ Licenses to see the Licenses dialog.


	Click Add License.


	If you have a license key in an email message, copy and paste both the Owner name and the License Key into the appropriate fields. If you can’t copy and paste the information, you’ll have to type it in; make sure you enter everything exactly as it appears in your license message, including the dashes. Also, double-check that the license you’re entering really is a license for OmniPlan 2; licenses for other Omni products or earlier versions of OmniPlan won’t work.


	The Type drop-down menu is grayed out by default, which limits the license type to Personal for the current user account on your Mac. OmniPlan has two different types of licenses:



	Personal: This license is for your personal use, and will only be available on this computer when you are logged in as the user who installed the license. You can install this license on more than one computer, but only for your personal use. You should not use the software on two different computers at the same time with this kind of license. If a personal license is available, the application will always use it.


	Computer: You can use this license on this computer, and so can any other user of this computer. However, you should not install this license on more computers than it has license seats for.








If there is more than one user account on your Mac, and you’d like everyone on your Mac to discover the awesomeness that is OmniPlan, you’ll need to jump through a couple of hoops (thanks to Apple’s mandated app sandboxing for OS X 10.7 and above). To set up a Computer license, follow these steps:



	Quit OmniPlan 2.


	Open a new Finder window.


	Switch the Finder’s view settings to Column, by choosing View ▸ as Columns (or use Command–3. This will make it easier for you to traverse the folder hierarchy on your Mac.


	Choose Go ▸ Computer.


	Choose your Mac’s hard drive (if you haven’t renamed it, it should be named Macintosh HD), and then traverse through the following folders:



	Library

	Application Support




	In the Application Support folder, create a new folder (choose File ▸ New Folder, or use Shift-Command-N) and name it Omni Group. You will need to enter your admin password to create a new folder at this level.


	In the Omni Group folder, create a new folder and name it Software Licenses.


	Open OmniPlan 2 again, and then choose OmniPlan ▸ Licenses.


	Click Add License.





When you click Add License, you’ll notice that the Type drop-down menu is no longer grayed out, and the Computer option is available for selection. Now just enter the Owner and License Key information you received from us, click Save, and you should be set.


To remove a license:



	Select the license you want to remove


	Click Delete License.





To move a license from one Mac to another:



	First, find the license file on the old computer. OmniPlan license files are located in the folder Library/Application Support/Omni Group/Software Licenses, where Library is either at the top level of your system disk (for computer licenses), or in your Home folder (for personal licenses). The file you are looking for has a name such as omniplan–123456.omnilicense. Move this file to the new computer.


	On the new computer, choose OmniPlan ▸ Licenses from the menu bar and then click Add License.


	On the sheet that appears, click Import License File.


	Locate and select the license file that you want to import.


	Click Open. If the license file is compatible - meaning, it is for the same version of OmniPlan - the license will be added to OmniPlan on your other system.





Again, the thing to remember here is that license keys are version-specific; the license key you have for OmniPlan 1 is not compatible with OmniPlan 2 (and vice versa).



Note

You can disregard the Licensing section if you've purchased your copy of OmniPlan from the Mac App Store. Licensing is only an issue if you've purchased your copy of OmniPlan direct from The Omni Group's website.








Getting Help


When you’re in need of help—whether you’re puzzled by the Gantt chart, having trouble syncing, or experiencing another issue with OmniPlan—it’s good to know that the Support Humans at The Omni Group are available to lend you a hand.





The OmniPlan Website


The OmniPlan website is a great place to find the latest information about OmniPlan, complete with an ever-growing support section. Here you'll find our ever-expanding and searchable body of OmniPlan support articles, which are a particularly great resource for when you're stuck or puzzled.





The Official Forums


The Omni Group maintains online forums for all of our products, and you’re invited! Come share your questions and ideas with other users and Omni staff.





Email Support


If you’re stuck, if you have a good idea for the next version of OmniPlan, or if you just want to let us know how we’re doing, go ahead and send us an email. Choose Send Feedback from the Help menu to conjure up a message addressed to us. We take support seriously, so you can expect a prompt response actually typed by human hands.





Release Notes


For detailed information about what has changed in each minor version of OmniPlan, check out the release notes in the Help menu.
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