
OmniFocus Manual
What OmniFocus Is
OmniFocus is place for you to keep all of the stuff you're meaning to do, whether it's the stack of 
paperwork sitting on your desk that's due now now now, or the marble monolith in your garage you've 
been meaning to sculpt one of these years.

Of course, you could just make a big list on paper or in an ordinary text editing application. But 
OmniFocus is carefully crafted to understand task lists: it can show you just what you need to know 
right now in order to make progress on your many projects. It can remember which projects you are 
putting off for later, which projects you claim are important but which you haven't touched in weeks, 
and which projects may blow up if you don't do something about them right away.

The really, really cool thing about OmniFocus is that once you get the hang of it, you can really trust 
your system and know that nothing is slipping through the cracks. The reward is certainty that you're 
doing exactly what you need to be doing right now, or even that you don't need to be doing anything 
at all.

Quick start video
We've put together an introductory video about OmniFocus; watching it is probably the best way to 
get acquainted with the software. And then if you want to learn more, this help will still be here when 
you're done!

http://www.omnigroup.com/applications/omnifocus/quickstart
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A quick tutorial
Tutorial 1: Create projects
OmniFocus starts out with a couple of projects already in the library. In this tutorial, we'll assume that 
you've looked them over and deleted them, but you can leave them around if you want.

Think of something you’re working on, or that you’d like to start working on, that will require several 
steps to complete. In OmniFocus, that’s called a project. To create a project, click the plus button at 
the bottom of the blue sidebar and type a name.

Each project you create in the sidebar also appears in the main outline. Make a few different projects 
to begin with.
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A quick tutorial

Tutorial 2: Add actions
Select a project in the main outline and then press Return to add an action to it. Try to be as specific 
as you can with your action titles; you should be able to know immediately upon looking at an action 
exactly what needs to be done. Keep pressing Return and typing names to add as many actions as you 
want. You don’t need to include every action between now and the completion of the project; you can 
always add new actions later.
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A quick tutorial

Tutorial 3: Create and assign contexts
It’s handy (or, for some people, crucial) to assign a context to each action. A simple way to think of 
contexts is as the place or mode you need to be in to do a given task: you can only make phone calls when 
you’re near a phone, you can only buy groceries when you’re out running errands, and you can only do 
research on the web when you’re at your Mac. These are contexts, and if you think about it, almost 
any task requires you to be in a certain context to do it.

Switch to context mode by clicking the @ sign on the mode switcher:

While the planning mode's blue sidebar holds your projects, the context mode's purple sidebar holds 
your contexts.

OmniFocus comes with a few contexts already created for you. Add some new contexts by clicking 
the plus button below the sidebar, or double-click an existing context's name to change it. Make as 
many contexts as you need for the various places and modes you have for doing work: Home, Office, 
Mac, Errands, Phone, and so on. You can always add more contexts later on when you find that you 
need them.
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A quick tutorial

Tutorial 3: Create and assign contexts

Now, go back to planning mode by clicking the little project icon on the mode switcher:

Open the pop-up menu on each action (where it says No Context), and choose from the contexts you 
just saw in context mode to assign a context to each action.
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A quick tutorial

Tutorial 4: Action status
You might have noticed that some of your actions are colored differently from others. Actions are 
styled based on their status, to give you an idea of their availability.

The next action in each project is colored purple. This represents what you can do to make progress 
on the project.

In your sequential projects, that is, projects whose actions need to be completed in order, only the 
next action is considered available. The rest are colored gray to show that they are unavailable until 
you complete the next action.

If you change one of your projects to be para%el by clicking the twin arows to the right of the project's 
name, you'll see the actions after the next action turn black. These actions are all available, because 
you don't need to do them in any particular order.
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A quick tutorial

Tutorial 5: Use the view bar
Once you have a significant amount of information in your OmniFocus database, it can start to get 
overwhelming. The view bar can help you whittle down all that data into something meaningful and 
manageable.

For instance, say you're ready to get some work done. Staying in planning mode with all of your 
projects and actions all over the place won't do. Try this:

Switch to context mode, where actions roam free of their project headings.

Click an empty area in the sidebar to deselect all contexts; all of your actions 
become visible in the main outline.

Show the view bar by clicking the glasses button in the toolbar; a row of pop-up 
menus appears.

From the action status menu (with the checkbox icon), choose Next Action. 
Everything but your next actions disappears from the view.

As you mark things complete, the view updates to keep giving you stuff to work 
on.

This is just one way the view bar can show you exactly what you're looking for. For more about how to 
use it, see the view bar section of the help.

If you ever get the view bar into a wacky state that doesn't show what you want, you can always choose 
Revert to Default View from the Perspectives menu.
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A quick tutorial

Tutorial 6: Drop things in the inbox
When some new chunk of work comes along, you don't necessarily want to go find the right project, 
add the action, and assign a context. For the time being, you can put newly-arrived stuff in the inbox.

Switch to planning mode.

Click the Inbox in the sidebar.

Press Return to create a new inbox item.

Type as descriptive a title as you want to give the item for now.

Keep pressing return and adding whatever bits of work come to mind.

That's it. You can add as much information to the inbox as you need, using it as a kind of holding area 
for stuff you haven't yet gotten around to fully adding to your library of projects. For extra-speedy brain-
dumping action, try the quick entry window.

Whenever you're ready, you can reword the items into proper actions, assign a project and a context to 
each item, then click the Clean Up button in the toolbar. The items shuffle off to where they 
belong. If you want to turn an inbox item into a project instead of an action, drag it to the sidebar.
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A quick tutorial

Tutorial 7: Review projects
Periodically, you should review your projects to make sure they're in good shape. For this example, 
imagine you've been using OmniFocus for a while now, long enough to reach the one-week review 
period for some of your projects.

In planning mode, show the view bar by clicking the glasses icon in the toolbar. From the project 
filter menu (above the sidebar), choose Remaining; this shows all of your active and on-hold 
projects. From the view bar's grouping menu (with a curly-brackets icon), choose Next Review; your 
projects are grouped in order of when they're due to be reviewed.

Look at each project and decide whether it's in the state it needs to be in. Are there new actions you 
need to add to it? Is it something you still plan on doing for sure, or should you change its status to On 
Hold? Is it something you should give up on, and change its status to Dropped? If it's already on hold, 
should you set it back to Active status? Once you're satisfied with the state of the project you're 
reviewing, choose Mark Reviewed from the Edit menu (or use the corresponding toolbar button) 
and move on to the next one.

This regular evaluation of each project can be a huge help; when you're planning well, you work well.
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How projects, actions, and contexts 
work together
Actions

In OmniFocus, the things you need to do are represented by actions. Ideally, an action is a distinct 
chunk of work, described by a name that starts with an unambiguous verb. This makes things less 
intimidating to start, and easier to finish: a list of ten actions such as "Carry boxes out the recycling 
bin" and "Assemble bookshelf" is much more approachable than the nebulous "Finish moving in". Of 
course, you should find the level of specificity that works best for you. As you create actions and move 
them around, OmniFocus keeps track of which ones are available, waiting on something else, or 
complete.

Projects

Related actions are grouped into projects, which represent a set of actions working toward a common 
goal. Anything you want to do that requires more than one action, like "Finish moving in" or "Get 
novella published", are good candidates for projects. Projects can then in turn be organized into 
folders, for keeping track of your broader areas of work.

Single-Action Lists

Some actions, like "Get a haircut", don't really fit into any particular project; they're just individual 
little things you need to do. You can keep this kind of action in a single-action list. These lists are 
similar to projects, but they don't assume that the actions they contain have anything to do with one 
another.

Contexts

It’s handy (or, for some people, crucial) to assign a context to each action. A simple way to think of 
contexts is as the place or mode you need to be in to do a given task: you can only make phone calls when 
you’re near a phone, you can only buy groceries when you’re out running errands, and you can only do 
research on the web when you’re at your Mac. If you think about it, almost any task requires you to be 
in a certain context to do it. You can use planning mode and context mode to look at your actions in 
terms of what project they belong to or what context they require.
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Creating a project
Make a project any time you realize you have something you need to do which requires more than one 
step.

To create a project:

Make sure you are in planning mode; the view switcher in the toolbar should have the Planning 
icon highlighted: 

Click the plus button at the bottom of the sidebar.

Type a title for your new project.

Regardless of which view mode you are in, you can also create a new project by clicking the Add 
Project button in the toolbar, choosing Add Project from the File menu, or typing Command-
Shift-N. OmniFocus switches to planning mode automatically.

Adding actions to a project
Add actions to a project whenever you think of something that you need to do in order to move the 
project forward.

To add an action to a project:

Make sure you are in planning mode; the view switcher in the toolbar should have the Planning 
icon highlighted: 

Select the project, either in the sidebar or in the main outline, by clicking the index-card icon 
next to its name. Or, select an already-existing action in the project.

Press Return or click the Add Action button in the toolbar; the new action appears 
immediately after the item you selected.

Type a name for your new action.

You can move an action between projects by clicking its bullet and dragging it to its new location. 
You can even turn an action into a project by dragging it to the top level of the outline or the sidebar.



OmniFocus manual — page 12

OmniFocus Manual

Attaching files and notes to actions and projects
You can use the notes area of an action or a project to store extra information or materials about the 
item.

When you have an action or a project selected, click the notes icon  on the far right side of the row 

(or press Command-apostrophe). You can type, paste, or drop plain text, rich text, links, images, or 
other files in this area. Click the notes icon again to hide the notes and attachments.

Another way to attach a file to an item is to select the item, then choose Attach File from the Edit 
menu.

By default, OmniFocus creates links to the files you attach, rather than adding the files to your 
OmniFocus database. The link will break if you delete the file or move the document to a different 
computer. To make OmniFocus copy a file into its database for safekeeping, hold the Control key as 
you drop the file, or select Embed the file in the document in the Attach File dialog.

An item with notes or attachments shows its notes icon all the time; others only show it when you 
select them or put the mouse pointer over them.

Keeping track of the next action in each project
Any active project keeps track of the next action that you have yet to complete, and styles it 
differently from the other actions—by default, the next action is purple. This is useful for figuring out 
what you ought to do to keep your projects moving forward.

When you are interested in next actions, you can hide everything else. Show the view bar by clicking 
its icon in the toolbar, then choose Next Action from the action filtering pop-up menu:

For sequential projects, where you need to do one thing before another, the next action is the only 
thing you can do right now to make progress on the project. For parallel projects, where you can do 
the actions in any order, the next action is just the first action in the list, and acts as more of a 
suggestion of what you might want to do next.
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Making a project sequential or parallel
Some projects consist of actions that can be done in any order, like picking up items at a few different 
shops; these are para%el projects. Other projects require one action to be done before the next one 
start, like building a papier-mâché pterodactyl; these are sequential projects. In a parallel project, all 
incomplete actions are available, and the "next action" is just the first one in the list. In a sequential 
project, only the next action is available.

Action groups, just like projects, can be parallel or sequential.

Whether a project is sequential  or parallel  is shown by the pair of arrows by the right side of its 

row in the outline. To switch to the other type, just click the icon. You can also choose a type from 
the inspector. If you find yourself using one type much more often than the other, you can change the 
default setting in the Data preferences.

Using action groups
The actions in a project can be organized hierarchically. This is useful for keeping track of 
complicated projects, or breaking actions into smaller actions without creating a whole separate 
project.

To give an action some child actions, thus turning it into a group: 

Select the action you want to be the parent of the new group.

Choose Add Child from the Structure menu, or press Command-}.

To create a group from some existing actions:

Select all of the actions you want to group.

Choose Group from the Structure menu, or press Command-Option-L.

Also, you can indent some actions to make them children of the action immediately before them in 
the outline:

Select the actions you want to indent, making sure that there's an action before them in the 
outline.

Choose Indent from the Structure menu, or press Command-], or click one of the items' 
handles and drag to the right.

If you mark an action group complete, all of its child actions are also marked as complete.

You can even nest groups within other groups, but that can get pretty ridiculous pretty quickly. If you 
have more than two levels of hierarchy in one project, you might want to consider splitting things up 
into separate projects.
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Organizing projects into folders
Folders are a convenient way of separating your projects, the same way you use folders to organize files 
on your Mac. For example, you could keep folders for each area of your life: perhaps Home, Work, 
Health, Education, Recreation, and Papier-Mâché Pterodactyls. That way, when you're concentrating 
on one area, you can keep just that folder expanded in the sidebar, or use the Focus feature to hide 
the others completely.

To create a folder:

Make sure you are in planning mode; the view switcher in the toolbar should have the Planning 
icon highlighted: 

Select the item just above where you want the new folder to appear.

Click the Add Folder button below the sidebar.

Name your new folder.

To put something (a project or another folder) inside your folder, just drag its icon onto the folder in 
the sidebar. You may have as many layers of folders as you can stand.
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Setting start dates and due dates
Actions and projects can have start dates and due dates. A start date determines when an action or 
project becomes available, while a due date determines when something is considered overdue. You 
can also use the Dates & Times section of the Data preferences to set how long before its due date an 
item should be considered "due soon".

Also in the Dates & Times section of the Data preferences, you can choose which time of day to use 
for when you enter a due date with no time. By default it is 12:00 AM, the very beginning of the day; 
you could for instance enter 11:59 PM to make items due at the very end of the day, or 5:00 PM to 
make items due at the end of the workday.

Start and due dates can be entered either in the main outline (if you have the date columns turned on 
in the View menu) or in the inspector. 

To group and sort by start or due dates, use the grouping and sorting menus in the view bar.

You can be pretty creative with the way you enter dates; OmniFocus is rather smart about guessing 
what you mean. For example:

2d, -3w, 1h, 1y1m, and so on — Relative dates and times put the date at a certain amount of time 
from right now.

2 days, -3 weeks, 1 hour, 1 year 1 month, and so on — You can use the full names of 
units too.

yesterday, tomorrow, next thursday, last month, this friday, and so on — You can 
refer to relative dates using common words. "This", "next", and "last" have specific meanings: 
this friday always means the Friday in this week, next friday always means the Friday in 
the next week, and last friday always means the Friday in last week, regardless of what day 
today is. Other units work in the same way.

september, thurs, 2019, and so on — If you enter the name of a specific time period, the date 
will be at its beginning. So september means September first.

5/23/08 10a, 9.30.09 2:00 PM, and so on — You can use the short date format as defined in 
your International system preferences.

2w sat, 4d @ 5p, tues 6a, aug 6 tues 5p, and so on — Mix the available formats however 
you like.

now, 9, 14:00, tom, and so on — OmniFocus makes its best guess at things like bare numbers, 
times, and word fragments. If you think something might work, give it a try.
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Setting up repeating actions and projects
When you have something that needs to be done more than once, you can set it up as a repeating 
item.

Open the inspector from the Inspectors menu or by clicking the Inspectors button in the 
toolbar.

Select the item you want to repeat, then click the Repeat checkbox in the inspector.

Enter a repeat interval.

Choose how to count the repeat interval. You can count from the original assigned date (for 
something that has to happen regularly, like paying the rent) or from the completion date (for 
something that needs to happen a certain duration after the last time you did it, like getting a 
haircut).

For example:

Start Tuesday 5:00 PM; due Tuesday 10:00 PM; repeat every 1 week from assigned date: take out 
the trash. This repeats from the assigned date because it is necessary to do it at the same time 
every week, regardless of when you last did it.

Start today 12:00 AM; due today 6:00 PM; repeat every 5 days from completion date: clean the 
kitchen. This repeats from the completion date because the next time you need to do it depends 
on the last time you did it.

When you mark a repeating item as complete, the next instance of it is created with its start and due 
dates pushed forward as indicated by the Repeat interval. If you want an item to stop repeating, just 
turn off the Repeat setting in the inspector.

Estimating action duration
If you like, you can note how long you expect actions to take. Then, when you're looking for 
something to do, you can choose based on how much time you have on hand.

To turn on the time estimate column in the main outline, choose View ▸ Columns ▸ Estimate.

To assign a time estimate, click in the estimate column for an action, then type a duration. By default, 
the numbers you type are interpreted as minutes (5m and so on). You can also type larger units, like 
hours (h) and days (d). 

To group and sort by time estimates, use the grouping and sorting menus in the view bar.
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Marking actions complete
When you've finished an action, just click its checkbox; its status changes to "completed". If it was 
the project's next action, and the action that follows it is available, that action becomes the next 
action.

Another way to mark something complete is to select the whole row and press Space. You can also 
right-click any number of selected items and choose "Complete" from the contextual menu, or click 
the Complete toolbar button.

If you mark a whole group complete, all of its child actions become complete too.

If you're marking an action that you actually completed a while ago, you can adjust the completion date 
so that your records are accurate. Just select the item, open the inspector, and edit the Completed 
field.

Remember that regardless of the actions they contain, projects stay active until you decide that there 
are no more actions to be added and you mark the project complete.

Flagging projects and actions
On the right end of any project or action row, there's a little flag that you can turn on or off. The flag 
has no inherent meaning of priority or anything special like that, so you can use it however you like. 
You could, for example, mark all of the things you'd like to get done before lunch, topics for a 
meeting you're about to present at, or projects to reconsider the next time you have a chance to think 
about them. It's entirely up to you.

To flag a project or action, click the little flag on the right side of the project or action row in the main 
outline. You can also select any number of actions and projects and then choose Set Flag from the 
Edit menu, or click the Flag toolbar button.

If you flag a project, all of its actions get an implicit "ghost" flag, and are treated as if they were flagged 
themselves. You can still flag them individually, too.

To see only items that are flagged, use the Flag State menu in the view bar.
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Keeping track of single actions
Sometimes you need to do something that doesn't really fit into a project. "Make rosemary lemonade" 
or "Buy a new cowboy hat", for example, probably don't contribute to the completion of any particular 
project. To keep track of such actions, you can use single-action lists.

To create a single-action list:

First, make sure you're in planning mode. Click the mode switcher in the toolbar , 

or choose Planning from the View menu.

Choose Add Single-Action List from the File menu or from the action menu  below 

the sidebar.

Enter a name for your new list, and drag it to wherever you'd like to keep it.

You can keep any number of single-action lists; some people like to make one for each top-level 
folder in their library. Others make a "Reading" list, a "Shopping" list, and so on. Single-action lists are 
similar to projects; you can drag them into folders, add actions to them from the Inbox, and so on. 
They are different in a couple of ways, though:

Single-action lists are always parallel; the actions in them don't block each other from becoming 
available.

All single actions count as "next actions", since each one is kind of a little tiny project in itself.

Single actions appear in a unique style—blue text by default.
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Assigning contexts to actions
In addition to keeping actions organized into projects, single-action lists, and folders, you can also 
assign each action a context, to indicate where you need to be or what you need to have available in 
order to complete the action.

To create a new context:

Make sure you are in context mode; the view switcher in the toolbar should have the Context 
icon highlighted: 

Click the plus button at the bottom of the sidebar.

Type a title for your new context.

To assign a context to an action in planning mode:

Click in the Context column for the action.

Type part of the name of the context you want to assign; OmniFocus tries to match what you 
typed with the names of your existing contexts.

If you see the context you want, select it. Otherwise, you can finish typing the context name and 
then press Command-Return to create it as a new context.

To assign a context in context mode, just drag an action into the context's entry in the sidebar.

Once your actions have contexts assigned, you can selectively view your actions by context, to see just 
the ones that are actually available to you wherever you are now.

Organizing contexts hierarchically
You can nest a context inside another context, creating a hierarchy as deep as you like. Just drag any 
context in the sidebar inside of any other context.

When you select a parent context, you can see all of the actions inside that context or inside any of its 
descendants. This way you can look at your actions assigned to a more general context (like Office) 
or a more specific one (like Office : Mac). You can also keep identically-named contexts inside of 
different parent contexts (like Office : Mac and Home : Mac).
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Viewing actions by context
When you're at the office and ready to get some work done, you probably don't care to see actions 
that require you to be at the store, at home, or at your cottage in Wisconsin. So it's useful to selectively 
view just the actions that fit your context right now.

To view the actions assigned to a particular context:

Make sure you are in context mode; the view switcher in the toolbar should have the Context 
icon highlighted: 

In the sidebar, click the context you are interested in. As you select it, only actions assigned to 
that context appear in the main outline.

If you like, Command- or Shift-click other contexts to select them at the same time.

When you find yourself using a certain set of contexts, focus, and view bar filters pretty often, you 
might want to save them as a perspective.

To see everything in the main outline again, deselect all contexts by clicking in an empty area of the 
sidebar or by Command-clicking all of the selected contexts.
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Using on-hold or "waiting" contexts
You can set a context's status to "On Hold" with the inspector; actions assigned to an on-hold 
context are considered unavailable, and they block the progress of sequential projects. There are two 
main situations in which you might want to use on-hold contexts:

First, you might create one or more "waiting" contexts for keeping track of actions that you've 
delegated to other people. You can't actually do anything until you hear back from that person; all you 
can do is wait for them to finish it, and maybe nudge them about it every now and then. So an action 
like "get annotated pterodactyl brochure draft back from Dennis" might go in your "Waiting : 
Dennis" context.

Second, you might have some contexts that you don't expect to be available to you any time soon. You 
could put your "Frankfurt" context on hold when you're in London, or put your "Boss" context on hold 
until she comes back from vacation, and any assigned actions are marked unavailable. This helps you 
see which actions and projects aren't likely to make progress until your situation changes.

Dropping contexts
If there's a context you don't intend to use anymore, such as the office for a job you left, or a person 
who transferred to a different department, you can drop it just like a project. All of your old actions 
that were assigned to it stay assigned to it, but the context doesn't appear in your Remaining contexts 
sidebar. Any remaining actions still assigned to a dropped context become unavailable and move to 
the No Context group of the context mode sidebar.
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Dropping stuff in the Inbox
The inbox is a kind of intermediary area between your brain and your OmniFocus library. Whenever 
you have something important that you don't want cluttering up your mind, but you're not quite ready 
to meticulously file it away in the right place in your OmniFocus structure, just put it in the inbox. 
Later on, when you process the inbox, you can decide whether each item is a new project or an action 
in an existing project, what its context is, and so on.

To create a new inbox item, just select the inbox (in the sidebar or in the main outline) and press 
Return. Type whatever's on your mind, forget about it for now, and get back to whatever you were 
doing! For extra bonus productivity-streamlining finesse, don't even switch to OmniFocus to do this; 
use the quick entry window or the clipping service instead.

You can create hierarchy in the inbox by using the Edit ▸ Outlining menu commands, if you already 
know that something is going to have sub-items. Later, you can add these groups to an existing project 
or make them into full-fledged projects themselves.

When you are ready, you can process your inbox items by assigning them projects and contexts.
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Using the Quick Entry window
So the inbox is a quick way to get things off of your mind. But! There's an even quicker way, if you're in 
the middle of something else and you don't want to switch your brain to a different mode: the quick 
entry window.

In the OmniFocus preferences, there's a setting for the quick entry keyboard shortcut. This is a key 
combination which, as long as OmniFocus is open, no matter what else you're doing on your Mac at 
the time, summons up a little window where you can send things to OmniFocus.

To collect stuff in the quick entry window:

Press the quick entry keyboard shortcut as you have set it in the preferences. By default, it's 
Control-Option-Space. The quick entry window appears.

Type in the quick entry window as if you were typing in the OmniFocus inbox. Create as many 
items as you want, with as much hierarchy as you want (you'll need to press Control-Return to 
create more than one item, as Return dismisses the window — you can change this in the 
General preferences). You can assign projects, contexts, dates, notes, and so on for each item.

When you're done, click the Save button or press Command-S. The items are whisked off to 
your inbox and you can keep on doing whatever you were doing. If you don't want to put the 
items in your inbox yet, press the quick entry shortcut again; the items will still be there the next 
time you open the quick entry window. If you want to get rid of the items entirely, click the 
Cancel button or press Command-Period.
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Processing inbox items
Items you put in the inbox stay there until you assign them a project or context (by using the 
inspector or by typing in the Project and Context columns). If you assign both a project and a 
context, then the next time you clean up the item is filed away where it belongs. Depending on your 
settings in the Inbox Processing section of the Data preferences, an inbox item with a project but not 
a context assigned, or vice versa, may stay in the inbox or may be automatically filed where it belongs.

Inbox items have both a Project column and a Context column. To assign a project or a context, you 
can click the pop-up button next to the appropriate cell to see a pop-up menu of all available projects 
or contexts.

Or, you can type directly into the cell. With each letter you type, OmniFocus guesses which of your 
projects or contexts you might mean. Most of the time you can get the right one with just a couple of 
key presses. For example, if you type aak or ado into a project cell, OmniFocus would find your 
"Adopt a Kitten" project. Once the correct project or context is highlighted, you can just leave the 
cell.

If you need to create a new project or context, just type its name into the cell and press Command-
Return instead of Return. OmniFocus creates the new project or context for you, and assigns the 
action to it.

To move inbox items to your library:

For an individual action, just assign a project and a context to it, then use the Clean Up 
command in the Edit menu or the Clean Up button on the toolbar to move it to its proper 
place. 

For any inbox item, including groups, you can click its handle and drag it to the sidebar or the 
main outline wherever you would like it to go. Drop it inside a project to add it to that project, or 
drop it anywhere else to turn it into a project.
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Clipping material from other applications
You may come across an email message, a web page, a newsreader article, or some other scrap of info 
that you'd like to turn into an OmniFocus action. In the olden days you might heft your mouse, 
highlight the text, copy it, summon up the OmniFocus quick entry window, and paste. But no, you're 
living in the future. You use the OmniFocus Clippings service.

To clip content from another application:

Highlight some text in any application (that is, any application that supports Mac OS X Services, 
which should be a% applications these days, ahem)

Press the Clipping keyboard shortcut (Command-Shift-Option-Period by default), or open the 
application menu and then the Services submenu, then choose OmniFocus: Send to 
Inbox.

A new item, with the highlighted content (rich text and embedded images) as its note, lands in 
the quick entry window for you to revise and save.
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You can change some details of how clippings work with the OmniFocus Clippings preferences. 
From the OmniFocus menu, choose Preferences, then click the Clippings tab.

To change the Clippings Shortcut, click in the field and type a key combination. To clear the 
shortcut, click the X button.

With the Copy Clippings to setting, you can choose whether to clip material into the quick 
entry window for review and revision, or to drop it straight into the Inbox.

OmniFocus processes material differently depending on which application it was clipped from, using 
application-specific plug-ins. For example, when you clip content from Mail in Mac OS X 10.5, the 
new action has the message's subject line as a title, and its note has a link to the original message. You 
can select an application in the plug-in list to see details about how it will process clipped content. 
You can also turn off plug-ins you don't intend to use, or for which you'd rather use the "Any 
Application" plug-in.

The OmniFocus Mail Clip-O-Tron 3000 is a little tool that adds the ability to clip the entirety of the 
selected message in the Mail message list. Just click the button in the lower-right corner of the 
Clippings preferences pane to install it. If you don't install it, you can still clip content highlighted in 
Mail's message content area. 
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Processing Mail messages into actions
When it's not convenient for you to put data directly into OmniFocus, you can send a specially-
formatted email to yourself and OmniFocus will process it later. To set it up, use the OmniFocus Mail 
preference pane.

To turn on Mail processing, select the Add Mail Rule to create OmniFocus actions 
checkbox.

Once the Mail Rule has been added, you can tell OmniFocus what kind of messages to look for. One 
way is to look for messages that have +omnifocus before the @ sign in the destination address, as in 
cornelius+omnifocus@omnigroup.com. If your mail service is properly set up for this type of 
addressing, the message arrives in the correct mailbox as if the plus sign and the extra word were not 
there, but they act as a label for special handling. The other way is to look for messages whose subject 
line begins with certain characters, -- by default.

If you want to keep the messages that OmniFocus processes in a certain mailbox, select Archive 
processed messages and choose a mailbox. Otherwise, they are deleted.

The Allowed From addresses list is automatically filled with any email addresses on the "Me" 
card in Address Book. You can add more addresses, if you expect to be sending yourself OmniFocus 
actions from any other accounts.

The way that messages are processed is pretty detailed, and you have a lot of power in how you can 
format your items:

The subject and body of the message are joined into a single block of text.

The first line, and any other lines starting with -- (double-hyphens), become new actions. 
Other lines become notes for the preceding action.

To specify a project, use > (greater-than sign) or :: (double-colons), followed by a project name 
or abbreviation. The colons are nicer for the iPhone because they are on the first shifted 
keyboard rather than the math keyboard. The project string is matched exactly as if it was 
entered in a project cell in OmniFocus.

To specify a context, use @ (at sign), followed by a context name or abbreviation. Like project 
names, the context name is matched exactly as it would be in OmniFocus.

To enter start or due dates, use # (number sign), followed by some date expression. The same 
expressions you use in OmniFocus (tomorrow, 9-30-2008, 2w, and so on) can be used in mail 
messages. If there is only one date, it becomes the due date. If there are two (each with its own 
number sign), the first becomes the start date and the second becomes the due date.

To enter a time estimate, use $ (dollar sign—time is money) followed by some duration 
expression (like 5m, 1h, and so on); you can use the same duration expressions that you use in 
OmniFocus.

You can also add a note on the same line as an action title by separating them with // (double-
slashes). Anything after the double-slashes becomes a note, but double-slashes in a URL like 
http://omnigroup.com don't count.
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Here are some examples of actions you could send to yourself:

-- Action
Note note note note note la la la
note la la
-- Another Action > Project 2 @ Context 3
Note wheeeeeee

I have empty lines in my note

It's great

-- Action 3 > Project 1 @ Context 1 // Same-line notes too, if 
you are into that kind of thing
-- Action 4 #friday // Due Friday, because I only entered one 
date
-- Action 5 #monday #friday // Starts Monday; due Friday.
-- Action 6 #monday # // Starts Monday; no due date.
-- Action 7 :: Project 3 // Written on my iPhone; colons work 
in place of greater-than sign.

--Action8>p2@c2#2d$5m//no spaces needed, nor full names
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Cleaning Up
The grouping, sorting, and filtering settings in the view bar control what parts of your database are 
visible and how they're arranged. For instance, most of the time you don't care to see actions you've 
already completed, so you use the action filter to show only remaining actions. Sure, that's handy, but 
you also don't want OmniFocus pulling stuff out from under you as you're working on it. For instance, 
if you mark an action complete, you probably don't want it to disappear that very moment; you may still 
change your mind and want to uncheck it, or copy its notes into an e-mail, or just double-check that 
you clicked the right thing. Likewise, you probably don't want an inbox item to be spirited away the 
instant you assign a context to it.

So, OmniFocus has a command called Clean Up. It happens automatically every now and then, so that 
things stay tidy, but you can also clean up manually by clicking the Clean Up toolbar button, or 
choosing Clean Up from the Edit menu.

Cleaning up puts everything where it belongs: items that don't match the filter settings disappear, 
visible items move into the appropriate groups, inbox items move to their assigned projects, and so 
on. After you change some items, you can Clean Up to make sure that your view is up to date.

Focusing on certain projects or folders
If you know that you want to concentrate for a while on a particular project, folder, or combination of 
items, the Focus feature can get everything else out of your way.

To focus:

Select a project or folder (or any combination of projects and folders) in the sidebar.

Click the Focus toolbar button, or choose Focus on — from the View menu. Everything 
outside your selection disappears from the sidebar, and the title at the top of the window 
changes to Focusing on —.

As you work in planning mode, or switch to context mode, OmniPlan ignores everything outside 
of your focus, as if the items you're focusing on are the only items in your library.

When you're done focusing, choose Show All Projects from the View menu, or click the 
Show All toolbar button. Your library comes back as if nothing ever happened!

When you find yourself using a certain set of contexts, focus, and view bar filters pretty often, you 
might want to save them as a perspective.
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Using the view bar to filter and arrange items
The view bar is a powerful way to filter and rearrange the items in your window. It has one pop-up 
menu to control what appears in the sidebar, and five pop-up menus to control what appears in the 
main outline. The various filters work together, so that you can come up with quite expressive 
combinations of settings, like Fla(ed next actions in active projects, that I can do in less than 15 minutes, 
sorted by due date.

When you find yourself using a certain set of contexts, focus, and view bar filters pretty often, you 
might want to save them as a perspective.

Project Filter

This appears above the sidebar in planning mode; click it to choose what kind of projects to show 
in the sidebar. You'll probably want this to be Active most of the time, so you can see only the 
projects you're working on now. You can also choose Remaining (any projects that haven't been 
completed or dropped), Stalled (any projects without any available actions), Pending (which 
would be active but have start dates in the future), On Hold, Dropped, Completed (states you 
can set on a project to remove it from the Active projects sidebar), or All.

Context Filter

This appears above the sidebar in context mode; click it to choose what kind of contexts to show 
in the sidebar. You can choose Remaining (contexts which haven't been dropped), Active 
(contexts that have actions assigned to them), Stalled (contexts without any actions), On Hold 
(contexts you've indicated should not allow their actions to become available), or All.

Grouping

Click this to choose how to group the projects in the Planning view outline, or the actions in the 
Context view outline. You can Ungroup everything, or group by Folder (for the same structure as 
you see in the sidebar), Due date, Start date, Completed date, Next Review date, Added 
date, or Changed date. Each group shows up as a collapsible bar in the main outline. Remember 
that in Planning view, the grouping applies to whole projects, not to the individual actions inside 
them.
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Sorting

Click this to choose how to order the projects in the Planning view outline, or the actions in the 
Context view outline. If you have a grouping selected, the sorting happens inside the groups but 
the groups themselves stay in the same order.

In planning mode, you can leave projects Unsorted, or sort them by Name, whether they are 
Flagged, their Due dates, Start dates, Completed dates, Next Review dates, Added dates, 
or Changed dates.

In context mode, you can sort individual actions by the order of the Project they belong to, 
whether they are Flagged, their Due dates, Start dates, Completed dates, Added dates, 
Changed dates, or their Time estimates.

Action Filter

Click this to choose what kind of actions of show in the main outline. You can choose to see 
actions with Any Status, Next actions (just the next thing to do in each eligible project), 
Available actions (things you can actually do, because they aren't blocked by earlier actions in a 
sequential project), Remaining actions (anything that's not completed), or Completed actions 
(things you've already done).

Estimated Time Filter

Click this to show actions whose time estimates fall within a certain range. You can choose to find 
All actions (regardless of their time estimates), or actions that are estimated to take less than 5 
minutes, less than 15 minutes, less than 30 minutes, less than 1 hour, more than 1 hour, 
or an Unknown amount of time (for actions you haven't estimated).

Flag Filter

Click this to show projects or actions based on whether they have flags set on them. You can 
choose to see items with Any Flag State, Flagged items, or Unflagged items. Note that 
flagging an action puts a kind of ghost flag on its parent project, making the project count as 
flagged too, and flagging a project ghost-flags all of its contained actions.
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Searching for actions or projects
The OmniFocus toolbar includes a Search field for filtering the main outline down to items that 
contain a certain string of text. As you type in it, items that don't match disappear dynamically. You 
can search based on action names, notes, context names, or project names.When you're done, click 
the clear button on the right side of the field and everything reappears.

OmniFocus also has a Find and Replace panel like many other applications; from the Edit menu, 
choose Find ▸ Find and Replace to summon it. You can find and replace text in the visible 
columns of any items that are visible in the main outline. Even dates and assigned contexts can be 
replaced, though the context you're replacing with has to match the name of an existing context.
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window settings
You may find certain ways of setting up your OmniFocus window that are useful enough to make you 
want to come back to them again and again: your morning glance at what's due today, your weekly 
review, or your retrospective of what you've gotten done lately. With perspectives, you can save view 
settings and get back to them whenever you like.

OmniFocus comes with a few built-in perspectives that you can't edit, as a way to get back to a few 
basic states. In the Perspectives menu, they are:

Remaining Items — Everything you have left to do.

Due Items — Your remaining items grouped by due date.

Completed Items — All of the items you've already finished.

All Items — Everything ever. This may take a while to load.

To create a perspective:

Set up an OmniFocus window with the view mode, columns, focused items, sidebar selection, 
and view bar settings just the way you like them.

From the Perspectives menu, choose Show Perspectives Window.

Click the plus button at the bottom of the Perspectives window.

Type a name for your new perspective.

There are several ways to open a perspective:

Double-click the perspective's icon in the Perspectives window.

Choose the perspective from the Perspectives menu.

Choose Customize Toolbar from the View menu, and add the perspective to your toolbar as 
a button; then click it.

If you want to change an existing perspective, you can take a new snapshot:

Get a window looking the way you want (possibly by opening the existing perspective and then 
changing a couple of things here and there).

Select the perspective to overwrite in the Perspectives window.

Click the camera icon at the bottom of the Perspectives window: .
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To edit a perspective's options, click the kinda arrowy-looking button at the bottom of the 
perspectives window: . You can choose whether the perspective should open in planning mode 

or context mode and whether the settings for both modes should be restored. The settings for 
whether to always open in a new window, for giving your perspective a keyboard shortcut, and for 
giving your perspective a custom icon are also here.

To quickly print a perspective without even having to open it, click the printer button at the bottom 
of the Perspectives window: . If you trust that the settings are right and you don't even want to 

see the Print panel, Command-click the button to print right away. You may find this handy for 
dashing off a copy of your errands perspective onto some note cards before you run out the door, for 
instance.

To delete a perspective, select it and then click the minus button at the bottom of the Perspectives 
window.

Reviewing projects
Reviewing is a good way to make sure all of the projects in your library are in good shape and are ready 
for you to take action. If you have projects without any actions left, or projects that aren't relevant 
anymore, or projects you don't mean to do any time soon, following a regular review process can help 
you keep them from falling through the cracks.

Each project has an interval for how often you intend to review it and a date when the next review is 
planned. You can change the default review interval in the Data preferences, and you can change the 
review interval and next review date of individual projects with the inspector.

To review your remaining projects:

Choose Remaining from the menu above the sidebar in the View bar (or in the View ▸ 
Sidebar Filter submenu); all of your projects that aren't completed or dropped appear.

Choose Next Review from the Grouping menu in the View bar (or in the View ▸ Grouping 
submenu) to organize your projects by when they are to be reviewed.

For each project in the Review Today group (or earlier groups), check whether the project is 
in the state it needs to be in: Should you revise its actions, or add new ones? Should you put it on 
hold, drop it, or complete it? Or is it just fine?

Once you're satisfied with the state of the project, select it and click the Mark Reviewed toolbar 
button or choose Mark Reviewed from the Edit menu. The project's next review date moves 
forward and you can go on to review another project.
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Eventually, oh frabjous day, you're going to reach the successful end of a project. When you're sure 
that you've really accomplished "Move in to new house", "Carve Halloween pumpkins", or "Write 
pterodactyl novel", you can mark the project complete. Select the project and then either click the 
Complete toolbar item, choose Edit ▸ Status ▸ Completed, or just press the Space bar. The 
project's status changes to Completed, and it is filed away in your library for safekeeping.

Putting a project on hold
If you're not quite sure whether you want to start (or continue) a project, you can put it on ice for a 
while. It disappears from your Active list in the sidebar, and its actions likewise stay hidden. Every 
now and then, you can set the project filter in the view bar to show On Hold projects (or All 
Projects), and review which ones you'd like to make active, which ones you'd like to drop, and which 
ones you'd like to keep on hold.

There are several ways to put a project on hold:

Select the project in the main outline, then use the Status control in the inspector to choose On 
Hold.

Select the project in the sidebar, then choose On Hold from the gear menu at the bottom of 
the sidebar.

Right-click or Control-click the project in the main outline or in the sidebar, then choose On 
Hold from the contextual menu.

To make an on-hold project active again:

Choose On Hold from the view bar's project filter pop-up menu.

Find the project, then use one of the same techniques as above to set the project's status back 
to Active.
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If you've decided not to work on a project any further, you can drop it completely. It disappears from 
your Active list in the sidebar, and its actions likewise stay hidden. Of course, you could just delete 
the project, but then you wouldn't have any record of it or its actions ever having existed. Keeping 
them around in a dropped state means you can go back and check on how often you give up on 
projects, check which actions you've completed regardless of whether they're from still-relevant 
projects, and so on.

There are several ways to drop a project:

Select the project in the main outline, then use the Status control in the inspector to choose 
Dropped.

Select the project in the sidebar, then choose Dropped from the gear menu at the bottom of 
the sidebar.

Right-click or Control-click the project in the main outline or in the sidebar, then choose 
Dropped from the contextual menu.

To make a dropped project active again:

Choose Dropped from the view bar's project filter pop-up menu.

Find the project, then use one of the same techniques as above to set the project's status back 
to Active.
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Page Setup and Printing
Printing your OmniFocus data is pretty straightforward: set up a window that contains exactly the data 
you want by focusing, selecting items in the sidebar, or expanding and collapsing rows in the main 
outline. Then choose Print from the File menu. OmniFocus resizes the content to fit horizontally on 
the paper you've chosen.

For more control over how your data is printed, choose Page Setup from the File menu, then 
choose OmniFocus from the Settings pop-up menu for OmniFocus-specifi c settings.

Completion checkboxes — you can choose to print the checkbox for each action (to 
differentiate between completed and incomplete actions, or if you like to have the box to mark 
off with a pen).

Completion style — you can choose to print completed actions with their completed action 
style applied (a strikethrough by default).

Window title — Add the title of the window to the top of your printed document.

Date and Time — Add the date and time of printing to the top of your printed document.

Convert to black & white — Ignore OmniFocus's color styling and draw all text in black text 
on a white background.

Rows — You can collapse all to show just the top level of the hierarchy, leave as displayed to 
use the expansion as it is in the window on your screen, or expand all to expose the collapsed 
rows.

Notes — You can hide all to put away the notes regardless of their visibility on the screen, 
leave as displayed to use the note visibility as it is on the screen, or show all to expose the 
notes for everything regardless of their visibility on the screen.

To print on unusually-sized paper:

Choose Page Setup from the File menu.

Make sure the Settings pop-up menu says Page Attributes.

Choose your printer from the Format for pop-up menu.

See if the paper you want to use is listed in the Paper Size pop up menu. If it is, choose it and 
print normally. If it isn't, choose Manage Custom Sizes to create it.

If you change the Page Setup for a window with a perspective open (you can tell because the 
perspective's name appears in the window's title bar), those settings are saved with the perspective. 
This means you can print your errands perspective on index cards in black and white at 120% scale 
and with no extra columns, print your weekly review perspective in full color on landscape-orientation 
letter paper, and so on.
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The Perspectives window has a special Quick Print button  at the bottom. Just select a 

perspective and click it to bring up the Print panel for that perspective; then you're just a click away 
from your printed perspective. If you trust that the settings are right and you don't even want to see 
the Print panel, Command-click the button to print right away.
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An excellent way to liberate your data from OmniFocus and communicate with lots of other 
applications and devices is to synchronize with iCal. Once your data is in iCal, you can share it in the 
iCalendar format understood by scads of calendar and to-do applications.

To synchronize OmniFocus with iCal:

Choose OmniFocus ▸ Preferences, then click the Sync icon.

Select the Unsynchronized group in the Calendar list; all of the contexts you're not 
synchronizing appear in the Contexts list.

Drag context names into the calendar name you'd like to synchronize them with. For instance, if 
you drag your "errands" context to your "Home" calendar, any actions assigned to your errands 
context will get corresponding to-do items in your Home calendar in iCal.

From the File menu choose Synchronize with iCal. For each context that you dragged into 
a calendar, its actions are synchronized to iCal.

Whenever you like, choose Synchronize with iCal to bring iCal and OmniFocus back in 
sync. New OmniFocus actions in synchronized contexts are copied to the associated calendars 
in iCal. New iCal to-dos in synchronized calendars are copied to the OmniFocus inbox. 
Changes to actions on either side are applied to the corresponding items on the other side.

In the Sync preferences, you can change just how the synchronization process works:

Add blocked actions to calendars — if this is selected, even actions that aren't available 
(because another action needs to be completed fi rst, for instance) are copied to iCal.

Add completed actions to calendars — if this is selected, even actions that you have 
already marked complete are copied to iCal.

If actions are deleted from calendars, delete them from OmniFocus — If you 
want to delete actions in iCal and have them be deleted from OmniFocus too, select this 
checkbox. Otherwise, you can be sure that synchronizing will never delete any of your actions in 
OmniFocus.

Include each action's context in its calendar item title — This prepends your action 
titles with the assigned context name, like @Office: alphabetize paperweights.
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If you have some data in an OmniOutliner document, especially a Kinkless GTD document, you can 
import it into your OmniFocus database.

To import an OmniOutliner document:

If the file you want to import is not a kGTD document, make sure it has the hierarchy you want 
and has a column for each kind of value you want to import (title, start date, due date, and so on).

From the File menu, choose Import.

Choose the OmniOutliner file you'd like to import. If it is a kGTD document, OmniFocus 
automatically figures out how to import it properly and you're done. If it's an ordinary 
OmniOutliner document, you'll have to help it along a bit; carry on to the next steps.

A column mapping dialog appears. For each column in the original file, choose an OmniFocus 
column to receive the data.

All of the data is imported as a single new project. If you want the top-level items of the outline 
to become their own projects, just select all the contents of the new project and choose Edit ▸ 
Outlining ▸ Outdent.

Backing up your database
We've made OmniFocus err on the side of obsessive, paranoid data preservation, just in case 
something bad happens to your database. After all, we're asking you to put your whole life into this 
app.

OmniFocus automatically backs up your database once a day, in the folder ~/Documents/
OmniFocus Backups/. To change when the automatic backups happen, or where they are saved, 
choose Preferences from the OmniFocus menu and use the General pane. You can choose to 
back up once or twice a day, and also to back up whenever you quit OmniFocus.

To manually back up your database, choose Back Up Database from the File menu. You can 
choose where to put the backup.

To restore a backed-up version of your database, choose Revert to Database Backup from the 
File menu, then choose a backup file to use. Your entire database is replaced by the version in the 
file; if you're not sure that the backup is what you want, you can double-click the backup file to open 
in it in its own window first and make sure it's right.
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Your data belongs to you; if you want to send it to other applications, run scripts on it, publish it on 
the web, or do other exciting stuff with it that we haven't even thought of, you're more than welcome 
to write it out it to the format of your liking and do so!

To export your database, first adjust your view settings (view bar, focus, sidebar selection, and so on) to 
show the data you want to export. When the window contains the data you want, choose Export from 
the File menu, then choose a format and a location. The available formats are:

OmniFocus Document — This is an ordinary OmniFocus document, just like the one that 
you use as your database. If you open such a file in OmniFocus, it appears in its own window and 
you can work with it normally, but application-wide settings such as preferences and 
perspectives don't come along with it.

Plain Text (TaskPaper) — This is a plain-text representation of your data, and it happens to 
be compatible with the light to-do application TaskPaper from Hog Bay Software. Of course, 
you don't need TaskPaper to use your plain text export; you can just give it a .txt extension 
and open it in the text editor of your choice.

Simple HTML — This is a single-file HTML representation of your data; the stylesheet and 
even the icons are embedded in the HTML. If you are proficient with CSS, you should be able 
to restyle the result however you like.

Comma Separated Values (CSV) and (CSV UTF-16)  — CSV is a kind of lingua )anca for 
applications old and new on all plaftorms, as it's just all of your data in a plain text file with its 
columns separated by commas. Once you have your data in CSV format, it's easy to run scripts 
on it, convert it to some other format, or open it in applications that understand it (like 
OmniPlan!). If you're having trouble persuading other applications to read the non-ASCII 
characters in your CSV file, such as accented letters or non-Roman characters, try exporting 
with the UTF-16 CSV option, and importing that into the other application. This makes it easier 
for some applications to detect the correct encoding and interpret your characters properly.
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The inspector window is a central place for setting the attributes of actions, groups, projects, and 
contexts. You can use it to examine or change one or many selected items. When you select 
something in the sidebar or the outline, the inspector window automatically switches to the applicable 
inspector.

Each inspector has controls that are relevant to the type of item you have selected, and some of these 
controls overlap between different types of items.

Project — For actions and groups, this sets which project the item belongs to. You can use this as an 
alternative to finding the destination project in the sidebar and dropping the item there.

Type — For groups and projects, you can choose whether the contained actions should become 
available sequentially or in parallel; that is, one at a time or all at once. You can also turn a project into a 
single-action list, for containing unrelated one-time actions.

Status — For projects, the status can be Active (a project you're still working on), On Hold (an on-
hold project is one you've set aside for some day in the future), Completed (a completed project is 
one you've successfully finished), or Dropped (a dropped project is one you've decided not to pursue 
anymore). For contexts, the status can be Available (a context you still intend to use), On Hold (an on-
hold context is one whose actions aren't available for you to work on), or Dropped (a dropped context 
is one you don't expect to use anymore).

Context — For actions, this sets the assigned context, just like choosing one in the Context column 
of the main outline.

Default Context — For groups and projects, this assigns a context to be automatically assigned to 
any new actions added to the group or project. This is handy if you have a project that you know is 
going to take place mainly in one context.

Estimated Time — For actions and groups, this is the amount of time you expect the item will take 
to complete. See estimating action duration for more information.

Start and Due — An action, group, or project's start date determines when it becomes available; if 
you can't start working on something until later, give it a start date so that it will stay out of your way (in 
Pending status) until then. If your action, group, or project has a deadline, enter a due date. As the 
due date approaches, the item appears in the due soon style, and if it becomes overdue, it appears in 
the overdue style. 

Completed — The date that an action, group, or project was completed is recorded here. You can 
edit the completion date, in case you actually completed something a while back but didn't get 
around to telling OmniFocus about it until just now.

Added and Changed — OmniFocus keeps track of when each item was added to your database and 
when you last changed it. Sometimes it's useful to check these values to see just how long you've been 
meaning to do something.
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Repeat — If you have an action, a group, or a project that needs to be done regularly, you can set up a 
repeat interval. The Next Start and Next Due dates show how the next repetition of the item 
would be scheduled if you completed this one right now.

Next Review — For projects, this indicates when the project is due to be reviewed. You can let 
OmniFocus determine this based on the review interval set below and the last time you marked it as 
reviewed, or you can enter your own date.

Review Every — The default interval between reviews is set in the Data Preferences, but you can 
change the interval on a per-project basis, if there are projects you want to keep a closer eye on or 
leave alone longer.

Last Reviewed — This is the last time you marked the project as reviewed (or the date it was 
created, if you have never reviewed it).
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In order to avoid too much fiddling around, OmniFocus doesn't support styling individual items. 
Instead, you can style all items of a particular type. For instance, if you select a single project row and 
make its font bigger, all projects in your OmniFocus database will also gain the new font size. You can 
independently change the appearance of the following types of items (listed with their default styles):

Next actions — purple

Available actions — black

Unavailable actions — gray

Completed actions — gray with strikethrough

Single actions — blue

Projects and single-action lists — bold

On-hold or dropped projects — gray

Completed projects — gray with strikethrough

Groups — bold

If you want to get back to the default style for anything, just select it and choose Clear Style from 
the Format menu.

In notes, you can do as much rich-text styling as you want. To change the default style for a% notes:

Style the text of an individual note to your liking.

Select the row that the note belongs to.

From the Format menu, choose Make Default Note Style. Any notes which didn't already 
have specific styles, and any new notes you create, get the style you chose.
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There are a few columns you may or may not want to see in the main outline:

Estimate

Start Date

Due Date

You can use the View ▸ Columns submenu to choose which of these columns are visible.

To customize column widths, first show the view bar by clicking its icon in the toolbar or choosing it 
from the View menu. Then drag the edges of the column headers that appear.

Your column visibility and width settings are saved with your perspective, so you can keep different 
settings for different situations.

General preferences
To get to the General preferences, just choose Preferences from the OmniFocus menu.

The General preferences pane contains settings for the Quick Entry window, the location of your 
database and how often the database should be backed up.

There's also a setting for how hierarchical project and context names should be displayed in the main 
outline. Say you have contexts called "Home" and "Office", each with another context called "Mac" 
inside it. When you see those contexts in planning mode's context column, you might want to see 
their hierarchy in order to tell them apart. You might also want to see the folder hierarchy for projects 
in context mode. When you turn on the Show full hierarchy setting, the contexts appear as 
Home : Mac and Office : Mac. If you're not a fan of the colon, you can choose or enter a different 
separator in the field to the right; this is used in the grouping headers and smart match cells whether 
you turn on the full hierarchy setting or not.
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To get to the Data preferences, just choose Preferences from the OmniFocus menu, then click 
the Data icon.

The Inbox Processing section of the Data preferences controls exactly how items should be 
handled when you perform a Clean Up.

You may want to require that an inbox item has A Project, A Context, or Both before it is 
automatically moved out of the inbox.

If you process items with a project but no context, they move into the appropriate project but also 
appear in the No Context group of context mode so that you can assign them a context at some 
point.

If you process items with a context but no project, they move into the Default List for Single 
Actions as indicated below; you can choose a single-action list for keeping your projectless 
actions, or let OmniFocus create a "Miscellaneous" list when it's needed.

You can also choose whether Clean Up should process completed Inbox items. If you 
want OmniFocus to file away inbox items you've marked complete, regardless of whether they have 
a project or context, turn this setting on. If you still want to go back and assign projects or contexts 
to your completed inbox items, so that they get filed away in the right place, turn this off.

In the Dates & Times section, you can control how OmniFocus handles time-related stuff.

The Mark actions due "soon" setting controls how long before an item's due date it should 
start appearing in the special style for almost-due items. By default, items start turning orange 2 
days before they are due.

The Show Due Soon and Overdue actions setting determines whether you should see 
colored counters next to items in the sidebar, a colored counter in the menu bar, or a colored 
badge on the OmniFocus Dock icon. If you choose to show an indicator in the menu bar, you can 
click it to see how many due soon or overdue items you have in your inbox and your individual 
contexts; choose an item from this menu to open an OmniFocus window on it.

You can set the review interval for new projects; by default each project is to be reviewed every 
week.

Below that, you can choose which day is considered the start of the week, for the purposes of 
entering dates like "next week". If you choose Default, the week starts on whichever day is 
normal for the region chosen in the International System Preferences pane.

The When entering due dates without times setting controls the time of day assigned to 
due dates that you enter without specifying a time, as described in the Setting start dates and due 
dates section of the help.

The setting in the Projects & Action Groups section determines whether newly created projects and 
groups should be parallel or sequential.
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By default, your database lives safely in your ~/Library/Application Support/OmniFocus/ 
folder. If for some reason you want to keep it somewhere else, or switch between independent 
databases, you can do so in the General preferences.

For example, you might like to keep your database on an external drive that you bring with you to the 
office, or even on a network-accessible drive (though that might be disagreeably slow).

To move your database somewhere else, and make OmniFocus look for it in the new location from 
now on:

Open OmniFocus's General preferences.

In the Database section, click the Move to a New Location button.

Choose a new home for your database.

To choose an existing file to use as your database from now on:

Open OmniFocus's General preferences.

In the Database section, click the Select a Different Database button.

Choose another OmniFocus database file to use from now on.

AppleScript support
OmniFocus has quite comprehensive AppleScript support. So if there's something you wish it did, you 
may be able to make it. Open OmniFocus's AppleScript dictionary in the Script Editor application for 
the relevant documentation.

Software Update preferences
OmniFocus can automatically use your internet connection to check for new and updated versions of 
itself; you can get to the automatic update options by choosing Preferences from the OmniFocus 
menu, then clicking the Update button.

If the Check for Updates checkbox is selected, you will be notified when there is a new version of 
OmniFocus ready for you to enjoy. Click the Check for Updates Now button to look for the 
newest version once right away.

You can select the Include system information checkbox to volunteer some information about 
your computer's configuration when you check for updates. For details about what kind of information 
we collect and how we use it, click the Learn More button on the preference pane.
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Select the Licenses menu item from the OmniFocus menu to see the Licenses dialog. From here 
you can review and edit your OmniFocus licenses, which verify that you've actually paid for the 
software. (Thanks!)

To buy a license:

Click the Buy Licenses button and you will find yourself magically transported to the Omni 
Group's store on the web. Naturally, this only works if you have a live Internet connection.

If you're considering buying a Family Pack license, note that a Family Pack licenses up to five 
members of a private household. If you're buying for a company or some other organization that's 
not a private household, you can't use a Family Pack. Also, if you're just planning on using 
OmniFocus on a couple of different machines by yourself, and you don't intend to have more 
than one copy running at a time, you can just buy a single license.

To add a new license:

Click the Add License button.

If you have a license key in an e-mail message, copy and paste both the Owner name and the 
License Key into the appropriate fields. If you can't copy and paste the information, you'll 
have to type it in; make sure you copy everything exactly as it appears in your license message. 
Any difference in capitalization, spacing, or punctuation will prevent the license from working. 
Also, double-check that the license you're entering really is a license for OmniFocus; licenses 
for other Omni Group products won't work.

Use the drop-down menu to select the type of license you would like to use. (Keep reading to 
learn about license types.)

Click the Save button.

OmniFocus has three different types of licenses:

Personal: This license is for your personal use, and will only be available on this computer 
when you are logged on as the user who installed the license. You can install this license on 
more than one computer, but only for your personal use. You should not use the software on two 
different computers at the same time with this kind of license. If a personal license is available, 
the application will always use it.

Computer: You can use this license on this computer, and so can any other user of this 
computer. However, you should not install this license on more than one computer. If both a 
network license and a computer license are available, the application will prefer the computer 
license.

Network: This license sits on your network and is available to any user on the network. 
However, only a certain number of users (indicated by the number of "seats") can use the 
license at one time. OmniFocus will only use a network license if neither a personal nor a 
computer license is available.
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To remove a license:

Select the license you want to remove.

Click the Delete License button.

To move a license from one Mac to another:

First, find the license file on the old computer. OmniFocus license files are located in the folder 
Library/Application Support/Omni Group/Software Licenses, where Library 
is either at the top level of your system disk (for computer licenses), or in your home folder (for 
personal licenses). The fi le you are looking for has a name like 
omnifocus-123456.omnilicense. Move this file to the new computer.

On the new computer, choose Licenses from the OmniFocus menu and then click the Add 
License button.

On the sheet that appears, click the Import License File button.

Locate the license file you want to import and select it.

Click the Open button.
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Getting help
The OmniFocus web site is a good place to find the latest information about 
OmniFocus: www.omnigroup.com/applications/omnifocus/

The Release notes, available from the Help menu, list all of the changes to 
OmniFocus for each version. Check them out if you'd like to keep up with what's 
new.

The Omni Group maintains online forums for all of our products, and you're 
invited! Come share your questions and ideas with other users and Omni staff: 
forums.omnigroup.com

If you're stuck, or if you just want to let us know how we're doing, go ahead and send 
us an e-mail. Choose Send Feedback from the Help menu to conjure up a message 
addressed to us, or just write to omnifocus@omnigroup.com. A real human reads and 
replies to every message we get. We'll do our best to help you out.


